New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Midori Web browser #10

Closed
voidpin opened this Issue Dec 6, 2018 · 11 comments

Comments

Projects
None yet
4 participants
@voidpin
Copy link

voidpin commented Dec 6, 2018

Hello people!
I just found out Midori is back from the dead, https://github.com/midori-browser/core
Looking through pkgsrc-wip I found you're still testing the unmaintained upstream version that saw its last update in early 2016.

Wouldn't it be better to shift focus to the new release?
I'm looking at an alternative to Firefox and used to like Midori.

Thx for your time!

@bsiegert

This comment has been minimized.

Copy link
Contributor

bsiegert commented Dec 6, 2018

Good idea! Feel free to submit a patch :)

@voidpin

This comment has been minimized.

Copy link

voidpin commented Dec 6, 2018

Thanks!
Do you think a patch is enough?
I belive the make file needs to be modified.
I'm not really sure how to proceed!?
I'm new on NetBSD and prior to that I've been using Linux for nearly 2 years.
I'm not an idiot, though ;-)... after all I'm running NetBSD with awesome wm on a laptop :-)
I'll see if it builds on my machine first.

@bsiegert bsiegert self-assigned this Dec 6, 2018

@voidpin

This comment has been minimized.

Copy link

voidpin commented Dec 6, 2018

@bsiegert
Thx for self-assign yourself to this.
But, somehow I feel I should learn how to build and package stuff for NetBSD.

@krytarowski

This comment has been minimized.

Copy link
Member

krytarowski commented Dec 6, 2018

https://github.com/joyent/pkgsrc/wiki good tutorials on packages

@bsiegert

This comment has been minimized.

Copy link
Contributor

bsiegert commented Dec 6, 2018

Unfortunately, this is a bit more involved as an update.

At least, it needs vala support in wip/gcr. I am looking into it.

@iamleot

This comment has been minimized.

Copy link
Member

iamleot commented Dec 6, 2018

@bsiegert

This comment has been minimized.

Copy link
Contributor

bsiegert commented Dec 6, 2018

I just committed a working midori-7.0 :) It needs a few cleanups but I can use it.

@voidpin

This comment has been minimized.

Copy link

voidpin commented Dec 6, 2018

@krytarowski
Thx! I'll read through it. I've created packages for Void before using xbps-src... I'm hoping its similar, since Void was created by Romero (xtraeme) inspired by pkgsrc.

@bsiegert
Yeap, gcr...
Man, that was fast ;o)
Waiting to pull it...

@iamleot
Cheers!

Thank you all of you! Amazing stuff!!!

@voidpin

This comment has been minimized.

Copy link

voidpin commented Dec 6, 2018

Giving you guys credit on UnitedBSD forum.
Thanks!!

@krytarowski

This comment has been minimized.

Copy link
Member

krytarowski commented Dec 6, 2018

The void linux person was a pkgsrc developer.

@voidpin

This comment has been minimized.

Copy link

voidpin commented Dec 6, 2018

@krytarowski
Yes, I know... That's one of the reasons I've picked NetBSD.
Haven't been here long enough, but I love Void and NetBSD's approach.

wip-sync pushed a commit that referenced this issue Dec 6, 2018

Enable vala support for gcr.
Bump revision.

Part of #10 (Midori update).

@wip-sync wip-sync closed this in 3538786 Dec 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment