New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fs.js:137 throw new ERR_INVALID_CALLBACK(); ^ TypeError [ERR_INVALID_CALLBACK]: Callback must be a function at makeCallback (fs.js:137:11) at Object.mkdir (fs.js:719:14) at start (/usr/local/lib/node_modules/pomelo/bin/pomelo:347:8) at Command.<anonymous> (/usr/local/lib/node_modules/pomelo/bin/pomelo:65:5) at Command.<anonymous> (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:249:8) at Command.emit (events.js:182:13) at Command.parseArgs (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:472:12) at Command.parse (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:370:21) at Object.<anonymous> (/usr/local/lib/node_modules/pomelo/bin/pomelo:142:9) at Module._compile (internal/modules/cjs/loader.js:688:30) #1125

Open
iiCircle opened this Issue Nov 6, 2018 · 4 comments

Comments

Projects
None yet
3 participants
@iiCircle

iiCircle commented Nov 6, 2018

fs.js:137
throw new ERR_INVALID_CALLBACK();
^

TypeError [ERR_INVALID_CALLBACK]: Callback must be a function
at makeCallback (fs.js:137:11)
at Object.mkdir (fs.js:719:14)
at start (/usr/local/lib/node_modules/pomelo/bin/pomelo:347:8)
at Command. (/usr/local/lib/node_modules/pomelo/bin/pomelo:65:5)
at Command. (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:249:8)
at Command.emit (events.js:182:13)
at Command.parseArgs (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:472:12)
at Command.parse (/usr/local/lib/node_modules/pomelo/node_modules/_commander@2.0.0@commander/index.js:370:21)
at Object. (/usr/local/lib/node_modules/pomelo/bin/pomelo:142:9)
at Module._compile (internal/modules/cjs/loader.js:688:30)

@ChenEgou

This comment has been minimized.

ChenEgou commented Nov 14, 2018

这坑好深,我也遇到了。
查遍了所有地方,找不到解决的方法。
我怀疑,是node的版本、或者是pomelo的版本有问题 。。

@shudingbo

This comment has been minimized.

shudingbo commented Nov 15, 2018

node10 有问题,可以用下面这个
https://github.com/sex-pomelo/sex-pomelo

@ChenEgou

This comment has been minimized.

ChenEgou commented Nov 15, 2018

node10 有问题,可以用下面这个
https://github.com/sex-pomelo/sex-pomelo

这是个新的项目么 ?

@shudingbo

This comment has been minimized.

shudingbo commented Nov 15, 2018

node10 有问题,可以用下面这个
https://github.com/sex-pomelo/sex-pomelo

这是个新的项目么 ?

新成立的社区,维护pomelo

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment