New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[SOLVED] Help: Install errors #356

Closed
micfan opened this Issue Dec 15, 2013 · 11 comments

Comments

Projects
None yet
7 participants
@micfan

micfan commented Dec 15, 2013

mic@ubt: ~/work/pomelo$ sudo npm install pomelo -g
npm http GET https://registry.npmjs.org/seq-queue/0.0.5
npm http GET https://registry.npmjs.org/socket.io/0.9.16
npm http GET https://registry.npmjs.org/async/0.2.5
npm http GET https://registry.npmjs.org/crc/0.2.0
npm http GET https://registry.npmjs.org/cliff/0.1.8
npm http GET https://registry.npmjs.org/mkdirp/0.3.3
npm http GET https://registry.npmjs.org/pomelo-loader/0.0.6
npm http GET https://registry.npmjs.org/pomelo-rpc/0.2.4
npm http GET https://registry.npmjs.org/pomelo-admin/0.2.6
npm http GET https://registry.npmjs.org/pomelo-protocol/0.1.2
npm http GET https://registry.npmjs.org/pomelo-monitor/0.3.7
npm http GET https://registry.npmjs.org/pomelo-logger/0.1.1
npm http GET https://registry.npmjs.org/pomelo-schedule/0.3.4
npm http GET https://registry.npmjs.org/ws/0.4.25
npm http GET https://registry.npmjs.org/toobusy/0.2.2
npm http GET https://registry.npmjs.org/node-bignumber/1.2.1
npm http GET https://registry.npmjs.org/pomelo-protobuf/0.4.0
npm http 304 https://registry.npmjs.org/seq-queue/0.0.5
npm http 304 https://registry.npmjs.org/crc/0.2.0
npm http 304 https://registry.npmjs.org/mkdirp/0.3.3
npm http 304 https://registry.npmjs.org/pomelo-loader/0.0.6
npm http 304 https://registry.npmjs.org/socket.io/0.9.16
npm http 304 https://registry.npmjs.org/cliff/0.1.8
npm http 304 https://registry.npmjs.org/pomelo-rpc/0.2.4
npm http 304 https://registry.npmjs.org/pomelo-admin/0.2.6
npm http 304 https://registry.npmjs.org/pomelo-protocol/0.1.2
npm http 304 https://registry.npmjs.org/pomelo-monitor/0.3.7
npm http 304 https://registry.npmjs.org/async/0.2.5
npm http 304 https://registry.npmjs.org/pomelo-logger/0.1.1
npm http 304 https://registry.npmjs.org/pomelo-schedule/0.3.4
npm http 304 https://registry.npmjs.org/ws/0.4.25
npm http 304 https://registry.npmjs.org/toobusy/0.2.2
npm http 304 https://registry.npmjs.org/node-bignumber/1.2.1
npm http 304 https://registry.npmjs.org/pomelo-protobuf/0.4.0
npm http GET https://registry.npmjs.org/log4js/0.6.7
npm http GET https://registry.npmjs.org/log4js
npm http GET https://registry.npmjs.org/bindings/1.0.0
npm http GET https://registry.npmjs.org/socket.io-client/0.9.16
npm http GET https://registry.npmjs.org/ndump
npm http GET https://registry.npmjs.org/policyfile/0.0.4
npm http GET https://registry.npmjs.org/base64id/0.1.0
npm http GET https://registry.npmjs.org/redis/0.7.3
npm http GET https://registry.npmjs.org/pomelo-loader/0.0.5
npm http GET https://registry.npmjs.org/stream-pkg/0.0.5
npm http GET https://registry.npmjs.org/node-uuid/1.4.0
npm http GET https://registry.npmjs.org/colors
npm http GET https://registry.npmjs.org/eyes
npm http GET https://registry.npmjs.org/winston
npm http GET https://registry.npmjs.org/commander
npm http GET https://registry.npmjs.org/tinycolor
npm http GET https://registry.npmjs.org/options
npm http 304 https://registry.npmjs.org/bindings/1.0.0

> toobusy@0.2.2 install /usr/local/lib/node_modules/pomelo/node_modules/toobusy
> node-gyp rebuild

gyp http GET http://nodejs.org/dist/v0.10.23/node-v0.10.23.tar.gz
gyp http 200 http://nodejs.org/dist/v0.10.23/node-v0.10.23.tar.gz
gyp ERR! UNCAUGHT EXCEPTION 
gyp ERR! stack Error: EPERM, utime '/home/mic/.node-gyp/0.10.23'
gyp ERR! System Linux 3.5.0-27-generic
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/pomelo/node_modules/toobusy
gyp ERR! node -v v0.10.23
gyp ERR! node-gyp -v v0.12.1
gyp ERR! This is a bug in `node-gyp`.
gyp ERR! Try to update node-gyp and file an Issue if it does not help:
gyp ERR!     <https://github.com/TooTallNate/node-gyp/issues>
npm http 304 https://registry.npmjs.org/ndump
npm http 304 https://registry.npmjs.org/log4js/0.6.7
npm http 304 https://registry.npmjs.org/policyfile/0.0.4
npm http 304 https://registry.npmjs.org/base64id/0.1.0
npm http GET https://registry.npmjs.org/async/0.1.15
npm http GET https://registry.npmjs.org/dequeue/1.0.3
npm http GET https://registry.npmjs.org/semver
npm http GET https://registry.npmjs.org/readable-stream
npm http 304 https://registry.npmjs.org/redis/0.7.3
npm http 304 https://registry.npmjs.org/pomelo-loader/0.0.5
npm http 304 https://registry.npmjs.org/stream-pkg/0.0.5
npm http 304 https://registry.npmjs.org/log4js
npm http 304 https://registry.npmjs.org/colors
npm http 304 https://registry.npmjs.org/node-uuid/1.4.0
npm http 304 https://registry.npmjs.org/eyes
npm http 304 https://registry.npmjs.org/winston
npm http GET https://registry.npmjs.org/pkginfo
npm http GET https://registry.npmjs.org/cycle
npm http GET https://registry.npmjs.org/request
npm http GET https://registry.npmjs.org/stack-trace
npm http GET https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/commander
npm http 304 https://registry.npmjs.org/options
npm http 304 https://registry.npmjs.org/tinycolor
npm http 304 https://registry.npmjs.org/async/0.1.15
npm http 304 https://registry.npmjs.org/dequeue/1.0.3
npm http 304 https://registry.npmjs.org/socket.io-client/0.9.16
npm http 304 https://registry.npmjs.org/semver
npm http 304 https://registry.npmjs.org/pkginfo
npm http 304 https://registry.npmjs.org/readable-stream
npm http 304 https://registry.npmjs.org/cycle
npm http 304 https://registry.npmjs.org/stack-trace
npm http 304 https://registry.npmjs.org/request
npm http 304 https://registry.npmjs.org/async

> ws@0.4.25 install /usr/local/lib/node_modules/pomelo/node_modules/ws
> (node-gyp rebuild 2> builderror.log) || (exit 0)



npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/pomelo/node_modules/pomelo-schedule/node_modules/log4js/node_modules/readable-stream/lib'
npm ERR! error rolling back  pomelo@0.7.6 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/pomelo/node_modules/pomelo-schedule/node_modules/log4js/node_modules/readable-stream/lib']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/usr/local/lib/node_modules/pomelo/node_modules/pomelo-schedule/node_modules/log4js/node_modules/readable-stream/lib' }
npm ERR! toobusy@0.2.2 install: `node-gyp rebuild`
npm ERR! Exit status 7
npm ERR! 
npm ERR! Failed at the toobusy@0.2.2 install script.
npm ERR! This is most likely a problem with the toobusy package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls toobusy
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 3.5.0-27-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "pomelo" "-g"
npm ERR! cwd /home/mic/work/pomelo
npm ERR! node -v v0.10.23
npm ERR! npm -v 1.3.17
npm ERR! code ELIFECYCLE
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/pomelo/node_modules/cliff/node_modules/winston/node_modules/request/tests/test-https.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! System Linux 3.5.0-27-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "pomelo" "-g"
npm ERR! cwd /home/mic/work/pomelo
npm ERR! node -v v0.10.23
npm ERR! npm -v 1.3.17
npm ERR! path /usr/local/lib/node_modules/pomelo/node_modules/cliff/node_modules/winston/node_modules/request/tests/test-https.js
npm ERR! code ENOENT
npm ERR! errno 34

> ndump@0.0.2 install /usr/local/lib/node_modules/pomelo/node_modules/pomelo-admin/node_modules/ndump
> node-gyp rebuild

chdir(): No such file or directory
@cynron

This comment has been minimized.

Show comment
Hide comment
@cynron

cynron Dec 23, 2013

Member

gcc? make?

$ sudo apt-get install build-essential
Member

cynron commented Dec 23, 2013

gcc? make?

$ sudo apt-get install build-essential
@micfan

This comment has been minimized.

Show comment
Hide comment
@micfan

micfan Dec 25, 2013

@cynron thank you, but it seems not for build tools

micfan commented Dec 25, 2013

@cynron thank you, but it seems not for build tools

@cynron

This comment has been minimized.

Show comment
Hide comment
@cynron

cynron Dec 27, 2013

Member

have you solved it?

Member

cynron commented Dec 27, 2013

have you solved it?

@zhfchen

This comment has been minimized.

Show comment
Hide comment
@zhfchen

zhfchen Jan 3, 2014

It seems that I have encountered the same problem here. On Mac OS 10.9.1 and NodeJS v.0.1024

zhfchen commented Jan 3, 2014

It seems that I have encountered the same problem here. On Mac OS 10.9.1 and NodeJS v.0.1024

@jayceefun

This comment has been minimized.

Show comment
Hide comment
@jayceefun

jayceefun Jan 3, 2014

I got this error too on Mac OS X 10.9.1, Node v.0.10.24.

jayceefun commented Jan 3, 2014

I got this error too on Mac OS X 10.9.1, Node v.0.10.24.

@cynron

This comment has been minimized.

Show comment
Hide comment
@cynron

cynron Jan 4, 2014

Member

remove ~/.node-gyp and clean npm cache by npm cache clean, then try again.

Member

cynron commented Jan 4, 2014

remove ~/.node-gyp and clean npm cache by npm cache clean, then try again.

@zhfchen

This comment has been minimized.

Show comment
Hide comment
@zhfchen

zhfchen Jan 4, 2014

yeah, it works!

zhfchen commented Jan 4, 2014

yeah, it works!

@micfan

This comment has been minimized.

Show comment
Hide comment
@micfan

micfan Jan 16, 2014

@cynron Hey, I don't what has happened, reinstall it today and everything is ok now!

micfan commented Jan 16, 2014

@cynron Hey, I don't what has happened, reinstall it today and everything is ok now!

@micfan micfan closed this Jan 17, 2014

@luccasmaso

This comment has been minimized.

Show comment
Hide comment
@luccasmaso

luccasmaso Jan 24, 2014

@cynron same here, thanks!

luccasmaso commented Jan 24, 2014

@cynron same here, thanks!

@mayognaise

This comment has been minimized.

Show comment
Hide comment
@mayognaise

mayognaise commented Sep 30, 2014

👍

@Svobi

This comment has been minimized.

Show comment
Hide comment
@Svobi

Svobi commented May 28, 2016

thx!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment