Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Pomelo 0.3 ubuntu install failed because pomelo-admin/0.0.19 not found #95

Closed
holywen opened this Issue Feb 17, 2013 · 12 comments

Comments

Projects
None yet
3 participants

holywen commented Feb 17, 2013

x86 64.
try to install with command:
npm install pomelo -g
but failed.

the error log:
707 silly addNameRange '0.9.12',
707 silly addNameRange '0.9.13' ] ]
708 verbose addNamed [ 'socket.io', '0.9.13' ]
709 verbose addNamed [ '0.9.13', '0.9.13' ]
710 silly lockFile 8f36e462-socket-io-0-9-13 socket.io@0.9.13
711 verbose lock socket.io@0.9.13 /home/holywen/.npm/8f36e462-socket-io-0-9-13.lock
712 info postuninstall pomelo@0.3.0
713 verbose read json /home/holywen/.npm/socket.io/0.9.13/package/package.json
714 silly lockFile 8f36e462-socket-io-0-9-13 socket.io@0.9.13
715 silly lockFile d8f1f1fb-socket-io-0-9-4 socket.io@>=0.9.4
716 error Error: version not found: 0.0.19 : pomelo-admin/0.0.19
716 error at RegClient. (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/request.js:259:14)
716 error at Request.init.self.callback (/usr/local/lib/node_modules/npm/node_modules/request/main.js:120:22)
716 error at Request.EventEmitter.emit (events.js:99:17)
716 error at Request. (/usr/local/lib/node_modules/npm/node_modules/request/main.js:648:16)
716 error at Request.EventEmitter.emit (events.js:126:20)
716 error at IncomingMessage.Request.start.self.req.self.httpModule.request.buffer (/usr/local/lib/node_modules/npm/node_modules/request/main.js:610:14)
716 error at IncomingMessage.EventEmitter.emit (events.js:126:20)
716 error at IncomingMessage._emitEnd (http.js:366:10)
716 error at HTTPParser.parserOnMessageComplete as onMessageComplete
716 error at CleartextStream.socketOnData as ondata
717 error If you need help, you may report this log at:
717 error http://github.com/isaacs/npm/issues
717 error or email it to:
717 error npm-@googlegroups.com
718 error System Linux 3.5.0-23-generic
719 error command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "pomelo" "-g"
720 error cwd /home/holywen
721 error node -v v0.8.18
722 error npm -v 1.2.2
723 verbose exit [ 1, true ]

Contributor

changchang commented Feb 17, 2013

0.3 branch is not ready now and pomelo-admin 0.0.19 has not publish to npm repository yet.

holywen commented Feb 17, 2013

When I type npm install pomelo, it will install 0.3.0 instead of a older version.
This could be a mistake in the release process?
Do you know when it will be published?

Contributor

changchang commented Feb 17, 2013

How your install command look like? I check the npm repository and the latest version is 0.2.4. I try it in my PC with npm install pomelo and it do install the 0.2.4 version.

holywen commented Feb 17, 2013

my command line is: sudo npm install pomelo -g
could it be caused by some time ago I tried to compile it with the latest git code?

Contributor

changchang commented Feb 17, 2013

How you compile with the latest git code? But I think it should be ok since source codes of 0.3 version are in a different branch in github.

holywen commented Feb 17, 2013

first installed g++, then

git clone https://github.com/NetEase/pomelo.git
make

and it will fail.

/bin/sh: 1: ./node_modules/.bin/mocha: not found
make: *** [test] Error 127

Contributor

changchang commented Feb 17, 2013

Makefile is used to run the test cases of pomelo but not for compiling and building the pomelo project. Use make test to run all the test cases.

holywen commented Feb 17, 2013

make test
get this same error:
/bin/sh: 1: ./node_modules/.bin/mocha: not found
make: *** [test] Error 127

Contributor

changchang commented Feb 17, 2013

The mocha has not installed yet and you should type npm install in pomelo directory first.

holywen commented Feb 17, 2013

npm install failed with the following error:

npm http 304 https://registry.npmjs.org/pomelo-sync
npm http 404 https://registry.npmjs.org/pomelo-rpc/0.1.0
npm ERR! Error: version not found: 0.1.0 : pomelo-rpc/0.1.0
npm ERR! at RegClient. (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/request.js:259:14)
npm ERR! at Request.init.self.callback (/usr/local/lib/node_modules/npm/node_modules/request/main.js:120:22)
npm ERR! at Request.EventEmitter.emit (events.js:99:17)
npm ERR! at Request. (/usr/local/lib/node_modules/npm/node_modules/request/main.js:648:16)
npm ERR! at Request.EventEmitter.emit (events.js:126:20)
npm ERR! at IncomingMessage.Request.start.self.req.self.httpModule.request.buffer (/usr/local/lib/node_modules/npm/node_modules/request/main.js:610:14)
npm ERR! at IncomingMessage.EventEmitter.emit (events.js:126:20)
npm ERR! at IncomingMessage._emitEnd (http.js:366:10)
npm ERR! at HTTPParser.parserOnMessageComplete as onMessageComplete
npm ERR! at CleartextStream.socketOnData as ondata
npm ERR! If you need help, you may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Linux 3.5.0-23-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! cwd /home/holywen/pomelo
npm ERR! node -v v0.8.18
npm ERR! npm -v 1.2.2
npm http 304 https://registry.npmjs.org/seq-queue/0.0.5

Contributor

changchang commented Feb 17, 2013

Yeah, some dependency modules have not published for latest pomelo code. Please checkout the stable verson 0.2.4 by git checkout v0.2.4 and try npm install again.

holywen commented Feb 22, 2013

thanks! it works finally.

@fantasyni fantasyni closed this Jan 20, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment