New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test 1b fails on Centos 6 #13

Open
robertpenz opened this Issue Nov 1, 2014 · 0 comments

Comments

Projects
None yet
1 participant
@robertpenz
Copy link

robertpenz commented Nov 1, 2014

First I needed to change the Makefile as ldconfig reports the ssl libs like this

        libssl3.so (libc6) => /usr/lib/libssl3.so
        libssldap60.so (libc6) => /usr/lib/libssldap60.so
        libssl.so.10 (libc6) => /usr/lib/libssl.so.10
        libssl.so (libc6) => /usr/lib/libssl.so

after that everything compiled ok but the Test 1b did fail:

# ./run_tests 
gcc -O2 -Wall -Wextra simple_server.c -lcrypto -lssl -o simple_server
Test 1a                 pass
Test 1b                 FAIL!
Test 1c                 pass
Test 1d                 pass
Test 1e                 pass
Test 2a                 pass
Test 2b                 pass
Test 2c                 pass
Test 3a                 pass
Test 3b                 pass
Test 4a                 pass
Test 4b                 pass
Test 4c                 pass
Test 5a                 pass
Test 5b                 pass
Test 5c                 pass
Test 5d                 pass

which is according to run_tests following check

## 1b. Check that tlsinterposer overrides the application's cipher,
## and that the defaults choose ECDHE (this may be dependent on the system running the test, though)
start_server_tlsi ""
regexp_test 1b "\sNew, [TLSv123./]*, Cipher is ECDHE-RSA-AES256-SHA.*echo: 1b\sread:errno=0\s$"

Which is also the problem I've with Apache on the same machine.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment