Skip to content
Commits on Nov 14, 2010
  1. fix indentation

    Neeraj Singh committed Nov 13, 2010
  2. add ; to fix lint warning

    Neeraj Singh committed Nov 13, 2010
  3. remove lint warning by replacing != with !==

    Neeraj Singh committed Nov 13, 2010
Commits on Nov 13, 2010
  1. add rubygems.org to Gemfile and Gemfile.lock

    Neeraj Singh committed Nov 13, 2010
Commits on Nov 12, 2010
  1. fix readme link

    Neeraj Singh committed Nov 12, 2010
  2. * master branch is dropping the support for jquery 1.4, 1.4.1 and 1.4…

    Neeraj Singh committed Nov 12, 2010
    ….2 .
    
    * If you are using one of those versions then use branch v1.4 .
    * All test files have been updated to reflect the same .
  3. add comments at the top. prepare to create a branch for lower version…

    Neeraj Singh committed Nov 12, 2010
    … of jquery
Commits on Nov 2, 2010
  1. add support for confirmation for button. closes issue #14

    Neeraj Singh committed Nov 2, 2010
Commits on Nov 1, 2010
  1. Revert "Added jquery event binding namespace 'rails' for easy unbindi…

    Neeraj Singh committed Nov 1, 2010
    …ng of all rails jquery magic."
    
    This reverts commit a9a7b20.
  2. add list of callbacks on ajax call

    Neeraj Singh committed Nov 1, 2010
  3. update readme to reflect the ability to run test against different ve…

    Neeraj Singh committed Nov 1, 2010
    …rsion of jQuery
  4. tidying up words

    Neeraj Singh committed Nov 1, 2010
  5. move the list of jquery supported version to top

    Neeraj Singh committed Nov 1, 2010
  6. remove there is no step3

    Neeraj Singh committed Nov 1, 2010
  7. @JangoSteve @josevalim
  8. @jherdman @josevalim

    Clean up var declarations

    jherdman committed with josevalim Nov 1, 2010
  9. @alexcrichton @josevalim

    Allow the two iframe tests to also have a variable jquery version.

    alexcrichton committed with josevalim Nov 1, 2010
    This also fixes the two tests because since 'vendor/jquery-1.4.2.js' was removed, neither test would pass because jQuery wasn't actually present for the tests sadly.
    
    Now, the index page embeds the jquery version into the request URL, so the two iframes load the same version as the one currently being tested
  10. @alexcrichton @josevalim

    Make that test a bit more reliable.

    alexcrichton committed with josevalim Oct 20, 2010
    I think slow responses from the server were causing these tests to fail because ajax:after is called after the ajax request is sent and it didn't look like it was guaranteed that the request had completed by the time ajax:after was called.
    
    Instead, call the start() method when the ajax:complete callback is triggered because in this case we know the ajax has completed and the other callbacks have already been run (their assertions were triggered)
  11. @alexcrichton @josevalim
  12. @alexcrichton @josevalim

    Copy src/rails.js into where it will be served up to the browser ever…

    alexcrichton committed with josevalim Oct 26, 2010
    …y time the index page is refreshed.
    
    This makes development easier by not having to always kill the server and/or edit a different file.
  13. @alexcrichton @josevalim
  14. @alexcrichton @josevalim

    This test was failing for me on all versions of jQuery because the wr…

    alexcrichton committed with josevalim Oct 20, 2010
    …ong event was being triggered on the wrong element.
    
    The 'submit' event was being bound via the 'live' call and this doesn't happen on the 'input' element, but rather it's form. Just locate the form instead and trigger the 'submit' event on it to simulate clicking the submit button.
Commits on Oct 25, 2010
  1. @josevalim

    remove the message that jquery 1.4.2 is not recommended. The issue ht…

    Neeraj Singh committed with josevalim Oct 23, 2010
    …tp://jsbin.com/uboxu3/7/ refers to is a jQuery issue and not jquery-ujs issue. jquery-ujs should not be recommending one version over another just because a version has a few bugs.
  2. @josevalim

    jQuery 1.4.3 fixed http://bugs.jquery.com/ticket/7217 because of which

    Neeraj Singh committed with josevalim Oct 23, 2010
    returning false is not same as e.stopImmediatePropagation.
    
    To get around this issues caused by jQuery 1.4.3, delegate is being used.
  3. @josevalim

    adding MIT-LICENSE

    Neeraj Singh committed with josevalim Oct 20, 2010
Commits on Oct 18, 2010
  1. @spastorino

    Update readme to state that it is recommended to use jquery 1.4.3

    Neeraj Singh committed with spastorino Oct 18, 2010
    Signed-off-by: Santiago Pastorino <santiago@wyeworks.com>
Commits on Oct 2, 2010
  1. @indirect @josevalim
Commits on Sep 10, 2010
  1. @siong1987 @josevalim

    User config.action_view_javascript_expansions[:defaults] instead of c…

    siong1987 committed with josevalim Sep 10, 2010
    …reating an initializer file.
Commits on Sep 7, 2010
  1. @samoli @stevestmartin
Commits on Jul 31, 2010
  1. @lucasuyezu @josevalim
  2. @lucasuyezu @josevalim
Commits on Jun 13, 2010
  1. @stefanpenner @josevalim
  2. @stefanpenner @josevalim
Something went wrong with that request. Please try again.