Skip to content
Permalink
Browse files

sensu: 1.0.3 -> 1.8.0

  • Loading branch information
peterhoeg committed Jul 23, 2019
1 parent 248a3d8 commit 7487d8f9d11fd9b0160a9952f6019f08535faa2b
@@ -2,12 +2,11 @@ source 'https://rubygems.org'

gem 'sensu'

# integration
gem 'sensu-plugins-influxdb'
# dependencies undeclared but needed by extensions/plugins
gem 'history' # needed by extensions-influxdb

# checks
gem 'sensu-plugins-http'
gem 'sensu-plugins-disk-checks'
gem 'sensu-plugins-logs'
gem 'sensu-plugins-systemd'
# gem 'sensu-plugins-process-checks'
# extensions
gem 'sensu-extensions-check-dependencies'
gem 'sensu-extensions-influxdb2'
gem 'sensu-extensions-snmp-trap'
gem 'sensu-extensions-system-profile'
@@ -1,80 +1,72 @@
GEM
remote: https://rubygems.org/
specs:
addressable (2.6.0)
public_suffix (>= 2.0.2, < 4.0)
amq-protocol (2.0.1)
amqp (1.6.0)
amq-protocol (>= 2.0.1)
eventmachine
aws-sdk (2.10.34)
aws-sdk-resources (= 2.10.34)
aws-sdk-core (2.10.34)
aws-sigv4 (~> 1.0)
jmespath (~> 1.0)
aws-sdk-resources (2.10.34)
aws-sdk-core (= 2.10.34)
aws-sigv4 (1.0.1)
cause (0.1)
childprocess (0.5.8)
ffi (~> 1.0, >= 1.0.11)
dentaku (2.0.9)
domain_name (0.5.20170404)
unf (>= 0.0.5, < 1.0.0)
cookiejar (0.3.3)
em-http-request (1.1.5)
addressable (>= 2.3.4)
cookiejar (!= 0.3.1)
em-socksify (>= 0.3)
eventmachine (>= 1.0.3)
http_parser.rb (>= 0.6.0)
em-http-server (0.1.8)
eventmachine
em-socksify (0.3.2)
eventmachine (>= 1.0.0.beta.4)
em-worker (0.0.2)
eventmachine
eventmachine (1.2.5)
ffi (1.9.18)
http-cookie (1.0.3)
domain_name (~> 0.5)
influxdb (0.3.13)
cause
json
jmespath (1.3.1)
json (1.8.6)
jsonpath (0.5.8)
multi_json
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mixlib-cli (1.7.0)
multi_json (1.12.1)
netrc (0.11.0)
eventmachine (1.2.7)
ffi (1.9.21)
history (0.3.0)
http_parser.rb (0.6.0)
multi_json (1.13.1)
oj (2.18.1)
parse-cron (0.1.4)
rest-client (2.0.2)
http-cookie (>= 1.0.2, < 2.0)
mime-types (>= 1.16, < 4.0)
netrc (~> 0.8)
sensu (1.0.3)
public_suffix (3.1.1)
sensu (1.8.0)
em-http-request (= 1.1.5)
em-http-server (= 0.1.8)
eventmachine (= 1.2.5)
eventmachine (= 1.2.7)
parse-cron (= 0.1.4)
sensu-extension (= 1.5.1)
sensu-extensions (= 1.9.0)
sensu-json (= 2.1.0)
sensu-logger (= 1.2.1)
sensu-redis (= 2.2.0)
sensu-settings (= 10.3.0)
sensu-spawn (= 2.2.1)
sensu-transport (= 7.0.2)
sensu-extension (1.5.1)
sensu-extension (= 1.5.2)
sensu-extensions (= 1.11.0)
sensu-json (= 2.1.1)
sensu-logger (= 1.2.2)
sensu-redis (= 2.4.0)
sensu-settings (= 10.16.0)
sensu-spawn (= 2.5.0)
sensu-transport (= 8.3.0)
sensu-extension (1.5.2)
eventmachine
sensu-extensions (1.9.0)
sensu-extensions (1.11.0)
sensu-extension
sensu-extensions-check-dependencies (= 1.0.1)
sensu-extensions-check-dependencies (= 1.1.0)
sensu-extensions-debug (= 1.0.0)
sensu-extensions-deregistration (= 1.0.0)
sensu-extensions-json (= 1.0.0)
sensu-extensions-occurrences (= 1.2.0)
sensu-extensions-only-check-output (= 1.0.0)
sensu-extensions-ruby-hash (= 1.0.0)
sensu-json (>= 1.1.0)
sensu-logger
sensu-settings
sensu-extensions-check-dependencies (1.0.1)
sensu-extensions-check-dependencies (1.1.0)
sensu-extension
sensu-extensions-debug (1.0.0)
sensu-extension
sensu-extensions-deregistration (1.0.0)
sensu-extension
sensu-extensions-influxdb2 (0.1.1)
em-http-request (~> 1.1)
multi_json
sensu-extension
sensu-extensions-json (1.0.0)
sensu-extension
sensu-extensions-occurrences (1.2.0)
@@ -83,60 +75,43 @@ GEM
sensu-extension
sensu-extensions-ruby-hash (1.0.0)
sensu-extension
sensu-json (2.1.0)
sensu-extensions-snmp-trap (0.2.0)
sensu-extension
snmp (= 1.2.0)
sensu-extensions-system-profile (1.0.0)
sensu-extension
sensu-json (2.1.1)
oj (= 2.18.1)
sensu-logger (1.2.1)
sensu-logger (1.2.2)
eventmachine
sensu-json
sensu-plugin (1.4.5)
json (< 2.0.0)
mixlib-cli (>= 1.5.0)
sensu-plugins-disk-checks (2.4.2)
sensu-plugin (~> 1.2)
sys-filesystem (= 1.1.7)
sensu-plugins-http (2.6.0)
aws-sdk (~> 2.3)
rest-client (~> 2.0.2)
sensu-plugin (~> 1.2)
sensu-plugins-influxdb (1.2.0)
dentaku (= 2.0.9)
influxdb (= 0.3.13)
jsonpath (= 0.5.8)
sensu-plugin (~> 1.3)
sensu-plugins-logs (1.2.0)
sensu-plugin (~> 1.2)
sensu-plugins-systemd (0.0.5)
sensu-plugin (~> 1.2)
sensu-redis (2.2.0)
sensu-redis (2.4.0)
eventmachine
sensu-settings (10.3.0)
sensu-settings (10.16.0)
parse-cron
sensu-json (>= 1.1.0)
sensu-spawn (2.2.1)
sensu-spawn (2.5.0)
childprocess (= 0.5.8)
em-worker (= 0.0.2)
eventmachine
sensu-transport (7.0.2)
ffi (= 1.9.21)
sensu-transport (8.3.0)
amq-protocol (= 2.0.1)
amqp (= 1.6.0)
eventmachine
sensu-redis (>= 1.0.0)
sys-filesystem (1.1.7)
ffi
unf (0.1.4)
unf_ext
unf_ext (0.0.7.4)
snmp (1.2.0)

PLATFORMS
ruby

DEPENDENCIES
history
sensu
sensu-plugins-disk-checks
sensu-plugins-http
sensu-plugins-influxdb
sensu-plugins-logs
sensu-plugins-systemd
sensu-extensions-check-dependencies
sensu-extensions-influxdb2
sensu-extensions-snmp-trap
sensu-extensions-system-profile

BUNDLED WITH
1.15.3
1.17.2
@@ -0,0 +1,30 @@
{ stdenv, fetchFromGitHub, python3Packages }:

python3Packages.buildPythonApplication rec {
name = "sensu-check-openvpn-${version}";
version = "20170630";

src = fetchFromGitHub {
owner = "liquidat";
repo = "nagios-icinga-openvpn";
rev = "ba625c3716d7ece5372989c9811561aae0b49c6b";
sha256 = "0b2g7ybm42vybcshaa3drkwp3i6xrlyilqgf77lh3v7kqajcfyxw";
};

dontBuild = true;
doCheck = false;

installPhase = ''
runHook preInstall
mkdir -p $out/bin
install -m755 check_openvpn $out/bin/check_openvpn
runHook postInstall
'';

meta = with stdenv.lib; {
description = "A sensu plugin for OpenVPN";
maintainers = with maintainers; [ peterhoeg ];
};
}
@@ -1,12 +1,11 @@
{ lib, bundlerEnv, ruby }:
{ lib, bundlerApp }:

bundlerEnv rec {
name = "sensu-${version}";
version = (import ./gemset.nix).sensu.version;

inherit ruby;
bundlerApp rec {
pname = "sensu";
gemdir = ./.;

exes = [ "sensu-*" ];

meta = with lib; {
description = "A monitoring framework that aims to be simple, malleable, and scalable";
homepage = https://sensuapp.org/;

0 comments on commit 7487d8f

Please sign in to comment.
You can’t perform that action at this time.