Skip to content
Permalink
Browse files

sensu: 1.0.3 -> 1.1.0

  • Loading branch information
peterhoeg committed Oct 10, 2017
1 parent 1fdca25 commit 8888225e392e4e423d4e214e73cd63268ffdb3b1
@@ -2,12 +2,35 @@ source 'https://rubygems.org'

gem 'sensu'

# dependencies undeclared but extensions/plugins
gem 'history' # needed by extensions-influxdb

# integration
gem 'sensu-plugins-influxdb'
gem 'sensu-plugins-mailer'
gem 'sensu-plugins-pushover'

# checks
gem 'sensu-plugins-http'
# extensions
gem 'sensu-extensions-check-dependencies'
# sensu-extensions-influxdb on rubygems.org is not the officially sanctioned extension
gem 'sensu-extensions-influxdb', github: 'sensu-extensions/sensu-extensions-influxdb2', ref: 'c6ccfbd12fd878d4a30096444d8a022aac433252'
gem 'sensu-extensions-snmp-trap'
gem 'sensu-extensions-system-profile'

# checks - cpu and process cannot be installed due to: https://github.com/manveru/bundix/issues/14
# gem 'sensu-plugins-cpu-checks'
# gem 'sensu-plugins-process-checks'
gem 'sensu-plugins-cgroups'
gem 'sensu-plugins-disk-checks'
gem 'sensu-plugins-http'
gem 'sensu-plugins-influxdb' # checks for influxdb, we do not care about the extension
gem 'sensu-plugins-ipmi'
gem 'sensu-plugins-load-checks'
gem 'sensu-plugins-logs'
gem 'sensu-plugins-network-checks'
gem 'sensu-plugins-raid-checks', github: 'sensu-plugins/sensu-plugins-raid-checks', ref: '5b13a690f317c96c8b44f90af767de2842adfae4'
gem 'sensu-plugins-rabbitmq'
gem 'sensu-plugins-redis'
gem 'sensu-plugins-sensu'
gem 'sensu-plugins-snmp'
gem 'sensu-plugins-systemd'
# gem 'sensu-plugins-process-checks'
gem 'sensu-plugins-uptime-checks'
@@ -1,52 +1,119 @@
GIT
remote: git://github.com/sensu-extensions/sensu-extensions-influxdb2.git
revision: c6ccfbd12fd878d4a30096444d8a022aac433252
ref: c6ccfbd12fd878d4a30096444d8a022aac433252
specs:
sensu-extensions-influxdb (0.0.2)
em-http-request
multi_json
sensu-extension

GIT
remote: git://github.com/sensu-plugins/sensu-plugins-raid-checks.git
revision: 5b13a690f317c96c8b44f90af767de2842adfae4
ref: 5b13a690f317c96c8b44f90af767de2842adfae4
specs:
sensu-plugins-raid-checks (1.0.0)
english (= 0.6.3)
sensu-plugin (~> 1.2)

GEM
remote: https://rubygems.org/
specs:
activesupport (4.2.10)
i18n (~> 0.7)
minitest (~> 5.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
addressable (2.5.2)
public_suffix (>= 2.0.2, < 4.0)
amq-protocol (2.0.1)
amqp (1.6.0)
amq-protocol (>= 2.0.1)
eventmachine
aws-sdk (2.10.34)
aws-sdk-resources (= 2.10.34)
aws-sdk-core (2.10.34)
aws-sdk (2.10.61)
aws-sdk-resources (= 2.10.61)
aws-sdk-core (2.10.61)
aws-sigv4 (~> 1.0)
jmespath (~> 1.0)
aws-sdk-resources (2.10.34)
aws-sdk-core (= 2.10.34)
aws-sigv4 (1.0.1)
aws-sdk-resources (2.10.61)
aws-sdk-core (= 2.10.61)
aws-ses (0.6.0)
builder
mail (> 2.2.5)
mime-types
xml-simple
aws-sigv4 (1.0.2)
builder (3.2.3)
bunny (2.5.0)
amq-protocol (>= 2.0.1)
carrot-top (0.0.7)
json
cause (0.1)
childprocess (0.5.8)
ffi (~> 1.0, >= 1.0.11)
chronic_duration (0.10.6)
numerizer (~> 0.1.1)
cookiejar (0.3.3)
dentaku (2.0.9)
dnsbl-client (1.0.2)
domain_name (0.5.20170404)
unf (>= 0.0.5, < 1.0.0)
em-http-request (1.1.5)
addressable (>= 2.3.4)
cookiejar (!= 0.3.1)
em-socksify (>= 0.3)
eventmachine (>= 1.0.3)
http_parser.rb (>= 0.6.0)
em-http-server (0.1.8)
eventmachine
em-socksify (0.3.1)
eventmachine (>= 1.0.0.beta.4)
em-worker (0.0.2)
eventmachine
english (0.6.3)
language
erubis (2.7.0)
eventmachine (1.2.5)
ffi (1.9.18)
history (0.3.0)
http-cookie (1.0.3)
domain_name (~> 0.5)
http_parser.rb (0.6.0)
i18n (0.8.6)
influxdb (0.3.13)
cause
json
inifile (3.0.0)
jmespath (1.3.1)
json (1.8.6)
jsonpath (0.5.8)
multi_json
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
language (0.6.0)
mail (2.6.3)
mime-types (>= 1.16, < 3)
mailgun-ruby (1.0.3)
json (~> 1.8)
rest-client (~> 1.6)
mime-types (2.99.3)
minitest (5.10.3)
mixlib-cli (1.7.0)
multi_json (1.12.1)
multi_json (1.12.2)
net-ping (1.7.8)
netrc (0.11.0)
numerizer (0.1.1)
oj (2.18.1)
parse-cron (0.1.4)
rest-client (2.0.2)
public_suffix (3.0.0)
redis (3.3.5)
rest-client (1.8.0)
http-cookie (>= 1.0.2, < 2.0)
mime-types (>= 1.16, < 4.0)
netrc (~> 0.8)
sensu (1.0.3)
mime-types (>= 1.16, < 3.0)
netrc (~> 0.7)
ruby-ntlm (0.0.3)
ruby_dig (0.0.2)
rubyipmi (0.10.0)
sensu (1.1.0)
em-http-server (= 0.1.8)
eventmachine (= 1.2.5)
parse-cron (= 0.1.4)
@@ -55,7 +122,7 @@ GEM
sensu-json (= 2.1.0)
sensu-logger (= 1.2.1)
sensu-redis (= 2.2.0)
sensu-settings (= 10.3.0)
sensu-settings (= 10.9.0)
sensu-spawn (= 2.2.1)
sensu-transport (= 7.0.2)
sensu-extension (1.5.1)
@@ -83,6 +150,11 @@ GEM
sensu-extension
sensu-extensions-ruby-hash (1.0.0)
sensu-extension
sensu-extensions-snmp-trap (0.0.33)
sensu-extension
snmp (= 1.2.0)
sensu-extensions-system-profile (1.0.0)
sensu-extension
sensu-json (2.1.0)
oj (= 2.18.1)
sensu-logger (1.2.1)
@@ -91,25 +163,70 @@ GEM
sensu-plugin (1.4.5)
json (< 2.0.0)
mixlib-cli (>= 1.5.0)
sensu-plugins-disk-checks (2.4.2)
sensu-plugins-cgroups (1.1.0)
sensu-plugin (~> 1.2)
sensu-plugins-disk-checks (2.5.0)
sensu-plugin (~> 1.2)
sys-filesystem (= 1.1.7)
sensu-plugins-http (2.6.0)
sensu-plugins-http (2.5.0)
aws-sdk (~> 2.3)
rest-client (~> 2.0.2)
rest-client (= 1.8.0)
sensu-plugin (~> 1.2)
sensu-plugins-influxdb (1.2.0)
dentaku (= 2.0.9)
influxdb (= 0.3.13)
jsonpath (= 0.5.8)
sensu-plugin (~> 1.3)
sensu-plugins-logs (1.2.0)
sensu-plugins-ipmi (1.0.1)
rubyipmi (= 0.10.0)
sensu-plugin (~> 1.2)
sensu-plugins-load-checks (4.0.0)
sensu-plugin (~> 1.2)
sensu-plugins-logs (1.3.1)
sensu-plugin (~> 1.2)
sensu-plugins-mailer (1.2.0)
aws-ses (= 0.6.0)
erubis (= 2.7.0)
mail (= 2.6.3)
mailgun-ruby (= 1.0.3)
ruby-ntlm (= 0.0.3)
sensu-plugin (~> 1.2)
sensu-plugins-network-checks (2.0.1)
activesupport (~> 4.2)
dnsbl-client (= 1.0.2)
net-ping (= 1.7.8)
sensu-plugin (~> 1.2)
whois (>= 4.0)
whois-parser (= 1.0.0)
sensu-plugins-pushover (1.0.0)
sensu-plugin (~> 1.2)
sensu-plugins-rabbitmq (3.6.0)
amq-protocol (= 2.0.1)
bunny (= 2.5.0)
carrot-top (= 0.0.7)
inifile (= 3.0.0)
rest-client (= 1.8.0)
ruby_dig (= 0.0.2)
sensu-plugin (~> 1.2)
stomp (= 1.4.3)
sensu-plugins-redis (2.2.1)
redis (~> 3.3)
sensu-plugin (~> 1.2)
sensu-plugins-sensu (2.3.1)
chronic_duration (= 0.10.6)
english (= 0.6.3)
rest-client (= 1.8.0)
sensu-plugin (~> 1.2)
sensu-plugins-snmp (1.1.0)
sensu-plugin (~> 1.2)
snmp (= 1.2.0)
sensu-plugins-systemd (0.1.0)
sensu-plugin (~> 1.2)
sensu-plugins-systemd (0.0.5)
sensu-plugins-uptime-checks (1.2.0)
sensu-plugin (~> 1.2)
sensu-redis (2.2.0)
eventmachine
sensu-settings (10.3.0)
sensu-settings (10.9.0)
parse-cron
sensu-json (>= 1.1.0)
sensu-spawn (2.2.1)
@@ -121,22 +238,49 @@ GEM
amqp (= 1.6.0)
eventmachine
sensu-redis (>= 1.0.0)
snmp (1.2.0)
stomp (1.4.3)
sys-filesystem (1.1.7)
ffi
thread_safe (0.3.6)
tzinfo (1.2.3)
thread_safe (~> 0.1)
unf (0.1.4)
unf_ext
unf_ext (0.0.7.4)
whois (4.0.4)
whois-parser (1.0.0)
activesupport (>= 4)
whois (>= 4.0.0)
xml-simple (1.1.5)

PLATFORMS
ruby

DEPENDENCIES
history
sensu
sensu-extensions-check-dependencies
sensu-extensions-influxdb!
sensu-extensions-snmp-trap
sensu-extensions-system-profile
sensu-plugins-cgroups
sensu-plugins-disk-checks
sensu-plugins-http
sensu-plugins-influxdb
sensu-plugins-ipmi
sensu-plugins-load-checks
sensu-plugins-logs
sensu-plugins-mailer
sensu-plugins-network-checks
sensu-plugins-pushover
sensu-plugins-rabbitmq
sensu-plugins-raid-checks!
sensu-plugins-redis
sensu-plugins-sensu
sensu-plugins-snmp
sensu-plugins-systemd
sensu-plugins-uptime-checks

BUNDLED WITH
1.15.3
1.14.6

0 comments on commit 8888225

Please sign in to comment.
You can’t perform that action at this time.