Package perl-Compress-Raw-Zlib build not isolated #107

Closed
noahl opened this Issue Aug 16, 2012 · 3 comments

Comments

Projects
None yet
4 participants
@noahl

noahl commented Aug 16, 2012

When building the package 'perl-Compress-Raw-Zlib' on OS X 10.6.8, the builder tells me that my version of the zlib header file (1.2.7) doesn't match the version of zlib I have installed (1.2.3).

I think this means the build environment is being contaminated by the operating system's built-in libraries.

edolstra pushed a commit to edolstra/nixpkgs that referenced this issue Oct 1, 2013

Merge pull request #107 from Davorak/fixXorgVMware
Fix Xorg-server on vmware inconjunction with
@shlevy

This comment has been minimized.

Show comment Hide comment
@shlevy

shlevy Apr 4, 2014

Member

Should hopefully be fixed as part of #1485

Member

shlevy commented Apr 4, 2014

Should hopefully be fixed as part of #1485

@shlevy shlevy added this to the 14.10 milestone Apr 4, 2014

@shlevy shlevy added the darwin label Apr 5, 2014

@shlevy shlevy removed this from the 14.10 milestone Apr 5, 2014

@shlevy shlevy self-assigned this Apr 5, 2014

@shlevy shlevy removed their assignment Aug 26, 2014

@shlevy

This comment has been minimized.

Show comment Hide comment
@shlevy

shlevy Aug 26, 2014

Member

This may not be a problem any more, but either way I'm no longer working on darwin stuff.

Member

shlevy commented Aug 26, 2014

This may not be a problem any more, but either way I'm no longer working on darwin stuff.

@mjhoy

This comment has been minimized.

Show comment Hide comment
@mjhoy

mjhoy Feb 21, 2016

Contributor

running nix-env -iA nixpkgs.perlPackages.CompressRawZlib appears to work for me (osx 10.9, nixos-unstable), although there is this curious output:

LD_RUN_PATH="/nix/store/0s5i71y9rjnbzxlmr6msdvf48qva5v99-zlib-1.2.8/lib" cc  -bundle -undefined dynamic_lookup -L/nix/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-Libsystem-osx-10.9.5/lib -fstack-protector Zlib.o  -o blib/arch/auto/Compress/Raw/Zlib/Zlib.bundle     \
   -L/nix/store/0s5i71y9rjnbzxlmr6msdvf48qva5v99-zlib-1.2.8/lib -lz     \

ld: warning: directory not found for option '-L/nix/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-Libsystem-osx-10.9.5/lib'
Contributor

mjhoy commented Feb 21, 2016

running nix-env -iA nixpkgs.perlPackages.CompressRawZlib appears to work for me (osx 10.9, nixos-unstable), although there is this curious output:

LD_RUN_PATH="/nix/store/0s5i71y9rjnbzxlmr6msdvf48qva5v99-zlib-1.2.8/lib" cc  -bundle -undefined dynamic_lookup -L/nix/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-Libsystem-osx-10.9.5/lib -fstack-protector Zlib.o  -o blib/arch/auto/Compress/Raw/Zlib/Zlib.bundle     \
   -L/nix/store/0s5i71y9rjnbzxlmr6msdvf48qva5v99-zlib-1.2.8/lib -lz     \

ld: warning: directory not found for option '-L/nix/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-Libsystem-osx-10.9.5/lib'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment