New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

i965: Failed to submit batchbuffer: Input/output error #41428

Open
lapp0 opened this Issue Jun 3, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@lapp0

lapp0 commented Jun 3, 2018

Issue description

Both mpv and electrum fail to start with the error i965: Failed to submit batchbuffer: Input/output error.

Fix

I don't know how to make this fix permanent and in a way that fixes not only mpv and electrum, but all the programs which may be affected.

However, the problem can be resolved by setting the environment variable export LIBGL_ALWAYS_SOFTWARE=1.

Technical details

~ » nix-shell -p nix-info --run "nix-info -m"                                                                                                                                                                                   
 - system: `"x86_64-linux"`
 - host os: `Linux 4.14.43, NixOS, 18.03.132561.03ba84eb565 (Impala)`
 - multi-user?: `yes`
 - sandbox: `no`
 - version: `nix-env (Nix) 2.0.2`
 - channels(andrew): `"nixos-18.03.132561.03ba84eb565"`
 - channels(root): `"nixos-18.03.132561.03ba84eb565"`
 - nixpkgs: `/nix/var/nix/profiles/per-user/root/channels/nixos/nixpkgs`
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment