New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dead link to boehm-gc-7.6.0-sys_select.patch #53809

Closed
liori opened this Issue Jan 11, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@liori
Copy link

liori commented Jan 11, 2019

Issue description

building '/home/liori/nix/store/9bbp05wgdg6j4jfhvqdwy3ig1xlgrnjb-boehm-gc-7.6.0-sys_select.patch.drv'...                                                                                                                                [6/1852]
            
trying https://gitweb.gentoo.org/proj/musl.git/plain/dev-libs/boehm-gc/files/boehm-gc-7.6.0-sys_select.patch
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current                                                                                                                                                               
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (22) The requested URL returned error: 404 Not found                                                                                                                                                                                    
error: cannot download boehm-gc-7.6.0-sys_select.patch from any mirror                                                                                                                                                                        
builder for '/home/liori/nix/store/9bbp05wgdg6j4jfhvqdwy3ig1xlgrnjb-boehm-gc-7.6.0-sys_select.patch.drv' failed with exit code 1
cannot build derivation '/home/liori/nix/store/r3an9qm984xmmlmwii09nzr0fm3pqcid-boehm-gc-8.0.0.drv': 1 dependencies couldn't be built
building '/home/liori/nix/store/mivxx4hjq1sfdsq8a6hmssps0q22xnlh-glibc-2.26.patch.drv'...
cannot build derivation '/home/liori/nix/store/6hbhxxd95259c1xcyhnab1nsvpvhxcf4-nix-2.1.3.drv': 1 dependencies couldn't be built
error: build of '/home/liori/nix/store/6hbhxxd95259c1xcyhnab1nsvpvhxcf4-nix-2.1.3.drv' failed

Steps to reproduce

Tried to compile nix as the first package after bootstrapping a nix install manually.

Technical details

liori:~/Programy/nix-lioried/nix-boot% nix-shell -p nix-info --run "nix-info -m"
error: file 'nixpkgs' was not found in the Nix search path (add it using $NIX_PATH or -I), at (string):1:13

@veprbl veprbl closed this in ac7f4c0 Jan 11, 2019

@dtzWill dtzWill referenced this issue Jan 15, 2019

Closed

boehmgc: fix musl build #53364

2 of 10 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment