Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python37Packages.janus: 0.5.0 -> 0.6.0 #100760

Closed
wants to merge 1 commit into from

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Oct 16, 2020

Automatic update generated by nixpkgs-update tools. This update was made based on information from passthru.updateScript.

meta.description for python37Packages.janus is: "Mixed sync-async queue"

meta.homepage for python37Packages.janus is: "https://github.com/aio-libs/janus"

meta.changelog for python37Packages.janus is: ""

Updates performed
  • Ran passthru.UpdateScript
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
32 total rebuild path(s)

8 package rebuild(s)

8 x86_64-linux rebuild(s)
8 i686-linux rebuild(s)
8 x86_64-darwin rebuild(s)
8 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
datasette
pantalaimon
python37Packages.datasette
python37Packages.entrance-with-router-features
python37Packages.janus
python38Packages.datasette
python38Packages.entrance-with-router-features
python38Packages.janus
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/n7kr1fszdx92q5bpqnvkgs169qvwsbxz-python3.7-janus-0.6.0 \
  --option binary-caches 'https://cache.nixos.org/ https://nix-community.cachix.org/' \
  --option trusted-public-keys '
  nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(The Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A python37Packages.janus https://github.com/r-ryantm/nixpkgs/archive/05e775b45d2d448c816b24aca5d2af289255bd42.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/n7kr1fszdx92q5bpqnvkgs169qvwsbxz-python3.7-janus-0.6.0
ls -la /nix/store/n7kr1fszdx92q5bpqnvkgs169qvwsbxz-python3.7-janus-0.6.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

2 packages failed to build:
  • datasette (python38Packages.datasette)
  • python37Packages.datasette
5 packages built:
  • pantalaimon
  • python37Packages.entrance-with-router-features
  • python37Packages.janus
  • python38Packages.entrance-with-router-features
  • python38Packages.janus

Maintainer pings

cc @simonchatts for testing.

Copy link
Contributor

@jonringer jonringer left a comment

breaks datasette

https://github.com/NixOS/nixpkgs/pull/100760
2 packages failed to build:
datasette python37Packages.datasette

5 packages built:
pantalaimon python37Packages.entrance-with-router-features python37Packages.janus python38Packages.entrance-with-router-features python38Packages.janus

@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Nov 27, 2020

  Processing ./datasette-0.46-py3-none-any.whl
  Requirement already satisfied: uvicorn in /nix/store/4y22snkzrx19g2vcn8hcl59pb6cnkpvb-python3.7-uvicorn-0.11.5/lib/python3.7/site-packages (from datasette==0.46) (0.11.5)
  Requirement already satisfied: asgi-csrf>=0.6 in /nix/store/y8d0ib0ii79mxh0416i4187s8pf41r59-python3.7-asgi-csrf-0.7.1/lib/python3.7/site-packages (from datasette==0.46) (0.7.1)
  Requirement already satisfied: mergedeep<1.4.0,>=1.1.1 in /nix/store/4xa51ywd5l0xyk420hmbbg6g6aknx8wd-python3.7-mergedeep-1.3.0/lib/python3.7/site-packages (from datasette==0.46) (1.3.0)  Requirement already satisfied: Jinja2<2.12.0,>=2.10.3 in /nix/store/clqg7xjwx0a90x6z8ilj0w7rg8p9ijy1-python3.7-Jinja2-2.11.2/lib/python3.7/site-packages (from datasette==0.46) (2.11.2)
  Requirement already satisfied: click in /nix/store/ywihhcx51bp3vchv87v8c5v7m7lm3f0i-python3.7-click-7.1.2/lib/python3.7/site-packages (from datasette==0.46) (7.1.2)
  Requirement already satisfied: aiofiles<0.6,>=0.4 in /nix/store/hvj26yd8f2lpqpk0mbs6xc97wsgsk6vv-python3.7-aiofiles-0.5.0/lib/python3.7/site-packages (from datasette==0.46) (0.5.0)
  ERROR: Could not find a version that satisfies the requirement janus<0.6,>=0.4 (from datasette==0.46) (from versions: none)
  ERROR: No matching distribution found for janus<0.6,>=0.4 (from datasette==0.46)
builder for '/nix/store/gkfmlma0dxw13zb2pg3km6nz5zzy0a31-python3.8-datasette-0.46.drv' failed with exit code 1; last 10 log lines:
  Requirement already satisfied: pint in /nix/store/yddmw7iwpzx8g485lyyma6bmjp3gykz5-python3.8-pint-0.14/lib/python3.8/site-packages (from datasette==0.46) (0.14)
  Requirement already satisfied: click-default-group in /nix/store/4cwf51xkfl1874kxn82h0bgz87bapzw4-python3.8-click-default-group-1.2.2/lib/python3.8/site-packages (from datasette==0.46) (1.2.2)
  Requirement already satisfied: Jinja2<2.12.0,>=2.10.3 in /nix/store/30fs2rcjszy2f0ymnm4m41c6r0c20110-python3.8-Jinja2-2.11.2/lib/python3.8/site-packages (from datasette==0.46) (2.11.2)
  Requirement already satisfied: mergedeep<1.4.0,>=1.1.1 in /nix/store/f5rabr9r04g8058dl01l5dly5gdwkkqs-python3.8-mergedeep-1.3.0/lib/python3.8/site-packages (from datasette==0.46) (1.3.0)  Requirement already satisfied: itsdangerous~=1.1 in /nix/store/2cqwybdwn6qhb6aqjcgmjw1gp3zv5xp1-python3.8-itsdangerous-1.1.0/lib/python3.8/site-packages (from datasette==0.46) (1.1.0)
  Requirement already satisfied: uvicorn in /nix/store/kzqkbscwifa4fnkxw131yw8pkfyppw67-python3.8-uvicorn-0.11.5/lib/python3.8/site-packages (from datasette==0.46) (0.11.5)
  Requirement already satisfied: aiofiles<0.6,>=0.4 in /nix/store/72zngqcsmzq46lvl5nx1danqv8qrfppl-python3.8-aiofiles-0.5.0/lib/python3.8/site-packages (from datasette==0.46) (0.5.0)
  Requirement already satisfied: PyYAML in /nix/store/2a8chkkhm9s2a4vdfn1ffaw56lgvms6k-python3.8-PyYAML-5.3.1/lib/python3.8/site-packages (from datasette==0.46) (5.3.1)
  ERROR: Could not find a version that satisfies the requirement janus<0.6,>=0.4 (from datasette==0.46) (from versions: none)
  ERROR: No matching distribution found for janus<0.6,>=0.4 (from datasette==0.46)
cannot build derivation '/nix/store/gmh3g5nxxyl40f7xgnjikg435yz7kals-env.drv': 2 dependencies couldn't be built

@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Jan 20, 2021

newer version on master

@r-ryantm r-ryantm deleted the auto-update/python3.7-janus branch Jan 21, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants