Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

abseil-cpp: 20200225.2 -> 20200923.1 #100827

Closed
wants to merge 1 commit into from

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Oct 17, 2020

Automatic update generated by nixpkgs-update tools. This update was made based on information from https://github.com/abseil/abseil-cpp/releases.

meta.description for abseil-cpp is: "An open-source collection of C++ code designed to augment the C++ standard library"

meta.homepage for abseil-cpp is: "https://abseil.io/"

meta.changelog for abseil-cpp is: ""

Updates performed
  • Version update
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
73 total rebuild path(s)

38 package rebuild(s)

38 x86_64-linux rebuild(s)
13 i686-linux rebuild(s)
9 x86_64-darwin rebuild(s)
13 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
abseil-cpp
google-cloud-cpp
grpc
linuxPackages-libre.sysdig
linuxPackages.sysdig
linuxPackages_4_14.sysdig
linuxPackages_4_19.sysdig
linuxPackages_4_4.sysdig
linuxPackages_4_9.sysdig
linuxPackages_5_4.sysdig
linuxPackages_5_8.sysdig
linuxPackages_5_9.sysdig
linuxPackages_hardened.sysdig
linuxPackages_hardkernel_4_14.sysdig
linuxPackages_hardkernel_latest.sysdig
linuxPackages_latest-libre.sysdig
linuxPackages_latest.sysdig
linuxPackages_latest_hardened.sysdig
linuxPackages_latest_xen_dom0.sysdig
linuxPackages_latest_xen_dom0_hardened.sysdig
linuxPackages_testing_bcachefs.sysdig
linuxPackages_xen_dom0.sysdig
linuxPackages_xen_dom0_hardened.sysdig
linuxPackages_zen.sysdig
murmur
or-tools
python27Packages.ortools
python37Packages.mask-rcnn
python37Packages.ortools
python37Packages.tensorflow-build_2
python37Packages.tensorflow_2
python38Packages.mask-rcnn
python38Packages.ortools
python38Packages.tensorflow-build_2
python38Packages.tensorflow_2
rippled
rippled-validator-keys-tool
sysdig
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/brrd48aksa2aqicgk6hii7y4z6zr9ic8-abseil-cpp-20200923.1 \
  --option binary-caches 'https://cache.nixos.org/ https://nix-community.cachix.org/' \
  --option trusted-public-keys '
  nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(The Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A abseil-cpp https://github.com/r-ryantm/nixpkgs/archive/603af7a8c70d1fb5d279015486b4bbb4a2c30729.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/brrd48aksa2aqicgk6hii7y4z6zr9ic8-abseil-cpp-20200923.1
ls -la /nix/store/brrd48aksa2aqicgk6hii7y4z6zr9ic8-abseil-cpp-20200923.1/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

8 packages failed to build:
  • google-cloud-cpp
  • murmur (murmur_git)
  • or-tools
  • python27Packages.ortools
  • python37Packages.ortools
  • python38Packages.ortools
  • rippled
  • rippled-validator-keys-tool
24 packages built:
  • abseil-cpp
  • grpc
  • linuxPackages-libre.sysdig
  • linuxPackages.sysdig
  • linuxPackages_4_14.sysdig
  • linuxPackages_4_19.sysdig
  • linuxPackages_4_4.sysdig
  • linuxPackages_4_9.sysdig
  • linuxPackages_5_8.sysdig
  • linuxPackages_5_9.sysdig
  • linuxPackages_hardened.sysdig
  • linuxPackages_latest-libre.sysdig
  • linuxPackages_latest_hardened.sysdig
  • linuxPackages_latest_xen_dom0.sysdig
  • linuxPackages_latest_xen_dom0_hardened.sysdig
  • linuxPackages_testing_bcachefs.sysdig
  • linuxPackages_xen_dom0.sysdig
  • linuxPackages_xen_dom0_hardened.sysdig
  • linuxPackages_zen.sysdig
  • python37Packages.mask-rcnn
  • python37Packages.tensorflow-build_2
  • python38Packages.mask-rcnn
  • python38Packages.tensorflow-build_2
  • sysdig

Maintainer pings

cc @andersk for testing.

Copy link
Contributor

@andersk andersk left a comment

This breaks or-tools 7.7, so we should upgrade or-tools to 8.0 at the same time.

Cc maintainers of other packages that would break:

@andersk
Copy link
Contributor

@andersk andersk commented Oct 18, 2020

The or-tools 8.0 release notes call out that or-tools now requires abseil-cpp to be built in C++17 mode, and I’ve empirically confirmed that this is needed.

--- a/pkgs/development/libraries/abseil-cpp/default.nix
+++ b/pkgs/development/libraries/abseil-cpp/default.nix
@@ -13,6 +13,8 @@ stdenv.mkDerivation rec {

   nativeBuildInputs = [ cmake ];

+  cmakeFlags = [ "-DCMAKE_CXX_STANDARD=17" ];
+
   meta = with stdenv.lib; {
     description = "An open-source collection of C++ code designed to augment the C++ standard library";
     homepage = "https://abseil.io/";

We’ll need to check if this will work for other abseil-cpp dependents, or if we need to make this a parameter…

@RaghavSood
Copy link
Member

@RaghavSood RaghavSood commented Oct 18, 2020

Thanks for catching that @andersk - I'll check on rippled today

@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Jan 19, 2021

Replaced by #107846

@r-ryantm r-ryantm deleted the auto-update/abseil-cpp branch Jan 21, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants