Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python37Packages.dominate: 2.5.2 -> 2.6.0 #101903

Merged
merged 1 commit into from Oct 28, 2020

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Oct 28, 2020

Automatic update generated by nixpkgs-update tools. This update was made based on information from passthru.updateScript.

meta.description for python37Packages.dominate is: "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API"

meta.homepage for python37Packages.dominate is: "https://github.com/Knio/dominate/"

meta.changelog for python37Packages.dominate is: ""

Updates performed
  • Ran passthru.UpdateScript
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
27 total rebuild path(s)

7 package rebuild(s)

7 x86_64-linux rebuild(s)
7 i686-linux rebuild(s)
6 x86_64-darwin rebuild(s)
7 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
buku
python27Packages.dominate
python27Packages.flask-bootstrap
python37Packages.dominate
python37Packages.flask-bootstrap
python38Packages.dominate
python38Packages.flask-bootstrap
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/pgsbfhfyffa4l241psi3ygikpjq9zyxz-python3.7-dominate-2.6.0 \
  --option binary-caches 'https://cache.nixos.org/ https://nix-community.cachix.org/' \
  --option trusted-public-keys '
  nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(The Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A python37Packages.dominate https://github.com/r-ryantm/nixpkgs/archive/c49501fcc72f457c25f135058c37ad46101cbbee.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/pgsbfhfyffa4l241psi3ygikpjq9zyxz-python3.7-dominate-2.6.0
ls -la /nix/store/pgsbfhfyffa4l241psi3ygikpjq9zyxz-python3.7-dominate-2.6.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

7 packages built:
  • buku
  • python27Packages.dominate
  • python27Packages.flask-bootstrap
  • python37Packages.dominate
  • python37Packages.flask-bootstrap
  • python38Packages.dominate
  • python38Packages.flask-bootstrap

Maintainer pings
@r-ryantm r-ryantm requested review from FRidh and jonringer as code owners Oct 28, 2020
@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Oct 28, 2020

Ofborg where are you?

@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Oct 28, 2020

Result of nixpkgs-review pr 101903 1 run on x86_64-darwin

6 packages built:
  • python27Packages.dominate
  • python27Packages.flask-bootstrap
  • python37Packages.dominate
  • python37Packages.flask-bootstrap
  • python38Packages.dominate
  • python38Packages.flask-bootstrap

Copy link
Contributor

@jonringer jonringer left a comment

LGTM

Result of nixpkgs-review pr 101903 1

7 packages built:
  • buku
  • python27Packages.dominate
  • python27Packages.flask-bootstrap
  • python37Packages.dominate
  • python37Packages.flask-bootstrap
  • python38Packages.dominate
  • python38Packages.flask-bootstrap

@jonringer jonringer merged commit 31d68e0 into NixOS:master Oct 28, 2020
2 of 3 checks passed
@r-ryantm r-ryantm deleted the auto-update/python3.7-dominate branch Oct 29, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants