Skip to content

Loading…

git: Update to 1.9.0 #1747

Closed
wants to merge 1 commit into from

4 participants

@linquize

No description provided.

@bjornfor

Pushed to master.

@bjornfor bjornfor closed this
@linquize linquize deleted the linquize:git-1.9.0 branch
@vizanto
 /nix/store/amwxl4679nv99xpfznlhwzjpg62bh3wi-git-1.9.0/libexec/git-core/git-submodule: line 552: git reset: command not found
@linquize

@vizanto
export PATH=/nix/store/amwxl4679nv99xpfznlhwzjpg62bh3wi-git-1.9.0:$PATH
git submodule foreach 'git reset --hard'
No problem for me.

@vizanto

Adding the root of git nixpkg to PATH? That doesn't seem right.

@vizanto

Btw I just rolled back to 1.8.5.2 which has no problems. 5b41db9
Might be a bug in git itself?

@linquize

I also tried
/nix/store/amwxl4679nv99xpfznlhwzjpg62bh3wi-git-1.9.0/bin/git submodule foreach '/nix/store/amwxl4679nv99xpfznlhwzjpg62bh3wi-git-1.9.0/bin/git reset --hard'
and it succeeded.

I also tried nix-env -i -f . -A git and then git submodule foreach 'git reset --hard'.
No problem.

@peti
Official Nix/Nixpkgs/NixOS member

Git 1.9.0 works just fine for me:

[simons@work:/tmp/mini-httpd]$ git --version
git version 1.9.0

[simons@work:/tmp/mini-httpd]$ git submodule foreach pwd
Entering 'libscheduler'
/tmp/mini-httpd/libscheduler
@vizanto

Odd. Git submodule command was run by Jenkins. Maybe it's a shell argument quoting difference, as they changed some of that in 1.9.0 in the submodule command.

This is the Jenkins log output with 1.9.0:

11:35:04 Resetting working tree
11:35:05 FATAL: Command "submodule foreach --recursive git reset --hard" returned status code 1:

Note the unquoted git reset --hard

No problems with 1.8.5.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Feb 15, 2014
  1. @linquize

    git: Update to 1.9.0

    linquize committed
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 2 deletions.
  1. +2 −2 pkgs/applications/version-management/git-and-tools/git/default.nix
View
4 pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -10,7 +10,7 @@
let
- version = "1.8.5.4";
+ version = "1.9.0";
svn = subversionClient.override { perlBindings = true; };
@@ -21,7 +21,7 @@ stdenv.mkDerivation {
src = fetchurl {
url = "http://git-core.googlecode.com/files/git-${version}.tar.gz";
- sha256 = "062z4j4hfhfdlvkxs2mzarsyvbqvfy4kv8j5h4c75ymb5yp8iklk";
+ sha256 = "10lq71vrg1zbqm923wb0p36ily6y5x057f2bryk4wqkdqgyrfc6y";
};
patches = [ ./docbook2texi.patch ./symlinks-in-bin.patch ];
Something went wrong with that request. Please try again.