New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

glava: 1.5.1 -> 1.5.5 #48086

Merged
merged 1 commit into from Oct 11, 2018

Conversation

Projects
None yet
3 participants
@eadwu
Contributor

eadwu commented Oct 8, 2018

Motivation for this change
Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nox --run "nox-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Fits CONTRIBUTING.md.

@eadwu eadwu changed the title from glava: 1.5.1 -> 1.5.3 to glava: 1.5.1 -> 1.5.4 Oct 9, 2018

@xeji

This comment has been minimized.

Contributor

xeji commented Oct 10, 2018

@GrahamcOfBorg build glava

@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 10, 2018

Unexpected error: command failed with exit code 1 on x86_64-linux (full log)

Attempted: glava

Partial log (click to expand)

remote: Counting objects: 100% (76/76), done.
remote: Compressing objects: 100% (69/69), done.
remote: Total 76 (delta 10), reused 34 (delta 3), pack-reused 0
From https://github.com/Dav1dde/glad
 * tag               v0.1.24    -> FETCH_HEAD
Switched to a new branch 'fetchgit'
removing `.git'...
fixed-output derivation produced path '/nix/store/5msba2vm2jqbw28vnl4zxbcnd6wp23wk-glava' with sha256 hash '10b977dap71af7jx73z15qws9ybxvrrl2s143r3hf5xpgf2s8c14' instead of the expected hash '0y5nz51r5brxs0xc100ingfrm96kl49gwnslhscvfxwwqrb6g1p1'
cannot build derivation '/nix/store/hhyb3jkbf0x4d61n8a44mz8ill69kicr-glava-1.5.4.drv': 1 dependencies couldn't be built
error: build of '/nix/store/hhyb3jkbf0x4d61n8a44mz8ill69kicr-glava-1.5.4.drv' failed

@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 10, 2018

Unexpected error: command failed with exit code 1 on aarch64-linux (full log)

Attempted: glava

Partial log (click to expand)

remote: Counting objects: 100% (76/76), done.
remote: Compressing objects: 100% (69/69), done.
remote: Total 76 (delta 10), reused 34 (delta 3), pack-reused 0
From https://github.com/Dav1dde/glad
 * tag               v0.1.24    -> FETCH_HEAD
Switched to a new branch 'fetchgit'
removing `.git'...
fixed-output derivation produced path '/nix/store/5msba2vm2jqbw28vnl4zxbcnd6wp23wk-glava' with sha256 hash '10b977dap71af7jx73z15qws9ybxvrrl2s143r3hf5xpgf2s8c14' instead of the expected hash '0y5nz51r5brxs0xc100ingfrm96kl49gwnslhscvfxwwqrb6g1p1'
cannot build derivation '/nix/store/xa3dmx7ry1zjp4paqlz8ybh6v4s4ahk5-glava-1.5.4.drv': 1 dependencies couldn't be built
error: build of '/nix/store/xa3dmx7ry1zjp4paqlz8ybh6v4s4ahk5-glava-1.5.4.drv' failed

@xeji

This comment has been minimized.

Contributor

xeji commented Oct 10, 2018

hash mismatch (in a git submodule?)

@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 10, 2018

No attempt on x86_64-darwin (full log)

The following builds were skipped because they don't evaluate on x86_64-darwin: glava

Partial log (click to expand)


a) For `nixos-rebuild` you can set
  { nixpkgs.config.allowUnsupportedSystem = true; }
in configuration.nix to override this.

b) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
  { allowUnsupportedSystem = true; }
to ~/.config/nixpkgs/config.nix.


@eadwu eadwu changed the title from glava: 1.5.1 -> 1.5.4 to glava: 1.5.1 -> 1.5.5 Oct 11, 2018

@eadwu

This comment has been minimized.

Contributor

eadwu commented Oct 11, 2018

With versions 1.5.4+, the glad submodule isn't needed anymore, though I'll just use the hash generated from --fetch-submodules then.

@xeji

This comment has been minimized.

Contributor

xeji commented Oct 11, 2018

@GrahamcOfBorg build glava

@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 11, 2018

Success on x86_64-linux (full log)

Attempted: glava

Partial log (click to expand)

'shaders/util' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/util'
'shaders/util/premultiply.frag' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/util/premultiply.frag'
'shaders/util/smooth.glsl' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/util/smooth.glsl'
'shaders/util/smooth_pass.frag' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/util/smooth_pass.frag'
'shaders/wave' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/wave'
'shaders/wave/1.frag' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/wave/1.frag'
'shaders/wave/2.frag' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/wave/2.frag'
'shaders/wave.glsl' -> '/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5/etc/xdg/glava/wave.glsl'
post-installation fixup
/nix/store/ibf0qsaq7c4iv9dl154bgs04hybi1kjp-glava-1.5.5

@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 11, 2018

Success on aarch64-linux (full log)

Attempted: glava

Partial log (click to expand)

'shaders/util' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/util'
'shaders/util/premultiply.frag' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/util/premultiply.frag'
'shaders/util/smooth.glsl' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/util/smooth.glsl'
'shaders/util/smooth_pass.frag' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/util/smooth_pass.frag'
'shaders/wave' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/wave'
'shaders/wave/1.frag' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/wave/1.frag'
'shaders/wave/2.frag' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/wave/2.frag'
'shaders/wave.glsl' -> '/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5/etc/xdg/glava/wave.glsl'
post-installation fixup
/nix/store/mkc5dlwdi2bkbdlc90883f7pgsjrfhbf-glava-1.5.5

@xeji

This comment has been minimized.

Contributor

xeji commented Oct 11, 2018

With versions 1.5.4+, the glad submodule isn't needed anymore, though I'll just use the hash generated from --fetch-submodules then.

That's fine for now. We generally prefer fetchFromGitHub (which does not fetch submodules by default) for fetching from Github repos. I suggest you change that with the next update.

@xeji xeji merged commit 1c0c0cb into NixOS:master Oct 11, 2018

8 checks passed

grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-nixos-manual nix-instantiate ./nixos/release.nix -A manual
Details
grahamcofborg-eval-nixos-options nix-instantiate ./nixos/release.nix -A options
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate ./pkgs/top-level/release.nix -A manual
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate ./pkgs/top-level/release.nix -A tarball
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate ./pkgs/top-level/release.nix -A unstable
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
@GrahamcOfBorg

This comment has been minimized.

GrahamcOfBorg commented Oct 11, 2018

No attempt on x86_64-darwin (full log)

The following builds were skipped because they don't evaluate on x86_64-darwin: glava

Partial log (click to expand)


a) For `nixos-rebuild` you can set
  { nixpkgs.config.allowUnsupportedSystem = true; }
in configuration.nix to override this.

b) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
  { allowUnsupportedSystem = true; }
to ~/.config/nixpkgs/config.nix.


Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment