Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ocamlPackages.opti: init at 1.0.3 #51033

Merged
merged 1 commit into from Dec 2, 2018

Conversation

Projects
None yet
5 participants
@magnusjonsson
Copy link
Contributor

magnusjonsson commented Nov 25, 2018

Motivation for this change

Help promote nix at work by making this package available.

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions (Arch Linux)
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nox --run "nox-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Assured whether relevant documentation is up to date
  • Fits CONTRIBUTING.md.

@magnusjonsson

This comment has been minimized.

Copy link
Contributor Author

magnusjonsson commented Nov 25, 2018

Hi, this is my first pull request to this project so please bear with me :). Happy to make any changes or additional testing if needed. Thanks!

@vbgl

This comment has been minimized.

Copy link
Contributor

vbgl commented Nov 25, 2018

@GrahamcOfBorg build ocamlPackages.opti

@vbgl vbgl added the 6.topic: ocaml label Nov 25, 2018

@GrahamcOfBorg

This comment has been minimized.

Copy link

GrahamcOfBorg commented Nov 25, 2018

Success on aarch64-linux (full log)

Attempted: ocamlPackages.opti

Partial log (click to expand)

Processing file opti.install as opti.
post-installation fixup
moving /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3/doc to /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3/share/doc
shrinking RPATHs of ELF executables and libraries in /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3
shrinking /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3/bin/opti
strip is /nix/store/6dpnd5aniypn8124mmy8f88s4mq2zl07-binutils-2.30/bin/strip
stripping (with command strip and flags -S) in /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3/lib  /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3/bin
patching script interpreter paths in /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3
checking for references to /build in /nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3...
/nix/store/fdapd4i3fcjjdhx8s0wbbjk9rv4xqpqx-ocaml4.06.1-opti-1.0.3

@GrahamcOfBorg

This comment has been minimized.

Copy link

GrahamcOfBorg commented Nov 25, 2018

Success on x86_64-linux (full log)

Attempted: ocamlPackages.opti

Partial log (click to expand)

Processing file opti.install as opti.
post-installation fixup
moving /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3/doc to /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3/share/doc
shrinking RPATHs of ELF executables and libraries in /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3
shrinking /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3/bin/opti
strip is /nix/store/rpbg8gmqxhz8g61p1plz5d2srs84pvmv-binutils-2.30/bin/strip
stripping (with command strip and flags -S) in /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3/lib  /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3/bin
patching script interpreter paths in /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3
checking for references to /build in /nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3...
/nix/store/a9acwf4kvpccpiqn7z6hgpvbv1k8p7bi-ocaml4.06.1-opti-1.0.3

@GrahamcOfBorg

This comment has been minimized.

Copy link

GrahamcOfBorg commented Nov 25, 2018

Success on x86_64-darwin (full log)

Attempted: ocamlPackages.opti

Partial log (click to expand)

   ocamlyacc lib/parser.{ml,mli}
1 rule never reduced
installing
Processing file opti.install as opti.
post-installation fixup
moving /nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3/doc to /nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3/share/doc
strip is /nix/store/rk3p99jbj4idl3dkkg1rxja5gz0qgs98-cctools-binutils-darwin/bin/strip
stripping (with command strip and flags -S) in /nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3/lib  /nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3/bin
patching script interpreter paths in /nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3
/nix/store/ninlqpx2054fqsim84rv2wd4ii1mm9vp-ocaml4.06.1-opti-1.0.3

Show resolved Hide resolved pkgs/development/ocaml-modules/opti/default.nix Outdated

@magnusjonsson magnusjonsson force-pushed the magnusjonsson:master branch to 1d5bc15 Dec 2, 2018

@magnusjonsson

This comment has been minimized.

Copy link
Contributor Author

magnusjonsson commented Dec 2, 2018

I believe this is ready to be merged.

@kalbasit kalbasit merged commit d23acab into NixOS:master Dec 2, 2018

9 checks passed

grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./nixos/release.nix -A manual
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./nixos/release.nix -A options
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A manual
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A tarball
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A unstable
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.