Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

libtorrentRasterbar: 1.1.11 -> 1.2.0 #54179

Closed

Conversation

@r-ryantm
Copy link
Contributor

commented Jan 17, 2019

Semi-automatic update generated by https://github.com/ryantm/nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/libtorrent-rasterbar/versions.

meta.description for libtorrentRasterbar is: '"A C++ BitTorrent implementation focusing on efficiency and scalability"'.

Release on GitHub

Compare changes on GitHub

Checks done (click to expand)
Rebuild report (if merged into master) (click to expand)

28 total rebuild path(s)

9 package rebuild(s)

9 x86_64-linux rebuild(s)
8 i686-linux rebuild(s)
4 x86_64-darwin rebuild(s)
7 aarch64-linux rebuild(s)

First fifty rebuilds by attrpath
btfs
deluge
kodiPlugins.yatp
libtorrentRasterbar
python27Packages.libtorrentRasterbar
python37Packages.libtorrentRasterbar
qbittorrent
springLobby
tribler

Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/zy84gv4ssxcq4l826wpfqgvb3j5bp01i-libtorrent-rasterbar-1.2.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)

Or, build yourself:

nix-build -A libtorrentRasterbar https://github.com/r-ryantm/nixpkgs/archive/4bd3671f5db2eeac836614932a9ad7f4de7f1164.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/zy84gv4ssxcq4l826wpfqgvb3j5bp01i-libtorrent-rasterbar-1.2.0
ls -la /nix/store/zy84gv4ssxcq4l826wpfqgvb3j5bp01i-libtorrent-rasterbar-1.2.0/bin

cc @Phreedom for testing.

libtorrentRasterbar: 1.1.11 -> 1.2.0
Semi-automatic update generated by
https://github.com/ryantm/nixpkgs-update tools. This update was made
based on information from
https://repology.org/metapackage/libtorrent-rasterbar/versions
@Infinisil

This comment has been minimized.

Copy link
Member

commented Jan 24, 2019

@GrahamcOfBorg build deluge tribler qbittorrent

@zookatron

This comment has been minimized.

Copy link
Contributor

commented Apr 10, 2019

@Phreedom

I tested out three of the major reverse dependencies of this library on x86_64-linux: Deluge, qBittorrent, and Tribler.

Deluge builds but does not run with this version of the library because it still uses the session_settings API that was removed in this release of the library and was previously deprecated. It looks like the in-development 2.0 version of Deluge will fix this in the future though.

qBittorrent does not build because the base/bittorrent/infohash.h file in the sources was incorrectly just including libtorrent/sha1_hash.hpp which used to include libtorrent/hex.hpp which has the to_hex and from_hex function that it makes use of, and was removed from libtorrent/sha1_hash.hpp in 1.2.0. It should have been including libtorrent/hex.hpp directly. There is a pull request open in the qBittorrent project to update the project sources to fully work with libtorrent 1.2.0 though: qbittorrent/qBittorrent#9704

Tribler builds but does not run due to it using the libtorrent.create_metadata_plugin python attribute which appears to have been renamed to libtorrent.create_ut_metadata_plugin in 1.2.0. This has been fixed on the devel branch of the Tribler GitHub repo and they have a pull request open for remaining fixes needed to support libtorrent 1.2.0 though, so it's likely we'll see a new release with support for this version of the library soon: Tribler/tribler#4396

All in all, I feel safe saying that NixOS is not ready for libtorrent 1.2.0 yet unless we want to have a separate 1.1.X version of the package for these packages to use.

@nixos-discourse

This comment has been minimized.

Copy link

commented Apr 10, 2019

This pull request has been mentioned on Nix community. There might be relevant details there:

https://discourse.nixos.org/t/discussion-pr-reviews/2619/26

@nixos-discourse

This comment has been minimized.

Copy link

commented Apr 10, 2019

This pull request has been mentioned on Nix community. There might be relevant details there:

https://discourse.nixos.org/t/prs-already-reviewed/2617/17

@dtzWill

This comment has been minimized.

Copy link
Contributor

commented Jul 9, 2019

in all, I feel safe saying that NixOS is not ready for libtorrent 1.2.0 yet unless we want to have a separate 1.1.X version of the package for these packages to use.

deluge ( #64542) seems good with newer libtorrent, but haven''t looked at others--hopefully if they've seen updates it'll include compat here fingers crossed :).

@globin

This comment has been minimized.

Copy link
Member

commented Aug 4, 2019

closing in favour of #64496

@globin globin closed this Aug 4, 2019

@r-ryantm r-ryantm deleted the r-ryantm:auto-update/libtorrent-rasterbar branch Aug 17, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.