Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dune: 1.6.2 -> 1.6.3 #54852

Closed
wants to merge 1 commit into from

Conversation

Projects
None yet
4 participants
@r-ryantm
Copy link
Contributor

commented Jan 28, 2019

Semi-automatic update generated by https://github.com/ryantm/nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/dune/versions.

meta.description for dune is: '"A composable build system"'.

Checks done (click to expand)
Rebuild report (if merged into master) (click to expand)

70 total rebuild path(s)

19 package rebuild(s)

19 x86_64-linux rebuild(s)
18 i686-linux rebuild(s)
16 x86_64-darwin rebuild(s)
17 aarch64-linux rebuild(s)

First fifty rebuilds by attrpath
acgtk
beluga
dune
eff
flow
fstar
google-drive-ocamlfuse
jackline
libbap
liquidsoap
ocaml-top
ocamlformat
patdiff
pyre
reason
satysfi
stog
trv
virt-top

Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/gdvqwp9jwkii0hflqr6lq0qicy3fqj4w-dune-1.6.3 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)

Or, build yourself:

nix-build -A dune https://github.com/r-ryantm/nixpkgs/archive/4ba89bbbb129b1f5b5e7a151d6d6bf776c2501e8.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/gdvqwp9jwkii0hflqr6lq0qicy3fqj4w-dune-1.6.3
ls -la /nix/store/gdvqwp9jwkii0hflqr6lq0qicy3fqj4w-dune-1.6.3/bin

cc @vbgl for testing.

dune: 1.6.2 -> 1.6.3
Semi-automatic update generated by
https://github.com/ryantm/nixpkgs-update tools. This update was made
based on information from
https://repology.org/metapackage/dune/versions
@Infinisil

This comment has been minimized.

Copy link
Contributor

commented Jan 28, 2019

@vbgl

This comment has been minimized.

Copy link
Contributor

commented Jan 29, 2019

@GrahamcOfBorg build ocaml-top

@vbgl vbgl closed this Jan 29, 2019

@Infinisil

This comment has been minimized.

Copy link
Contributor

commented Jan 29, 2019

@vbgl Why closing?

@vbgl

This comment has been minimized.

Copy link
Contributor

commented Feb 1, 2019

This breaks ocaml-top (see https://logs.nix.ci/?key=nixos/nixpkgs.54852&attempt_id=f692e52c-2014-4c94-9cc0-9fbca8e16f5c).

Is someone willing to investigate the issue?

@r-ryantm r-ryantm deleted the r-ryantm:auto-update/dune branch Feb 3, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.