Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

qutebrowser: 1.5.2 -> 1.6.0 #56349

Merged
merged 1 commit into from Feb 28, 2019
Merged

qutebrowser: 1.5.2 -> 1.6.0 #56349

merged 1 commit into from Feb 28, 2019

Conversation

@dotlambda
Copy link
Member

dotlambda commented Feb 25, 2019

Motivation for this change

https://github.com/qutebrowser/qutebrowser/releases/tag/v1.6.0

I have not tested pdf.js.

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nox --run "nox-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Assured whether relevant documentation is up to date
  • Fits CONTRIBUTING.md.

@dotlambda

This comment has been minimized.

Copy link
Member Author

dotlambda commented Feb 25, 2019

I'm getting

WARNING: Combining PyQt 5.11.3 with Qt 5.12.0 is unsupported! Ensure all versions are newer than 5.12 to avoid potential issues.

That should be fixed once we upgrade our PyQt version.

@xeji
xeji approved these changes Feb 25, 2019
Copy link
Contributor

xeji left a comment

Same warning here, but seems to work.

@xeji

This comment has been minimized.

Copy link
Contributor

xeji commented Feb 25, 2019

@dotlambda does it make sense to merge this now without the pyqt5 update to get it into 19.03 ?

@dotlambda

This comment has been minimized.

Copy link
Member Author

dotlambda commented Feb 25, 2019

I guess so because the version difference between between qt5 and pyqt5 is independent from the upgrade.

@xeji xeji merged commit c60d946 into NixOS:master Feb 28, 2019
13 checks passed
13 checks passed
qutebrowser on x86_64-darwin No attempt
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./nixos/release.nix -A manual
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./nixos/release.nix -A options
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A manual
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A tarball
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./pkgs/top-level/release.nix -A unstable
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
qutebrowser on aarch64-linux Success
Details
qutebrowser on x86_64-linux Success
Details
fpletz added a commit that referenced this pull request Mar 2, 2019
(cherry picked from commit c60d946)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.