Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

hpack-convert: 1.0.1 -> 1.0.2 #59438

Closed
wants to merge 1 commit into from

Conversation

@expipiplus1
Copy link
Contributor

expipiplus1 commented Apr 14, 2019

1.0.1 does not compile with the current package set

Motivation for this change
Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nix-review --run "nix-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Assured whether relevant documentation is up to date
  • Fits CONTRIBUTING.md.

@aanderse
Copy link
Contributor

aanderse commented May 12, 2019

@expipiplus1 Could you please rebase this?
@basvandijk Are you able to review?

@expipiplus1 expipiplus1 force-pushed the expipiplus1:joe-fix-hpack-convert branch from fd28f02 to decc031 May 12, 2019
@expipiplus1
Copy link
Contributor Author

expipiplus1 commented May 12, 2019

@aanderse rebased

1.0.1 does not compile with the current package set
@expipiplus1 expipiplus1 force-pushed the expipiplus1:joe-fix-hpack-convert branch from decc031 to 33c78e4 May 12, 2019
# Get hpack-convert to compile with the versions of its dependencies in nixpkgs.
# The tests are still broken
hpack-convert = dontCheck (overrideSrc super.hpack-convert {
version = "1.0.2";

This comment has been minimized.

Copy link
@Infinisil

Infinisil May 13, 2019

Member

As far as I can see, 1.0.2 is not released? https://github.com/yamadapc/hpack-convert/releases

@aanderse
Copy link
Contributor

aanderse commented May 16, 2019

@expipiplus1
Copy link
Contributor Author

expipiplus1 commented May 16, 2019

@Infinisil
Copy link
Member

Infinisil commented May 16, 2019

I suggest to only use the patch that actually fixes the error. What is the error anyways?

And the package in nixpkgs will automatically be updated to the newest version once released on hackage.

@expipiplus1
Copy link
Contributor Author

expipiplus1 commented May 22, 2019

@Infinisil by patch, I meant the same code but expressed as a patch against what's on hackage instead of a reference to a git tree, so no real difference.

The error, just bitrot:

 $ nix-build '<nixpkgs>' -A haskellPackages.hpack-convert
these derivations will be built:
  /nix/store/mdr6q7jac873q0xi3mp3nscchkfjfl65-hpack-convert-1.0.1.drv
building '/nix/store/mdr6q7jac873q0xi3mp3nscchkfjfl65-hpack-convert-1.0.1.drv'...
setupCompilerEnvironmentPhase
Build with /nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5.
unpacking sources
unpacking source archive /nix/store/9sr13hnrp7xqdw0sjpdhsgns43xh46mq-hpack-convert-1.0.1.tar.gz
source root is hpack-convert-1.0.1
setting SOURCE_DATE_EPOCH to timestamp 1498167964 of file hpack-convert-1.0.1/hpack-convert.cabal
patching sources
compileBuildDriverPhase
setupCompileFlags: -package-db=/tmp/nix-build-hpack-convert-1.0.1.drv-0/setup-package.conf.d -j4 -threaded
[1 of 1] Compiling Main             ( Setup.lhs, /tmp/nix-build-hpack-convert-1.0.1.drv-0/Main.o )
Linking Setup ...
configuring
configureFlags: --verbose --prefix=/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1 --libdir=$prefix/lib/$compiler --libsubdir=$abi/$libname --docdir=/nix/store/c2yyxvmdizjqj2c41p04jp4vba6hkgf9-hpack-convert-1.0.1-doc/share/doc/hpack-convert-1.0.1 --with-gcc=gcc --package-db=/tmp/nix-build-hpack-convert-1.0.1.drv-0/package.conf.d --ghc-option=-j4 --disable-split-objs --enable-library-profiling --profiling-detail=exported-functions --disable-profiling --enable-shared --disable-coverage --enable-static --disable-executable-dynamic --enable-tests --disable-benchmarks --enable-library-vanilla --disable-library-for-ghci --ghc-option=-split-sections --extra-lib-dirs=/nix/store/gfwnxwkqn7lgqrjy9wdqazak5yiv39xf-ncurses-6.1-20190112/lib --extra-lib-dirs=/nix/store/ypkza8mghfl5vjj5nysg60flql03d8y2-libffi-3.2.1/lib --extra-lib-dirs=/nix/store/g8x2j5p7d4yihcsh76l3dbqsg7rfn0fr-gmp-6.1.2/lib
Using Parsec parser
Configuring hpack-convert-1.0.1...
Dependency Cabal >=1.22: using Cabal-2.4.0.1
Dependency Glob -any: using Glob-0.9.3
Dependency aeson -any: using aeson-1.4.2.0
Dependency base >=4.7 && <5: using base-4.12.0.0
Dependency base-compat >=0.8: using base-compat-0.10.5
Dependency bytestring -any: using bytestring-0.10.8.2
Dependency containers -any: using containers-0.6.0.1
Dependency deepseq -any: using deepseq-1.4.4.0
Dependency directory -any: using directory-1.3.3.0
Dependency filepath -any: using filepath-1.4.2.1
Dependency pretty -any: using pretty-1.1.3.6
Dependency split -any: using split-0.2.3.3
Dependency text -any: using text-1.2.3.1
Dependency unordered-containers >=0.2.7.1: using unordered-containers-0.2.9.0
Dependency vector -any: using vector-0.12.0.3
Dependency yaml -any: using yaml-0.11.0.0
Dependency Cabal >=1.22: using Cabal-2.4.0.1
Dependency Glob -any: using Glob-0.9.3
Dependency aeson -any: using aeson-1.4.2.0
Dependency base >=4.7 && <5: using base-4.12.0.0
Dependency base-compat >=0.8: using base-compat-0.10.5
Dependency bytestring -any: using bytestring-0.10.8.2
Dependency containers -any: using containers-0.6.0.1
Dependency deepseq -any: using deepseq-1.4.4.0
Dependency directory -any: using directory-1.3.3.0
Dependency filepath -any: using filepath-1.4.2.1
Dependency pretty -any: using pretty-1.1.3.6
Dependency split -any: using split-0.2.3.3
Dependency text -any: using text-1.2.3.1
Dependency unordered-containers >=0.2.7.1: using unordered-containers-0.2.9.0
Dependency vector -any: using vector-0.12.0.3
Dependency yaml -any: using yaml-0.11.0.0
Dependency Cabal >=1.22: using Cabal-2.4.0.1
Dependency Glob -any: using Glob-0.9.3
Dependency QuickCheck -any: using QuickCheck-2.12.6.1
Dependency aeson -any: using aeson-1.4.2.0
Dependency aeson-qq -any: using aeson-qq-0.8.2
Dependency base >=4.7 && <5: using base-4.12.0.0
Dependency base-compat >=0.8: using base-compat-0.10.5
Dependency bytestring -any: using bytestring-0.10.8.2
Dependency containers -any: using containers-0.6.0.1
Dependency deepseq -any: using deepseq-1.4.4.0
Dependency directory -any: using directory-1.3.3.0
Dependency filepath -any: using filepath-1.4.2.1
Dependency hspec ==2.*: using hspec-2.6.1
Dependency interpolate -any: using interpolate-0.2.0
Dependency mockery >=0.3: using mockery-0.3.5
Dependency pretty -any: using pretty-1.1.3.6
Dependency split -any: using split-0.2.3.3
Dependency temporary -any: using temporary-1.3
Dependency text -any: using text-1.2.3.1
Dependency unordered-containers >=0.2.7.1: using unordered-containers-0.2.9.0
Dependency vector -any: using vector-0.12.0.3
Dependency yaml -any: using yaml-0.11.0.0
Source component graph:
    component test:spec
    component exe:hpack-convert
    component lib
Configured component graph:
    component hpack-convert-1.0.1-25BcR78FdU3HKczDxbRTBJ-spec
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include QuickCheck-2.12.6.1-JyVWDgZJAFGJC5rmVxfUSm
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include aeson-qq-0.8.2-IxZHmeM1BmVH9UEeaOAq4v
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include hspec-2.6.1-LTb1DHFxhgIBvS5vnMkjZd
        include interpolate-0.2.0-Jd143B82DpODz76BOYurWM
        include mockery-0.3.5-5nxdgV6F7KpAJ9L7HhAWLd
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include temporary-1.3-CB9fHlG082HEdRH1lvSErG
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    component hpack-convert-1.0.1-Dl1f2Q2aTCFJ0YHUD9iSC6-hpack-convert
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    component hpack-convert-1.0.1-6UPflyOAng82GqGq3sNdRh
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
Linked component graph:
    unit hpack-convert-1.0.1-25BcR78FdU3HKczDxbRTBJ-spec
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include QuickCheck-2.12.6.1-JyVWDgZJAFGJC5rmVxfUSm
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include aeson-qq-0.8.2-IxZHmeM1BmVH9UEeaOAq4v
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include hspec-2.6.1-LTb1DHFxhgIBvS5vnMkjZd
        include interpolate-0.2.0-Jd143B82DpODz76BOYurWM
        include mockery-0.3.5-5nxdgV6F7KpAJ9L7HhAWLd
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include temporary-1.3-CB9fHlG082HEdRH1lvSErG
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    unit hpack-convert-1.0.1-Dl1f2Q2aTCFJ0YHUD9iSC6-hpack-convert
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    unit hpack-convert-1.0.1-6UPflyOAng82GqGq3sNdRh
        include Cabal-2.4.0.1
        include Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        include aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        include base-4.12.0.0
        include base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        include bytestring-0.10.8.2
        include containers-0.6.0.1
        include deepseq-1.4.4.0
        include directory-1.3.3.0
        include filepath-1.4.2.1
        include pretty-1.1.3.6
        include split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        include text-1.2.3.1
        include unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        include vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        include yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
        Hpack.Convert=hpack-convert-1.0.1-6UPflyOAng82GqGq3sNdRh:Hpack.Convert
Ready component graph:
    definite hpack-convert-1.0.1-Dl1f2Q2aTCFJ0YHUD9iSC6-hpack-convert
        depends Cabal-2.4.0.1
        depends Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        depends aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        depends base-4.12.0.0
        depends base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        depends bytestring-0.10.8.2
        depends containers-0.6.0.1
        depends deepseq-1.4.4.0
        depends directory-1.3.3.0
        depends filepath-1.4.2.1
        depends pretty-1.1.3.6
        depends split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        depends text-1.2.3.1
        depends unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        depends vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        depends yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    definite hpack-convert-1.0.1-6UPflyOAng82GqGq3sNdRh
        depends Cabal-2.4.0.1
        depends Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        depends aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        depends base-4.12.0.0
        depends base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        depends bytestring-0.10.8.2
        depends containers-0.6.0.1
        depends deepseq-1.4.4.0
        depends directory-1.3.3.0
        depends filepath-1.4.2.1
        depends pretty-1.1.3.6
        depends split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        depends text-1.2.3.1
        depends unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        depends vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        depends yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
    definite hpack-convert-1.0.1-25BcR78FdU3HKczDxbRTBJ-spec
        depends Cabal-2.4.0.1
        depends Glob-0.9.3-3s9l1uOjBy2Kl63YnQwmq1
        depends QuickCheck-2.12.6.1-JyVWDgZJAFGJC5rmVxfUSm
        depends aeson-1.4.2.0-JZqYuUdHBw93faVr1pymZn
        depends aeson-qq-0.8.2-IxZHmeM1BmVH9UEeaOAq4v
        depends base-4.12.0.0
        depends base-compat-0.10.5-FRXoAxOVtbG2qLNIZm1tTr
        depends bytestring-0.10.8.2
        depends containers-0.6.0.1
        depends deepseq-1.4.4.0
        depends directory-1.3.3.0
        depends filepath-1.4.2.1
        depends hspec-2.6.1-LTb1DHFxhgIBvS5vnMkjZd
        depends interpolate-0.2.0-Jd143B82DpODz76BOYurWM
        depends mockery-0.3.5-5nxdgV6F7KpAJ9L7HhAWLd
        depends pretty-1.1.3.6
        depends split-0.2.3.3-CwXUcGD2U4I4pJUogujB5u
        depends temporary-1.3-CB9fHlG082HEdRH1lvSErG
        depends text-1.2.3.1
        depends unordered-containers-0.2.9.0-9doDsrqzw7xAm9zCbYj8Qi
        depends vector-0.12.0.3-2LEYu9M2i7lERDtz76XG3n
        depends yaml-0.11.0.0-CsUjJIWremZIQFiLXvTIHp
Using Cabal-2.4.0.1 compiled by ghc-8.6
Using compiler: ghc-8.6.5
Using install prefix:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1
Executables installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/bin
Libraries installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/hpack-convert-1.0.1-6UPflyOAng82GqGq3sNdRh
Dynamic Libraries installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5
Private executables installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/libexec/x86_64-linux-ghc-8.6.5/hpack-convert-1.0.1
Data files installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/share/x86_64-linux-ghc-8.6.5/hpack-convert-1.0.1
Documentation installed in:
/nix/store/c2yyxvmdizjqj2c41p04jp4vba6hkgf9-hpack-convert-1.0.1-doc/share/doc/hpack-convert-1.0.1
Configuration files installed in:
/nix/store/ayfsqw30yp8zwz2x03xzndsqv6f9iwfh-hpack-convert-1.0.1/etc
No alex found
Using ar found on system at:
/nix/store/6k95q6vvnmspf3c0nm8q55sixsvmn9nc-binutils-2.31.1/bin/ar
No c2hs found
No cpphs found
No doctest found
Using gcc version 7.4.0 given by user at:
/nix/store/sy6cxd224k9mk64n0xx70ar2vfjin6wv-gcc-wrapper-7.4.0/bin/gcc
Using ghc version 8.6.5 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/ghc
Using ghc-pkg version 8.6.5 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/ghc-pkg
No ghcjs found
No ghcjs-pkg found
No greencard found
Using haddock version 2.22.0 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/haddock
No happy found
Using haskell-suite found on system at: haskell-suite-dummy-location
Using haskell-suite-pkg found on system at: haskell-suite-pkg-dummy-location
No hmake found
Using hpc version 0.67 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/hpc
Using hsc2hs version 0.68.5 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/hsc2hs
Using hscolour version 1.24 found on system at:
/nix/store/5yg1bdhn27p24knja0va22mjpnsanz7c-hscolour-1.24.4/bin/HsColour
No jhc found
Using ld found on system at:
/nix/store/3g4bgh46msclfldnyl9pqxfsp8980z89-binutils-wrapper-2.31.1/bin/ld
No pkg-config found
Using runghc version 8.6.5 found on system at:
/nix/store/j6av0ybqw0div0bynv9gmx9xig2x9r5p-ghc-8.6.5/bin/runghc
Using strip version 2.31 found on system at:
/nix/store/6k95q6vvnmspf3c0nm8q55sixsvmn9nc-binutils-2.31.1/bin/strip
Using tar found on system at:
/nix/store/lqdgxavfilyjn8mskv9q2k17d7hbminv-gnutar-1.32/bin/tar
No uhc found
building
Preprocessing executable 'hpack-convert' for hpack-convert-1.0.1..
Building executable 'hpack-convert' for hpack-convert-1.0.1..

on the commandline: warning:
    -fcontext-stack=100 is deprecated: use -freduction-depth=100 instead

<no location info>: warning: [-Wmissing-home-modules]
    These modules are needed for compilation but not listed in your .cabal file's other-modules:
        Paths_hpack_convert
[ 1 of 13] Compiling Hpack.GenericsUtil ( src/Hpack/GenericsUtil.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/GenericsUtil.o )
[ 2 of 13] Compiling Hpack.Haskell    ( src/Hpack/Haskell.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/Haskell.o )
[ 3 of 13] Compiling Hpack.Render     ( src/Hpack/Render.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/Render.o )
[ 4 of 13] Compiling Hpack.FormattingHints ( src/Hpack/FormattingHints.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/FormattingHints.o )
[ 5 of 13] Compiling Hpack.Util       ( src/Hpack/Util.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/Util.o )

src/Hpack/Util.hs:106:21: error:
    • Couldn't match type ‘[[FilePath]]’ with ‘([[FilePath]], b0)’
      Expected type: IO ([[FilePath]], b0)
        Actual type: IO [[FilePath]]
    • In the second argument of ‘(<$>)’, namely
        ‘globDir compiledPatterns dir’
      In the first argument of ‘(>>=)’, namely
        ‘(fst <$> globDir compiledPatterns dir)’
      In a stmt of a 'do' block:
        files <- (fst <$> globDir compiledPatterns dir)
                   >>= mapM removeDirectories
    |
106 |   files <- (fst <$> globDir compiledPatterns dir) >>= mapM removeDirectories
    |                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[ 6 of 13] Compiling Hpack.Yaml       ( src/Hpack/Yaml.hs, dist/build/hpack-convert/hpack-convert-tmp/Hpack/Yaml.o )
[11 of 13] Compiling Paths_hpack_convert ( dist/build/hpack-convert/autogen/Paths_hpack_convert.hs, dist/build/hpack-convert/hpack-convert-tmp/Paths_hpack_convert.o )
builder for '/nix/store/mdr6q7jac873q0xi3mp3nscchkfjfl65-hpack-convert-1.0.1.drv' failed with exit code 1
error: build of '/nix/store/mdr6q7jac873q0xi3mp3nscchkfjfl65-hpack-convert-1.0.1.drv' failed
@cdepillabout
Copy link
Member

cdepillabout commented May 5, 2020

This PR appears to be over a year old, so I am going to go ahead and close it.

But if you'd still like to see this fixed up, please feel free to open a new PR against the current haskell-updates branch.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

5 participants
You can’t perform that action at this time.