Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add/Update python packages #64962

Closed

Conversation

@kalbasit
Copy link
Member

@kalbasit kalbasit commented Jul 17, 2019

Motivation for this change
Things done

Updating some Python packages and adding new ones I need at work.

  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nix-review --run "nix-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 17, 2019

@GrahamcOfBorg build build h3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 17, 2019

It's failing for Darwin on ofborg. I forgot my Darwin at home so I cannot test this today.

cc @jonringer @FRidh @mwilsoninsight

clang-7: warning: argument unused during compilation: '-fno-strict-overflow' [-Wunused-command-line-argument]
[  1%] Built target format
Scanning dependencies of target h3
[  2%] Building C object CMakeFiles/h3.dir/src/h3lib/lib/algos.c.o
/tmp/nix-build-h3-3.4.4.drv-0/source/src/h3lib/include/geoCoord.h:25:10: error: 'stdio.h' file not found [clang-diagnostic-error]
#include <stdio.h>
         ^
1 error generated.
Error while processing /tmp/nix-build-h3-3.4.4.drv-0/source/src/h3lib/lib/algos.c.
Found compiler error(s).
make[2]: *** [CMakeFiles/h3.dir/build.make:63: CMakeFiles/h3.dir/src/h3lib/lib/algos.c.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1062: CMakeFiles/h3.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
builder for '/nix/store/mys53r7xganp0k9z2qqa7x04avh3sr7k-h3-3.4.4.drv' failed with exit code 2
cannot build derivation '/nix/store/4ln2ahr9sd2b8s3g4349apcsb601rbkc-python3.7-h3-3.4.3.drv': 1 dependencies couldn't be built
@jonringer
Copy link
Contributor

@jonringer jonringer commented Jul 17, 2019

im not familiar at all with h3 :(

However, stdio.h should be part of libc, I'm not sure why that isn't being looked up.

One guess would be that it's using a c++ stdlib, in which the libc headers are prefixed with c, so stdio.h would need to be referenced as cstdio.h

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 17, 2019

Perhaps h3 needs to be told to use CC, guessing from the manual. @LnL7 thoughts here?

@jonringer
Copy link
Contributor

@jonringer jonringer commented Jul 17, 2019

Since they use cmake, you can try

cmakeFlags = [
    "-DSET_STANDARD=C99"
];

my mac is at home as well.

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 18, 2019

I don't know Cmake, I need some help to fix it. I'm seeing this when I try to build it.

configuring                                                                                                                                          [110/372]
fixing cmake files...
cmake flags: -DCMAKE_FIND_PACKAGE_NO_SYSTEM_PACKAGE_REGISTRY=ON -DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY=ON -DCMAKE_EXPORT_NO_PACKAGE_REGISTRY=ON -DCMAKE_BUIL
D_TYPE=Release -DCMAKE_SKIP_BUILD_RPATH=ON -DBUILD_TESTING=OFF -DCMAKE_INSTALL_INCLUDEDIR=/nix/store/03k57iy9jzacl8g8l6lqnmrb2p04m4xv-h3-3.4.4/include -DCMAKE
_INSTALL_LIBDIR=/nix/store/03k57iy9jzacl8g8l6lqnmrb2p04m4xv-h3-3.4.4/lib -DCMAKE_INSTALL_NAME_DIR=/nix/store/03k57iy9jzacl8g8l6lqnmrb2p04m4xv-h3-3.4.4/lib -DC
MAKE_POLICY_DEFAULT_CMP0025=NEW -DCMAKE_OSX_DEPLOYMENT_TARGET= -DCMAKE_OSX_SYSROOT= -DCMAKE_FIND_FRAMEWORK=last -DCMAKE_STRIP=/nix/store/2pj2hdfy8jqy41hbh5h6z
7sqhmcpi7xy-cctools-binutils-darwin/bin/strip -DCMAKE_RANLIB=/nix/store/2pj2hdfy8jqy41hbh5h6z7sqhmcpi7xy-cctools-binutils-darwin/bin/ranlib -DCMAKE_AR=/nix/st
ore/2pj2hdfy8jqy41hbh5h6z7sqhmcpi7xy-cctools-binutils-darwin/bin/ar -DCMAKE_C_COMPILER=clang -DCMAKE_CXX_COMPILER=clang++ -DCMAKE_INSTALL_PREFIX=/nix/store/03
k57iy9jzacl8g8l6lqnmrb2p04m4xv-h3-3.4.4 -DBUILD_SHARED_LIBS=ON
-- The C compiler identification is Clang 7.1.0
-- Check for working C compiler: /nix/store/qvagarl5ghs07v39zhszm5x9rn08k231-clang-wrapper-7.1.0/bin/clang                                                    -- Check for working C compiler: /nix/store/qvagarl5ghs07v39zhszm5x9rn08k231-clang-wrapper-7.1.0/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- Configuring done
CMake Warning (dev):
  Policy CMP0068 is not set: RPATH settings on macOS do not affect
  install_name.  Run "cmake --help-policy CMP0068" for policy details.  Use
  the cmake_policy command to set the policy and suppress this warning.

  For compatibility with older versions of CMake, the install_name fields for
  the following targets are still affected by RPATH settings:

   h3

This warning is for project developers.  Use -Wno-dev to suppress it.

-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_CXX_COMPILER
    CMAKE_EXPORT_NO_PACKAGE_REGISTRY
    CMAKE_INSTALL_INCLUDEDIR
    CMAKE_INSTALL_LIBDIR
    CMAKE_POLICY_DEFAULT_CMP0025
@jonringer
Copy link
Contributor

@jonringer jonringer commented Jul 18, 2019

-DCMAKE_CXX_COMPILER=clang++ I think this is your issue, it's using a compiler that will use the c++ stdlib which is why you can't find <stdio.h> because in libstdc++ this is <cstdio.h>

I feel asleep yesterday and wasn't able to get around to doing my own testing. :(

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 18, 2019

-DCMAKE_CXX_COMPILER=clang++ I think this is your issue, it's using a compiler that will use the c++ stdlib which is why you can't find <stdio.h> because in libstdc++ this is <cstdio.h>

I believe that's the default compiler on Darwin, which can be overridden of course. However, it also says that CMAKE_CXX_COMPILER was not used by this project, so 🤷‍♂️

I feel asleep yesterday and wasn't able to get around to doing my own testing. :(

No worries, thank you for helping me out with this one.

@LnL7
Copy link
Member

@LnL7 LnL7 commented Jul 18, 2019

I see what's going on here, the build uses clang for linting. But our cc-wrappers only wrap the compilers so other binaries like clang-tidy won't automatically find nix dependencies, including libc++.

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 19, 2019

@LnL7 thank you for your help, much appreciated!

@GrahamcOfBorg build h3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 19, 2019

@GrahamcOfBorg build h3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3 python3Packages.area python3Packages.azure-common python3Packages.azure-storage-blob python3Packages.azure-storage-common python3Packages.geographiclib python3Packages.h3 python3Packages.pycryptodomex python3Packages.requests python3Packages.s3transfer python3Packages.simple-salesforce python3Packages.snowflake-connector-python python3Packages.snowflake-sqlalchemy python3Packages.sqlalchemy python3Packages.timezonefinder python3Packages.urllib3

@jonringer
Copy link
Contributor

@jonringer jonringer commented Jul 19, 2019

scikit-learn already exists, but it was added as pythonPackages.scikitlearn

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Jul 19, 2019

scikit-learn already exists, but it was added as pythonPackages.scikitlearn

🤦‍♂️ I should have checked for that. Thank you for letting me know!

pkgs/development/misc/h3/default.nix Outdated Show resolved Hide resolved
pkgs/development/python-modules/h3/default.nix Outdated Show resolved Hide resolved
pkgs/development/python-modules/h3/default.nix Outdated Show resolved Hide resolved
pkgs/development/python-modules/h3/default.nix Outdated Show resolved Hide resolved
pkgs/development/python-modules/h3/default.nix Outdated Show resolved Hide resolved
@FRidh
Copy link
Member

@FRidh FRidh commented Jul 19, 2019

callPackage ... { inherit (pkgs) h3; };

@kalbasit kalbasit force-pushed the kalbasit:nixpkgs_get_requirements_upstream branch 2 times, most recently from 5fb2cd6 to d9d9a30 Jul 19, 2019
@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Aug 13, 2019

I extracted sqlalchemy to #66574.

Copy link
Contributor

@jonringer jonringer left a comment

most of the non-azure packages are broken on master for other reasons, but the azure packages seem to be horribly broken

36 package failed to build:
aws-sam-cli csvs-to-sqlite elasticsearch-curator nixops_1_6_1 python27Packages.azure-cosmosdb-table python27Packages.azure-storage-file python27Packages.azure-storage-queue python27Packages.cufflinks python27Packages.gensim python27Packages.paperspace python37Packages.acoustics python37Packages.aplpy python37Packages.azure-cosmosdb-table python37Packages.azure-storage-file python37Packages.azure-storage-queue python37Packages.blaze python37Packages.cufflinks python37Packages.dask-glm python37Packages.dask-ml python37Packages.dask-xgboost python37Packages.datashader python37Packages.dftfit python37Packages.ibis-framework python37Packages.imbalanced-learn python37Packages.intake python37Packages.odo python37Packages.optuna python37Packages.osmnx python37Packages.paperspace python37Packages.patator python37Packages.scikit-bio python37Packages.starfish python37Packages.streamz python37Packages.sunpy python37Packages.trackpy python37Packages.xgboost

321 package were build:
aws-google-auth aws_shell awscli awslogs beets buildbot buildbot-full buildbot-ui credstash electrum h3 iceshelf luigi nixops nixopsUnstable poretools python27Packages.Quandl python27Packages.altair python27Packages.area python27Packages.atomman python27Packages.awkward python27Packages.aws-adfs python27Packages.aws-sam-translator python27Packages.azure-applicationinsights python27Packages.azure-batch python27Packages.azure-cli-core python27Packages.azure-common python27Packages.azure-datalake-store python27Packages.azure-eventgrid python27Packages.azure-graphrbac python27Packages.azure-keyvault python27Packages.azure-loganalytics python27Packages.azure-mgmt-advisor python27Packages.azure-mgmt-applicationinsights python27Packages.azure-mgmt-authorization python27Packages.azure-mgmt-batch python27Packages.azure-mgmt-batchai python27Packages.azure-mgmt-billing python27Packages.azure-mgmt-cdn python27Packages.azure-mgmt-cognitiveservices python27Packages.azure-mgmt-commerce python27Packages.azure-mgmt-common python27Packages.azure-mgmt-compute python27Packages.azure-mgmt-consumption python27Packages.azure-mgmt-containerinstance python27Packages.azure-mgmt-containerservice python27Packages.azure-mgmt-cosmosdb python27Packages.azure-mgmt-datafactory python27Packages.azure-mgmt-datalake-analytics python27Packages.azure-mgmt-datalake-store python27Packages.azure-mgmt-datamigration python27Packages.azure-mgmt-devspaces python27Packages.azure-mgmt-devtestlabs python27Packages.azure-mgmt-dns python27Packages.azure-mgmt-eventgrid python27Packages.azure-mgmt-eventhub python27Packages.azure-mgmt-hanaonazure python27Packages.azure-mgmt-iotcentral python27Packages.azure-mgmt-iothub python27Packages.azure-mgmt-iothubprovisioningservices python27Packages.azure-mgmt-keyvault python27Packages.azure-mgmt-loganalytics python27Packages.azure-mgmt-logic python27Packages.azure-mgmt-machinelearningcompute python27Packages.azure-mgmt-managementgroups python27Packages.azure-mgmt-managementpartner python27Packages.azure-mgmt-maps python27Packages.azure-mgmt-marketplaceordering python27Packages.azure-mgmt-media python27Packages.azure-mgmt-monitor python27Packages.azure-mgmt-msi python27Packages.azure-mgmt-network python27Packages.azure-mgmt-notificationhubs python27Packages.azure-mgmt-policyinsights python27Packages.azure-mgmt-powerbiembedded python27Packages.azure-mgmt-rdbms python27Packages.azure-mgmt-recoveryservices python27Packages.azure-mgmt-recoveryservicesbackup python27Packages.azure-mgmt-redis python27Packages.azure-mgmt-relay python27Packages.azure-mgmt-reservations python27Packages.azure-mgmt-resource python27Packages.azure-mgmt-scheduler python27Packages.azure-mgmt-search python27Packages.azure-mgmt-servicebus python27Packages.azure-mgmt-servicefabric python27Packages.azure-mgmt-signalr python27Packages.azure-mgmt-sql python27Packages.azure-mgmt-storage python27Packages.azure-mgmt-subscription python27Packages.azure-mgmt-trafficmanager python27Packages.azure-mgmt-web python27Packages.azure-servicebus python27Packages.azure-servicefabric python27Packages.azure-servicemanagement-legacy python27Packages.azure-storage python27Packages.azure-storage-blob python27Packages.azure-storage-common python27Packages.bkcharts python27Packages.bokeh python27Packages.boto3 python27Packages.cartopy python27Packages.celery python27Packages.cfn-lint python27Packages.credstash python27Packages.csvs-to-sqlite python27Packages.djmail python27Packages.drms python27Packages.fastparquet python27Packages.fiona python27Packages.flowlogs_reader python27Packages.fs-s3fs python27Packages.geographiclib python27Packages.geopandas python27Packages.geopy python27Packages.glances python27Packages.gmusicapi python27Packages.google_cloud_bigquery python27Packages.google_cloud_monitoring python27Packages.gpsoauth python27Packages.h3 python27Packages.histbook python27Packages.holoviews python27Packages.hvplot python27Packages.imbalanced-learn python27Packages.ledgerblue python27Packages.mapsplotlib python27Packages.moto python27Packages.pandas python27Packages.panel python27Packages.partd python27Packages.pvlib python27Packages.pyarrow python27Packages.pycryptodomex python27Packages.pyjwkest python27Packages.pymatgen python27Packages.pysnmp python27Packages.pytrends python27Packages.rasterio python27Packages.s3fs python27Packages.s3transfer python27Packages.seaborn python27Packages.serverlessrepo python27Packages.smart_open python27Packages.snowflake-connector-python python27Packages.snowflake-sqlalchemy python27Packages.statsmodels python27Packages.sumo python27Packages.tablib python27Packages.timezonefinder python27Packages.tiros python27Packages.trackpy python27Packages.uproot python27Packages.uproot-methods python27Packages.vega python27Packages.vega_datasets python27Packages.vidstab python27Packages.warrant python37Packages.Quandl python37Packages.altair python37Packages.area python37Packages.atomman python37Packages.awkward python37Packages.aws-adfs python37Packages.aws-sam-translator python37Packages.azure-applicationinsights python37Packages.azure-batch python37Packages.azure-cli-core python37Packages.azure-common python37Packages.azure-datalake-store python37Packages.azure-eventgrid python37Packages.azure-graphrbac python37Packages.azure-keyvault python37Packages.azure-loganalytics python37Packages.azure-mgmt-advisor python37Packages.azure-mgmt-applicationinsights python37Packages.azure-mgmt-authorization python37Packages.azure-mgmt-batch python37Packages.azure-mgmt-batchai python37Packages.azure-mgmt-billing python37Packages.azure-mgmt-cdn python37Packages.azure-mgmt-cognitiveservices python37Packages.azure-mgmt-commerce python37Packages.azure-mgmt-common python37Packages.azure-mgmt-compute python37Packages.azure-mgmt-consumption python37Packages.azure-mgmt-containerinstance python37Packages.azure-mgmt-containerservice python37Packages.azure-mgmt-cosmosdb python37Packages.azure-mgmt-datafactory python37Packages.azure-mgmt-datalake-analytics python37Packages.azure-mgmt-datalake-store python37Packages.azure-mgmt-datamigration python37Packages.azure-mgmt-devspaces python37Packages.azure-mgmt-devtestlabs python37Packages.azure-mgmt-dns python37Packages.azure-mgmt-eventgrid python37Packages.azure-mgmt-eventhub python37Packages.azure-mgmt-hanaonazure python37Packages.azure-mgmt-iotcentral python37Packages.azure-mgmt-iothub python37Packages.azure-mgmt-iothubprovisioningservices python37Packages.azure-mgmt-keyvault python37Packages.azure-mgmt-loganalytics python37Packages.azure-mgmt-logic python37Packages.azure-mgmt-machinelearningcompute python37Packages.azure-mgmt-managementgroups python37Packages.azure-mgmt-managementpartner python37Packages.azure-mgmt-maps python37Packages.azure-mgmt-marketplaceordering python37Packages.azure-mgmt-media python37Packages.azure-mgmt-monitor python37Packages.azure-mgmt-msi python37Packages.azure-mgmt-network python37Packages.azure-mgmt-notificationhubs python37Packages.azure-mgmt-policyinsights python37Packages.azure-mgmt-powerbiembedded python37Packages.azure-mgmt-rdbms python37Packages.azure-mgmt-recoveryservices python37Packages.azure-mgmt-recoveryservicesbackup python37Packages.azure-mgmt-redis python37Packages.azure-mgmt-relay python37Packages.azure-mgmt-reservations python37Packages.azure-mgmt-resource python37Packages.azure-mgmt-scheduler python37Packages.azure-mgmt-search python37Packages.azure-mgmt-servicebus python37Packages.azure-mgmt-servicefabric python37Packages.azure-mgmt-signalr python37Packages.azure-mgmt-sql python37Packages.azure-mgmt-storage python37Packages.azure-mgmt-subscription python37Packages.azure-mgmt-trafficmanager python37Packages.azure-mgmt-web python37Packages.azure-servicebus python37Packages.azure-servicefabric python37Packages.azure-servicemanagement-legacy python37Packages.azure-storage python37Packages.azure-storage-blob python37Packages.azure-storage-common python37Packages.bkcharts python37Packages.bokeh python37Packages.boto3 python37Packages.buildbot-plugins.console-view python37Packages.buildbot-plugins.grid-view python37Packages.buildbot-plugins.waterfall-view python37Packages.buildbot-plugins.wsgi-dashboards python37Packages.caffe python37Packages.cartopy python37Packages.celery python37Packages.cfn-lint python37Packages.dask python37Packages.dask-image python37Packages.dask-jobqueue python37Packages.dask-mpi python37Packages.distributed python37Packages.djmail python37Packages.drms python37Packages.fastparquet python37Packages.fiona python37Packages.flowlogs_reader python37Packages.fs-s3fs python37Packages.gensim python37Packages.geographiclib python37Packages.geopandas python37Packages.geopy python37Packages.glances python37Packages.glymur python37Packages.gmusicapi python37Packages.google_cloud_bigquery python37Packages.google_cloud_monitoring python37Packages.gpsoauth python37Packages.h3 python37Packages.histbook python37Packages.holoviews python37Packages.hvplot python37Packages.image-match python37Packages.lammps-cython python37Packages.ledgerblue python37Packages.moto python37Packages.pandas python37Packages.panel python37Packages.partd python37Packages.pims python37Packages.pvlib python37Packages.pyarrow python37Packages.pycryptodomex python37Packages.pyfftw python37Packages.pyjwkest python37Packages.pymatgen python37Packages.pymatgen-lammps python37Packages.pymc3 python37Packages.pysnmp python37Packages.pytrends python37Packages.rasterio python37Packages.rl-coach python37Packages.s3fs python37Packages.s3transfer python37Packages.scikitimage python37Packages.seaborn python37Packages.serverlessrepo python37Packages.slicedimage python37Packages.smart_open python37Packages.snowflake-connector-python python37Packages.snowflake-sqlalchemy python37Packages.statsmodels python37Packages.stumpy python37Packages.sumo python37Packages.tablib python37Packages.timezonefinder python37Packages.tiros python37Packages.uproot python37Packages.uproot-methods python37Packages.vega python37Packages.vega_datasets python37Packages.vidstab python37Packages.warrant python37Packages.wrf-python python37Packages.xarray s4cmd visidata
Full fail log
builder for '/nix/store/90xmnhrb89pya3mz12g0dvpvc64ad8m5-python3.7-PyYAML-3.12.drv' failed with exit code 1; last 10 log lines:
  AssertionError: see below
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  'expected an exception'
  ---------------------------------------------------------------------------
  tests/data/colon-in-flow-context.loader-error:
  { foo:bar }
  ===========================================================================
  TESTS: 2585
  FAILURES: 2
  error: Tests failed
builder for '/nix/store/0ibvygr1mg1qc8vl23wg2nkljmdsh3da-python2.7-azure-cosmosdb-table-1.0.5.drv' failed with exit code 1; last 10 log lines:
  /build/azure-cosmosdb-table-1.0.5/dist /build/azure-cosmosdb-table-1.0.5
  DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
  Processing ./azure_cosmosdb_table-1.0.5-py2.py3-none-any.whl
  Requirement already satisfied: futures; python_version <= "2.7" in /nix/store/vfmzpm36bxp3cw5krs22sa4hwphfylx9-python2.7-futures-3.2.0/lib/python2.7/site-packages (from azure-cosmosdb-table==1.0.5) (3.2.0)
  Requirement already satisfied: azure-cosmosdb-nspkg>=2.0.0 in /nix/store/vldw6ah4bk4lw5v54c6jfp91sjng4mhv-python2.7-azure-cosmosdb-nspkg-2.0.2/lib/python2.7/site-packages (from azure-cosmosdb-table==1.0.5) (2.0.2)
  Requirement already satisfied: azure-common>=1.1.5 in /nix/store/y5rp14x6dl63987v2axxy1kqqb4kw6gi-python2.7-azure-common-1.1.23/lib/python2.7/site-packages (from azure-cosmosdb-table==1.0.5) (1.1.23)
  Requirement already satisfied: requests in /nix/store/2z98bib9lz1khzsisjyis92g45ikcrqn-python2.7-requests-2.22.0/lib/python2.7/site-packages (from azure-cosmosdb-table==1.0.5) (2.22.0)
  Collecting azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5)
builder for '/nix/store/22rwbi5fyfjnnb2h2p5zxgkz3drxwmx9-python2.7-azure-storage-file-1.4.0.drv' failed with exit code 1; last 10 log lines:
  adding 'azure_storage_file-1.4.0.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/azure-storage-file-1.4.0/dist /build/azure-storage-file-1.4.0
  DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
  Processing ./azure_storage_file-1.4.0-py2.py3-none-any.whl
  Requirement already satisfied: azure-common>=1.1.5 in /nix/store/y5rp14x6dl63987v2axxy1kqqb4kw6gi-python2.7-azure-common-1.1.23/lib/python2.7/site-packages (from azure-storage-file==1.4.0) (1.1.23)
  Collecting azure-storage-common~=1.4 (from azure-storage-file==1.4.0)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.4 (from azure-storage-file==1.4.0) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.4 (from azure-storage-file==1.4.0)
builder for '/nix/store/b65zq4hy86488bzckbs9yi34lr68givr-python2.7-azure-storage-queue-1.4.0.drv' failed with exit code 1; last 10 log lines:
  adding 'azure_storage_queue-1.4.0.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/azure-storage-queue-1.4.0/dist /build/azure-storage-queue-1.4.0
  DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
  Processing ./azure_storage_queue-1.4.0-py2.py3-none-any.whl
  Requirement already satisfied: azure-common>=1.1.5 in /nix/store/y5rp14x6dl63987v2axxy1kqqb4kw6gi-python2.7-azure-common-1.1.23/lib/python2.7/site-packages (from azure-storage-queue==1.4.0) (1.1.23)
  Collecting azure-storage-common~=1.4 (from azure-storage-queue==1.4.0)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.4 (from azure-storage-queue==1.4.0) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.4 (from azure-storage-queue==1.4.0)
builder for '/nix/store/mkcl9s6fj5y0qm9gyijgvvvifawzvmpk-instantclient-basic-linux.x64-12.2.0.1.0.zip.drv' failed with exit code 1; last 10 log lines:
  ***
  Unfortunately, we cannot download file instantclient-basic-linux.x64-12.2.0.1.0.zip automatically.
  Please go to http://www.oracle.com/technetwork/database/database-technologies/instant-client/downloads/index.html to download it yourself, and add it to the Nix store
  using either
    nix-store --add-fixed sha256 instantclient-basic-linux.x64-12.2.0.1.0.zip
  or
    nix-prefetch-url --type sha256 file:///path/to/instantclient-basic-linux.x64-12.2.0.1.0.zip

  ***
builder for '/nix/store/fsfwc9fy986m0wi1lwfcw3mmvpjq1kc0-instantclient-sqlplus-linux.x64-12.2.0.1.0.zip.drv' failed with exit code 1; last 10 log lines:
  ***
  Unfortunately, we cannot download file instantclient-sqlplus-linux.x64-12.2.0.1.0.zip automatically.
  Please go to http://www.oracle.com/technetwork/database/database-technologies/instant-client/downloads/index.html to download it yourself, and add it to the Nix store
  using either
    nix-store --add-fixed sha256 instantclient-sqlplus-linux.x64-12.2.0.1.0.zip
  or
    nix-prefetch-url --type sha256 file:///path/to/instantclient-sqlplus-linux.x64-12.2.0.1.0.zip

  ***
builder for '/nix/store/mdqm5fqg7qqwzb92yb8b7m0qmy3j2pf2-python3.7-azure-cosmosdb-table-1.0.5.drv' failed with exit code 1; last 10 log lines:
  adding 'azure_cosmosdb_table-1.0.5.dist-info/top_level.txt'
  adding 'azure_cosmosdb_table-1.0.5.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/azure-cosmosdb-table-1.0.5/dist /build/azure-cosmosdb-table-1.0.5
  Processing ./azure_cosmosdb_table-1.0.5-py2.py3-none-any.whl
  Requirement already satisfied: cryptography in /nix/store/k8saz4pi0r739knvg8zhz22a6l9d2avz-python3.7-cryptography-2.7/lib/python3.7/site-packages (from azure-cosmosdb-table==1.0.5) (2.7)
  Collecting azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.1 (from azure-cosmosdb-table==1.0.5)
builder for '/nix/store/ibfk47aznsdjqykfipikx8w52dcmrhz0-python3.7-azure-storage-file-1.4.0.drv' failed with exit code 1; last 10 log lines:
  adding 'azure_storage_file-1.4.0.dist-info/top_level.txt'
  adding 'azure_storage_file-1.4.0.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/azure-storage-file-1.4.0/dist /build/azure-storage-file-1.4.0
  Processing ./azure_storage_file-1.4.0-py2.py3-none-any.whl
  Requirement already satisfied: azure-common>=1.1.5 in /nix/store/mkx7yqlk99q8qrh880sy4sp1nl6yw2fv-python3.7-azure-common-1.1.23/lib/python3.7/site-packages (from azure-storage-file==1.4.0) (1.1.23)
  Collecting azure-storage-common~=1.4 (from azure-storage-file==1.4.0)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.4 (from azure-storage-file==1.4.0) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.4 (from azure-storage-file==1.4.0)
builder for '/nix/store/mi6asjx43snmy38lcsca62cvizv7j6bb-python3.7-azure-storage-queue-1.4.0.drv' failed with exit code 1; last 10 log lines:
  adding 'azure_storage_queue-1.4.0.dist-info/top_level.txt'
  adding 'azure_storage_queue-1.4.0.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/azure-storage-queue-1.4.0/dist /build/azure-storage-queue-1.4.0
  Processing ./azure_storage_queue-1.4.0-py2.py3-none-any.whl
  Requirement already satisfied: azure-common>=1.1.5 in /nix/store/mkx7yqlk99q8qrh880sy4sp1nl6yw2fv-python3.7-azure-common-1.1.23/lib/python3.7/site-packages (from azure-storage-queue==1.4.0) (1.1.23)
  Collecting azure-storage-common~=1.4 (from azure-storage-queue==1.4.0)
    ERROR: Could not find a version that satisfies the requirement azure-storage-common~=1.4 (from azure-storage-queue==1.4.0) (from versions: none)
  ERROR: No matching distribution found for azure-storage-common~=1.4 (from azure-storage-queue==1.4.0)
builder for '/nix/store/j0k4zsmx8g73ylj4nzrx2ikjlfpcwxdr-instantclient-sdk-linux.x64-12.2.0.1.0.zip.drv' failed with exit code 1; last 10 log lines:
  ***
  Unfortunately, we cannot download file instantclient-sdk-linux.x64-12.2.0.1.0.zip automatically.
  Please go to http://www.oracle.com/technetwork/database/database-technologies/instant-client/downloads/index.html to download it yourself, and add it to the Nix store
  using either
    nix-store --add-fixed sha256 instantclient-sdk-linux.x64-12.2.0.1.0.zip
  or
    nix-prefetch-url --type sha256 file:///path/to/instantclient-sdk-linux.x64-12.2.0.1.0.zip

  ***
cannot build derivation '/nix/store/cw2s8rhsrgigs8jzm7hr0kwbz7p9swgq-oracle-instantclient-12.2.0.1.0.drv': 3 dependencies couldn't be built
cannot build derivation '/nix/store/bams62w1zqzi4p9qk3ql61q7prbbikar-odpic-3.1.0.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/287wh11lc2p48wy5qj151bqj6l23apg3-python3.7-cx_Oracle-7.1.3.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/dn8475ihjh1jyb4q4vx59d4l153inw6n-python3.7-elasticsearch-curator-5.7.6.drv': 1 dependencies couldn't be built
builder for '/nix/store/cg6fq2hg6jn91zzxbq3zcdm1b1igx1k4-nixops-1.6.1.drv' failed with exit code 1; last 10 log lines:
      from nixops import deployment
    File "/nix/store/w6ylhd6aj5vlxsf06q3psvxgip74g8q2-nixops-1.6.1/lib/python2.7/site-packages/nixops/deployment.py", line 1274, in <module>
      _load_modules_from("backends")
    File "/nix/store/w6ylhd6aj5vlxsf06q3psvxgip74g8q2-nixops-1.6.1/lib/python2.7/site-packages/nixops/deployment.py", line 1272, in _load_modules_from
      __import__("nixops." + dir + "." + module[:-3], globals(), locals())
    File "/nix/store/w6ylhd6aj5vlxsf06q3psvxgip74g8q2-nixops-1.6.1/lib/python2.7/site-packages/nixops/backends/azure_vm.py", line 23, in <module>
      from nixops.azure_common import ResourceDefinition, ResourceState, ResId, normalize_location
    File "/nix/store/w6ylhd6aj5vlxsf06q3psvxgip74g8q2-nixops-1.6.1/lib/python2.7/site-packages/nixops/azure_common.py", line 15, in <module>
      from azure.mgmt.common import SubscriptionCloudCredentials
  ImportError: No module named common
builder for '/nix/store/yw7n5mvjwfz7118cfa1p69h947qw93jp-python2.7-paperspace-0.0.19.drv' failed with exit code 1; last 10 log lines:
  adding 'paperspace-0.0.19.dist-info/top_level.txt'
  adding 'paperspace-0.0.19.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/paperspace-0.0.19/dist /build/paperspace-0.0.19
  DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
  Processing ./paperspace-0.0.19-py2.py3-none-any.whl
  Collecting gradient-statsd (from paperspace==0.0.19)
    ERROR: Could not find a version that satisfies the requirement gradient-statsd (from paperspace==0.0.19) (from versions: none)
  ERROR: No matching distribution found for gradient-statsd (from paperspace==0.0.19)
builder for '/nix/store/f5xjr8y3i8886r361qlffi0dzcf0iq1x-aws-sam-cli-0.16.1.drv' failed with exit code 1; last 10 log lines:
  DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
  Processing ./aws_sam_cli-0.16.1-py2-none-any.whl
  Requirement already satisfied: click~=6.7 in /nix/store/8sjjmvfwgjsnly9vm54vx8pr55jm7yi5-python2.7-click-6.7/lib/python2.7/site-packages (from aws-sam-cli==0.16.1) (6.7)
  Requirement already satisfied: serverlessrepo==0.1.8 in /nix/store/j0f797x7lbagrmwmwkkwf3fiwjkb07yz-python2.7-serverlessrepo-0.1.8/lib/python2.7/site-packages (from aws-sam-cli==0.16.1) (0.1.8)
  Requirement already satisfied: aws-sam-translator==1.10.0 in /nix/store/gpg9rx5g23fwhp6jdradcqm9lsif975k-python2.7-aws-sam-translator-1.10.0/lib/python2.7/site-packages (from aws-sam-cli==0.16.1) (1.10.0)
  Requirement already satisfied: cookiecutter~=1.6.0 in /nix/store/1fn2hkqbx3vf3m92kp6ffln8pmcyxaqr-python2.7-cookiecutter-1.6.0/lib/python2.7/site-packages (from aws-sam-cli==0.16.1) (1.6.0)
  Requirement already satisfied: enum34~=1.1.6; python_version < "3.4" in /nix/store/h8kwx02169bsdp3cz8w6d1nz2dcgxj0s-python2.7-enum34-1.1.6/lib/python2.7/site-packages (from aws-sam-cli==0.16.1) (1.1.6)
  Collecting requests==2.21.0 (from aws-sam-cli==0.16.1)
    ERROR: Could not find a version that satisfies the requirement requests==2.21.0 (from aws-sam-cli==0.16.1) (from versions: none)
  ERROR: No matching distribution found for requests==2.21.0 (from aws-sam-cli==0.16.1)
builder for '/nix/store/8vw6iw5mkzdkv1mjm99avhmfnjhi4lc1-python2.7-gensim-3.8.0.drv' failed with exit code 1; last 10 log lines:
      replace_conflicting=replace_conflicting
    File "/nix/store/6wxgc8hmsszcq0iynd23zphbksln7khr-python2.7-bootstrapped-pip-19.1.1/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1065, in best_match
      return self.obtain(req, installer)
    File "/nix/store/6wxgc8hmsszcq0iynd23zphbksln7khr-python2.7-bootstrapped-pip-19.1.1/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1077, in obtain
      return installer(requirement)
    File "/nix/store/6wxgc8hmsszcq0iynd23zphbksln7khr-python2.7-bootstrapped-pip-19.1.1/lib/python2.7/site-packages/setuptools/dist.py", line 784, in fetch_build_egg
      return cmd.easy_install(req)
    File "/nix/store/6wxgc8hmsszcq0iynd23zphbksln7khr-python2.7-bootstrapped-pip-19.1.1/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 673, in easy_install
      raise DistutilsError(msg)
  distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('numpy<=1.16.1,>=1.11.3')
builder for '/nix/store/4z3g48f035w0lf8ccfb380jfy09hhggr-python3.7-paperspace-0.0.19.drv' failed with exit code 1; last 10 log lines:
  adding 'paperspace-0.0.19.dist-info/top_level.txt'
  adding 'paperspace-0.0.19.dist-info/RECORD'
  removing build/bdist.linux-x86_64/wheel
  installing
  /build/paperspace-0.0.19/dist /build/paperspace-0.0.19
  Processing ./paperspace-0.0.19-py2.py3-none-any.whl
  Requirement already satisfied: botocore in /nix/store/q1x0qs8q3h3fln893xq1ffdlwbbjcczh-python3.7-botocore-1.12.160/lib/python3.7/site-packages (from paperspace==0.0.19) (1.12.160)
  Collecting terminaltables (from paperspace==0.0.19)
    ERROR: Could not find a version that satisfies the requirement terminaltables (from paperspace==0.0.19) (from versions: none)
  ERROR: No matching distribution found for terminaltables (from paperspace==0.0.19)
cannot build derivation '/nix/store/hn7r12v9g0xwi8f4v4yvywabg7z8vd5j-python3.7-patator-0.7.drv': 1 dependencies couldn't be built
builder for '/nix/store/58573dizh2zlkkskhfi7iamsawrvxakz-python3.7-astropy-3.2.1.drv' failed with exit code 1; last 10 log lines:

  >   ???
  E   DeprecationWarning: Numpy has detected that you (may be) writing to an array with
  E   overlapping memory from np.broadcast_arrays. If this is intentional
  E   set the WRITEABLE flag True or make a copy immediately before writing.

  stringsource:349: DeprecationWarning
  ===== 276 failed, 10977 passed, 982 skipped, 69 xfailed in 251.04 seconds ======
  /build/astropy-3.2.1/build/lib.linux-x86_64-3.7/astropy/config/configuration.py:532: ConfigurationMissingWarning: Configuration defaults will be used due to FileNotFoundError:2 on None
    warn(ConfigurationMissingWarning(msg))
cannot build derivation '/nix/store/6v3gibf7m3s7pjj0cpxv4454crvi9cr6-python3.7-asdf-2.3.3.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/cjjqx9675sqixiacavjmvaxcbg4ql403-python3.7-astropy-healpix-0.4.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/jbb0wvbid018s15zpwxik03whxxf8lii-python3.7-pyavm-0.9.4.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/bak2gcsykhnad5jgw33fsck8776472s4-python3.7-pyregion-2.0.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/jq5pc7hc61256c8madnkbaqy6mjpiacm-python3.7-reproject-0.4.drv': 2 dependencies couldn't be built
builder for '/nix/store/6pq4kwvvyaqnwqxncgmygqs2igfa0as6-python3.7-scikit-learn-0.21.2.drv' failed with exit code 1; last 10 log lines:
  utils/tests/test_validation.py::test_check_array_force_all_finiteinvalid[csr_matrix-nan-1-Input contains NaN, infinity]
    /nix/store/sq5bhiz1gszpykrklym3p0smccmvi2fr-python3.7-scipy-1.3.0/lib/python3.7/site-packages/scipy/sparse/_index.py:69: SparseEfficiencyWarning: Changing the sparsity structure of a csr_matrix is expensive. lil_matrix is more efficient.
      self._set_intXint(row, col, x.flat[0])

  utils/tests/test_validation.py::test_np_matrix
    /nix/store/nzkcc4xcawfrijr0c8nay8cpqfiipzaq-python3.7-scikit-learn-0.21.2/lib/python3.7/site-packages/sklearn/utils/tests/test_validation.py:114: PendingDeprecationWarning: the matrix subclass is not the recommended way to represent matrices or deal with linear algebra (see https://docs.scipy.org/doc/numpy/user/numpy-for-matlab-users.html). Please adjust your code to use regular ndarray.
      assert not isinstance(as_float_array(np.matrix(X)), np.matrix)

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
   1 failed, 12156 passed, 149 skipped, 1 deselected, 3 xfailed, 1912 warnings in 502.81 seconds
cannot build derivation '/nix/store/xgdyjj2s9r3r8cichccrxchclz2hsd8a-python3.7-lightgbm-2.2.3.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/vsgh5wyqh7xy5lxjgqyglqqzfa8jgadz-python3.7-scikit-optimize-0.6.drv': 1 dependencies couldn't be built
builder for '/nix/store/q57bbhjxdyfw3rljqfsxd6qkpyjvw3yl-python2.7-cufflinks-0.15.drv' failed with exit code 1; last 10 log lines:
  ImportError:
  The plotly.plotly module is deprecated,
  please install the chart-studio package and use the
  chart_studio.plotly module instead.


  ----------------------------------------------------------------------
  Ran 1 test in 0.001s

  FAILED (errors=1)
cannot build derivation '/nix/store/djy1g3xyhizq1i0kaibkvhwy5za85842-python3.7-imbalanced-learn-0.5.0.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/lc5a3myj2r854vj3bhkasdlpz72jph9c-python3.7-scikit-bio-0.5.5.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/sa32kzc9nlwk2y4wig6cgvrnh6q8lmbv-python3.7-xgboost-0.90.drv': 1 dependencies couldn't be built
builder for '/nix/store/wmr7vz9910dfi6dchniliyfb0zd30za4-python3.7-csvs-to-sqlite-0.9.drv' failed with exit code 1; last 10 log lines:
  E         ...Full output truncated (2 lines hidden), use '-vv' to show

  tests/test_utils.py:24: AssertionError
  =============================== warnings summary ===============================
  /nix/store/y57cpzdigqr760al7b8c8hlay9l6dgys-python3.7-dateparser-0.7.1/lib/python3.7/site-packages/dateparser/date.py:320
    /nix/store/y57cpzdigqr760al7b8c8hlay9l6dgys-python3.7-dateparser-0.7.1/lib/python3.7/site-packages/dateparser/date.py:320: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working
      if not isinstance(languages, (list, tuple, collections.Set)) and languages is not None:

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
  =============== 1 failed, 18 passed, 1 warnings in 1.93 seconds ================
cannot build derivation '/nix/store/8wfnj6nx8fdi33ncqbmzhin49797051p-python3.7-optuna-0.13.0.drv': 3 dependencies couldn't be built
builder for '/nix/store/hz02n0mjmmr8qfj1g2bk01pgrgipz7s4-python3.7-acoustics-0.2.1.drv' failed with exit code 1; last 10 log lines:
  E       IndexError: tuple index out of range

  /nix/store/sm5dh9azr3m918pwapdsam7mlgpc9wr0-python3.7-matplotlib-3.1.1/lib/python3.7/site-packages/matplotlib/axes/_base.py:399: IndexError
  =============================== warnings summary ===============================
  standards/test_iec_61672_1_2013.py:30
    /build/acoustics-0.2.1/tests/standards/test_iec_61672_1_2013.py:30: DeprecationWarning: invalid escape sequence \c
      """

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
  ============== 6 failed, 498 passed, 1 warnings in 26.89 seconds ===============
builder for '/nix/store/5x4msfvz5600dv5ark15q6s7jmcmzbw9-python3.7-cufflinks-0.15.drv' failed with exit code 1; last 10 log lines:
  ImportError:
  The plotly.plotly module is deprecated,
  please install the chart-studio package and use the
  chart_studio.plotly module instead.


  ----------------------------------------------------------------------
  Ran 1 test in 0.001s

  FAILED (errors=1)
cannot build derivation '/nix/store/44hl46vvnq4pnb65qnhp7fcyrpq8800a-python3.7-dask-glm-0.2.0.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/y3d8hs6w5vyp71wy6jfyklj4rip2abf8-python3.7-dask-ml-0.11.0.drv': 2 dependencies couldn't be built
cannot build derivation '/nix/store/mj6ffv0ddc4f75s0vpmlwq2h271fsc6i-python3.7-dask-xgboost-0.1.5.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/z6wp2hjdq290nprh13rds0qfl0n8an98-python3.7-osmnx-0.9.drv': 1 dependencies couldn't be built
builder for '/nix/store/8m869bvgayhp6sm9dj64qlcfy05zbm4a-python3.7-intake-0.4.4.drv' failed with exit code 2; last 10 log lines:
      ihook = self.gethookproxy(dirpath)
  /nix/store/r2pjw4idffl5hypfdng9h9cg16jr8hws-python3.7-pytest-4.6.3/lib/python3.7/site-packages/_pytest/main.py:482: in gethookproxy
      my_conftestmodules = pm._getconftestmodules(fspath)
  /nix/store/r2pjw4idffl5hypfdng9h9cg16jr8hws-python3.7-pytest-4.6.3/lib/python3.7/site-packages/_pytest/config/__init__.py:424: in _getconftestmodules
      mod = self._importconftest(conftestpath.realpath())
  /nix/store/r2pjw4idffl5hypfdng9h9cg16jr8hws-python3.7-pytest-4.6.3/lib/python3.7/site-packages/_pytest/config/__init__.py:463: in _importconftest
      raise ConftestImportFailure(conftestpath, sys.exc_info())
  E   _pytest.config.ConftestImportFailure: (local('/build/intake-0.4.4/intake/conftest.py'), (<class 'ImportError'>, ImportError("cannot import name 'infer_storage_options' from 'dask.bytes.utils' (/nix/store/2xi5sha7s8q9mbq4d58arngqpljlf4ny-python3.7-dask-2.2.0/lib/python3.7/site-packages/dask/bytes/utils.py)"), <traceback object at 0x7ffff6148b90>))
  !!!!!!!!!!!!!!!!!!! Interrupted: 1 errors during collection !!!!!!!!!!!!!!!!!!!!
  =========================== 1 error in 0.67 seconds ============================
builder for '/nix/store/cn5k2fa53a2wd4p0n7aj3xv9l293aqsg-python3.7-odo-unstable-2019-07-16.drv' failed with exit code 1; last 10 log lines:
      return bool(asarray(a1 == a2).all())

  odo/backends/tests/test_sql.py::test_numeric_append
  odo/backends/tests/test_sql.py::test_decimal_conversion
    /nix/store/d7vh6ccrp5zpbnqsj70jvxw16m8r60jy-python3.7-SQLAlchemy-1.2.14/lib/python3.7/site-packages/sqlalchemy/sql/sqltypes.py:603: SAWarning: Dialect sqlite+pysqlite does *not* support Decimal objects natively, and SQLAlchemy must convert from floating point - rounding errors and other issues may occur. Please consider storing Decimal numbers as strings or integers on this platform for lossless storage.
      'storage.' % (dialect.name, dialect.driver))

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
   51 failed, 258 passed, 25 skipped, 8 deselected, 5 xfailed, 158 warnings in 20.57 seconds
  Closing remaining open files:/build/tmpgjwn2w8c.h5...done
cannot build derivation '/nix/store/480p1n2vhsp1ky1dkcypc8ixwky6x3jq-python3.7-blaze-0.11.3.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/p1xp6qfxgm2nlv93yk0243hl3y5kjsin-python3.7-dftfit-0.5.0.drv': 1 dependencies couldn't be built
[8/333/354 built (23 failed), 685 copied (2450.6/2453.3 MiB), 594.3 MiB DL] building python3.7-altair-3.2.0 (installCheckPhase): altair/tests/test_magics.py .......        builder for '/nix/store/162p7gc156bdbg7ipl60drzikmkr6491-python3.7-ibis-framework-1.2.0.drv' failed with exit code 1; last 10 log lines:
  ibis/pandas/execution/tests/test_operations.py::test_simple_case_scalar
    /build/ibis-framework-1.2.0/ibis/pandas/execution/generic.py:1010: FutureWarning: `item` has been deprecated and will be removed in a future version
      return result.item()

  ibis/pandas/execution/tests/test_temporal.py::test_cast_integer_to_date
    /build/ibis-framework-1.2.0/ibis/pandas/execution/generic.py:160: FutureWarning: the 'box' keyword is deprecated and will be removed in a future version. Please take steps to stop the use of 'box'
      pd.to_datetime(data.values, box=False, unit='D'),

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
   2 failed, 3275 passed, 3872 skipped, 134 xfailed, 4 warnings in 141.67 seconds
builder for '/nix/store/ark5d58nvvqc1xk0pwm92x0gc93k16cs-python3.7-trackpy-0.4.1.drv' failed with exit code 1; last 10 log lines:
  trackpy/tests/test_linking.py::TestMockSubnetlinker::test_single_subnet
    /build/source/trackpy/tests/test_linking.py:798: DeprecationWarning: Please use assertEqual instead.
      self.assertEquals(len(source), 1)

  trackpy/tests/test_linking.py::TestMockSubnetlinker::test_single_subnet
    /build/source/trackpy/tests/test_linking.py:799: DeprecationWarning: Please use assertEqual instead.
      self.assertEquals(len(dest), 4)

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
  ====== 1 failed, 474 passed, 125 skipped, 4136 warnings in 161.65 seconds ======
cannot build derivation '/nix/store/nhf2n2l962apy9f4yvs8p2klr6rg043d-python3.7-aplpy-2.0.3.drv': 4 dependencies couldn't be built
cannot build derivation '/nix/store/9as243rgd080770f3fd57pxb4xjjc92s-python3.7-sunpy-1.0.2.drv': 2 dependencies couldn't be built
builder for '/nix/store/cav4fnbinfry6z4ax7sw7h82hfdxklq2-python3.7-datashader-0.7.0.drv' failed with exit code 1; last 10 log lines:
  Requirement already satisfied: scikit-image in /nix/store/872fdh8gx53qnqaf51dilg5gb4ymw4kp-python3.7-scikit-image-0.14.2/lib/python3.7/site-packages (from datashader==0.7.0) (0.14.2)
  Requirement already satisfied: xarray>=0.9.6 in /nix/store/jxjknll39fcgq2xhh3k1n8jgc92z8hgl-python3.7-xarray-0.12.3/lib/python3.7/site-packages (from datashader==0.7.0) (0.12.3)
  Requirement already satisfied: datashape>=0.5.1 in /nix/store/i1hapxd1hnf4xn5xcvis135g70cd1gik-python3.7-datashape-0.5.4/lib/python3.7/site-packages (from datashader==0.7.0) (0.5.4)
  Requirement already satisfied: pytz>=2017.2 in /nix/store/s52jvm9721kf38mq2bwn5avhj8088q50-python3.7-pytz-2019.1/lib/python3.7/site-packages (from pandas>=0.20.3->datashader==0.7.0) (2019.1)
  Requirement already satisfied: python-dateutil>=2.6.1 in /nix/store/gd98s8nbx8ad4kz5hf584qawakmrchqg-python3.7-python-dateutil-2.8.0/lib/python3.7/site-packages (from pandas>=0.20.3->datashader==0.7.0) (2.8.0)
  Requirement already satisfied: cloudpickle>=0.2.1; extra == "complete" in /nix/store/bfv4ihdsxm5dsg6hsl1p82xb18mxacwm-python3.7-cloudpickle-0.8.1/lib/python3.7/site-packages (from dask[complete]>=0.18.0->datashader==0.7.0) (0.8.1)
  Requirement already satisfied: partd>=0.3.10; extra == "complete" in /nix/store/xhi34hz5by0axkgjl0idirmn8rm27gi3-python3.7-partd-0.3.10/lib/python3.7/site-packages (from dask[complete]>=0.18.0->datashader==0.7.0) (0.3.10)
  Collecting distributed>=2.0; extra == "complete" (from dask[complete]>=0.18.0->datashader==0.7.0)
    ERROR: Could not find a version that satisfies the requirement distributed>=2.0; extra == "complete" (from dask[complete]>=0.18.0->datashader==0.7.0) (from versions: none)
  ERROR: No matching distribution found for distributed>=2.0; extra == "complete" (from dask[complete]>=0.18.0->datashader==0.7.0)
cannot build derivation '/nix/store/6xfczr6yw9icp24ry87j0krmrh00z9rb-python3.7-starfish-0.1.3.drv': 2 dependencies couldn't be built
builder for '/nix/store/f7w876a3slcddwq5b1h1rd1y9lq4kc5i-python3.7-streamz-0.5.1.drv' failed with exit code 1; last 10 log lines:
  streamz/dataframe/tests/test_dataframes.py::test_groupby_windowing_value[<lambda>3-<lambda>3-<lambda>1-1d-<lambda>1]
  streamz/dataframe/tests/test_dataframes.py::test_groupby_windowing_value[<lambda>3-<lambda>3-<lambda>1-1d-<lambda>2]
  streamz/dataframe/tests/test_dataframes.py::test_groupby_windowing_value[<lambda>3-<lambda>3-<lambda>1-1d-<lambda>3]
  streamz/dataframe/tests/test_dataframes.py::test_groupby_windowing_value[<lambda>3-<lambda>3-<lambda>1-1d-<lambda>4]
  streamz/dataframe/tests/test_dataframes.py::test_groupby_windowing_value[<lambda>3-<lambda>3-<lambda>1-1d-<lambda>5]
    /build/streamz-0.5.1/streamz/dataframe/tests/test_dataframes.py:728: FutureWarning: Creating a DatetimeIndex by passing range endpoints is deprecated.  Use `pandas.date_range` instead.
      index = pd.DatetimeIndex(start='2000-01-01', end='2000-01-03', freq='1h')

  -- Docs: https://docs.pytest.org/en/latest/warnings.html
   2 failed, 1536 passed, 9 skipped, 2 deselected, 24 xfailed, 112 xpassed, 890 warnings in 349.78 seconds
cannot build derivation '/nix/store/2d54a8zhnjswa9qf8c9g2w0s5l2r0l1z-env.drv': 36 dependencies couldn't be built
@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Aug 13, 2019

@jonringer I'll extract it out then into a separate PR and fix what's broken there. Might need your help to split the work. I'll get back to my keyboard in an hour or so.

kalbasit and others added 11 commits Jul 16, 2019
Disable linting as it uses clang-tidy, which isn't a cc-wrapper and
won't find our dependencies automatically.
@kalbasit kalbasit force-pushed the kalbasit:nixpkgs_get_requirements_upstream branch from c23fa15 to 6f40b1c Aug 13, 2019
@kalbasit kalbasit mentioned this pull request Aug 13, 2019
0 of 10 tasks complete
@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Aug 13, 2019

@GrahamcOfBorg build pythonPackages.area pythonPackages.geographiclib h3 pythonPackages.h3 pythonPackages.pycryptodomex pythonPackages.s3transfer pythonPackages.snowflake-connector-python pythonPackages.snowflake-sqlalchemy pythonPackages.timezonefinder pythonPackages.geopy

@kalbasit
Copy link
Member Author

@kalbasit kalbasit commented Aug 14, 2019

@jonringer azure is now in #66592, PTAL.

@kalbasit kalbasit closed this Jan 4, 2020
@kalbasit kalbasit deleted the kalbasit:nixpkgs_get_requirements_upstream branch Jan 4, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants
You can’t perform that action at this time.