Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pythonPackages.cooldict: init at unstable-2019-10-29 #68428

Closed
wants to merge 1 commit into from

Conversation

@Pamplemousse
Copy link
Member

@Pamplemousse Pamplemousse commented Sep 10, 2019

Motivation for this change

I am trying to make angr, the binary analysis framework, available on NixOS.
This is part of the modules it requires.

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Fits CONTRIBUTING.md.
@Pamplemousse Pamplemousse requested a review from FRidh as a code owner Sep 10, 2019
@Pamplemousse Pamplemousse force-pushed the Pamplemousse:cooldict branch 2 times, most recently from 3d20a7a to 3b7fb96 Sep 10, 2019
@Pamplemousse Pamplemousse changed the title pythonPackages.cooldict: init at 1.04 [WIP] pythonPackages.cooldict: init at 1.04 Sep 10, 2019
@Pamplemousse
Copy link
Member Author

@Pamplemousse Pamplemousse commented Sep 10, 2019

Waiting for cooldict to remove its dependency on ana: zardus/cooldict#11 .


As of now, cooldict has a requirement on ana.

However, this should not be the case, and should be fixed; See issue referenced above.

For this package to build, I wrote an expression to have the ana package locally (as in #68426).

@Pamplemousse Pamplemousse force-pushed the Pamplemousse:cooldict branch from 3b7fb96 to bfb52cf Sep 10, 2019
@lheckemann lheckemann added this to the 20.03 milestone Sep 12, 2019
@Pamplemousse Pamplemousse force-pushed the Pamplemousse:cooldict branch from bfb52cf to 00f7ef7 Oct 30, 2019
@Pamplemousse Pamplemousse changed the title [WIP] pythonPackages.cooldict: init at 1.04 pythonPackages.cooldict: init at unstable-2019-10-29 Oct 30, 2019
@Pamplemousse
Copy link
Member Author

@Pamplemousse Pamplemousse commented Oct 30, 2019

Finally, cooldict removed its requiment on ana.

@jonringer , @FRidh , ready for review :)

@Pamplemousse Pamplemousse force-pushed the Pamplemousse:cooldict branch from 00f7ef7 to e4b89d6 Nov 13, 2019
@Pamplemousse Pamplemousse requested a review from jonringer Nov 13, 2019
Copy link
Contributor

@jonringer jonringer left a comment

this package im less thrilled at adding to nixpkgs,

  • very little activity/usage on github
  • no tests
  • no releases
  • unhelpful readme

I would put it into NUR

@Pamplemousse
Copy link
Member Author

@Pamplemousse Pamplemousse commented Nov 14, 2019

I am working on trying to get angr in nixpkgs (see #67413), and cooldict is one of its (home-made) component.


  • very little activity/usage on github: On this package as such yes, but angr is very active.
  • no releases: Actually, releases are numbered on PyPi.
  • no tests
  • unhelpful readme

I think this imply a broader discussion, moving to #67413 .

@Pamplemousse Pamplemousse mentioned this pull request Nov 14, 2019
@Pamplemousse
Copy link
Member Author

@Pamplemousse Pamplemousse commented Nov 15, 2019

angr remove its dependency to cooldict! angr/angr@aace252

I have added to my NUR repo: Pamplemousse/nur-packages@f66e316 .

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.