Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

rpm: 4.14.2.1 -> 4.15.0 #72956

Open
wants to merge 1 commit into
base: master
from
Open

rpm: 4.14.2.1 -> 4.15.0 #72956

wants to merge 1 commit into from

Conversation

@JohnAZoidberg
Copy link
Member

JohnAZoidberg commented Nov 7, 2019

Motivation for this change

https://rpm.org/wiki/Releases/4.15.0

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nix-review --run "nix-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
Notify maintainers

cc @copumpkin

@mmahut

This comment has been minimized.

Copy link
Member

mmahut commented Nov 7, 2019

configure: error: Python interpreter is too old```
@JohnAZoidberg

This comment has been minimized.

Copy link
Member Author

JohnAZoidberg commented Nov 7, 2019

Ooops, forgot to commit all-packages.nix.
Thanks :)

@JohnAZoidberg JohnAZoidberg force-pushed the JohnAZoidberg:rpm-415 branch from ba84e9b to 10e1523 Nov 7, 2019
Copy link
Contributor

c0bw3b left a comment

Result of nix-review pr 72956 1

1 package are marked as broken and were skipped:
  • osquery (python37Packages.rpm)
6 package failed to build:
  • lattice-diamond (python37Packages.rpm)
  • oracleXE (python37Packages.rpm)
  • plex (python37Packages.rpm)
  • plexRaw (python37Packages.rpm)
  • python27Packages.koji (python37Packages.rpm)
  • python27Packages.rpm (python37Packages.rpm)
43 package were build:
  • aliza (python37Packages.rpm)
  • arrayfire (python37Packages.rpm)
  • aucdtect (python37Packages.rpm)
  • bluejeans-gui (python37Packages.rpm)
  • clair (python37Packages.rpm)
  • clickshare-csc1 (python37Packages.rpm)
  • createrepo_c (python37Packages.rpm)
  • dell-530cdn (python37Packages.rpm)
  • diffoscope (python37Packages.rpm)
  • doodle (python37Packages.rpm)
  • drawio (python37Packages.rpm)
  • dsseries (python37Packages.rpm)
  • dtrx (python37Packages.rpm)
  • ec2-utils (python37Packages.rpm)
  • epkowa (python37Packages.rpm)
  • epm (python37Packages.rpm)
  • epson-201106w (python37Packages.rpm)
  • epson-workforce-635-nx625-series (python37Packages.rpm)
  • epson_201207w (python37Packages.rpm)
  • flatpak-builder (python37Packages.rpm)
  • forge (python37Packages.rpm)
  • gnunet (python37Packages.rpm)
  • gnunet_git (python37Packages.rpm)
  • gutenprintBin (python37Packages.rpm)
  • hpmyroom (python37Packages.rpm)
  • hydra (python37Packages.rpm)
  • intel-ocl (python37Packages.rpm)
  • libextractor (python37Packages.rpm)
  • libsolv (python37Packages.rpm)
  • megacli (python37Packages.rpm)
  • mkl (python37Packages.rpm)
  • postscript-lexmark (python37Packages.rpm)
  • python27Packages.mkl-service (python37Packages.rpm)
  • python27Packages.rhpl (python37Packages.rpm)
  • python37Packages.mkl-service (python37Packages.rpm)
  • rpm (python37Packages.rpm)
  • python38Packages.mkl-service (python37Packages.rpm)
  • python38Packages.rpm (python37Packages.rpm)
  • rpm-ostree (python37Packages.rpm)
  • rpmextract (python37Packages.rpm)
  • vdrPlugins.xineliboutput (python37Packages.rpm)
  • vk-messenger (python37Packages.rpm)
  • yandex-disk (python37Packages.rpm)

  • lattice-diamond and oracleXE failed only because I don't have the sources prefetched in my store
  • plex and plexRaw because unfree
  • python27Packages.rpm and python27Packages.koji are new failures

Logs from python27Packages.rpm are explicit:

checking whether python3 version is >= 2.7... no
configure: error: Python interpreter is too old

-> it's now Py3 only

@JohnAZoidberg JohnAZoidberg force-pushed the JohnAZoidberg:rpm-415 branch from 4d7d246 to 9c6bcef Nov 8, 2019
@JohnAZoidberg JohnAZoidberg requested review from FRidh and jonringer as code owners Nov 8, 2019
It's only compatible with Python3 now.
@JohnAZoidberg JohnAZoidberg force-pushed the JohnAZoidberg:rpm-415 branch from 9c6bcef to a98e796 Nov 9, 2019
@@ -18,7 +18,7 @@ let
packages = ( self:

let
inherit (python.passthru) isPy27 isPy33 isPy34 isPy35 isPy36 isPy37 isPy38 isPy3k isPyPy pythonAtLeast pythonOlder;
inherit (python.passthru) isPy27 isPy2 isPy33 isPy34 isPy35 isPy36 isPy37 isPy38 isPy3k isPyPy pythonAtLeast pythonOlder;

This comment has been minimized.

Copy link
@jonringer

jonringer Nov 9, 2019

Contributor

@FRidh this used to be exported, and is still set on python itself, was isPy2 removed for a reason?

This comment has been minimized.

Copy link
@FRidh

FRidh Nov 15, 2019

Member

yes it was removed because !isPy3k achieves the same and because the naming was inconsistent with isPy3k.

This comment has been minimized.

Copy link
@JohnAZoidberg

JohnAZoidberg Nov 15, 2019

Author Member

Hmm.

  • !isPy3k is technically wrong when we want to express that it only works in Python 2.x and will break when Python 4 is released
  • Py3k is not wrongly named, it was/is a name used for Python 3

But yeah, if we've migrated away from it already, I'll do that here, too.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.