Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python38Packages.spyder-kernels: 0.5.2 -> 1.0.1 #74608

Closed

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Nov 29, 2019

Semi-automatic update generated by https://github.com/ryantm/nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/python3.8-spyder-kernels/versions.

meta.description for python38Packages.spyder-kernels is: '"Jupyter kernels for Spyder's console"'.

meta.homepage for python38Packages.spyder-kernels is: '"https://github.com/spyder-ide/spyder-kernels"

Checks done (click to expand)
Rebuild report (if merged into master) (click to expand)

24 total rebuild path(s)

7 package rebuild(s)

7 x86_64-linux rebuild(s)
7 i686-linux rebuild(s)
3 x86_64-darwin rebuild(s)
7 aarch64-linux rebuild(s)

First fifty rebuilds by attrpath
python27Packages.spyder
python27Packages.spyder-kernels
python37Packages.spyder
python37Packages.spyder-kernels
python38Packages.spyder
python38Packages.spyder-kernels
spyder

Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/8hxyi6mcbikg1ibask1g5myrzjbnybhx-python3.8-spyder-kernels-1.0.1 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)

Or, build yourself:

nix-build -A python38Packages.spyder-kernels https://github.com/r-ryantm/nixpkgs/archive/114af1752f61c1ccb18a7af24e755aab6567df62.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/8hxyi6mcbikg1ibask1g5myrzjbnybhx-python3.8-spyder-kernels-1.0.1
ls -la /nix/store/8hxyi6mcbikg1ibask1g5myrzjbnybhx-python3.8-spyder-kernels-1.0.1/bin

cc @gebner for testing.

@r-ryantm r-ryantm requested review from FRidh and jonringer as code owners Nov 29, 2019
@ofborg ofborg bot added the 6.topic: python label Nov 29, 2019
@ofborg ofborg bot requested a review from gebner Nov 29, 2019
Copy link
Contributor

@jonringer jonringer left a comment

don't merge, 2 regressions:

[4 built (3 failed), 207 copied (613.8 MiB), 129.7 MiB DL]
error: build of '/nix/store/hmc622ri1sdylnl18mp15rxy30vr671v-env.drv' failed
https://github.com/NixOS/nixpkgs/pull/74608
3 package failed to build:
python27Packages.spyder spyder python38Packages.spyder

3 package were built:
python27Packages.spyder-kernels python37Packages.spyder-kernels python38Packages.spyder-kernels
@FRidh FRidh self-assigned this Nov 30, 2019
@FRidh
Copy link
Member

@FRidh FRidh commented Nov 30, 2019

This is only for development spyder, don't merge.

@FRidh
Copy link
Member

@FRidh FRidh commented Feb 9, 2020

We're at 1.8.1 already.

@FRidh FRidh closed this Feb 9, 2020
@r-ryantm r-ryantm deleted the r-ryantm:auto-update/python3.8-spyder-kernels branch Feb 11, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.