Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python38Packages.breathe: 4.13.1 -> 4.14.0 #75325

Closed

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Dec 9, 2019

Semi-automatic update generated by https://github.com/ryantm/nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/python3.8-breathe/versions.

meta.description for python38Packages.breathe is: '"Sphinx Doxygen renderer"'.

meta.homepage for python38Packages.breathe is: '"https://github.com/michaeljones/breathe"

Checks done (click to expand)
Rebuild report (if merged into master) (click to expand)

12 total rebuild path(s)

3 package rebuild(s)

3 x86_64-linux rebuild(s)
3 i686-linux rebuild(s)
3 x86_64-darwin rebuild(s)
3 aarch64-linux rebuild(s)

First fifty rebuilds by attrpath
python27Packages.breathe
python37Packages.breathe
python38Packages.breathe

Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/y5imkg2ad79r14sr15d8zmhk10qil7n3-python3.8-breathe-4.14.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)

Or, build yourself:

nix-build -A python38Packages.breathe https://github.com/r-ryantm/nixpkgs/archive/bae22d15c247fd7ccb2dfc9cf67d1822828e1166.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/y5imkg2ad79r14sr15d8zmhk10qil7n3-python3.8-breathe-4.14.0
ls -la /nix/store/y5imkg2ad79r14sr15d8zmhk10qil7n3-python3.8-breathe-4.14.0/bin

Copy link
Contributor

@jonringer jonringer left a comment

either this or sphinx should be updated to reflect that python2 is no longer supported

  ERROR: Sphinx requires at least Python 3.5 to run.
cannot build derivation '/nix/store/pr6mjnrsxgfmfy8qj3g0g5m5pn9y75v5-env.drv': 1 dependencies couldn't be built
[3 built (1 failed), 15 copied (54.0 MiB), 8.4 MiB DL]
error: build of '/nix/store/pr6mjnrsxgfmfy8qj3g0g5m5pn9y75v5-env.drv' failed
https://github.com/NixOS/nixpkgs/pull/75325
1 package failed to build:
python27Packages.breathe

2 package were built:
python37Packages.breathe python38Packages.breathe
@jonringer jonringer closed this Apr 13, 2020
@r-ryantm r-ryantm deleted the r-ryantm:auto-update/python3.8-breathe branch Apr 14, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants
You can’t perform that action at this time.