Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Agda cubical #76994

Merged
merged 14 commits into from May 19, 2020
Merged

Agda cubical #76994

merged 14 commits into from May 19, 2020

Conversation

@ryanorendorff
Copy link
Contributor

ryanorendorff commented Jan 5, 2020

Motivation for this change

Adds the cubical type theory library to nixpkgs. I asked the maintainers and @Saizan gave approval to add this library to nixpkgs.

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests) (checked for any tests, there do not appear to be).
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/) (all agda files compile)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date (I cannot find a place in the documentation for Agda things)
  • Fits CONTRIBUTING.md.
Notify maintainers

cc @jwiegley @laMudri

@laMudri
Copy link
Contributor

laMudri commented Jan 5, 2020

Possibly some modifications will be needed when #76653 is merged. /cc @alexarice

@alexarice
Copy link
Contributor

alexarice commented Jan 6, 2020

This would need to be modified slightly, either this can be merged and I rebase on top of it or the other way round

@alexarice
Copy link
Contributor

alexarice commented Jan 6, 2020

Might be easier to merge this first

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented Jan 12, 2020

Doesn't matter to me. I can also modify this if the other PR is merged first. @alexarice

@veprbl
Copy link
Member

veprbl commented May 15, 2020

@alexarice
Copy link
Contributor

alexarice commented May 15, 2020

Note that v0.1 won't compile with agda 2.6.1 and there is not a more recent version

@veprbl
Copy link
Member

veprbl commented May 15, 2020

@alexarice This warrants getting more versions of Agda in nixpkgs?

@alexarice
Copy link
Contributor

alexarice commented May 15, 2020

Perhaps, I feel the libraries should release a version that works with the new agda version, as the master versions of these libraries work

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 15, 2020

@alexarice
Copy link
Contributor

alexarice commented May 15, 2020

I feel this is the sensible option

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 15, 2020

@Saizan
Copy link

Saizan commented May 19, 2020

I ended up tagging a recent master as the 0.2 release, it does work with 2.6.1:
https://github.com/agda/cubical/releases/tag/v0.2

@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

@Saizan I tried out that commit and get the following error:

these derivations will be built:
  /nix/store/1xsk4ln5yi13y5s0cn1i57ccl42nchj9-cubical-0.2.drv
building '/nix/store/1xsk4ln5yi13y5s0cn1i57ccl42nchj9-cubical-0.2.drv'...
unpacking sources
unpacking source archive /nix/store/r5mlcnbhcp77y5wn7xxhggyi1wsaqnas-source
source root is source
patching sources
configuring
no configure script, doing nothing
building
runhaskell ./Everythings.hs gen-except Core Foundations Codata Experiments
Everythings.hs: ./Cubical/Data/DescendingList/Strict.agda: hGetContents: invalid argument (invalid byte sequence)
make: *** [GNUmakefile:30: gen-everythings] Error 1
builder for '/nix/store/1xsk4ln5yi13y5s0cn1i57ccl42nchj9-cubical-0.2.drv' failed with exit code 2
error: build of '/nix/store/1xsk4ln5yi13y5s0cn1i57ccl42nchj9-cubical-0.2.drv' failed
@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 19, 2020

I just got the same error. I'll push up what I have at the moment.

@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

The problem doesn't happen outside a nix-build

@Saizan
Copy link

Saizan commented May 19, 2020

I believe the script expects the locale to be UTF-8, is that something that can be set for the build?

@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

I think it can

@Saizan
Copy link

Saizan commented May 19, 2020

One can test it with ghc -e "print System.IO.localeEncoding".

However make all is currently doing testing, it's not something useful for "installation"

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 19, 2020

The output from the localeEncoding is ASCII. I'll try to change it to UTF-8.

maintainers/maintainer-list.nix Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
pkgs/development/libraries/agda/cubical/default.nix Outdated Show resolved Hide resolved
ryanorendorff and others added 2 commits May 19, 2020
Co-authored-by: Alex Rice <alexrice999@hotmail.co.uk>
@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

I think LC_ALL = "en_US.UTF-8"; is what we are looking for with the locale

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 19, 2020

I think LC_ALL = "en_US.UTF-8"; is what we are looking for with the locale

Hmm this leads to fun other errors:

runhaskell ./Everythings.hs gen-except Core Foundations Codata Experiments
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/nix/store/81wybawvkr95c7j8gj5ab3y740mq1fli-bash-4.4-p23/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Everythings.hs: ./Cubical/Data/DescendingList/Strict.agda: hGetContents: invalid argument (invalid byte sequence)
make: *** [GNUmakefile:30: gen-everythings] Error 1
builder for '/nix/store/kh89hx2jpkz4kfy3rzwsdvvvpwdjhi37-cubical-0.2.drv' failed with exit code 2
@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

Try to add glibcLocales to buildInputs? EDIT: Probably nativeBuildInputs

@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 19, 2020

Try to add glibcLocales to buildInputs? EDIT: Probably nativeBuildInputs

Yes that worked. Building now.

@ofborg ofborg bot requested a review from alexarice May 19, 2020
Fixes the following build error.

```
building
runhaskell ./Everythings.hs gen-except Core Foundations Codata Experiments
Everythings.hs: ./Cubical/Data/DescendingList/Strict.agda: hGetContents: invalid argument (invalid byte sequence)
make: *** [GNUmakefile:30: gen-everythings] Error 1
```
@ryanorendorff
Copy link
Contributor Author

ryanorendorff commented May 19, 2020

Builds correctly and I was able to type check some cubical code that I had.

Copy link
Contributor

alexarice left a comment

Nix-review passes
Package builds on nixos
Looks ready apart from rebase

@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

@GrahamcOfBorg build agdaPackages.cubical

sha256 = "07qlp2f189jvzbn3aqvpqk2zxpkmkxhhkjsn62iq436kxqj3z6c2";
};

LC_ALL = "en_US.UTF-8";

This comment has been minimized.

Copy link
@laMudri

laMudri May 19, 2020

Contributor

Does this not affect nearly every other Agda package? It feels like it should be the default.

This comment has been minimized.

Copy link
@alexarice

alexarice May 19, 2020

Contributor

Maybe though we haven't run into this problem before. Also this only seems to arise on the haskell building of Everything files and I don't think it is to do with agda I'm not sure it is correct to add it to the builder

This comment has been minimized.

Copy link
@laMudri

laMudri May 19, 2020

Contributor

Aah, okay, that explains a bit what's going on. I see stdlib's equivalent Haskell file makes sure everything is done in UTF-8, which is probably the right thing to do upstream.

@veprbl veprbl merged commit f7ad47a into NixOS:master May 19, 2020
16 checks passed
16 checks passed
agdaPackages.cubical on aarch64-linux Timed out, unknown build status
Details
Evaluation Performance Report Evaluator Performance Report
Details
agdaPackages.cubical on x86_64-linux Success
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-darwin nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./pkgs/t
Details
grahamcofborg-eval-lib-tests nix-build --arg pkgs import ./. {} ./lib/tests/release.nix
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./nixos/
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./nixos/
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./nixos/
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="84c3076"; rev="84c3076377e6345a41d9e02f2cfc92471b0b6ddc"; } ./pkgs/t
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
@alexarice
Copy link
Contributor

alexarice commented May 19, 2020

Thanks @ryanorendorff , @Saizan , and @veprbl for merging 😄

NickHu added a commit to NickHu/nixpkgs that referenced this pull request May 20, 2020
Co-authored-by: Alex Rice <alexrice999@hotmail.co.uk>
github-actions bot added a commit to utdemir/dotfiles that referenced this pull request May 21, 2020
Dependencies updates.

## Changelog for nixpkgs:
Commits: [NixOS/nixpkgs@62e866e...a0d7927a](NixOS/nixpkgs@62e866e...a0d7927)

* [`d65850e9`](NixOS/nixpkgs@d65850e) palp: 2.1 -> 2.11
* [`c5c0bc82`](NixOS/nixpkgs@c5c0bc8) kodi: Fix build
* [`029d3b3f`](NixOS/nixpkgs@029d3b3) teamspeak_client: 3.3.2 -> 3.5.3
* [`f3cd040e`](NixOS/nixpkgs@f3cd040) pdfarranger: 1.5.1 -> 1.5.3
* [`4459844e`](NixOS/nixpkgs@4459844) xpra: fix NixOS/nixpkgs#41106
* [`2b5d59cb`](NixOS/nixpkgs@2b5d59c) linux: Enable fbcon deferred takeover when possible
* [`ac3e9096`](NixOS/nixpkgs@ac3e909) kernelPackages.ena: 2.1.2 -> 2.2.7
* [`c3b743a6`](NixOS/nixpkgs@c3b743a) oraclejdk8: 8u241 -> 8u251
* [`09472fb9`](NixOS/nixpkgs@09472fb) cpu-x: 3.2.4 -> 4.0.0
* [`4e271593`](NixOS/nixpkgs@4e27159) nixos/binfmt: move systemd-binfmt.service to binfmt module
* [`431106a1`](NixOS/nixpkgs@431106a) nixos/zfs: add missing dependendy nettools
* [`e3f7c3e8`](NixOS/nixpkgs@e3f7c3e) editorconfig-checker: 2.0.3 -> 2.0.4
* [`fd491558`](NixOS/nixpkgs@fd49155) nixosTests.systemd-binfmt: init
* [`64decd9d`](NixOS/nixpkgs@64decd9) gitea: fix wiki template incompatibility with go 1.14
* [`64661c6e`](NixOS/nixpkgs@64661c6) lazygit: 0.18 -> 0.20.3
* [`1f689421`](NixOS/nixpkgs@1f68942) .editorconfig: set docbook indent size
* [`190577d4`](NixOS/nixpkgs@190577d) .editorconfig: ignore diffs/patches
* [`de77326d`](NixOS/nixpkgs@de77326) ytop: 0.6.1 -> 0.6.2 (NixOS/nixpkgs#88064)
* [`6b729556`](NixOS/nixpkgs@6b72955) helm: 3.2.0 -> 3.2.1
* [`311e883b`](NixOS/nixpkgs@311e883) ocamlPackages.dune-private-libs: disable for OCaml < 4.07
* [`f31adf28`](NixOS/nixpkgs@f31adf2) ocamlPackages.dune_2: use pkgs.dune_2 for OCaml < 4.07
* [`4a873aa2`](NixOS/nixpkgs@4a873aa) ocamlPackages.ppxlib: minor refactoring
* [`962f93c4`](NixOS/nixpkgs@962f93c) ocamlPackages.labltk: init at 8.06.8 for OCaml 4.10
* [`85077d9e`](NixOS/nixpkgs@85077d9) denemo: 2.3.0 -> 2.4.0
* [`7ed1c6f1`](NixOS/nixpkgs@7ed1c6f) exim: 4.92.3 -> 4.93.0.4
* [`cd2a208b`](NixOS/nixpkgs@cd2a208) nextcloud17: 17.0.4 -> 17.0.6
* [`ec1f8e26`](NixOS/nixpkgs@ec1f8e2) redis-dump: add redis-load
* [`ed301e71`](NixOS/nixpkgs@ed301e7) nextcloud18: 18.0.3 -> 18.0.4
* [`09efe9dc`](NixOS/nixpkgs@09efe9d) fira-code: 3.1 -> 4
* [`b64d1c28`](NixOS/nixpkgs@b64d1c2) openconnect: 8.05 -> 8.10
* [`2ee9aac3`](NixOS/nixpkgs@2ee9aac) skopeo: 0.2.0 -> 1.0.0
* [`a5cbd4fa`](NixOS/nixpkgs@a5cbd4f) fwupdate: remove
* [`4b377b2d`](NixOS/nixpkgs@4b377b2) hugo: 0.70.0 -> 0.71.0
* [`effceb8b`](NixOS/nixpkgs@effceb8) nixos/display-managers: Use dbus socket unit shipped by upstream
* [`fe45946f`](NixOS/nixpkgs@fe45946) podman: don't build "podman-remote"
* [`277b1da2`](NixOS/nixpkgs@277b1da) nixos/podman: add crun to test
* [`7eda9f6e`](NixOS/nixpkgs@7eda9f6) cni-plugins: add passthru.tests
* [`cd345dde`](NixOS/nixpkgs@cd345dd) conmon: add passthru.tests
* [`e469b77b`](NixOS/nixpkgs@e469b77) crun: add passthru.tests
* [`032462fc`](NixOS/nixpkgs@032462f) runc: add passthru.tests
* [`c3eef07b`](NixOS/nixpkgs@c3eef07) fuse-overlayfs: add passthru.tests
* [`71dafd02`](NixOS/nixpkgs@71dafd0) slirp4netns: add passthru.tests
* [`78fd74cf`](NixOS/nixpkgs@78fd74c) amass: 3.6.0 -> 3.6.1
* [`fe7d3db9`](NixOS/nixpkgs@fe7d3db) pythonPackage.txdbus: init at 1.1.0
* [`738df6f5`](NixOS/nixpkgs@738df6f) pythonPackage.bleak: init at 0.6.2
* [`3859ef98`](NixOS/nixpkgs@3859ef9) postgresqlPackages.timescaledb: 1.7.0 -> 1.7.1
* [`aac35831`](NixOS/nixpkgs@aac3583) firefox-beta-bin: 77.0b6 -> 77.0b7
* [`b3f79e19`](NixOS/nixpkgs@b3f79e1) firefox-devedition-bin: 77.0b6 -> 77.0b7
* [`a6137ea1`](NixOS/nixpkgs@a6137ea) mu: 1.4.5 -> 1.4.6
* [`85c2774b`](NixOS/nixpkgs@85c2774) antibody: 6.0.0 -> 6.0.1
* [`a6d8b5e0`](NixOS/nixpkgs@a6d8b5e) pythonPackages.discordpy: 1.2.5 -> 1.3.3
* [`c34d4bbe`](NixOS/nixpkgs@c34d4bb) ffsend: 0.2.61 -> 0.2.64
* [`8c97bde7`](NixOS/nixpkgs@8c97bde) aws-vault: 5.3.2 -> 5.4.4
* [`7f39cf68`](NixOS/nixpkgs@7f39cf6) bettercap: 2.27 -> 2.27.1 (NixOS/nixpkgs#88114)
* [`a6230bc3`](NixOS/nixpkgs@a6230bc) circleci-cli: 0.1.7179 -> 0.1.7523
* [`27512436`](NixOS/nixpkgs@2751243) clair: 2.1.2 -> 2.1.3
* [`0f2cbf45`](NixOS/nixpkgs@0f2cbf4) clevis: 12 -> 13
* [`715c01dd`](NixOS/nixpkgs@715c01d) clojure-lsp: 20200413T141742 -> 20200514T134144
* [`4e96cae7`](NixOS/nixpkgs@4e96cae) cloudflare-wrangler: 1.8.4 -> 1.9.0
* [`e1889cf4`](NixOS/nixpkgs@e1889cf) codeql: 2.1.1 -> 2.1.3
* [`4682a2ab`](NixOS/nixpkgs@4682a2a) cutelyst: 2.10.0 -> 2.11.0
* [`0635b562`](NixOS/nixpkgs@0635b56) dasht: 2.3.0 -> 2.4.0
* [`ed077f68`](NixOS/nixpkgs@ed077f6) handbrake: allow building from checkout
* [`3e008b34`](NixOS/nixpkgs@3e008b3) dnsproxy: 0.27.1 -> 0.28.1
* [`c644a17b`](NixOS/nixpkgs@c644a17) doctest: 2.3.7 -> 2.3.8
* [`b44b4c87`](NixOS/nixpkgs@b44b4c8) xurls: 2.0.0 -> 2.2.0
* [`748e2fcf`](NixOS/nixpkgs@748e2fc) elan: 0.10.0 -> 0.10.2
* [`072aa716`](NixOS/nixpkgs@072aa71) emplace: 0.3.1 -> 0.3.3
* [`e07f5789`](NixOS/nixpkgs@e07f578) flow: 0.124.0 -> 0.125.1
* [`c77c661d`](NixOS/nixpkgs@c77c661) fluent-bit: 1.4.3 -> 1.4.4
* [`28194c70`](NixOS/nixpkgs@28194c7) flyctl: 0.0.117 -> 0.0.123
* [`3cb5a4b9`](NixOS/nixpkgs@3cb5a4b) freenect: 0.6.0 -> 0.6.1
* [`8bd913f8`](NixOS/nixpkgs@8bd913f) ft2-clone: 1.23 -> 1.24
* [`a14f976f`](NixOS/nixpkgs@a14f976) geoipupdate: 4.2.2 -> 4.3.0
* [`667b1fa5`](NixOS/nixpkgs@667b1fa) git-quick-stats: 2.0.16 -> 2.1.1
* [`2dd8a2ca`](NixOS/nixpkgs@2dd8a2c) gomodifytags: 1.4.0 -> 1.6.0
* [`59775da4`](NixOS/nixpkgs@59775da) gotop: 3.5.0 -> 3.5.2
* [`07a46f3b`](NixOS/nixpkgs@07a46f3) wireguard-tools: 1.0.20200510 -> 1.0.20200513
* [`f5447db7`](NixOS/nixpkgs@f5447db) hebcal: 4.19 -> 4.20
* [`99f3fee1`](NixOS/nixpkgs@99f3fee) caf: 0.17.4 -> 0.17.5
* [`d2f078d5`](NixOS/nixpkgs@d2f078d) ipscan: 3.7.0 -> 3.7.1
* [`754562f8`](NixOS/nixpkgs@754562f) janet: 1.8.1 -> 1.9.1
* [`6c5e4491`](NixOS/nixpkgs@6c5e449) klayout: 0.26.4 -> 0.26.5
* [`e9576c83`](NixOS/nixpkgs@e9576c8) kube3d: 1.6.0 -> 1.7.0
* [`b44794de`](NixOS/nixpkgs@b44794d) keepass: 2.40 -> 2.45
* [`a2aec3d5`](NixOS/nixpkgs@a2aec3d) kubeseal: 0.12.0 -> 0.12.3
* [`58ba20dd`](NixOS/nixpkgs@58ba20d) kubie: 0.8.4 -> 0.9.1
* [`d890ac89`](NixOS/nixpkgs@d890ac8) kubie: use installShellFiles
* [`9c320acd`](NixOS/nixpkgs@9c320ac) flyctl: set build flags
* [`69dff5ce`](NixOS/nixpkgs@69dff5c) kubeseal: set build flags
* [`71c01067`](NixOS/nixpkgs@71c0106) dasht: install completions
* [`f80ee739`](NixOS/nixpkgs@f80ee73) kubie: enable on darwin
* [`403d4506`](NixOS/nixpkgs@403d450) libcint: 3.0.19 -> 3.0.20
* [`f0bc5221`](NixOS/nixpkgs@f0bc522) ripgrep-all: 0.9.5 -> 0.9.6
* [`6d035a9d`](NixOS/nixpkgs@6d035a9) oh-my-zsh: 2020-05-16 -> 2020-05-18
* [`f44e3d45`](NixOS/nixpkgs@f44e3d4) skypeforlinux: 8.59.0.77 -> 8.60.0.76
* [`20b3ba16`](NixOS/nixpkgs@20b3ba1) vivaldi: 2.11 -> 3.0
* [`c729ec59`](NixOS/nixpkgs@c729ec5) doc and remove superfluous toString
* [`0db36eaa`](NixOS/nixpkgs@0db36ea) riot-web: 1.6.0 -> 1.6.1
* [`8b5a3127`](NixOS/nixpkgs@8b5a312) linux: 5.7-rc4 -> 5.7-rc6
* [`307dfd90`](NixOS/nixpkgs@307dfd9) riot-desktop: 1.6.0 -> 1.6.1
* [`2a5b0bc8`](NixOS/nixpkgs@2a5b0bc) matrix-synapse: 1.12.4 -> 1.13.0
* [`aae9af96`](NixOS/nixpkgs@aae9af9) palp: fix hash
* [`f7ad47a8`](NixOS/nixpkgs@f7ad47a) agdaPackages.cubical: init at 0.2 (NixOS/nixpkgs#76994)
* [`1e873266`](NixOS/nixpkgs@1e87326) liquibase: 3.8.9 -> 3.9.0
* [`b9d37e55`](NixOS/nixpkgs@b9d37e5) maxx: drop (NixOS/nixpkgs#87715)
* [`14a70f54`](NixOS/nixpkgs@14a70f5) ocamlPackages.textutils: remove at 112.17.00
* [`431e12c0`](NixOS/nixpkgs@431e12c) minify: 2.7.3 -> 2.7.4
* [`92688a1e`](NixOS/nixpkgs@92688a1) bcompare - 4.3.2.24472 -> 4.3.4.24657 (NixOS/nixpkgs#84521)
* [`322b135f`](NixOS/nixpkgs@322b135) fd: 8.0.0 -> 8.1.0
* [`311f2ffd`](NixOS/nixpkgs@311f2ff) mutagen: 0.11.2 -> 0.11.4
* [`2f40a6c5`](NixOS/nixpkgs@2f40a6c) mame: 0.220 -> 0.221 (NixOS/nixpkgs#88146)
* [`f23c95b9`](NixOS/nixpkgs@f23c95b) netdata: 1.21.1 -> 1.22.1
* [`c24b312b`](NixOS/nixpkgs@c24b312) nfpm: 1.2.0 -> 1.2.1
* [`61335d51`](NixOS/nixpkgs@61335d5) gambit: disable use of poll() on Darwin
* [`4beef272`](NixOS/nixpkgs@4beef27) pgcenter: 0.6.4 -> 0.6.5
* [`2dde5ffe`](NixOS/nixpkgs@2dde5ff) pirate-get: 0.3.5 -> 0.3.7
* [`f4264028`](NixOS/nixpkgs@f426402) solfege: 3.22.2 -> 3.23.4
* [`4a8a4c2b`](NixOS/nixpkgs@4a8a4c2) libdeflate: 1.5 -> 1.6 (NixOS/nixpkgs#88163)
* [`3389db60`](NixOS/nixpkgs@3389db6) libdeflate: remove local prefix
* [`ec8cc560`](NixOS/nixpkgs@ec8cc56) nodejs-14_x: 14.2.0 -> 14.3.0
* [`8d6bf86d`](NixOS/nixpkgs@8d6bf86) python3Packages.azure-mgmt-batch: 7.0.0 -> 8.0.0
* [`9a9f8278`](NixOS/nixpkgs@9a9f827) python3Packages.azure-mgmt-core: 1.0.0 -> 1.1.0
* [`a807b5a9`](NixOS/nixpkgs@a807b5a) python3Packages.azure-mgmt-cosmosdb: 0.13.0 -> 0.14.0
* [`b181c7d5`](NixOS/nixpkgs@b181c7d) python3Packages.azure-mgmt-eventhub: 3.0.0 -> 3.1.0
* [`385e082b`](NixOS/nixpkgs@385e082) python3Packages.azure-mgmt-iothub: 0.11.0 -> 0.12.0
* [`0744df0b`](NixOS/nixpkgs@0744df0) python3Packages.azure-mgmt-network: 10.1.0 -> 10.2.0
* [`478c24b0`](NixOS/nixpkgs@478c24b) python3Packages.azure-mgmt-storage: 9.0.0 -> 10.0.0
* [`a6d1a993`](NixOS/nixpkgs@a6d1a99) python3Packages.azure-multiapi-storage: 0.2.4 -> 0.3.2
* [`f86a44a4`](NixOS/nixpkgs@f86a44a) python3Packages.azure-servicefabric: 7.0.0.0 -> 7.1.0.45
* [`5e82ba48`](NixOS/nixpkgs@5e82ba4) azure-cli: 2.4.0 -> 2.5.1
* [`17812e65`](NixOS/nixpkgs@17812e6) fluidasserts: 20.2.30165 -> deleted
* [`88c8f0d5`](NixOS/nixpkgs@88c8f0d) maintainers: add rpearce
* [`cc2e800a`](NixOS/nixpkgs@cc2e800) bashcards: init at v0.1.2
* [`8f1459dc`](NixOS/nixpkgs@8f1459d) run: 0.7.1 -> 0.7.2
* [`0527318a`](NixOS/nixpkgs@0527318) etcd: 3.3.20 -> 3.3.21
* [`f17dae17`](NixOS/nixpkgs@f17dae1) spdx-license-list-data: 3.8 -> 3.9
* [`b8946720`](NixOS/nixpkgs@b894672) telegraf: 1.14.1 -> 1.14.2
* [`ae876f03`](NixOS/nixpkgs@ae876f0) .editorconfig: fix invalid value for diffs/patches
* [`aef6544c`](NixOS/nixpkgs@aef6544) hobbes: 2020-03-10 -> 2020-05-19
* [`9d92aa38`](NixOS/nixpkgs@9d92aa3) etcd: add maintainer
* [`e0df66e6`](NixOS/nixpkgs@e0df66e) etcd_3_4: init at 3.4.8
* [`423296fc`](NixOS/nixpkgs@423296f) handbrake: do not harden on arm
* [`37d76c0e`](NixOS/nixpkgs@37d76c0) twitterBootstrap: 4.4.1 -> 4.5.0
* [`0900872b`](NixOS/nixpkgs@0900872) ocamlPackages.batteries: fix for OCaml 4.10
* [`cccb4f49`](NixOS/nixpkgs@cccb4f4) autorandr: 1.10 -> 1.10.1
github-actions bot added a commit to nothingelsematters/nixconfigs that referenced this pull request May 21, 2020
dependencies updates.

## Changelog for nixpkgs:
Commits: [NixOS/nixpkgs@6bcb1de...a0d7927a](NixOS/nixpkgs@6bcb1de...a0d7927)

* [`20b0143c`](NixOS/nixpkgs@20b0143) ocamlPackages.async_extra: remove at 112.24.00
* [`c3b743a6`](NixOS/nixpkgs@c3b743a) oraclejdk8: 8u241 -> 8u251
* [`09472fb9`](NixOS/nixpkgs@09472fb) cpu-x: 3.2.4 -> 4.0.0
* [`4e271593`](NixOS/nixpkgs@4e27159) nixos/binfmt: move systemd-binfmt.service to binfmt module
* [`431106a1`](NixOS/nixpkgs@431106a) nixos/zfs: add missing dependendy nettools
* [`e3f7c3e8`](NixOS/nixpkgs@e3f7c3e) editorconfig-checker: 2.0.3 -> 2.0.4
* [`fd491558`](NixOS/nixpkgs@fd49155) nixosTests.systemd-binfmt: init
* [`64decd9d`](NixOS/nixpkgs@64decd9) gitea: fix wiki template incompatibility with go 1.14
* [`64661c6e`](NixOS/nixpkgs@64661c6) lazygit: 0.18 -> 0.20.3
* [`1f689421`](NixOS/nixpkgs@1f68942) .editorconfig: set docbook indent size
* [`190577d4`](NixOS/nixpkgs@190577d) .editorconfig: ignore diffs/patches
* [`de77326d`](NixOS/nixpkgs@de77326) ytop: 0.6.1 -> 0.6.2 (NixOS/nixpkgs#88064)
* [`6b729556`](NixOS/nixpkgs@6b72955) helm: 3.2.0 -> 3.2.1
* [`311e883b`](NixOS/nixpkgs@311e883) ocamlPackages.dune-private-libs: disable for OCaml < 4.07
* [`f31adf28`](NixOS/nixpkgs@f31adf2) ocamlPackages.dune_2: use pkgs.dune_2 for OCaml < 4.07
* [`4a873aa2`](NixOS/nixpkgs@4a873aa) ocamlPackages.ppxlib: minor refactoring
* [`962f93c4`](NixOS/nixpkgs@962f93c) ocamlPackages.labltk: init at 8.06.8 for OCaml 4.10
* [`85077d9e`](NixOS/nixpkgs@85077d9) denemo: 2.3.0 -> 2.4.0
* [`7ed1c6f1`](NixOS/nixpkgs@7ed1c6f) exim: 4.92.3 -> 4.93.0.4
* [`cd2a208b`](NixOS/nixpkgs@cd2a208) nextcloud17: 17.0.4 -> 17.0.6
* [`ec1f8e26`](NixOS/nixpkgs@ec1f8e2) redis-dump: add redis-load
* [`ed301e71`](NixOS/nixpkgs@ed301e7) nextcloud18: 18.0.3 -> 18.0.4
* [`09efe9dc`](NixOS/nixpkgs@09efe9d) fira-code: 3.1 -> 4
* [`b64d1c28`](NixOS/nixpkgs@b64d1c2) openconnect: 8.05 -> 8.10
* [`2ee9aac3`](NixOS/nixpkgs@2ee9aac) skopeo: 0.2.0 -> 1.0.0
* [`a5cbd4fa`](NixOS/nixpkgs@a5cbd4f) fwupdate: remove
* [`4b377b2d`](NixOS/nixpkgs@4b377b2) hugo: 0.70.0 -> 0.71.0
* [`effceb8b`](NixOS/nixpkgs@effceb8) nixos/display-managers: Use dbus socket unit shipped by upstream
* [`fe45946f`](NixOS/nixpkgs@fe45946) podman: don't build "podman-remote"
* [`277b1da2`](NixOS/nixpkgs@277b1da) nixos/podman: add crun to test
* [`7eda9f6e`](NixOS/nixpkgs@7eda9f6) cni-plugins: add passthru.tests
* [`cd345dde`](NixOS/nixpkgs@cd345dd) conmon: add passthru.tests
* [`e469b77b`](NixOS/nixpkgs@e469b77) crun: add passthru.tests
* [`032462fc`](NixOS/nixpkgs@032462f) runc: add passthru.tests
* [`c3eef07b`](NixOS/nixpkgs@c3eef07) fuse-overlayfs: add passthru.tests
* [`71dafd02`](NixOS/nixpkgs@71dafd0) slirp4netns: add passthru.tests
* [`78fd74cf`](NixOS/nixpkgs@78fd74c) amass: 3.6.0 -> 3.6.1
* [`fe7d3db9`](NixOS/nixpkgs@fe7d3db) pythonPackage.txdbus: init at 1.1.0
* [`738df6f5`](NixOS/nixpkgs@738df6f) pythonPackage.bleak: init at 0.6.2
* [`3859ef98`](NixOS/nixpkgs@3859ef9) postgresqlPackages.timescaledb: 1.7.0 -> 1.7.1
* [`aac35831`](NixOS/nixpkgs@aac3583) firefox-beta-bin: 77.0b6 -> 77.0b7
* [`b3f79e19`](NixOS/nixpkgs@b3f79e1) firefox-devedition-bin: 77.0b6 -> 77.0b7
* [`a6137ea1`](NixOS/nixpkgs@a6137ea) mu: 1.4.5 -> 1.4.6
* [`85c2774b`](NixOS/nixpkgs@85c2774) antibody: 6.0.0 -> 6.0.1
* [`a6d8b5e0`](NixOS/nixpkgs@a6d8b5e) pythonPackages.discordpy: 1.2.5 -> 1.3.3
* [`c34d4bbe`](NixOS/nixpkgs@c34d4bb) ffsend: 0.2.61 -> 0.2.64
* [`8c97bde7`](NixOS/nixpkgs@8c97bde) aws-vault: 5.3.2 -> 5.4.4
* [`7f39cf68`](NixOS/nixpkgs@7f39cf6) bettercap: 2.27 -> 2.27.1 (NixOS/nixpkgs#88114)
* [`a6230bc3`](NixOS/nixpkgs@a6230bc) circleci-cli: 0.1.7179 -> 0.1.7523
* [`27512436`](NixOS/nixpkgs@2751243) clair: 2.1.2 -> 2.1.3
* [`0f2cbf45`](NixOS/nixpkgs@0f2cbf4) clevis: 12 -> 13
* [`715c01dd`](NixOS/nixpkgs@715c01d) clojure-lsp: 20200413T141742 -> 20200514T134144
* [`4e96cae7`](NixOS/nixpkgs@4e96cae) cloudflare-wrangler: 1.8.4 -> 1.9.0
* [`e1889cf4`](NixOS/nixpkgs@e1889cf) codeql: 2.1.1 -> 2.1.3
* [`4682a2ab`](NixOS/nixpkgs@4682a2a) cutelyst: 2.10.0 -> 2.11.0
* [`0635b562`](NixOS/nixpkgs@0635b56) dasht: 2.3.0 -> 2.4.0
* [`ed077f68`](NixOS/nixpkgs@ed077f6) handbrake: allow building from checkout
* [`3e008b34`](NixOS/nixpkgs@3e008b3) dnsproxy: 0.27.1 -> 0.28.1
* [`c644a17b`](NixOS/nixpkgs@c644a17) doctest: 2.3.7 -> 2.3.8
* [`b44b4c87`](NixOS/nixpkgs@b44b4c8) xurls: 2.0.0 -> 2.2.0
* [`748e2fcf`](NixOS/nixpkgs@748e2fc) elan: 0.10.0 -> 0.10.2
* [`072aa716`](NixOS/nixpkgs@072aa71) emplace: 0.3.1 -> 0.3.3
* [`e07f5789`](NixOS/nixpkgs@e07f578) flow: 0.124.0 -> 0.125.1
* [`c77c661d`](NixOS/nixpkgs@c77c661) fluent-bit: 1.4.3 -> 1.4.4
* [`28194c70`](NixOS/nixpkgs@28194c7) flyctl: 0.0.117 -> 0.0.123
* [`3cb5a4b9`](NixOS/nixpkgs@3cb5a4b) freenect: 0.6.0 -> 0.6.1
* [`8bd913f8`](NixOS/nixpkgs@8bd913f) ft2-clone: 1.23 -> 1.24
* [`a14f976f`](NixOS/nixpkgs@a14f976) geoipupdate: 4.2.2 -> 4.3.0
* [`667b1fa5`](NixOS/nixpkgs@667b1fa) git-quick-stats: 2.0.16 -> 2.1.1
* [`2dd8a2ca`](NixOS/nixpkgs@2dd8a2c) gomodifytags: 1.4.0 -> 1.6.0
* [`59775da4`](NixOS/nixpkgs@59775da) gotop: 3.5.0 -> 3.5.2
* [`07a46f3b`](NixOS/nixpkgs@07a46f3) wireguard-tools: 1.0.20200510 -> 1.0.20200513
* [`f5447db7`](NixOS/nixpkgs@f5447db) hebcal: 4.19 -> 4.20
* [`99f3fee1`](NixOS/nixpkgs@99f3fee) caf: 0.17.4 -> 0.17.5
* [`d2f078d5`](NixOS/nixpkgs@d2f078d) ipscan: 3.7.0 -> 3.7.1
* [`754562f8`](NixOS/nixpkgs@754562f) janet: 1.8.1 -> 1.9.1
* [`6c5e4491`](NixOS/nixpkgs@6c5e449) klayout: 0.26.4 -> 0.26.5
* [`e9576c83`](NixOS/nixpkgs@e9576c8) kube3d: 1.6.0 -> 1.7.0
* [`b44794de`](NixOS/nixpkgs@b44794d) keepass: 2.40 -> 2.45
* [`a2aec3d5`](NixOS/nixpkgs@a2aec3d) kubeseal: 0.12.0 -> 0.12.3
* [`58ba20dd`](NixOS/nixpkgs@58ba20d) kubie: 0.8.4 -> 0.9.1
* [`d890ac89`](NixOS/nixpkgs@d890ac8) kubie: use installShellFiles
* [`9c320acd`](NixOS/nixpkgs@9c320ac) flyctl: set build flags
* [`69dff5ce`](NixOS/nixpkgs@69dff5c) kubeseal: set build flags
* [`71c01067`](NixOS/nixpkgs@71c0106) dasht: install completions
* [`f80ee739`](NixOS/nixpkgs@f80ee73) kubie: enable on darwin
* [`403d4506`](NixOS/nixpkgs@403d450) libcint: 3.0.19 -> 3.0.20
* [`f0bc5221`](NixOS/nixpkgs@f0bc522) ripgrep-all: 0.9.5 -> 0.9.6
* [`6d035a9d`](NixOS/nixpkgs@6d035a9) oh-my-zsh: 2020-05-16 -> 2020-05-18
* [`f44e3d45`](NixOS/nixpkgs@f44e3d4) skypeforlinux: 8.59.0.77 -> 8.60.0.76
* [`20b3ba16`](NixOS/nixpkgs@20b3ba1) vivaldi: 2.11 -> 3.0
* [`c729ec59`](NixOS/nixpkgs@c729ec5) doc and remove superfluous toString
* [`0db36eaa`](NixOS/nixpkgs@0db36ea) riot-web: 1.6.0 -> 1.6.1
* [`8b5a3127`](NixOS/nixpkgs@8b5a312) linux: 5.7-rc4 -> 5.7-rc6
* [`307dfd90`](NixOS/nixpkgs@307dfd9) riot-desktop: 1.6.0 -> 1.6.1
* [`2a5b0bc8`](NixOS/nixpkgs@2a5b0bc) matrix-synapse: 1.12.4 -> 1.13.0
* [`aae9af96`](NixOS/nixpkgs@aae9af9) palp: fix hash
* [`f7ad47a8`](NixOS/nixpkgs@f7ad47a) agdaPackages.cubical: init at 0.2 (NixOS/nixpkgs#76994)
* [`1e873266`](NixOS/nixpkgs@1e87326) liquibase: 3.8.9 -> 3.9.0
* [`b9d37e55`](NixOS/nixpkgs@b9d37e5) maxx: drop (NixOS/nixpkgs#87715)
* [`14a70f54`](NixOS/nixpkgs@14a70f5) ocamlPackages.textutils: remove at 112.17.00
* [`431e12c0`](NixOS/nixpkgs@431e12c) minify: 2.7.3 -> 2.7.4
* [`92688a1e`](NixOS/nixpkgs@92688a1) bcompare - 4.3.2.24472 -> 4.3.4.24657 (NixOS/nixpkgs#84521)
* [`322b135f`](NixOS/nixpkgs@322b135) fd: 8.0.0 -> 8.1.0
* [`311f2ffd`](NixOS/nixpkgs@311f2ff) mutagen: 0.11.2 -> 0.11.4
* [`2f40a6c5`](NixOS/nixpkgs@2f40a6c) mame: 0.220 -> 0.221 (NixOS/nixpkgs#88146)
* [`f23c95b9`](NixOS/nixpkgs@f23c95b) netdata: 1.21.1 -> 1.22.1
* [`c24b312b`](NixOS/nixpkgs@c24b312) nfpm: 1.2.0 -> 1.2.1
* [`61335d51`](NixOS/nixpkgs@61335d5) gambit: disable use of poll() on Darwin
* [`4beef272`](NixOS/nixpkgs@4beef27) pgcenter: 0.6.4 -> 0.6.5
* [`2dde5ffe`](NixOS/nixpkgs@2dde5ff) pirate-get: 0.3.5 -> 0.3.7
* [`f4264028`](NixOS/nixpkgs@f426402) solfege: 3.22.2 -> 3.23.4
* [`4a8a4c2b`](NixOS/nixpkgs@4a8a4c2) libdeflate: 1.5 -> 1.6 (NixOS/nixpkgs#88163)
* [`3389db60`](NixOS/nixpkgs@3389db6) libdeflate: remove local prefix
* [`ec8cc560`](NixOS/nixpkgs@ec8cc56) nodejs-14_x: 14.2.0 -> 14.3.0
* [`8d6bf86d`](NixOS/nixpkgs@8d6bf86) python3Packages.azure-mgmt-batch: 7.0.0 -> 8.0.0
* [`9a9f8278`](NixOS/nixpkgs@9a9f827) python3Packages.azure-mgmt-core: 1.0.0 -> 1.1.0
* [`a807b5a9`](NixOS/nixpkgs@a807b5a) python3Packages.azure-mgmt-cosmosdb: 0.13.0 -> 0.14.0
* [`b181c7d5`](NixOS/nixpkgs@b181c7d) python3Packages.azure-mgmt-eventhub: 3.0.0 -> 3.1.0
* [`385e082b`](NixOS/nixpkgs@385e082) python3Packages.azure-mgmt-iothub: 0.11.0 -> 0.12.0
* [`0744df0b`](NixOS/nixpkgs@0744df0) python3Packages.azure-mgmt-network: 10.1.0 -> 10.2.0
* [`478c24b0`](NixOS/nixpkgs@478c24b) python3Packages.azure-mgmt-storage: 9.0.0 -> 10.0.0
* [`a6d1a993`](NixOS/nixpkgs@a6d1a99) python3Packages.azure-multiapi-storage: 0.2.4 -> 0.3.2
* [`f86a44a4`](NixOS/nixpkgs@f86a44a) python3Packages.azure-servicefabric: 7.0.0.0 -> 7.1.0.45
* [`5e82ba48`](NixOS/nixpkgs@5e82ba4) azure-cli: 2.4.0 -> 2.5.1
* [`17812e65`](NixOS/nixpkgs@17812e6) fluidasserts: 20.2.30165 -> deleted
* [`88c8f0d5`](NixOS/nixpkgs@88c8f0d) maintainers: add rpearce
* [`cc2e800a`](NixOS/nixpkgs@cc2e800) bashcards: init at v0.1.2
* [`8f1459dc`](NixOS/nixpkgs@8f1459d) run: 0.7.1 -> 0.7.2
* [`0527318a`](NixOS/nixpkgs@0527318) etcd: 3.3.20 -> 3.3.21
* [`f17dae17`](NixOS/nixpkgs@f17dae1) spdx-license-list-data: 3.8 -> 3.9
* [`b8946720`](NixOS/nixpkgs@b894672) telegraf: 1.14.1 -> 1.14.2
* [`ae876f03`](NixOS/nixpkgs@ae876f0) .editorconfig: fix invalid value for diffs/patches
* [`aef6544c`](NixOS/nixpkgs@aef6544) hobbes: 2020-03-10 -> 2020-05-19
* [`9d92aa38`](NixOS/nixpkgs@9d92aa3) etcd: add maintainer
* [`e0df66e6`](NixOS/nixpkgs@e0df66e) etcd_3_4: init at 3.4.8
* [`423296fc`](NixOS/nixpkgs@423296f) handbrake: do not harden on arm
* [`37d76c0e`](NixOS/nixpkgs@37d76c0) twitterBootstrap: 4.4.1 -> 4.5.0
* [`0900872b`](NixOS/nixpkgs@0900872) ocamlPackages.batteries: fix for OCaml 4.10
* [`cccb4f49`](NixOS/nixpkgs@cccb4f4) autorandr: 1.10 -> 1.10.1
nothingelsematters pushed a commit to nothingelsematters/nixconfigs that referenced this pull request May 21, 2020
dependencies updates.

## Changelog for nixpkgs:
Commits: [NixOS/nixpkgs@6bcb1de...a0d7927a](NixOS/nixpkgs@6bcb1de...a0d7927)

* [`20b0143c`](NixOS/nixpkgs@20b0143) ocamlPackages.async_extra: remove at 112.24.00
* [`c3b743a6`](NixOS/nixpkgs@c3b743a) oraclejdk8: 8u241 -> 8u251
* [`09472fb9`](NixOS/nixpkgs@09472fb) cpu-x: 3.2.4 -> 4.0.0
* [`4e271593`](NixOS/nixpkgs@4e27159) nixos/binfmt: move systemd-binfmt.service to binfmt module
* [`431106a1`](NixOS/nixpkgs@431106a) nixos/zfs: add missing dependendy nettools
* [`e3f7c3e8`](NixOS/nixpkgs@e3f7c3e) editorconfig-checker: 2.0.3 -> 2.0.4
* [`fd491558`](NixOS/nixpkgs@fd49155) nixosTests.systemd-binfmt: init
* [`64decd9d`](NixOS/nixpkgs@64decd9) gitea: fix wiki template incompatibility with go 1.14
* [`64661c6e`](NixOS/nixpkgs@64661c6) lazygit: 0.18 -> 0.20.3
* [`1f689421`](NixOS/nixpkgs@1f68942) .editorconfig: set docbook indent size
* [`190577d4`](NixOS/nixpkgs@190577d) .editorconfig: ignore diffs/patches
* [`de77326d`](NixOS/nixpkgs@de77326) ytop: 0.6.1 -> 0.6.2 (NixOS/nixpkgs#88064)
* [`6b729556`](NixOS/nixpkgs@6b72955) helm: 3.2.0 -> 3.2.1
* [`311e883b`](NixOS/nixpkgs@311e883) ocamlPackages.dune-private-libs: disable for OCaml < 4.07
* [`f31adf28`](NixOS/nixpkgs@f31adf2) ocamlPackages.dune_2: use pkgs.dune_2 for OCaml < 4.07
* [`4a873aa2`](NixOS/nixpkgs@4a873aa) ocamlPackages.ppxlib: minor refactoring
* [`962f93c4`](NixOS/nixpkgs@962f93c) ocamlPackages.labltk: init at 8.06.8 for OCaml 4.10
* [`85077d9e`](NixOS/nixpkgs@85077d9) denemo: 2.3.0 -> 2.4.0
* [`7ed1c6f1`](NixOS/nixpkgs@7ed1c6f) exim: 4.92.3 -> 4.93.0.4
* [`cd2a208b`](NixOS/nixpkgs@cd2a208) nextcloud17: 17.0.4 -> 17.0.6
* [`ec1f8e26`](NixOS/nixpkgs@ec1f8e2) redis-dump: add redis-load
* [`ed301e71`](NixOS/nixpkgs@ed301e7) nextcloud18: 18.0.3 -> 18.0.4
* [`09efe9dc`](NixOS/nixpkgs@09efe9d) fira-code: 3.1 -> 4
* [`b64d1c28`](NixOS/nixpkgs@b64d1c2) openconnect: 8.05 -> 8.10
* [`2ee9aac3`](NixOS/nixpkgs@2ee9aac) skopeo: 0.2.0 -> 1.0.0
* [`a5cbd4fa`](NixOS/nixpkgs@a5cbd4f) fwupdate: remove
* [`4b377b2d`](NixOS/nixpkgs@4b377b2) hugo: 0.70.0 -> 0.71.0
* [`effceb8b`](NixOS/nixpkgs@effceb8) nixos/display-managers: Use dbus socket unit shipped by upstream
* [`fe45946f`](NixOS/nixpkgs@fe45946) podman: don't build "podman-remote"
* [`277b1da2`](NixOS/nixpkgs@277b1da) nixos/podman: add crun to test
* [`7eda9f6e`](NixOS/nixpkgs@7eda9f6) cni-plugins: add passthru.tests
* [`cd345dde`](NixOS/nixpkgs@cd345dd) conmon: add passthru.tests
* [`e469b77b`](NixOS/nixpkgs@e469b77) crun: add passthru.tests
* [`032462fc`](NixOS/nixpkgs@032462f) runc: add passthru.tests
* [`c3eef07b`](NixOS/nixpkgs@c3eef07) fuse-overlayfs: add passthru.tests
* [`71dafd02`](NixOS/nixpkgs@71dafd0) slirp4netns: add passthru.tests
* [`78fd74cf`](NixOS/nixpkgs@78fd74c) amass: 3.6.0 -> 3.6.1
* [`fe7d3db9`](NixOS/nixpkgs@fe7d3db) pythonPackage.txdbus: init at 1.1.0
* [`738df6f5`](NixOS/nixpkgs@738df6f) pythonPackage.bleak: init at 0.6.2
* [`3859ef98`](NixOS/nixpkgs@3859ef9) postgresqlPackages.timescaledb: 1.7.0 -> 1.7.1
* [`aac35831`](NixOS/nixpkgs@aac3583) firefox-beta-bin: 77.0b6 -> 77.0b7
* [`b3f79e19`](NixOS/nixpkgs@b3f79e1) firefox-devedition-bin: 77.0b6 -> 77.0b7
* [`a6137ea1`](NixOS/nixpkgs@a6137ea) mu: 1.4.5 -> 1.4.6
* [`85c2774b`](NixOS/nixpkgs@85c2774) antibody: 6.0.0 -> 6.0.1
* [`a6d8b5e0`](NixOS/nixpkgs@a6d8b5e) pythonPackages.discordpy: 1.2.5 -> 1.3.3
* [`c34d4bbe`](NixOS/nixpkgs@c34d4bb) ffsend: 0.2.61 -> 0.2.64
* [`8c97bde7`](NixOS/nixpkgs@8c97bde) aws-vault: 5.3.2 -> 5.4.4
* [`7f39cf68`](NixOS/nixpkgs@7f39cf6) bettercap: 2.27 -> 2.27.1 (NixOS/nixpkgs#88114)
* [`a6230bc3`](NixOS/nixpkgs@a6230bc) circleci-cli: 0.1.7179 -> 0.1.7523
* [`27512436`](NixOS/nixpkgs@2751243) clair: 2.1.2 -> 2.1.3
* [`0f2cbf45`](NixOS/nixpkgs@0f2cbf4) clevis: 12 -> 13
* [`715c01dd`](NixOS/nixpkgs@715c01d) clojure-lsp: 20200413T141742 -> 20200514T134144
* [`4e96cae7`](NixOS/nixpkgs@4e96cae) cloudflare-wrangler: 1.8.4 -> 1.9.0
* [`e1889cf4`](NixOS/nixpkgs@e1889cf) codeql: 2.1.1 -> 2.1.3
* [`4682a2ab`](NixOS/nixpkgs@4682a2a) cutelyst: 2.10.0 -> 2.11.0
* [`0635b562`](NixOS/nixpkgs@0635b56) dasht: 2.3.0 -> 2.4.0
* [`ed077f68`](NixOS/nixpkgs@ed077f6) handbrake: allow building from checkout
* [`3e008b34`](NixOS/nixpkgs@3e008b3) dnsproxy: 0.27.1 -> 0.28.1
* [`c644a17b`](NixOS/nixpkgs@c644a17) doctest: 2.3.7 -> 2.3.8
* [`b44b4c87`](NixOS/nixpkgs@b44b4c8) xurls: 2.0.0 -> 2.2.0
* [`748e2fcf`](NixOS/nixpkgs@748e2fc) elan: 0.10.0 -> 0.10.2
* [`072aa716`](NixOS/nixpkgs@072aa71) emplace: 0.3.1 -> 0.3.3
* [`e07f5789`](NixOS/nixpkgs@e07f578) flow: 0.124.0 -> 0.125.1
* [`c77c661d`](NixOS/nixpkgs@c77c661) fluent-bit: 1.4.3 -> 1.4.4
* [`28194c70`](NixOS/nixpkgs@28194c7) flyctl: 0.0.117 -> 0.0.123
* [`3cb5a4b9`](NixOS/nixpkgs@3cb5a4b) freenect: 0.6.0 -> 0.6.1
* [`8bd913f8`](NixOS/nixpkgs@8bd913f) ft2-clone: 1.23 -> 1.24
* [`a14f976f`](NixOS/nixpkgs@a14f976) geoipupdate: 4.2.2 -> 4.3.0
* [`667b1fa5`](NixOS/nixpkgs@667b1fa) git-quick-stats: 2.0.16 -> 2.1.1
* [`2dd8a2ca`](NixOS/nixpkgs@2dd8a2c) gomodifytags: 1.4.0 -> 1.6.0
* [`59775da4`](NixOS/nixpkgs@59775da) gotop: 3.5.0 -> 3.5.2
* [`07a46f3b`](NixOS/nixpkgs@07a46f3) wireguard-tools: 1.0.20200510 -> 1.0.20200513
* [`f5447db7`](NixOS/nixpkgs@f5447db) hebcal: 4.19 -> 4.20
* [`99f3fee1`](NixOS/nixpkgs@99f3fee) caf: 0.17.4 -> 0.17.5
* [`d2f078d5`](NixOS/nixpkgs@d2f078d) ipscan: 3.7.0 -> 3.7.1
* [`754562f8`](NixOS/nixpkgs@754562f) janet: 1.8.1 -> 1.9.1
* [`6c5e4491`](NixOS/nixpkgs@6c5e449) klayout: 0.26.4 -> 0.26.5
* [`e9576c83`](NixOS/nixpkgs@e9576c8) kube3d: 1.6.0 -> 1.7.0
* [`b44794de`](NixOS/nixpkgs@b44794d) keepass: 2.40 -> 2.45
* [`a2aec3d5`](NixOS/nixpkgs@a2aec3d) kubeseal: 0.12.0 -> 0.12.3
* [`58ba20dd`](NixOS/nixpkgs@58ba20d) kubie: 0.8.4 -> 0.9.1
* [`d890ac89`](NixOS/nixpkgs@d890ac8) kubie: use installShellFiles
* [`9c320acd`](NixOS/nixpkgs@9c320ac) flyctl: set build flags
* [`69dff5ce`](NixOS/nixpkgs@69dff5c) kubeseal: set build flags
* [`71c01067`](NixOS/nixpkgs@71c0106) dasht: install completions
* [`f80ee739`](NixOS/nixpkgs@f80ee73) kubie: enable on darwin
* [`403d4506`](NixOS/nixpkgs@403d450) libcint: 3.0.19 -> 3.0.20
* [`f0bc5221`](NixOS/nixpkgs@f0bc522) ripgrep-all: 0.9.5 -> 0.9.6
* [`6d035a9d`](NixOS/nixpkgs@6d035a9) oh-my-zsh: 2020-05-16 -> 2020-05-18
* [`f44e3d45`](NixOS/nixpkgs@f44e3d4) skypeforlinux: 8.59.0.77 -> 8.60.0.76
* [`20b3ba16`](NixOS/nixpkgs@20b3ba1) vivaldi: 2.11 -> 3.0
* [`c729ec59`](NixOS/nixpkgs@c729ec5) doc and remove superfluous toString
* [`0db36eaa`](NixOS/nixpkgs@0db36ea) riot-web: 1.6.0 -> 1.6.1
* [`8b5a3127`](NixOS/nixpkgs@8b5a312) linux: 5.7-rc4 -> 5.7-rc6
* [`307dfd90`](NixOS/nixpkgs@307dfd9) riot-desktop: 1.6.0 -> 1.6.1
* [`2a5b0bc8`](NixOS/nixpkgs@2a5b0bc) matrix-synapse: 1.12.4 -> 1.13.0
* [`aae9af96`](NixOS/nixpkgs@aae9af9) palp: fix hash
* [`f7ad47a8`](NixOS/nixpkgs@f7ad47a) agdaPackages.cubical: init at 0.2 (NixOS/nixpkgs#76994)
* [`1e873266`](NixOS/nixpkgs@1e87326) liquibase: 3.8.9 -> 3.9.0
* [`b9d37e55`](NixOS/nixpkgs@b9d37e5) maxx: drop (NixOS/nixpkgs#87715)
* [`14a70f54`](NixOS/nixpkgs@14a70f5) ocamlPackages.textutils: remove at 112.17.00
* [`431e12c0`](NixOS/nixpkgs@431e12c) minify: 2.7.3 -> 2.7.4
* [`92688a1e`](NixOS/nixpkgs@92688a1) bcompare - 4.3.2.24472 -> 4.3.4.24657 (NixOS/nixpkgs#84521)
* [`322b135f`](NixOS/nixpkgs@322b135) fd: 8.0.0 -> 8.1.0
* [`311f2ffd`](NixOS/nixpkgs@311f2ff) mutagen: 0.11.2 -> 0.11.4
* [`2f40a6c5`](NixOS/nixpkgs@2f40a6c) mame: 0.220 -> 0.221 (NixOS/nixpkgs#88146)
* [`f23c95b9`](NixOS/nixpkgs@f23c95b) netdata: 1.21.1 -> 1.22.1
* [`c24b312b`](NixOS/nixpkgs@c24b312) nfpm: 1.2.0 -> 1.2.1
* [`61335d51`](NixOS/nixpkgs@61335d5) gambit: disable use of poll() on Darwin
* [`4beef272`](NixOS/nixpkgs@4beef27) pgcenter: 0.6.4 -> 0.6.5
* [`2dde5ffe`](NixOS/nixpkgs@2dde5ff) pirate-get: 0.3.5 -> 0.3.7
* [`f4264028`](NixOS/nixpkgs@f426402) solfege: 3.22.2 -> 3.23.4
* [`4a8a4c2b`](NixOS/nixpkgs@4a8a4c2) libdeflate: 1.5 -> 1.6 (NixOS/nixpkgs#88163)
* [`3389db60`](NixOS/nixpkgs@3389db6) libdeflate: remove local prefix
* [`ec8cc560`](NixOS/nixpkgs@ec8cc56) nodejs-14_x: 14.2.0 -> 14.3.0
* [`8d6bf86d`](NixOS/nixpkgs@8d6bf86) python3Packages.azure-mgmt-batch: 7.0.0 -> 8.0.0
* [`9a9f8278`](NixOS/nixpkgs@9a9f827) python3Packages.azure-mgmt-core: 1.0.0 -> 1.1.0
* [`a807b5a9`](NixOS/nixpkgs@a807b5a) python3Packages.azure-mgmt-cosmosdb: 0.13.0 -> 0.14.0
* [`b181c7d5`](NixOS/nixpkgs@b181c7d) python3Packages.azure-mgmt-eventhub: 3.0.0 -> 3.1.0
* [`385e082b`](NixOS/nixpkgs@385e082) python3Packages.azure-mgmt-iothub: 0.11.0 -> 0.12.0
* [`0744df0b`](NixOS/nixpkgs@0744df0) python3Packages.azure-mgmt-network: 10.1.0 -> 10.2.0
* [`478c24b0`](NixOS/nixpkgs@478c24b) python3Packages.azure-mgmt-storage: 9.0.0 -> 10.0.0
* [`a6d1a993`](NixOS/nixpkgs@a6d1a99) python3Packages.azure-multiapi-storage: 0.2.4 -> 0.3.2
* [`f86a44a4`](NixOS/nixpkgs@f86a44a) python3Packages.azure-servicefabric: 7.0.0.0 -> 7.1.0.45
* [`5e82ba48`](NixOS/nixpkgs@5e82ba4) azure-cli: 2.4.0 -> 2.5.1
* [`17812e65`](NixOS/nixpkgs@17812e6) fluidasserts: 20.2.30165 -> deleted
* [`88c8f0d5`](NixOS/nixpkgs@88c8f0d) maintainers: add rpearce
* [`cc2e800a`](NixOS/nixpkgs@cc2e800) bashcards: init at v0.1.2
* [`8f1459dc`](NixOS/nixpkgs@8f1459d) run: 0.7.1 -> 0.7.2
* [`0527318a`](NixOS/nixpkgs@0527318) etcd: 3.3.20 -> 3.3.21
* [`f17dae17`](NixOS/nixpkgs@f17dae1) spdx-license-list-data: 3.8 -> 3.9
* [`b8946720`](NixOS/nixpkgs@b894672) telegraf: 1.14.1 -> 1.14.2
* [`ae876f03`](NixOS/nixpkgs@ae876f0) .editorconfig: fix invalid value for diffs/patches
* [`aef6544c`](NixOS/nixpkgs@aef6544) hobbes: 2020-03-10 -> 2020-05-19
* [`9d92aa38`](NixOS/nixpkgs@9d92aa3) etcd: add maintainer
* [`e0df66e6`](NixOS/nixpkgs@e0df66e) etcd_3_4: init at 3.4.8
* [`423296fc`](NixOS/nixpkgs@423296f) handbrake: do not harden on arm
* [`37d76c0e`](NixOS/nixpkgs@37d76c0) twitterBootstrap: 4.4.1 -> 4.5.0
* [`0900872b`](NixOS/nixpkgs@0900872) ocamlPackages.batteries: fix for OCaml 4.10
* [`cccb4f49`](NixOS/nixpkgs@cccb4f4) autorandr: 1.10 -> 1.10.1

Co-authored-by: github-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>
nothingelsematters added a commit to nothingelsematters/nixconfigs that referenced this pull request Jun 14, 2020
dependencies updates.

## Changelog for nixpkgs:
Commits: [NixOS/nixpkgs@6bcb1de...a0d7927a](NixOS/nixpkgs@6bcb1de...a0d7927)

* [`20b0143c`](NixOS/nixpkgs@20b0143) ocamlPackages.async_extra: remove at 112.24.00
* [`c3b743a6`](NixOS/nixpkgs@c3b743a) oraclejdk8: 8u241 -> 8u251
* [`09472fb9`](NixOS/nixpkgs@09472fb) cpu-x: 3.2.4 -> 4.0.0
* [`4e271593`](NixOS/nixpkgs@4e27159) nixos/binfmt: move systemd-binfmt.service to binfmt module
* [`431106a1`](NixOS/nixpkgs@431106a) nixos/zfs: add missing dependendy nettools
* [`e3f7c3e8`](NixOS/nixpkgs@e3f7c3e) editorconfig-checker: 2.0.3 -> 2.0.4
* [`fd491558`](NixOS/nixpkgs@fd49155) nixosTests.systemd-binfmt: init
* [`64decd9d`](NixOS/nixpkgs@64decd9) gitea: fix wiki template incompatibility with go 1.14
* [`64661c6e`](NixOS/nixpkgs@64661c6) lazygit: 0.18 -> 0.20.3
* [`1f689421`](NixOS/nixpkgs@1f68942) .editorconfig: set docbook indent size
* [`190577d4`](NixOS/nixpkgs@190577d) .editorconfig: ignore diffs/patches
* [`de77326d`](NixOS/nixpkgs@de77326) ytop: 0.6.1 -> 0.6.2 (NixOS/nixpkgs#88064)
* [`6b729556`](NixOS/nixpkgs@6b72955) helm: 3.2.0 -> 3.2.1
* [`311e883b`](NixOS/nixpkgs@311e883) ocamlPackages.dune-private-libs: disable for OCaml < 4.07
* [`f31adf28`](NixOS/nixpkgs@f31adf2) ocamlPackages.dune_2: use pkgs.dune_2 for OCaml < 4.07
* [`4a873aa2`](NixOS/nixpkgs@4a873aa) ocamlPackages.ppxlib: minor refactoring
* [`962f93c4`](NixOS/nixpkgs@962f93c) ocamlPackages.labltk: init at 8.06.8 for OCaml 4.10
* [`85077d9e`](NixOS/nixpkgs@85077d9) denemo: 2.3.0 -> 2.4.0
* [`7ed1c6f1`](NixOS/nixpkgs@7ed1c6f) exim: 4.92.3 -> 4.93.0.4
* [`cd2a208b`](NixOS/nixpkgs@cd2a208) nextcloud17: 17.0.4 -> 17.0.6
* [`ec1f8e26`](NixOS/nixpkgs@ec1f8e2) redis-dump: add redis-load
* [`ed301e71`](NixOS/nixpkgs@ed301e7) nextcloud18: 18.0.3 -> 18.0.4
* [`09efe9dc`](NixOS/nixpkgs@09efe9d) fira-code: 3.1 -> 4
* [`b64d1c28`](NixOS/nixpkgs@b64d1c2) openconnect: 8.05 -> 8.10
* [`2ee9aac3`](NixOS/nixpkgs@2ee9aac) skopeo: 0.2.0 -> 1.0.0
* [`a5cbd4fa`](NixOS/nixpkgs@a5cbd4f) fwupdate: remove
* [`4b377b2d`](NixOS/nixpkgs@4b377b2) hugo: 0.70.0 -> 0.71.0
* [`effceb8b`](NixOS/nixpkgs@effceb8) nixos/display-managers: Use dbus socket unit shipped by upstream
* [`fe45946f`](NixOS/nixpkgs@fe45946) podman: don't build "podman-remote"
* [`277b1da2`](NixOS/nixpkgs@277b1da) nixos/podman: add crun to test
* [`7eda9f6e`](NixOS/nixpkgs@7eda9f6) cni-plugins: add passthru.tests
* [`cd345dde`](NixOS/nixpkgs@cd345dd) conmon: add passthru.tests
* [`e469b77b`](NixOS/nixpkgs@e469b77) crun: add passthru.tests
* [`032462fc`](NixOS/nixpkgs@032462f) runc: add passthru.tests
* [`c3eef07b`](NixOS/nixpkgs@c3eef07) fuse-overlayfs: add passthru.tests
* [`71dafd02`](NixOS/nixpkgs@71dafd0) slirp4netns: add passthru.tests
* [`78fd74cf`](NixOS/nixpkgs@78fd74c) amass: 3.6.0 -> 3.6.1
* [`fe7d3db9`](NixOS/nixpkgs@fe7d3db) pythonPackage.txdbus: init at 1.1.0
* [`738df6f5`](NixOS/nixpkgs@738df6f) pythonPackage.bleak: init at 0.6.2
* [`3859ef98`](NixOS/nixpkgs@3859ef9) postgresqlPackages.timescaledb: 1.7.0 -> 1.7.1
* [`aac35831`](NixOS/nixpkgs@aac3583) firefox-beta-bin: 77.0b6 -> 77.0b7
* [`b3f79e19`](NixOS/nixpkgs@b3f79e1) firefox-devedition-bin: 77.0b6 -> 77.0b7
* [`a6137ea1`](NixOS/nixpkgs@a6137ea) mu: 1.4.5 -> 1.4.6
* [`85c2774b`](NixOS/nixpkgs@85c2774) antibody: 6.0.0 -> 6.0.1
* [`a6d8b5e0`](NixOS/nixpkgs@a6d8b5e) pythonPackages.discordpy: 1.2.5 -> 1.3.3
* [`c34d4bbe`](NixOS/nixpkgs@c34d4bb) ffsend: 0.2.61 -> 0.2.64
* [`8c97bde7`](NixOS/nixpkgs@8c97bde) aws-vault: 5.3.2 -> 5.4.4
* [`7f39cf68`](NixOS/nixpkgs@7f39cf6) bettercap: 2.27 -> 2.27.1 (NixOS/nixpkgs#88114)
* [`a6230bc3`](NixOS/nixpkgs@a6230bc) circleci-cli: 0.1.7179 -> 0.1.7523
* [`27512436`](NixOS/nixpkgs@2751243) clair: 2.1.2 -> 2.1.3
* [`0f2cbf45`](NixOS/nixpkgs@0f2cbf4) clevis: 12 -> 13
* [`715c01dd`](NixOS/nixpkgs@715c01d) clojure-lsp: 20200413T141742 -> 20200514T134144
* [`4e96cae7`](NixOS/nixpkgs@4e96cae) cloudflare-wrangler: 1.8.4 -> 1.9.0
* [`e1889cf4`](NixOS/nixpkgs@e1889cf) codeql: 2.1.1 -> 2.1.3
* [`4682a2ab`](NixOS/nixpkgs@4682a2a) cutelyst: 2.10.0 -> 2.11.0
* [`0635b562`](NixOS/nixpkgs@0635b56) dasht: 2.3.0 -> 2.4.0
* [`ed077f68`](NixOS/nixpkgs@ed077f6) handbrake: allow building from checkout
* [`3e008b34`](NixOS/nixpkgs@3e008b3) dnsproxy: 0.27.1 -> 0.28.1
* [`c644a17b`](NixOS/nixpkgs@c644a17) doctest: 2.3.7 -> 2.3.8
* [`b44b4c87`](NixOS/nixpkgs@b44b4c8) xurls: 2.0.0 -> 2.2.0
* [`748e2fcf`](NixOS/nixpkgs@748e2fc) elan: 0.10.0 -> 0.10.2
* [`072aa716`](NixOS/nixpkgs@072aa71) emplace: 0.3.1 -> 0.3.3
* [`e07f5789`](NixOS/nixpkgs@e07f578) flow: 0.124.0 -> 0.125.1
* [`c77c661d`](NixOS/nixpkgs@c77c661) fluent-bit: 1.4.3 -> 1.4.4
* [`28194c70`](NixOS/nixpkgs@28194c7) flyctl: 0.0.117 -> 0.0.123
* [`3cb5a4b9`](NixOS/nixpkgs@3cb5a4b) freenect: 0.6.0 -> 0.6.1
* [`8bd913f8`](NixOS/nixpkgs@8bd913f) ft2-clone: 1.23 -> 1.24
* [`a14f976f`](NixOS/nixpkgs@a14f976) geoipupdate: 4.2.2 -> 4.3.0
* [`667b1fa5`](NixOS/nixpkgs@667b1fa) git-quick-stats: 2.0.16 -> 2.1.1
* [`2dd8a2ca`](NixOS/nixpkgs@2dd8a2c) gomodifytags: 1.4.0 -> 1.6.0
* [`59775da4`](NixOS/nixpkgs@59775da) gotop: 3.5.0 -> 3.5.2
* [`07a46f3b`](NixOS/nixpkgs@07a46f3) wireguard-tools: 1.0.20200510 -> 1.0.20200513
* [`f5447db7`](NixOS/nixpkgs@f5447db) hebcal: 4.19 -> 4.20
* [`99f3fee1`](NixOS/nixpkgs@99f3fee) caf: 0.17.4 -> 0.17.5
* [`d2f078d5`](NixOS/nixpkgs@d2f078d) ipscan: 3.7.0 -> 3.7.1
* [`754562f8`](NixOS/nixpkgs@754562f) janet: 1.8.1 -> 1.9.1
* [`6c5e4491`](NixOS/nixpkgs@6c5e449) klayout: 0.26.4 -> 0.26.5
* [`e9576c83`](NixOS/nixpkgs@e9576c8) kube3d: 1.6.0 -> 1.7.0
* [`b44794de`](NixOS/nixpkgs@b44794d) keepass: 2.40 -> 2.45
* [`a2aec3d5`](NixOS/nixpkgs@a2aec3d) kubeseal: 0.12.0 -> 0.12.3
* [`58ba20dd`](NixOS/nixpkgs@58ba20d) kubie: 0.8.4 -> 0.9.1
* [`d890ac89`](NixOS/nixpkgs@d890ac8) kubie: use installShellFiles
* [`9c320acd`](NixOS/nixpkgs@9c320ac) flyctl: set build flags
* [`69dff5ce`](NixOS/nixpkgs@69dff5c) kubeseal: set build flags
* [`71c01067`](NixOS/nixpkgs@71c0106) dasht: install completions
* [`f80ee739`](NixOS/nixpkgs@f80ee73) kubie: enable on darwin
* [`403d4506`](NixOS/nixpkgs@403d450) libcint: 3.0.19 -> 3.0.20
* [`f0bc5221`](NixOS/nixpkgs@f0bc522) ripgrep-all: 0.9.5 -> 0.9.6
* [`6d035a9d`](NixOS/nixpkgs@6d035a9) oh-my-zsh: 2020-05-16 -> 2020-05-18
* [`f44e3d45`](NixOS/nixpkgs@f44e3d4) skypeforlinux: 8.59.0.77 -> 8.60.0.76
* [`20b3ba16`](NixOS/nixpkgs@20b3ba1) vivaldi: 2.11 -> 3.0
* [`c729ec59`](NixOS/nixpkgs@c729ec5) doc and remove superfluous toString
* [`0db36eaa`](NixOS/nixpkgs@0db36ea) riot-web: 1.6.0 -> 1.6.1
* [`8b5a3127`](NixOS/nixpkgs@8b5a312) linux: 5.7-rc4 -> 5.7-rc6
* [`307dfd90`](NixOS/nixpkgs@307dfd9) riot-desktop: 1.6.0 -> 1.6.1
* [`2a5b0bc8`](NixOS/nixpkgs@2a5b0bc) matrix-synapse: 1.12.4 -> 1.13.0
* [`aae9af96`](NixOS/nixpkgs@aae9af9) palp: fix hash
* [`f7ad47a8`](NixOS/nixpkgs@f7ad47a) agdaPackages.cubical: init at 0.2 (NixOS/nixpkgs#76994)
* [`1e873266`](NixOS/nixpkgs@1e87326) liquibase: 3.8.9 -> 3.9.0
* [`b9d37e55`](NixOS/nixpkgs@b9d37e5) maxx: drop (NixOS/nixpkgs#87715)
* [`14a70f54`](NixOS/nixpkgs@14a70f5) ocamlPackages.textutils: remove at 112.17.00
* [`431e12c0`](NixOS/nixpkgs@431e12c) minify: 2.7.3 -> 2.7.4
* [`92688a1e`](NixOS/nixpkgs@92688a1) bcompare - 4.3.2.24472 -> 4.3.4.24657 (NixOS/nixpkgs#84521)
* [`322b135f`](NixOS/nixpkgs@322b135) fd: 8.0.0 -> 8.1.0
* [`311f2ffd`](NixOS/nixpkgs@311f2ff) mutagen: 0.11.2 -> 0.11.4
* [`2f40a6c5`](NixOS/nixpkgs@2f40a6c) mame: 0.220 -> 0.221 (NixOS/nixpkgs#88146)
* [`f23c95b9`](NixOS/nixpkgs@f23c95b) netdata: 1.21.1 -> 1.22.1
* [`c24b312b`](NixOS/nixpkgs@c24b312) nfpm: 1.2.0 -> 1.2.1
* [`61335d51`](NixOS/nixpkgs@61335d5) gambit: disable use of poll() on Darwin
* [`4beef272`](NixOS/nixpkgs@4beef27) pgcenter: 0.6.4 -> 0.6.5
* [`2dde5ffe`](NixOS/nixpkgs@2dde5ff) pirate-get: 0.3.5 -> 0.3.7
* [`f4264028`](NixOS/nixpkgs@f426402) solfege: 3.22.2 -> 3.23.4
* [`4a8a4c2b`](NixOS/nixpkgs@4a8a4c2) libdeflate: 1.5 -> 1.6 (NixOS/nixpkgs#88163)
* [`3389db60`](NixOS/nixpkgs@3389db6) libdeflate: remove local prefix
* [`ec8cc560`](NixOS/nixpkgs@ec8cc56) nodejs-14_x: 14.2.0 -> 14.3.0
* [`8d6bf86d`](NixOS/nixpkgs@8d6bf86) python3Packages.azure-mgmt-batch: 7.0.0 -> 8.0.0
* [`9a9f8278`](NixOS/nixpkgs@9a9f827) python3Packages.azure-mgmt-core: 1.0.0 -> 1.1.0
* [`a807b5a9`](NixOS/nixpkgs@a807b5a) python3Packages.azure-mgmt-cosmosdb: 0.13.0 -> 0.14.0
* [`b181c7d5`](NixOS/nixpkgs@b181c7d) python3Packages.azure-mgmt-eventhub: 3.0.0 -> 3.1.0
* [`385e082b`](NixOS/nixpkgs@385e082) python3Packages.azure-mgmt-iothub: 0.11.0 -> 0.12.0
* [`0744df0b`](NixOS/nixpkgs@0744df0) python3Packages.azure-mgmt-network: 10.1.0 -> 10.2.0
* [`478c24b0`](NixOS/nixpkgs@478c24b) python3Packages.azure-mgmt-storage: 9.0.0 -> 10.0.0
* [`a6d1a993`](NixOS/nixpkgs@a6d1a99) python3Packages.azure-multiapi-storage: 0.2.4 -> 0.3.2
* [`f86a44a4`](NixOS/nixpkgs@f86a44a) python3Packages.azure-servicefabric: 7.0.0.0 -> 7.1.0.45
* [`5e82ba48`](NixOS/nixpkgs@5e82ba4) azure-cli: 2.4.0 -> 2.5.1
* [`17812e65`](NixOS/nixpkgs@17812e6) fluidasserts: 20.2.30165 -> deleted
* [`88c8f0d5`](NixOS/nixpkgs@88c8f0d) maintainers: add rpearce
* [`cc2e800a`](NixOS/nixpkgs@cc2e800) bashcards: init at v0.1.2
* [`8f1459dc`](NixOS/nixpkgs@8f1459d) run: 0.7.1 -> 0.7.2
* [`0527318a`](NixOS/nixpkgs@0527318) etcd: 3.3.20 -> 3.3.21
* [`f17dae17`](NixOS/nixpkgs@f17dae1) spdx-license-list-data: 3.8 -> 3.9
* [`b8946720`](NixOS/nixpkgs@b894672) telegraf: 1.14.1 -> 1.14.2
* [`ae876f03`](NixOS/nixpkgs@ae876f0) .editorconfig: fix invalid value for diffs/patches
* [`aef6544c`](NixOS/nixpkgs@aef6544) hobbes: 2020-03-10 -> 2020-05-19
* [`9d92aa38`](NixOS/nixpkgs@9d92aa3) etcd: add maintainer
* [`e0df66e6`](NixOS/nixpkgs@e0df66e) etcd_3_4: init at 3.4.8
* [`423296fc`](NixOS/nixpkgs@423296f) handbrake: do not harden on arm
* [`37d76c0e`](NixOS/nixpkgs@37d76c0) twitterBootstrap: 4.4.1 -> 4.5.0
* [`0900872b`](NixOS/nixpkgs@0900872) ocamlPackages.batteries: fix for OCaml 4.10
* [`cccb4f49`](NixOS/nixpkgs@cccb4f4) autorandr: 1.10 -> 1.10.1

Co-authored-by: github-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

5 participants
You can’t perform that action at this time.