Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

plasma-applet-volumewin7mixer fix missing dependency #79088

Conversation

@mdevlamynck
Copy link
Contributor

@mdevlamynck mdevlamynck commented Feb 2, 2020

Fixes missing dependency on specific qml elements.

Motivation for this change

One day the applet stopped working complaining that it could not find the module QtMultimedia. I'm not sure what changed but this seems to fix it.

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
Fixes missing dependency on specific qml elements.
@aanderse
Copy link
Contributor

@aanderse aanderse commented Mar 26, 2020

@doronbehar you have tested this ensuring it works?

@doronbehar
Copy link
Contributor

@doronbehar doronbehar commented Mar 26, 2020

No 😬 , I just saw the diff and it makes sense.

@aanderse
Copy link
Contributor

@aanderse aanderse commented Mar 26, 2020

@doronbehar ok thanks for clarifying.
@mdevlamynck sorry for the delay, I'll try to test this in the next day or two and get back to you.

@aanderse
Copy link
Contributor

@aanderse aanderse commented Apr 2, 2020

I just tested plasma-applet-volumewin7mixer on 20.03 and it seems to work fine. Can you explain in more details your issue?

@mdevlamynck
Copy link
Contributor Author

@mdevlamynck mdevlamynck commented Apr 2, 2020

I recently switched to 20.03 and I also can't reproduce. So I guess we can close this.

The issue I had was that was that the applet was displaying a qml error instead of its UI. The error was about a dependency not found (QtMultimedia). I don't remember the exact error message though.

@aanderse
Copy link
Contributor

@aanderse aanderse commented Apr 2, 2020

Glad to hear you're up and running! Thanks.

@aanderse aanderse closed this Apr 2, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.