Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python3Packages.snowflake-connector-python: 2.1.2 -> 2.2.0 #79986

Merged
merged 1 commit into from Feb 13, 2020

Conversation

@jonringer
Copy link
Contributor

@jonringer jonringer commented Feb 13, 2020

Motivation for this change

was broken

  Requirement already satisfied: idna<3.0.0 in /nix/store/gz66km41kna7ra24z3i0890whins2vqj-python2.7-idna-2.8/lib/python2.7/site-packages (from snowflake-connector-python==2.1.2) (2.8)
  Requirement already satisfied: cryptography<3.0.0,>=1.8.2 in /nix/store/lvj2s04cigjj5g4997qjdwqhjckclhd5-python2.7-cryptography-2.8/lib/python2.7/site-packages (from snowflake-connector-python==2.1.2) (2.8)
  Requirement already satisfied: enum34; python_version < "3.4" in /nix/store/1c99n4gh7hlm0k4yc3ycr186vhrkfy9h-python2.7-enum34-1.1.6/lib/python2.7/site-packages (from snowflake-connector-python==2.1.2) (1.1.6)
  Requirement already satisfied: pyOpenSSL<21.0.0,>=16.2.0 in /nix/store/rw79wlf69n3qjxwfpd3iyvgas09rzgca-python2.7-pyOpenSSL-19.1.0/lib/python2.7/site-packages (from snowflake-connector-python==2.1.2) (19.1.0)
  Requirement already satisfied: requests<2.23.0 in /nix/store/b6x46svpq60pdlaxxvijslxriw1av4jy-python2.7-requests-2.22.0/lib/python2.7/site-packages (from snowflake-connector-python==2.1.2) (2.22.0)
  ERROR: Could not find a version that satisfies the requirement boto3<1.11.0,>=1.4.4 (from snowflake-connector-python==2.1.2) (from versions: none)
  ERROR: No matching distribution found for boto3<1.11.0,>=1.4.4 (from snowflake-connector-python==2.1.2)
Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
[1 built, 0.0 MiB DL]
https://github.com/NixOS/nixpkgs/pull/79986
4 package built:
python37Packages.snowflake-connector-python python37Packages.snowflake-sqlalchemy python38Packages.snowflake-connector-python python38Packages.snowflake-sqlalchemy
@jonringer jonringer force-pushed the jonringer:bump-snowflake branch from 1ec44e2 to c14fdc1 Feb 13, 2020
@jonringer
Copy link
Contributor Author

@jonringer jonringer commented Feb 13, 2020

@GrahamcOfBorg build python37Packages.snowflake-connector-python python37Packages.snowflake-sqlalchemy python38Packages.snowflake-connector-python python38Packages.snowflake-sqlalchemy

@jonringer jonringer merged commit 3b7f5c6 into NixOS:master Feb 13, 2020
5 of 7 checks passed
5 of 7 checks passed
grahamcofborg-eval Beginning Evaluations
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="ofborg"; } ./nixos/release-combined.nix -A tested
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
python37Packages.snowflake-connector-python, python37Packages.snowflake-sqlalchemy, python38Packages.snowflake-connector-python, python38Packages.snowflake-sqlalchemy on aarch64-linux Success
Details
python37Packages.snowflake-connector-python, python37Packages.snowflake-sqlalchemy, python38Packages.snowflake-connector-python, python38Packages.snowflake-sqlalchemy on x86_64-darwin Success
Details
python37Packages.snowflake-connector-python, python37Packages.snowflake-sqlalchemy, python38Packages.snowflake-connector-python, python38Packages.snowflake-sqlalchemy on x86_64-linux Success
Details
@jonringer jonringer deleted the jonringer:bump-snowflake branch Feb 13, 2020
@ofborg ofborg bot added the 8.has: clean-up label Feb 13, 2020
@jonringer jonringer mentioned this pull request Feb 14, 2020
5 of 10 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

1 participant
You can’t perform that action at this time.