Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python27Packages.deprecation: 2.0.7 -> 2.1.0 #87100

Closed

Conversation

@r-ryantm
Copy link
Contributor

r-ryantm commented May 6, 2020

Semi-automatic update generated by nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/python2.7-deprecation/versions.

meta.description for python27Packages.deprecation is: "A library to handle automated deprecations"

meta.homepage for python27Packages.deprecation is: "https://deprecation.readthedocs.io/"

Updates performed
  • Version update
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
15 total rebuild path(s)

4 package rebuild(s)

4 x86_64-linux rebuild(s)
4 i686-linux rebuild(s)
3 x86_64-darwin rebuild(s)
4 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
conan
python27Packages.deprecation
python37Packages.deprecation
python38Packages.deprecation
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/9sqm46kmwbgxzl75ysg59xbb0mzx1dl1-python2.7-deprecation-2.1.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A python27Packages.deprecation https://github.com/r-ryantm/nixpkgs/archive/c93e6f49b13271b34825409c78e888c54f92e6bc.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/9sqm46kmwbgxzl75ysg59xbb0mzx1dl1-python2.7-deprecation-2.1.0
ls -la /nix/store/9sqm46kmwbgxzl75ysg59xbb0mzx1dl1-python2.7-deprecation-2.1.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

1 package failed to build:
- conan
3 packages built:
- python27Packages.deprecation
- python37Packages.deprecation
- python38Packages.deprecation

Maintainer pings
@drewrisinger
Copy link
Contributor

drewrisinger commented May 6, 2020

nixpkgs-review pr 87100:

https://github.com/NixOS/nixpkgs/pull/87100
1 package failed to build:
conan

3 package built:
python27Packages.deprecation python37Packages.deprecation python38Packages.deprecation

I started resolving this on my own branch, but noticed something strange: the GitHub repo for deprecation doesn't have a 2.1 release, but PyPi does. I'm not sure what caused this, and I opened an issue there briancurtin/deprecation#49. EDIT: resolved, maintainer forgot to push tag

@drewrisinger
Copy link
Contributor

drewrisinger commented May 6, 2020

Here's a patch on Conan that I tested (build only) for whoever comes across this later.

diff --git a/pkgs/development/tools/build-managers/conan/default.nix b/pkgs/development/tools/build-managers/conan/default.nix
index cc44ac1a220..d7aec3527b3 100644
--- a/pkgs/development/tools/build-managers/conan/default.nix
+++ b/pkgs/development/tools/build-managers/conan/default.nix
@@ -1,7 +1,7 @@
 { lib, python3, git, pkgconfig }:
 
 # Note:
-# Conan has specific dependency demanands; check
+# Conan has specific dependency demands; check
 #     https://github.com/conan-io/conan/blob/master/conans/requirements.txt
 #     https://github.com/conan-io/conan/blob/master/conans/requirements_server.txt
 # on the release branch/commit we're packaging.
@@ -39,12 +39,12 @@ let newPython = python3.override {
 };
 
 in newPython.pkgs.buildPythonApplication rec {
-  version = "1.24.0";
+  version = "1.25.0";
   pname = "conan";
 
   src = newPython.pkgs.fetchPypi {
     inherit pname version;
-    sha256 = "0nkh4f6plamijwcfw536ydm0i04y74qmkh5l1nanyb8p0c3z3x0y";
+    sha256 = "1wgmx6s4h5m6zixb3wlaicy56rsqcy2srzmvii80xdx9g5wvi9pv";
   };
 
   propagatedBuildInputs = with newPython.pkgs; [
@@ -90,7 +90,8 @@ in newPython.pkgs.buildPythonApplication rec {
 
   postPatch = ''
     substituteInPlace conans/requirements.txt \
-      --replace "PyYAML>=3.11, <3.14.0" "PyYAML"
+      --replace "PyYAML>=3.11, <3.14.0" "PyYAML" \
+      --replace "deprecation>=2.0, <2.1" "deprecation"
   '';
 
   meta = with lib; {
@drewrisinger
Copy link
Contributor

drewrisinger commented May 6, 2020

Resolved: maintainer forgot to push tag to GitHub. v2.1.0 appears legitimate

@r-ryantm r-ryantm deleted the r-ryantm:auto-update/python2.7-deprecation branch May 7, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants
You can’t perform that action at this time.