Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[20.03] samba: 4.11.5 -> 4.11.9 #87807

Merged
merged 1 commit into from Jun 18, 2020

Conversation

@mmilata
Copy link
Member

mmilata commented May 14, 2020

This is not a backport from master since it has samba-4.12.

Release notes:

Motivation for this change

The 4.11.8 release fixes:

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
@mweinelt
Copy link
Member

mweinelt commented May 19, 2020

Result of nixpkgs-review pr 87807 1

3 packages failed to build:
- meguca
- obs-ndi
- rabbitvcs
136 packages built:
- adapta-gtk-theme
- almanah
- atom
- atom-beta
- autofs5
- calls
- cantata
- celluloid
- chrome-gnome-shell
- cinnamon.cinnamon-control-center
- clementine
- clementineUnfree
- curseradio
- deepin.dde-file-manager
- deepin.deepin-movie-reborn
- deepin.startdde
- deja-dup
- dropbox-cli
- elementary-planner
- elisa
- empathy (gnome3.empathy)
- enum4linux
- evolution-data-server (gnome3.evolution-data-server ,gnome3.evolution_data_server)
- far2l
- feedreader
- ffmpeg-full
- folks (gnome3.folks)
- gfbgraph (gnome3.gfbgraph)
- gnome-online-accounts (gnome3.gnome-online-accounts ,gnome3.gnome_online_accounts)
- gnome-photos (gnome3.gnome-photos)
- gnome-recipes
- gvfs (gnome2.gvfs)
- gnome3.bijiben (gnome3.gnome-notes)
- gnome3.cheese
- gnome3.evolution
- gnome3.file-roller
- gnome3.geary
- gnome3.gnome-applets
- gnome3.gnome-books
- gnome3.gnome-boxes
- gnome3.gnome-calendar
- gnome3.gnome-contacts
- gnome3.gnome-control-center (gnome3.gnome_control_center)
- gnome3.gnome-documents
- gnome3.gnome-initial-setup
- gnome3.gnome-maps
- gnome3.gnome-music
- gnome3.gnome-online-miners
- gnome3.gnome-panel
- gnome3.gnome-session (gnome3.gnome_session)
- gnome3.gnome-shell (gnome3.gnome_shell)
- gnome3.gnome-software
- gnome3.gnome-terminal (gnome3.gnome_terminal)
- gnome3.gnome-todo
- gnome3.gnome-tweaks (gnome3.gnome-tweak-tool)
- gnome3.gnome-user-share
- grilo-plugins (gnome3.grilo-plugins)
- gnome3.gvfs
- libgdata (gnome3.libgdata)
- libzapojit (gnome3.libzapojit)
- gnome3.nautilus
- gnome3.nautilus-python
- gnome3.pomodoro
- shotwell (gnome3.shotwell)
- gnome3.totem
- tracker-miners (gnome3.tracker-miners)
- gnomeExtensions.gsconnect
- handbrake
- hydron
- kdeApplications.kdenetwork-filesharing
- kdenlive (kdeApplications.kdenlive)
- kdeApplications.kio-extras
- kodi
- kodi-wayland
- kodiPlain (kodiPlugins.kodi)
- kodiPlainWayland
- kodiPlugins.inputstream-adaptive
- kodiPlugins.joystick
- kodiPlugins.kodi-platform
- kodiPlugins.pvr-hdhomerun
- kodiPlugins.pvr-hts
- kodiPlugins.pvr-iptvsimple
- kodiPlugins.steam-controller
- kodiPlugins.vfs-libarchive
- kodiPlugins.vfs-sftp
- libsForQt5.phonon-backend-vlc (libsForQt512.phonon-backend-vlc)
- vlc (libsForQt5.vlc ,vlc_qt5)
- liquidsoap
- lutris
- lutris-free
- manim
- megaglest
- minitube
- mpc-qt
- mpd
- mpv
- mpv-with-scripts
- netease-cloud-music
- obs-linuxbrowser
- obs-studio
- obs-wlrobs
- olive-editor
- pantheon.elementary-calendar
- pantheon.elementary-greeter
- pantheon.elementary-session-settings
- pantheon.extra-elementary-contracts
- pantheon.wingpanel-indicator-datetime
- pantheon.wingpanel-with-indicators
- pipelight
- playonlinux
- plex-media-player
- pympress
- python27Packages.pydub
- python27Packages.pysmbc
- python27Packages.python-vlc
- python37Packages.mpv
- python37Packages.pydub
- python37Packages.pysmbc
- python37Packages.python-vlc
- python38Packages.mpv
- python38Packages.pydub
- python38Packages.pysmbc
- python38Packages.python-vlc
- samba (samba4)
- sambaFull (samba4Full)
- smbnetfs
- soundkonverter
- sssd
- strawberry
- system-config-printer
- tribler
- wine (winePackages.full)
- wine-staging
- wineWowPackages.full
- winetricks
- xmonad_log_applet
@mmilata
Copy link
Member Author

mmilata commented May 19, 2020

Thanks for building the deps! The failures seem to be unrelated to the PR:

meguca:

% nix-build -A meguca
error: Package ‘meguca-unstable-2019-03-12’ in /home/mmilata/work/nixpkgs/pkgs/servers/meguca/default.nix:45 is marked as broken, refusing to evaluate.

a) For `nixos-rebuild` you can set
  { nixpkgs.config.allowBroken = true; }
in configuration.nix to override this.

b) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
  { allowBroken = true; }
to ~/.config/nixpkgs/config.nix.

(use '--show-trace' to show detailed location information)

obs-ndi:

% nix-build -A obs-ndi
these derivations will be built:
  /nix/store/3jyhg7nmragdism1zrr8cx27sqfcljjr-samba-4.11.9.drv
  /nix/store/xisb66dyb9j0206xib3yj0zybvs206mq-InstallNDISDK_v4_Linux.tar.gz.drv
  /nix/store/7320mdrn8cpwvdv9zjyf7jj8wgbrwwax-ndi-4.drv
  /nix/store/g8piz9yk1d51j0rk2ivvphvahshwh7ph-vlc-3.0.8.drv
  /nix/store/vg4g7r9lxfkx6ynw2ki743w2pnn846vl-obs-studio-24.0.6.drv
  /nix/store/zpgagybypj644jqmr8d1dhhw419z92kq-obs-ndi-4.7.1.drv
building '/nix/store/xisb66dyb9j0206xib3yj0zybvs206mq-InstallNDISDK_v4_Linux.tar.gz.drv'...
waiting for locks or build slots...

***
In order to use the NDI SDK, you need to comply with NewTek's license and
download the Linux version 4 tarball from:

https://ndi.tv/sdk/

Once you have downloaded the file, please use the following command and
re-run the installation:

nix-prefetch-url file://$PWD/InstallNDISDK_v4_Linux.tar.gz

***

builder for '/nix/store/xisb66dyb9j0206xib3yj0zybvs206mq-InstallNDISDK_v4_Linux.tar.gz.drv' failed with exit code 1
cannot build derivation '/nix/store/7320mdrn8cpwvdv9zjyf7jj8wgbrwwax-ndi-4.drv': 1 dependencies couldn't be built
cannot build derivation '/nix/store/zpgagybypj644jqmr8d1dhhw419z92kq-obs-ndi-4.7.1.drv': 1 dependencies couldn't be built
error: build of '/nix/store/zpgagybypj644jqmr8d1dhhw419z92kq-obs-ndi-4.7.1.drv' failed

rabbitvcs:

% nix-build -A rabbitvcs
error: Package ‘python2.7-pysvn-1.8.0’ in /home/mmilata/work/nixpkgs/pkgs/development/python-modules/pysvn/default.nix:53 is marked as broken, refusing to evaluate.

a) For `nixos-rebuild` you can set
  { nixpkgs.config.allowBroken = true; }
in configuration.nix to override this.

b) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
  { allowBroken = true; }
to ~/.config/nixpkgs/config.nix.

(use '--show-trace' to show detailed location information)
@worldofpeace worldofpeace merged commit 7ea8a46 into NixOS:release-20.03 Jun 18, 2020
16 checks passed
16 checks passed
Evaluation Performance Report Evaluator Performance Report
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-darwin nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./pkgs/t
Details
grahamcofborg-eval-lib-tests nix-build --arg pkgs import ./. {} ./lib/tests/release.nix
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./nixos/
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./nixos/
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./nixos/
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="8830690"; rev="8830690924d800e3bef08870e3d9f2dc773721ac"; } ./pkgs/t
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
samba, samba.passthru.tests on aarch64-linux Success
Details
samba, samba.passthru.tests on x86_64-linux Success
Details
@worldofpeace
Copy link
Member

worldofpeace commented Jun 18, 2020

Thanks a lot

@mmilata mmilata deleted the mmilata:20.03/samba-4.11.9 branch Jun 18, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

5 participants
You can’t perform that action at this time.