Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python37Packages.loguru: 0.4.1 -> 0.5.0 #88684

Open
wants to merge 1 commit into
base: master
from

Conversation

@r-ryantm
Copy link
Contributor

r-ryantm commented May 23, 2020

Semi-automatic update generated by nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/python3.7-loguru/versions.

meta.description for python37Packages.loguru is: "Python logging made (stupidly) simple"

meta.homepage for python37Packages.loguru is: "https://github.com/Delgan/loguru"

Updates performed
  • Version update
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
24 total rebuild path(s)

6 package rebuild(s)

6 x86_64-linux rebuild(s)
6 i686-linux rebuild(s)
6 x86_64-darwin rebuild(s)
6 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
flexget
google-music-scripts
python37Packages.aria2p
python37Packages.loguru
python38Packages.aria2p
python38Packages.loguru
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/cn18a9f6dc01n564iznpagnmkpk3qyng-python3.7-loguru-0.5.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A python37Packages.loguru https://github.com/r-ryantm/nixpkgs/archive/9c9781863cec5bb97f7a3375e2f73ce1d2796bb7.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/cn18a9f6dc01n564iznpagnmkpk3qyng-python3.7-loguru-0.5.0
ls -la /nix/store/cn18a9f6dc01n564iznpagnmkpk3qyng-python3.7-loguru-0.5.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

1 package failed to build:
- google-music-scripts
5 packages built:
- flexget
- python37Packages.aria2p
- python37Packages.loguru
- python38Packages.aria2p
- python38Packages.loguru

Maintainer pings

cc @jbaum98 for testing.

Copy link
Contributor

jonringer left a comment

regression in google-music-scripts

  ERROR: Could not find a version that satisfies the requirement loguru<0.5.0,>=0.4.0 (from google-music-scripts==4.3.0) (from versions: none)
  ERROR: No matching distribution found for loguru<0.5.0,>=0.4.0 (from google-music-scripts==4.3.0)
cannot build derivation '/nix/store/kwpmmjv6dyb8sb44xwfvmcc75m2wrs1k-env.drv': 1 dependencies couldn't be built
[6 built (1 failed), 85 copied (51.9 MiB), 16.3 MiB DL]
error: build of '/nix/store/kwpmmjv6dyb8sb44xwfvmcc75m2wrs1k-env.drv' failed
https://github.com/NixOS/nixpkgs/pull/88684
1 package failed to build:
google-music-scripts

5 packages built:
flexget python37Packages.aria2p python37Packages.loguru python38Packages.aria2p python38Packages.loguru
@jbaum98
Copy link
Contributor

jbaum98 commented May 29, 2020

I fixed the issues in this branch. Not sure if I should add these commits to this PR or make a new one.

@ryantm
Copy link
Member

ryantm commented May 30, 2020

@jbaum98 If you do not have nixpkgs commit access, you should just open a new PR and do a review on this one "requesting changes", saying this shouldn't be merged and the other one should.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants
You can’t perform that action at this time.