Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fritzing: Use wrapQtAppsHook #89117

Merged
merged 1 commit into from Aug 6, 2020
Merged

Conversation

@reardencode
Copy link
Contributor

reardencode commented May 28, 2020

Motivation for this change

#65399 (Fritzing wouldn't run without this change)

Things done
  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
@IvarWithoutBones
Copy link
Contributor

IvarWithoutBones commented May 28, 2020

Shouldn't QT's mkDerivation be used instead of wrapQtAppsHook? As the manual states

Qt applications need to be wrapped to find runtime dependencies. If you cannot use mkDerivation or mkDerivationWith above, include wrapQtAppsHook in nativeBuildInputs.

@reardencode
Copy link
Contributor Author

reardencode commented May 28, 2020

I'm a newb and this was the first solution to my problem that DuckDuckGo found me. I'll see if I can get mkDeriviation to work.

@reardencode reardencode force-pushed the reardencode:fritzing_wrapqtappshook branch from d2eb169 to 49593ac May 28, 2020
@bhipple
Copy link
Contributor

bhipple commented Jun 4, 2020

Result of nixpkgs-review pr 89117 1

1 package failed to build:
- fritzing
@josephtheengineer
Copy link
Contributor

josephtheengineer commented Jun 5, 2020

Got this on NixOS:

src/version/partschecker.cpp: In static member function 'static bool PartsChecker::newPartsAvailable(const QString&, const QString&, bool, QString&, PartsCheckerResult&)':
src/version/partschecker.cpp:129:71: error: too few arguments to function 'int git_remote_connect(git_remote*, git_direction, const git_remote_callbacks*, const git_proxy_options*, const git_strarray*)'
  129 |     error = git_remote_connect(remote, GIT_DIRECTION_FETCH, &callbacks);
      |                                                                       ^
In file included from /nix/store/glrmvdybni2ial8prlp9k7bxqh6fsd4w-libgit2-1.0.0/include/git2/clone.h:14,
                 from /nix/store/glrmvdybni2ial8prlp9k7bxqh6fsd4w-libgit2-1.0.0/include/git2.h:21,
                 from src/version/partschecker.cpp:43:
/nix/store/glrmvdybni2ial8prlp9k7bxqh6fsd4w-libgit2-1.0.0/include/git2/remote.h:339:17: note: declared here
  339 | GIT_EXTERN(int) git_remote_connect(git_remote *remote, git_direction direction, const git_remote_callbacks *callbacks, const git_proxy_options *proxy_opts, const git_strarray *custom_headers);
      |                 ^~~~~~~~~~~~~~~~~~
make[1]: *** [Makefile.Release:4040: release/partschecker.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/build/source'
make: *** [Makefile:42: release] Error 2
builder for '/nix/store/hszgiaw0yrxmdf20k19pg5c6qvgid7sh-fritzing-0.9.3b.drv' failed with exit code 2
error: build of '/nix/store/hszgiaw0yrxmdf20k19pg5c6qvgid7sh-fritzing-0.9.3b.drv' failed
@josephtheengineer
Copy link
Contributor

josephtheengineer commented Jun 5, 2020

Seems to be an issue with libgit2

@josephtheengineer
Copy link
Contributor

josephtheengineer commented Jun 5, 2020

Fritzing patch notes (latest version) Now links with recent libgit2 (0.28.1)
Our libgit2 (git 2) is at version 1.0.0
Looks like Fritzing requires the older (0.28.1) libgit

@josephtheengineer
Copy link
Contributor

josephtheengineer commented Jun 5, 2020

I got the build working with commit 8a766883fe0061ef60e5f0b70a95844957ec777 on pkgs/development/libraries/git2/default.nix (libgit2 0.28.4)!

Should we package version 0.28.4 of git2?

@Mic92
Copy link
Contributor

Mic92 commented Jun 5, 2020

@reardencode
Copy link
Contributor Author

reardencode commented Jun 5, 2020

This PR doesn't change the situation regarding building Fritzing, so I think a separate PR should be made to patch it for the updated git2 version.l

@Ekleog
Copy link
Member

Ekleog commented Aug 6, 2020

This looks like an incremental improvement to me, using Qt's mkDerivation is already better than the stdenv one, and fritzing already does not build (at least here).

So I'm landing this.

@josephtheengineer @Mic92 If you have found the changes required to make this pass the finish line and actually build, maybe you could open a PR that makes fritzing actually build? (or @reardencode, you could maybe do it based on their feedback, if you want to use it someone will have to after all :))

@Ekleog Ekleog merged commit bceadaf into NixOS:master Aug 6, 2020
14 checks passed
14 checks passed
Evaluation Performance Report Evaluator Performance Report
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-darwin nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./pkgs/t
Details
grahamcofborg-eval-lib-tests nix-build --arg pkgs import ./. {} ./lib/tests/release.nix
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./nixos/
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./nixos/
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./nixos/
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="49593ac"; rev="49593ac8e6f51d0b2c9d985dbf92ef74b62d1962"; } ./pkgs/t
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
github-actions bot added a commit to pbogdan/shell-cmd that referenced this pull request Aug 9, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@8e2b14a...b50ef9af](NixOS/nixpkgs@8e2b14a...b50ef9a)

* [`2e3bc79c`](NixOS/nixpkgs@2e3bc79) linux: 4.14.191 -> 4.14.192
* [`af3de724`](NixOS/nixpkgs@af3de72) linux: 4.19.136 -> 4.19.137
* [`b2ef4872`](NixOS/nixpkgs@b2ef487) linux: 5.4.55 -> 5.4.56
* [`72c9b56c`](NixOS/nixpkgs@72c9b56) linux: 5.7.12 -> 5.7.13
* [`42de8384`](NixOS/nixpkgs@42de838) nodePackages.get-graphql-schema: init at 2.1.2
* [`5c62904a`](NixOS/nixpkgs@5c62904) python3Packages.trezor: 0.12.0 -> 0.12.1
* [`31dde677`](NixOS/nixpkgs@31dde67) gtg: refactor (description, platform, version, requirement, formatting)
* [`3d31c28c`](NixOS/nixpkgs@3d31c28) gnunet: 0.12.2 -> 0.13.1
* [`779e3587`](NixOS/nixpkgs@779e358) gnunet-gtk: 0.12.0 -> 0.13.1
* [`e5b91d92`](NixOS/nixpkgs@e5b91d9) valgrind: try fixing on darwin
* [`3d53c051`](NixOS/nixpkgs@3d53c05) element-web: 1.7.2 -> 1.7.3
* [`6e405a8e`](NixOS/nixpkgs@6e405a8) element-desktop: 1.7.2 -> 1.7.3
* [`5e6fe939`](NixOS/nixpkgs@5e6fe93) epkowa: update hashes (NixOS/nixpkgs#93846)
* [`1f01916d`](NixOS/nixpkgs@1f01916) kitty: remove myself from the maintainer list
* [`ff6c4637`](NixOS/nixpkgs@ff6c463) hiawatha: 10.9 -> 10.11
* [`72ff02c9`](NixOS/nixpkgs@72ff02c) kopia: init at 0.5.2
* [`f9f48250`](NixOS/nixpkgs@f9f4825) nixos/smartd: add option for notifiction email sender
* [`4f5fc729`](NixOS/nixpkgs@4f5fc72) nixos/postgresql: use a standard default value for dataDir
* [`e50e89e1`](NixOS/nixpkgs@e50e89e) nixos/postgresql: conditionally provision data directory with StateDirectory
* [`f42f8a6d`](NixOS/nixpkgs@f42f8a6) nixos/postgresql: replace deprecated usage of PermissionsStartOnly
* [`ab602aa6`](NixOS/nixpkgs@ab602aa) sacc: init at 1.01
* [`cc8d2ba2`](NixOS/nixpkgs@cc8d2ba) wire-desktop: linux 3.18.2925 -> 3.19.2928
* [`787a38bf`](NixOS/nixpkgs@787a38b) wire-desktop: mac 3.18.3728 -> 3.19.3799
* [`744d43f8`](NixOS/nixpkgs@744d43f) ledger: fix build on darwin
* [`8d57f75f`](NixOS/nixpkgs@8d57f75) nixos/smartd: fix description for docbook
* [`7503f280`](NixOS/nixpkgs@7503f28) nixos/systemd: fix TUN networking in LXC containers (NixOS/nixpkgs#81481)
* [`e74a6bcc`](NixOS/nixpkgs@e74a6bc) csxcad: init at unstable-2020-02-08
* [`0e0aba23`](NixOS/nixpkgs@0e0aba2) mailcore2: 0.6.3 -> 0.6.4
* [`98f9f814`](NixOS/nixpkgs@98f9f81) micronaut: 1.3.6 -> 1.3.7
* [`f0913d9a`](NixOS/nixpkgs@f0913d9) minder: 1.9.0 -> 1.9.1
* [`c6117648`](NixOS/nixpkgs@c611764) osu-lazer: 2020.725.0 -> 2020.801.0
* [`b41f79fe`](NixOS/nixpkgs@b41f79f) openxray: 558 -> 730
* [`29bdfffd`](NixOS/nixpkgs@29bdfff) adlplug, opnplug: 1.0.1 -> 1.0.2
* [`eaf6ef8f`](NixOS/nixpkgs@eaf6ef8) ArchiSteamFarm: 4.2.3.3 -> 4.2.3.6
* [`2774941c`](NixOS/nixpkgs@2774941) kmsxx: 2020-02-14 -> 2020-08-04
* [`de0caa8e`](NixOS/nixpkgs@de0caa8) openjk: 2019-11-29 -> 2020-07-03
* [`059675cd`](NixOS/nixpkgs@059675c) opl3bankeditor: 1.5 -> 1.5.1
* [`1ace8444`](NixOS/nixpkgs@1ace844) opn2bankeditor: 1.3-beta -> 1.3
* [`28300eb8`](NixOS/nixpkgs@28300eb) kustomize: 3.8.0 -> 3.8.1
* [`668e9f2c`](NixOS/nixpkgs@668e9f2) ldb: 2.1.4 -> 2.2.0
* [`461e2a61`](NixOS/nixpkgs@461e2a6) runc: 1.0.0-rc91 -> 1.0.0-rc92
* [`3f5258b6`](NixOS/nixpkgs@3f5258b) redshift,redshift-wlr: Fix a file path in postInstall
* [`79415b0b`](NixOS/nixpkgs@79415b0) gammastep: init at 2.0.1
* [`f4a0f554`](NixOS/nixpkgs@f4a0f55) cypress: 4.9.0 -> 4.12.1
* [`dfda85ce`](NixOS/nixpkgs@dfda85c) libmatroska: 1.6.0 -> 1.6.1
* [`3a64e5f7`](NixOS/nixpkgs@3a64e5f) arcanist: 20200127 -> 20200711 (NixOS/nixpkgs#93678)
* [`23511891`](NixOS/nixpkgs@2351189) .github/workflows/*: minor fixes
* [`3f1eb952`](NixOS/nixpkgs@3f1eb95) pahole: 1.16 -> 1.17
* [`deb12d39`](NixOS/nixpkgs@deb12d3) linux/hardened/patches/5.6: remove
* [`0834620b`](NixOS/nixpkgs@0834620) libmysofa: disable CODE_COVERAGE in build
* [`be42a66c`](NixOS/nixpkgs@be42a66) oh-my-zsh: 2020-07-30 -> 2020-08-06
* [`0afe6a28`](NixOS/nixpkgs@0afe6a2) openjdk8: 1.8.0_242 -> 1.8.0_265
* [`0c0cfa7b`](NixOS/nixpkgs@0c0cfa7) mcfly: 0.4.0 -> 0.4.1
* [`d3178c99`](NixOS/nixpkgs@d3178c9) monolith: 2.3.0 -> 2.3.1
* [`1e6f11a2`](NixOS/nixpkgs@1e6f11a) antimicro 2.3 -> antimicroX 3.0
* [`cecc4ce3`](NixOS/nixpkgs@cecc4ce) php.extensions.{mongodb,intl}: switch back to icu64
* [`43093651`](NixOS/nixpkgs@4309365) python3Packages.wxPython_4_0: remove unused dependencies
* [`8b76b920`](NixOS/nixpkgs@8b76b92) python3Packages.wxPython_4_0: enable format hardening
* [`7f15e316`](NixOS/nixpkgs@7f15e31) python3Packages.wxPython_4_0: remove manual wrapPythonPrograms invocation
* [`77c4dae8`](NixOS/nixpkgs@77c4dae) skaffold: 1.12.1 → 1.13.1
* [`4390d9b9`](NixOS/nixpkgs@4390d9b) hyp2mat: init at 0.0.17
* [`d4554905`](NixOS/nixpkgs@d455490) musikcube: 0.92.1 -> 0.93.1
* [`cee4e14b`](NixOS/nixpkgs@cee4e14) nixos/postgresql: fix setup script
* [`a4e77ce9`](NixOS/nixpkgs@a4e77ce) strace: 5.7 -> 5.8
* [`ded6c3db`](NixOS/nixpkgs@ded6c3d) discord: 0.0.10 -> 0.0.11
* [`deb0a6ce`](NixOS/nixpkgs@deb0a6c) gl2ps: make cmake a native build input
* [`5efc22d2`](NixOS/nixpkgs@5efc22d) sfrotz: init at 2.52
* [`76ee4f6d`](NixOS/nixpkgs@76ee4f6) discord-ptb: 0.0.20 -> 0.0.21
* [`9fbbe30a`](NixOS/nixpkgs@9fbbe30) discord-canary: 0.0.105 -> 0.0.106
* [`67712587`](NixOS/nixpkgs@6771258) frotz: 2.44 -> 2.52
* [`048e885b`](NixOS/nixpkgs@048e885) kdeApplications.okteta: 0.26.3 -> 0.26.4
* [`8fe906a8`](NixOS/nixpkgs@8fe906a) doona: init at unstable-2019-03-08
* [`bceadafb`](NixOS/nixpkgs@bceadaf) fritzing: use Qt's mkDerivation (NixOS/nixpkgs#89117)
* [`f3c31c1f`](NixOS/nixpkgs@f3c31c1) marble: switch from qtwebkit to qtwebengine
* [`d55276d7`](NixOS/nixpkgs@d55276d) beets: apply patch to fix incompatibilites with python 3.8
* [`5144ec19`](NixOS/nixpkgs@5144ec1) jetbrains.rider: fix dotnet location
* [`8bb50e72`](NixOS/nixpkgs@8bb50e7) Allow jdiskreport to build on Darwin
* [`7cd05de0`](NixOS/nixpkgs@7cd05de) multitail: add pkg-config dependency, needed for darwin builds
* [`ef3cb36b`](NixOS/nixpkgs@ef3cb36) torsocks: Fix the Darwin build
* [`6a359b23`](NixOS/nixpkgs@6a359b2) libxml2Python: Darwin builds require libintl (better fix)
* [`6dbeed2d`](NixOS/nixpkgs@6dbeed2) factorio: add .desktop file
* [`98e8c6be`](NixOS/nixpkgs@98e8c6b) pdns-recursor: 4.3.2 -> 4.3.3
* [`1365b9ac`](NixOS/nixpkgs@1365b9a) nixos/manual: Fix build
* [`846baaa1`](NixOS/nixpkgs@846baaa) postgresql11Packages.pgrouting: 3.0.1 -> 3.0.2
* [`2a49db6a`](NixOS/nixpkgs@2a49db6) transmission: apply RFC0042 and harden the service
* [`69eb22e4`](NixOS/nixpkgs@69eb22e) nixos/gitlab: fix module after NixOS/nixpkgs#94454
* [`d525a689`](NixOS/nixpkgs@d525a68) argo: 2.9.4 -> 2.9.5
* [`ca9c2e35`](NixOS/nixpkgs@ca9c2e3) petsc: 3.13.2 -> 3.13.3
* [`5ca7be38`](NixOS/nixpkgs@5ca7be3) .github/workflows/wait-ofborg.yml: 360 -> 540
* [`ed2e74d9`](NixOS/nixpkgs@ed2e74d) ocamlPackages.gmetadom: use patch file extension
* [`32e87e8b`](NixOS/nixpkgs@32e87e8) cproto: use patch file extension
* [`866752ce`](NixOS/nixpkgs@866752c) yasr: use patch file extension
* [`95ec8d2b`](NixOS/nixpkgs@95ec8d2) minikube: 1.12.1 -> 1.12.2
* [`1a83aa11`](NixOS/nixpkgs@1a83aa1) go_1_13: 1.13.14 -> 1.13.15
* [`22594a9d`](NixOS/nixpkgs@22594a9) ocamlformat: 0.14.2 -> 0.15.0
* [`07e74acd`](NixOS/nixpkgs@07e74ac) ocamlformat: add marsam to maintainers
* [`e4f471da`](NixOS/nixpkgs@e4f471d) packet-cli: 0.0.7 -> 0.0.8
* [`3a2d677b`](NixOS/nixpkgs@3a2d677) v4l-utils: fix by patchShebangs on cec-gen.pl
* [`dc5428e7`](NixOS/nixpkgs@dc5428e) packet-cli: alias packet-cli as packet
* [`20032b1e`](NixOS/nixpkgs@20032b1) python37Packages.cfgv: 3.1.0 -> 3.2.0
* [`bfac8637`](NixOS/nixpkgs@bfac863) python27Packages.cli-helpers: 2.0.1 -> 2.1.0
* [`4b5bae26`](NixOS/nixpkgs@4b5bae2) python3Packages.itemloaders: init at 1.0.1
* [`cf5bc04f`](NixOS/nixpkgs@cf5bc04) python3Packages.scrapy: 2.2.1 -> 2.3.0
* [`4d67cf18`](NixOS/nixpkgs@4d67cf1) python27Packages.azure-mgmt-monitor: 0.10.0 -> 0.11.0
* [`c542d216`](NixOS/nixpkgs@c542d21) mockgen: 1.4.3 -> 1.4.4
* [`c5564e17`](NixOS/nixpkgs@c5564e1) jetty: 9.4.29.v20200521 -> 9.4.31.v20200723
* [`002ecd07`](NixOS/nixpkgs@002ecd0) geekbench: 5.2.1 -> 5.2.3
* [`585e00a3`](NixOS/nixpkgs@585e00a) imgproxy: 2.14.0 -> 2.14.1
* [`0ca9e6b2`](NixOS/nixpkgs@0ca9e6b) ghq: 1.1.2 -> 1.1.5
* [`31e67d68`](NixOS/nixpkgs@31e67d6) giada: 0.16.3 -> 0.16.3.1
* [`6e276d36`](NixOS/nixpkgs@6e276d3) dbmate: 1.9.0 -> 1.9.1
* [`30469ea4`](NixOS/nixpkgs@30469ea) grml-zsh-config: 0.17.3 -> 0.17.4
* [`37e6ac04`](NixOS/nixpkgs@37e6ac0) flyctl: 0.0.135 -> 0.0.137
* [`9175f114`](NixOS/nixpkgs@9175f11) fwts: 20.06.01 -> 20.07.00
* [`c337ad41`](NixOS/nixpkgs@c337ad4) cockroachdb: 20.1.2 -> 20.1.3
* [`2cfff96e`](NixOS/nixpkgs@2cfff96) qtwebkit: 5.212-alpha-01-26-2018 -> 5.212.0-alpha4
* [`014d494e`](NixOS/nixpkgs@014d494) faudio: 20.07 -> 20.08
* [`3a49eaa7`](NixOS/nixpkgs@3a49eaa) mnemosyne: 2.7.1 -> 2.7.2
* [`6d85f8d5`](NixOS/nixpkgs@6d85f8d) python27Packages.braintree: 4.2.0 -> 4.3.0
* [`585aa266`](NixOS/nixpkgs@585aa26) gitlab-runner: 13.2.0 -> 13.2.2 (NixOS/nixpkgs#94818)
* [`febbcb62`](NixOS/nixpkgs@febbcb6) nim: 1.2.4 -> 1.2.6
* [`0ca30931`](NixOS/nixpkgs@0ca3093) snapper: 0.8.10 -> 0.8.12
* [`3012ed98`](NixOS/nixpkgs@3012ed9) waybar: 0.9.2 -> 0.9.3
* [`6c2f1e7f`](NixOS/nixpkgs@6c2f1e7) octopus: 9.2 -> 10.0
* [`91da8094`](NixOS/nixpkgs@91da809) thunderbird-bin: 78.1.0 -> 78.1.1
* [`821146db`](NixOS/nixpkgs@821146d) thunderbird: 78.1.0 -> 78.1.1
* [`1e99541b`](NixOS/nixpkgs@1e99541) thunderbird-bin: 68.10.0 -> 68.11.0
* [`997e6315`](NixOS/nixpkgs@997e631) thunderbird: 68.10.0 -> 68.11.0
* [`ba930d86`](NixOS/nixpkgs@ba930d8) nixos/modules: remove trailing whitespace
* [`49ef0fd5`](NixOS/nixpkgs@49ef0fd) rocclr: fix build (no OpenCL library is required)
* [`3f13e1af`](NixOS/nixpkgs@3f13e1a) openmpi: enable C++ bindings
* [`da88c6ee`](NixOS/nixpkgs@da88c6e) nixos/railcar: fix typo
* [`9bae9409`](NixOS/nixpkgs@9bae940) mame: 0.222 -> 0.223 (NixOS/nixpkgs#94853)
* [`2b09ecd1`](NixOS/nixpkgs@2b09ecd) pythonPackages.cot: init at 2.2.1
* [`8af72d55`](NixOS/nixpkgs@8af72d5) osu-lazer: osu-lazer: 2020.801.0 -> 2020.806.0
* [`4efcd73d`](NixOS/nixpkgs@4efcd73) azure-cli: pin cryptography
* [`ce10e04a`](NixOS/nixpkgs@ce10e04) cramfsprogs: init at 1.1
* [`07ea06b1`](NixOS/nixpkgs@07ea06b) cramfsswap: Make binary available
* [`35c702cc`](NixOS/nixpkgs@35c702c) pythonPackages.binwalk: add dependencies
* [`e165f419`](NixOS/nixpkgs@e165f41) LTS Haskell 16.8
* [`9613e64f`](NixOS/nixpkgs@9613e64) hackage2nix: update list of broken packages to fix evaluation errors
* [`7b3dbe3d`](NixOS/nixpkgs@7b3dbe3) ghc-{8.8.3, 8.8.4, 8.10.1}: fix typos
* [`81475fab`](NixOS/nixpkgs@81475fa) hackage-packages.nix: automatic Haskell package set update
* [`a08c537c`](NixOS/nixpkgs@a08c537) ghc-8.10.x: update override for dhall
* [`b38e6cf1`](NixOS/nixpkgs@b38e6cf) ghc-8.10.x: update override for optics-core
* [`f50a34bb`](NixOS/nixpkgs@f50a34b) haskell-lsp-test: update override to the latest version
* [`ed162342`](NixOS/nixpkgs@ed16234) ghcHEAD: 8.11.20200505 -> 8.11.20200731
* [`adcaeef3`](NixOS/nixpkgs@adcaeef) wob: 0.8 -> 0.9
* [`036d9248`](NixOS/nixpkgs@036d924) python3Packages.vega: fix build
* [`c9c957d4`](NixOS/nixpkgs@c9c957d) gopls: 0.4.3 -> 0.4.4 (NixOS/nixpkgs#94888)
* [`2204f74b`](NixOS/nixpkgs@2204f74) hdhomerun-config-gui: init at 20200521
* [`e768fce7`](NixOS/nixpkgs@e768fce) libhdhomerun: add comment about UDP firewall rule
* [`716cd39e`](NixOS/nixpkgs@716cd39) qt-video-wlr: init at 2020-08-03
* [`102864c2`](NixOS/nixpkgs@102864c) pythonPackages.jupyterhub: 1.0.0 -> 1.1.0
* [`b794182c`](NixOS/nixpkgs@b794182) pythonPackages.jupyter-telemetry: init at 0.1.0
* [`86fbad84`](NixOS/nixpkgs@86fbad8) ocamlPackages.lua-ml: 0.9 → 0.9.1
* [`b8dfca14`](NixOS/nixpkgs@b8dfca1) coq_8_12: 8.12+β1 → 8.12.0
* [`99f6fe15`](NixOS/nixpkgs@99f6fe1) pythonPackages.batchspawer: init at 1.0.0
* [`dcde3405`](NixOS/nixpkgs@dcde340) pythonPackages.dockerspawner: init at 0.11.1
* [`5d22e3ce`](NixOS/nixpkgs@5d22e3c) electrum: 3.3.8 -> 4.0.2
* [`18b5eb3f`](NixOS/nixpkgs@18b5eb3) kodi: 18.6 -> 18.8
* [`fa2b8b01`](NixOS/nixpkgs@fa2b8b0) maintainers.0x4A6F: update email
* [`cb8a5e5b`](NixOS/nixpkgs@cb8a5e5) spaceship-prompt: install prompt_spaceship_setup (NixOS/nixpkgs#94604)
* [`6ffc0fd6`](NixOS/nixpkgs@6ffc0fd) python3Packages.pytorch: fix Darwin build by disabling GCD
* [`bc7b404b`](NixOS/nixpkgs@bc7b404) python3Packages.pytorch: fix library names in lib output on Darwin
* [`ddd897c2`](NixOS/nixpkgs@ddd897c) prosody: update community modules to revision 2dcbc01c9931
github-actions bot added a commit to pbogdan/tag that referenced this pull request Aug 9, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@8e2b14a...b50ef9af](NixOS/nixpkgs@8e2b14a...b50ef9a)

* [`2e3bc79c`](NixOS/nixpkgs@2e3bc79) linux: 4.14.191 -> 4.14.192
* [`af3de724`](NixOS/nixpkgs@af3de72) linux: 4.19.136 -> 4.19.137
* [`b2ef4872`](NixOS/nixpkgs@b2ef487) linux: 5.4.55 -> 5.4.56
* [`72c9b56c`](NixOS/nixpkgs@72c9b56) linux: 5.7.12 -> 5.7.13
* [`42de8384`](NixOS/nixpkgs@42de838) nodePackages.get-graphql-schema: init at 2.1.2
* [`5c62904a`](NixOS/nixpkgs@5c62904) python3Packages.trezor: 0.12.0 -> 0.12.1
* [`31dde677`](NixOS/nixpkgs@31dde67) gtg: refactor (description, platform, version, requirement, formatting)
* [`3d31c28c`](NixOS/nixpkgs@3d31c28) gnunet: 0.12.2 -> 0.13.1
* [`779e3587`](NixOS/nixpkgs@779e358) gnunet-gtk: 0.12.0 -> 0.13.1
* [`e5b91d92`](NixOS/nixpkgs@e5b91d9) valgrind: try fixing on darwin
* [`3d53c051`](NixOS/nixpkgs@3d53c05) element-web: 1.7.2 -> 1.7.3
* [`6e405a8e`](NixOS/nixpkgs@6e405a8) element-desktop: 1.7.2 -> 1.7.3
* [`5e6fe939`](NixOS/nixpkgs@5e6fe93) epkowa: update hashes (NixOS/nixpkgs#93846)
* [`1f01916d`](NixOS/nixpkgs@1f01916) kitty: remove myself from the maintainer list
* [`ff6c4637`](NixOS/nixpkgs@ff6c463) hiawatha: 10.9 -> 10.11
* [`72ff02c9`](NixOS/nixpkgs@72ff02c) kopia: init at 0.5.2
* [`f9f48250`](NixOS/nixpkgs@f9f4825) nixos/smartd: add option for notifiction email sender
* [`4f5fc729`](NixOS/nixpkgs@4f5fc72) nixos/postgresql: use a standard default value for dataDir
* [`e50e89e1`](NixOS/nixpkgs@e50e89e) nixos/postgresql: conditionally provision data directory with StateDirectory
* [`f42f8a6d`](NixOS/nixpkgs@f42f8a6) nixos/postgresql: replace deprecated usage of PermissionsStartOnly
* [`ab602aa6`](NixOS/nixpkgs@ab602aa) sacc: init at 1.01
* [`cc8d2ba2`](NixOS/nixpkgs@cc8d2ba) wire-desktop: linux 3.18.2925 -> 3.19.2928
* [`787a38bf`](NixOS/nixpkgs@787a38b) wire-desktop: mac 3.18.3728 -> 3.19.3799
* [`744d43f8`](NixOS/nixpkgs@744d43f) ledger: fix build on darwin
* [`8d57f75f`](NixOS/nixpkgs@8d57f75) nixos/smartd: fix description for docbook
* [`7503f280`](NixOS/nixpkgs@7503f28) nixos/systemd: fix TUN networking in LXC containers (NixOS/nixpkgs#81481)
* [`e74a6bcc`](NixOS/nixpkgs@e74a6bc) csxcad: init at unstable-2020-02-08
* [`0e0aba23`](NixOS/nixpkgs@0e0aba2) mailcore2: 0.6.3 -> 0.6.4
* [`98f9f814`](NixOS/nixpkgs@98f9f81) micronaut: 1.3.6 -> 1.3.7
* [`f0913d9a`](NixOS/nixpkgs@f0913d9) minder: 1.9.0 -> 1.9.1
* [`c6117648`](NixOS/nixpkgs@c611764) osu-lazer: 2020.725.0 -> 2020.801.0
* [`b41f79fe`](NixOS/nixpkgs@b41f79f) openxray: 558 -> 730
* [`29bdfffd`](NixOS/nixpkgs@29bdfff) adlplug, opnplug: 1.0.1 -> 1.0.2
* [`eaf6ef8f`](NixOS/nixpkgs@eaf6ef8) ArchiSteamFarm: 4.2.3.3 -> 4.2.3.6
* [`2774941c`](NixOS/nixpkgs@2774941) kmsxx: 2020-02-14 -> 2020-08-04
* [`de0caa8e`](NixOS/nixpkgs@de0caa8) openjk: 2019-11-29 -> 2020-07-03
* [`059675cd`](NixOS/nixpkgs@059675c) opl3bankeditor: 1.5 -> 1.5.1
* [`1ace8444`](NixOS/nixpkgs@1ace844) opn2bankeditor: 1.3-beta -> 1.3
* [`28300eb8`](NixOS/nixpkgs@28300eb) kustomize: 3.8.0 -> 3.8.1
* [`668e9f2c`](NixOS/nixpkgs@668e9f2) ldb: 2.1.4 -> 2.2.0
* [`461e2a61`](NixOS/nixpkgs@461e2a6) runc: 1.0.0-rc91 -> 1.0.0-rc92
* [`3f5258b6`](NixOS/nixpkgs@3f5258b) redshift,redshift-wlr: Fix a file path in postInstall
* [`79415b0b`](NixOS/nixpkgs@79415b0) gammastep: init at 2.0.1
* [`f4a0f554`](NixOS/nixpkgs@f4a0f55) cypress: 4.9.0 -> 4.12.1
* [`dfda85ce`](NixOS/nixpkgs@dfda85c) libmatroska: 1.6.0 -> 1.6.1
* [`3a64e5f7`](NixOS/nixpkgs@3a64e5f) arcanist: 20200127 -> 20200711 (NixOS/nixpkgs#93678)
* [`23511891`](NixOS/nixpkgs@2351189) .github/workflows/*: minor fixes
* [`3f1eb952`](NixOS/nixpkgs@3f1eb95) pahole: 1.16 -> 1.17
* [`deb12d39`](NixOS/nixpkgs@deb12d3) linux/hardened/patches/5.6: remove
* [`0834620b`](NixOS/nixpkgs@0834620) libmysofa: disable CODE_COVERAGE in build
* [`be42a66c`](NixOS/nixpkgs@be42a66) oh-my-zsh: 2020-07-30 -> 2020-08-06
* [`0afe6a28`](NixOS/nixpkgs@0afe6a2) openjdk8: 1.8.0_242 -> 1.8.0_265
* [`0c0cfa7b`](NixOS/nixpkgs@0c0cfa7) mcfly: 0.4.0 -> 0.4.1
* [`d3178c99`](NixOS/nixpkgs@d3178c9) monolith: 2.3.0 -> 2.3.1
* [`1e6f11a2`](NixOS/nixpkgs@1e6f11a) antimicro 2.3 -> antimicroX 3.0
* [`cecc4ce3`](NixOS/nixpkgs@cecc4ce) php.extensions.{mongodb,intl}: switch back to icu64
* [`43093651`](NixOS/nixpkgs@4309365) python3Packages.wxPython_4_0: remove unused dependencies
* [`8b76b920`](NixOS/nixpkgs@8b76b92) python3Packages.wxPython_4_0: enable format hardening
* [`7f15e316`](NixOS/nixpkgs@7f15e31) python3Packages.wxPython_4_0: remove manual wrapPythonPrograms invocation
* [`77c4dae8`](NixOS/nixpkgs@77c4dae) skaffold: 1.12.1 → 1.13.1
* [`4390d9b9`](NixOS/nixpkgs@4390d9b) hyp2mat: init at 0.0.17
* [`d4554905`](NixOS/nixpkgs@d455490) musikcube: 0.92.1 -> 0.93.1
* [`cee4e14b`](NixOS/nixpkgs@cee4e14) nixos/postgresql: fix setup script
* [`a4e77ce9`](NixOS/nixpkgs@a4e77ce) strace: 5.7 -> 5.8
* [`ded6c3db`](NixOS/nixpkgs@ded6c3d) discord: 0.0.10 -> 0.0.11
* [`deb0a6ce`](NixOS/nixpkgs@deb0a6c) gl2ps: make cmake a native build input
* [`5efc22d2`](NixOS/nixpkgs@5efc22d) sfrotz: init at 2.52
* [`76ee4f6d`](NixOS/nixpkgs@76ee4f6) discord-ptb: 0.0.20 -> 0.0.21
* [`9fbbe30a`](NixOS/nixpkgs@9fbbe30) discord-canary: 0.0.105 -> 0.0.106
* [`67712587`](NixOS/nixpkgs@6771258) frotz: 2.44 -> 2.52
* [`048e885b`](NixOS/nixpkgs@048e885) kdeApplications.okteta: 0.26.3 -> 0.26.4
* [`8fe906a8`](NixOS/nixpkgs@8fe906a) doona: init at unstable-2019-03-08
* [`bceadafb`](NixOS/nixpkgs@bceadaf) fritzing: use Qt's mkDerivation (NixOS/nixpkgs#89117)
* [`f3c31c1f`](NixOS/nixpkgs@f3c31c1) marble: switch from qtwebkit to qtwebengine
* [`d55276d7`](NixOS/nixpkgs@d55276d) beets: apply patch to fix incompatibilites with python 3.8
* [`5144ec19`](NixOS/nixpkgs@5144ec1) jetbrains.rider: fix dotnet location
* [`8bb50e72`](NixOS/nixpkgs@8bb50e7) Allow jdiskreport to build on Darwin
* [`7cd05de0`](NixOS/nixpkgs@7cd05de) multitail: add pkg-config dependency, needed for darwin builds
* [`ef3cb36b`](NixOS/nixpkgs@ef3cb36) torsocks: Fix the Darwin build
* [`6a359b23`](NixOS/nixpkgs@6a359b2) libxml2Python: Darwin builds require libintl (better fix)
* [`6dbeed2d`](NixOS/nixpkgs@6dbeed2) factorio: add .desktop file
* [`98e8c6be`](NixOS/nixpkgs@98e8c6b) pdns-recursor: 4.3.2 -> 4.3.3
* [`1365b9ac`](NixOS/nixpkgs@1365b9a) nixos/manual: Fix build
* [`846baaa1`](NixOS/nixpkgs@846baaa) postgresql11Packages.pgrouting: 3.0.1 -> 3.0.2
* [`2a49db6a`](NixOS/nixpkgs@2a49db6) transmission: apply RFC0042 and harden the service
* [`69eb22e4`](NixOS/nixpkgs@69eb22e) nixos/gitlab: fix module after NixOS/nixpkgs#94454
* [`d525a689`](NixOS/nixpkgs@d525a68) argo: 2.9.4 -> 2.9.5
* [`ca9c2e35`](NixOS/nixpkgs@ca9c2e3) petsc: 3.13.2 -> 3.13.3
* [`5ca7be38`](NixOS/nixpkgs@5ca7be3) .github/workflows/wait-ofborg.yml: 360 -> 540
* [`ed2e74d9`](NixOS/nixpkgs@ed2e74d) ocamlPackages.gmetadom: use patch file extension
* [`32e87e8b`](NixOS/nixpkgs@32e87e8) cproto: use patch file extension
* [`866752ce`](NixOS/nixpkgs@866752c) yasr: use patch file extension
* [`95ec8d2b`](NixOS/nixpkgs@95ec8d2) minikube: 1.12.1 -> 1.12.2
* [`1a83aa11`](NixOS/nixpkgs@1a83aa1) go_1_13: 1.13.14 -> 1.13.15
* [`22594a9d`](NixOS/nixpkgs@22594a9) ocamlformat: 0.14.2 -> 0.15.0
* [`07e74acd`](NixOS/nixpkgs@07e74ac) ocamlformat: add marsam to maintainers
* [`e4f471da`](NixOS/nixpkgs@e4f471d) packet-cli: 0.0.7 -> 0.0.8
* [`3a2d677b`](NixOS/nixpkgs@3a2d677) v4l-utils: fix by patchShebangs on cec-gen.pl
* [`dc5428e7`](NixOS/nixpkgs@dc5428e) packet-cli: alias packet-cli as packet
* [`20032b1e`](NixOS/nixpkgs@20032b1) python37Packages.cfgv: 3.1.0 -> 3.2.0
* [`bfac8637`](NixOS/nixpkgs@bfac863) python27Packages.cli-helpers: 2.0.1 -> 2.1.0
* [`4b5bae26`](NixOS/nixpkgs@4b5bae2) python3Packages.itemloaders: init at 1.0.1
* [`cf5bc04f`](NixOS/nixpkgs@cf5bc04) python3Packages.scrapy: 2.2.1 -> 2.3.0
* [`4d67cf18`](NixOS/nixpkgs@4d67cf1) python27Packages.azure-mgmt-monitor: 0.10.0 -> 0.11.0
* [`c542d216`](NixOS/nixpkgs@c542d21) mockgen: 1.4.3 -> 1.4.4
* [`c5564e17`](NixOS/nixpkgs@c5564e1) jetty: 9.4.29.v20200521 -> 9.4.31.v20200723
* [`002ecd07`](NixOS/nixpkgs@002ecd0) geekbench: 5.2.1 -> 5.2.3
* [`585e00a3`](NixOS/nixpkgs@585e00a) imgproxy: 2.14.0 -> 2.14.1
* [`0ca9e6b2`](NixOS/nixpkgs@0ca9e6b) ghq: 1.1.2 -> 1.1.5
* [`31e67d68`](NixOS/nixpkgs@31e67d6) giada: 0.16.3 -> 0.16.3.1
* [`6e276d36`](NixOS/nixpkgs@6e276d3) dbmate: 1.9.0 -> 1.9.1
* [`30469ea4`](NixOS/nixpkgs@30469ea) grml-zsh-config: 0.17.3 -> 0.17.4
* [`37e6ac04`](NixOS/nixpkgs@37e6ac0) flyctl: 0.0.135 -> 0.0.137
* [`9175f114`](NixOS/nixpkgs@9175f11) fwts: 20.06.01 -> 20.07.00
* [`c337ad41`](NixOS/nixpkgs@c337ad4) cockroachdb: 20.1.2 -> 20.1.3
* [`2cfff96e`](NixOS/nixpkgs@2cfff96) qtwebkit: 5.212-alpha-01-26-2018 -> 5.212.0-alpha4
* [`014d494e`](NixOS/nixpkgs@014d494) faudio: 20.07 -> 20.08
* [`3a49eaa7`](NixOS/nixpkgs@3a49eaa) mnemosyne: 2.7.1 -> 2.7.2
* [`6d85f8d5`](NixOS/nixpkgs@6d85f8d) python27Packages.braintree: 4.2.0 -> 4.3.0
* [`585aa266`](NixOS/nixpkgs@585aa26) gitlab-runner: 13.2.0 -> 13.2.2 (NixOS/nixpkgs#94818)
* [`febbcb62`](NixOS/nixpkgs@febbcb6) nim: 1.2.4 -> 1.2.6
* [`0ca30931`](NixOS/nixpkgs@0ca3093) snapper: 0.8.10 -> 0.8.12
* [`3012ed98`](NixOS/nixpkgs@3012ed9) waybar: 0.9.2 -> 0.9.3
* [`6c2f1e7f`](NixOS/nixpkgs@6c2f1e7) octopus: 9.2 -> 10.0
* [`91da8094`](NixOS/nixpkgs@91da809) thunderbird-bin: 78.1.0 -> 78.1.1
* [`821146db`](NixOS/nixpkgs@821146d) thunderbird: 78.1.0 -> 78.1.1
* [`1e99541b`](NixOS/nixpkgs@1e99541) thunderbird-bin: 68.10.0 -> 68.11.0
* [`997e6315`](NixOS/nixpkgs@997e631) thunderbird: 68.10.0 -> 68.11.0
* [`ba930d86`](NixOS/nixpkgs@ba930d8) nixos/modules: remove trailing whitespace
* [`49ef0fd5`](NixOS/nixpkgs@49ef0fd) rocclr: fix build (no OpenCL library is required)
* [`3f13e1af`](NixOS/nixpkgs@3f13e1a) openmpi: enable C++ bindings
* [`da88c6ee`](NixOS/nixpkgs@da88c6e) nixos/railcar: fix typo
* [`9bae9409`](NixOS/nixpkgs@9bae940) mame: 0.222 -> 0.223 (NixOS/nixpkgs#94853)
* [`2b09ecd1`](NixOS/nixpkgs@2b09ecd) pythonPackages.cot: init at 2.2.1
* [`8af72d55`](NixOS/nixpkgs@8af72d5) osu-lazer: osu-lazer: 2020.801.0 -> 2020.806.0
* [`4efcd73d`](NixOS/nixpkgs@4efcd73) azure-cli: pin cryptography
* [`ce10e04a`](NixOS/nixpkgs@ce10e04) cramfsprogs: init at 1.1
* [`07ea06b1`](NixOS/nixpkgs@07ea06b) cramfsswap: Make binary available
* [`35c702cc`](NixOS/nixpkgs@35c702c) pythonPackages.binwalk: add dependencies
* [`e165f419`](NixOS/nixpkgs@e165f41) LTS Haskell 16.8
* [`9613e64f`](NixOS/nixpkgs@9613e64) hackage2nix: update list of broken packages to fix evaluation errors
* [`7b3dbe3d`](NixOS/nixpkgs@7b3dbe3) ghc-{8.8.3, 8.8.4, 8.10.1}: fix typos
* [`81475fab`](NixOS/nixpkgs@81475fa) hackage-packages.nix: automatic Haskell package set update
* [`a08c537c`](NixOS/nixpkgs@a08c537) ghc-8.10.x: update override for dhall
* [`b38e6cf1`](NixOS/nixpkgs@b38e6cf) ghc-8.10.x: update override for optics-core
* [`f50a34bb`](NixOS/nixpkgs@f50a34b) haskell-lsp-test: update override to the latest version
* [`ed162342`](NixOS/nixpkgs@ed16234) ghcHEAD: 8.11.20200505 -> 8.11.20200731
* [`adcaeef3`](NixOS/nixpkgs@adcaeef) wob: 0.8 -> 0.9
* [`036d9248`](NixOS/nixpkgs@036d924) python3Packages.vega: fix build
* [`c9c957d4`](NixOS/nixpkgs@c9c957d) gopls: 0.4.3 -> 0.4.4 (NixOS/nixpkgs#94888)
* [`2204f74b`](NixOS/nixpkgs@2204f74) hdhomerun-config-gui: init at 20200521
* [`e768fce7`](NixOS/nixpkgs@e768fce) libhdhomerun: add comment about UDP firewall rule
* [`716cd39e`](NixOS/nixpkgs@716cd39) qt-video-wlr: init at 2020-08-03
* [`102864c2`](NixOS/nixpkgs@102864c) pythonPackages.jupyterhub: 1.0.0 -> 1.1.0
* [`b794182c`](NixOS/nixpkgs@b794182) pythonPackages.jupyter-telemetry: init at 0.1.0
* [`86fbad84`](NixOS/nixpkgs@86fbad8) ocamlPackages.lua-ml: 0.9 → 0.9.1
* [`b8dfca14`](NixOS/nixpkgs@b8dfca1) coq_8_12: 8.12+β1 → 8.12.0
* [`99f6fe15`](NixOS/nixpkgs@99f6fe1) pythonPackages.batchspawer: init at 1.0.0
* [`dcde3405`](NixOS/nixpkgs@dcde340) pythonPackages.dockerspawner: init at 0.11.1
* [`5d22e3ce`](NixOS/nixpkgs@5d22e3c) electrum: 3.3.8 -> 4.0.2
* [`18b5eb3f`](NixOS/nixpkgs@18b5eb3) kodi: 18.6 -> 18.8
* [`fa2b8b01`](NixOS/nixpkgs@fa2b8b0) maintainers.0x4A6F: update email
* [`cb8a5e5b`](NixOS/nixpkgs@cb8a5e5) spaceship-prompt: install prompt_spaceship_setup (NixOS/nixpkgs#94604)
* [`6ffc0fd6`](NixOS/nixpkgs@6ffc0fd) python3Packages.pytorch: fix Darwin build by disabling GCD
* [`bc7b404b`](NixOS/nixpkgs@bc7b404) python3Packages.pytorch: fix library names in lib output on Darwin
* [`ddd897c2`](NixOS/nixpkgs@ddd897c) prosody: update community modules to revision 2dcbc01c9931
github-actions bot added a commit to pbogdan/nix-hie that referenced this pull request Aug 9, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@8e2b14a...b50ef9af](NixOS/nixpkgs@8e2b14a...b50ef9a)

* [`2e3bc79c`](NixOS/nixpkgs@2e3bc79) linux: 4.14.191 -> 4.14.192
* [`af3de724`](NixOS/nixpkgs@af3de72) linux: 4.19.136 -> 4.19.137
* [`b2ef4872`](NixOS/nixpkgs@b2ef487) linux: 5.4.55 -> 5.4.56
* [`72c9b56c`](NixOS/nixpkgs@72c9b56) linux: 5.7.12 -> 5.7.13
* [`42de8384`](NixOS/nixpkgs@42de838) nodePackages.get-graphql-schema: init at 2.1.2
* [`5c62904a`](NixOS/nixpkgs@5c62904) python3Packages.trezor: 0.12.0 -> 0.12.1
* [`31dde677`](NixOS/nixpkgs@31dde67) gtg: refactor (description, platform, version, requirement, formatting)
* [`3d31c28c`](NixOS/nixpkgs@3d31c28) gnunet: 0.12.2 -> 0.13.1
* [`779e3587`](NixOS/nixpkgs@779e358) gnunet-gtk: 0.12.0 -> 0.13.1
* [`e5b91d92`](NixOS/nixpkgs@e5b91d9) valgrind: try fixing on darwin
* [`3d53c051`](NixOS/nixpkgs@3d53c05) element-web: 1.7.2 -> 1.7.3
* [`6e405a8e`](NixOS/nixpkgs@6e405a8) element-desktop: 1.7.2 -> 1.7.3
* [`5e6fe939`](NixOS/nixpkgs@5e6fe93) epkowa: update hashes (NixOS/nixpkgs#93846)
* [`1f01916d`](NixOS/nixpkgs@1f01916) kitty: remove myself from the maintainer list
* [`ff6c4637`](NixOS/nixpkgs@ff6c463) hiawatha: 10.9 -> 10.11
* [`72ff02c9`](NixOS/nixpkgs@72ff02c) kopia: init at 0.5.2
* [`f9f48250`](NixOS/nixpkgs@f9f4825) nixos/smartd: add option for notifiction email sender
* [`4f5fc729`](NixOS/nixpkgs@4f5fc72) nixos/postgresql: use a standard default value for dataDir
* [`e50e89e1`](NixOS/nixpkgs@e50e89e) nixos/postgresql: conditionally provision data directory with StateDirectory
* [`f42f8a6d`](NixOS/nixpkgs@f42f8a6) nixos/postgresql: replace deprecated usage of PermissionsStartOnly
* [`ab602aa6`](NixOS/nixpkgs@ab602aa) sacc: init at 1.01
* [`cc8d2ba2`](NixOS/nixpkgs@cc8d2ba) wire-desktop: linux 3.18.2925 -> 3.19.2928
* [`787a38bf`](NixOS/nixpkgs@787a38b) wire-desktop: mac 3.18.3728 -> 3.19.3799
* [`744d43f8`](NixOS/nixpkgs@744d43f) ledger: fix build on darwin
* [`8d57f75f`](NixOS/nixpkgs@8d57f75) nixos/smartd: fix description for docbook
* [`7503f280`](NixOS/nixpkgs@7503f28) nixos/systemd: fix TUN networking in LXC containers (NixOS/nixpkgs#81481)
* [`e74a6bcc`](NixOS/nixpkgs@e74a6bc) csxcad: init at unstable-2020-02-08
* [`0e0aba23`](NixOS/nixpkgs@0e0aba2) mailcore2: 0.6.3 -> 0.6.4
* [`98f9f814`](NixOS/nixpkgs@98f9f81) micronaut: 1.3.6 -> 1.3.7
* [`f0913d9a`](NixOS/nixpkgs@f0913d9) minder: 1.9.0 -> 1.9.1
* [`c6117648`](NixOS/nixpkgs@c611764) osu-lazer: 2020.725.0 -> 2020.801.0
* [`b41f79fe`](NixOS/nixpkgs@b41f79f) openxray: 558 -> 730
* [`29bdfffd`](NixOS/nixpkgs@29bdfff) adlplug, opnplug: 1.0.1 -> 1.0.2
* [`eaf6ef8f`](NixOS/nixpkgs@eaf6ef8) ArchiSteamFarm: 4.2.3.3 -> 4.2.3.6
* [`2774941c`](NixOS/nixpkgs@2774941) kmsxx: 2020-02-14 -> 2020-08-04
* [`de0caa8e`](NixOS/nixpkgs@de0caa8) openjk: 2019-11-29 -> 2020-07-03
* [`059675cd`](NixOS/nixpkgs@059675c) opl3bankeditor: 1.5 -> 1.5.1
* [`1ace8444`](NixOS/nixpkgs@1ace844) opn2bankeditor: 1.3-beta -> 1.3
* [`28300eb8`](NixOS/nixpkgs@28300eb) kustomize: 3.8.0 -> 3.8.1
* [`668e9f2c`](NixOS/nixpkgs@668e9f2) ldb: 2.1.4 -> 2.2.0
* [`461e2a61`](NixOS/nixpkgs@461e2a6) runc: 1.0.0-rc91 -> 1.0.0-rc92
* [`3f5258b6`](NixOS/nixpkgs@3f5258b) redshift,redshift-wlr: Fix a file path in postInstall
* [`79415b0b`](NixOS/nixpkgs@79415b0) gammastep: init at 2.0.1
* [`f4a0f554`](NixOS/nixpkgs@f4a0f55) cypress: 4.9.0 -> 4.12.1
* [`dfda85ce`](NixOS/nixpkgs@dfda85c) libmatroska: 1.6.0 -> 1.6.1
* [`3a64e5f7`](NixOS/nixpkgs@3a64e5f) arcanist: 20200127 -> 20200711 (NixOS/nixpkgs#93678)
* [`23511891`](NixOS/nixpkgs@2351189) .github/workflows/*: minor fixes
* [`3f1eb952`](NixOS/nixpkgs@3f1eb95) pahole: 1.16 -> 1.17
* [`deb12d39`](NixOS/nixpkgs@deb12d3) linux/hardened/patches/5.6: remove
* [`0834620b`](NixOS/nixpkgs@0834620) libmysofa: disable CODE_COVERAGE in build
* [`be42a66c`](NixOS/nixpkgs@be42a66) oh-my-zsh: 2020-07-30 -> 2020-08-06
* [`0afe6a28`](NixOS/nixpkgs@0afe6a2) openjdk8: 1.8.0_242 -> 1.8.0_265
* [`0c0cfa7b`](NixOS/nixpkgs@0c0cfa7) mcfly: 0.4.0 -> 0.4.1
* [`d3178c99`](NixOS/nixpkgs@d3178c9) monolith: 2.3.0 -> 2.3.1
* [`1e6f11a2`](NixOS/nixpkgs@1e6f11a) antimicro 2.3 -> antimicroX 3.0
* [`cecc4ce3`](NixOS/nixpkgs@cecc4ce) php.extensions.{mongodb,intl}: switch back to icu64
* [`43093651`](NixOS/nixpkgs@4309365) python3Packages.wxPython_4_0: remove unused dependencies
* [`8b76b920`](NixOS/nixpkgs@8b76b92) python3Packages.wxPython_4_0: enable format hardening
* [`7f15e316`](NixOS/nixpkgs@7f15e31) python3Packages.wxPython_4_0: remove manual wrapPythonPrograms invocation
* [`77c4dae8`](NixOS/nixpkgs@77c4dae) skaffold: 1.12.1 → 1.13.1
* [`4390d9b9`](NixOS/nixpkgs@4390d9b) hyp2mat: init at 0.0.17
* [`d4554905`](NixOS/nixpkgs@d455490) musikcube: 0.92.1 -> 0.93.1
* [`cee4e14b`](NixOS/nixpkgs@cee4e14) nixos/postgresql: fix setup script
* [`a4e77ce9`](NixOS/nixpkgs@a4e77ce) strace: 5.7 -> 5.8
* [`ded6c3db`](NixOS/nixpkgs@ded6c3d) discord: 0.0.10 -> 0.0.11
* [`deb0a6ce`](NixOS/nixpkgs@deb0a6c) gl2ps: make cmake a native build input
* [`5efc22d2`](NixOS/nixpkgs@5efc22d) sfrotz: init at 2.52
* [`76ee4f6d`](NixOS/nixpkgs@76ee4f6) discord-ptb: 0.0.20 -> 0.0.21
* [`9fbbe30a`](NixOS/nixpkgs@9fbbe30) discord-canary: 0.0.105 -> 0.0.106
* [`67712587`](NixOS/nixpkgs@6771258) frotz: 2.44 -> 2.52
* [`048e885b`](NixOS/nixpkgs@048e885) kdeApplications.okteta: 0.26.3 -> 0.26.4
* [`8fe906a8`](NixOS/nixpkgs@8fe906a) doona: init at unstable-2019-03-08
* [`bceadafb`](NixOS/nixpkgs@bceadaf) fritzing: use Qt's mkDerivation (NixOS/nixpkgs#89117)
* [`f3c31c1f`](NixOS/nixpkgs@f3c31c1) marble: switch from qtwebkit to qtwebengine
* [`d55276d7`](NixOS/nixpkgs@d55276d) beets: apply patch to fix incompatibilites with python 3.8
* [`5144ec19`](NixOS/nixpkgs@5144ec1) jetbrains.rider: fix dotnet location
* [`8bb50e72`](NixOS/nixpkgs@8bb50e7) Allow jdiskreport to build on Darwin
* [`7cd05de0`](NixOS/nixpkgs@7cd05de) multitail: add pkg-config dependency, needed for darwin builds
* [`ef3cb36b`](NixOS/nixpkgs@ef3cb36) torsocks: Fix the Darwin build
* [`6a359b23`](NixOS/nixpkgs@6a359b2) libxml2Python: Darwin builds require libintl (better fix)
* [`6dbeed2d`](NixOS/nixpkgs@6dbeed2) factorio: add .desktop file
* [`98e8c6be`](NixOS/nixpkgs@98e8c6b) pdns-recursor: 4.3.2 -> 4.3.3
* [`1365b9ac`](NixOS/nixpkgs@1365b9a) nixos/manual: Fix build
* [`846baaa1`](NixOS/nixpkgs@846baaa) postgresql11Packages.pgrouting: 3.0.1 -> 3.0.2
* [`2a49db6a`](NixOS/nixpkgs@2a49db6) transmission: apply RFC0042 and harden the service
* [`69eb22e4`](NixOS/nixpkgs@69eb22e) nixos/gitlab: fix module after NixOS/nixpkgs#94454
* [`d525a689`](NixOS/nixpkgs@d525a68) argo: 2.9.4 -> 2.9.5
* [`ca9c2e35`](NixOS/nixpkgs@ca9c2e3) petsc: 3.13.2 -> 3.13.3
* [`5ca7be38`](NixOS/nixpkgs@5ca7be3) .github/workflows/wait-ofborg.yml: 360 -> 540
* [`ed2e74d9`](NixOS/nixpkgs@ed2e74d) ocamlPackages.gmetadom: use patch file extension
* [`32e87e8b`](NixOS/nixpkgs@32e87e8) cproto: use patch file extension
* [`866752ce`](NixOS/nixpkgs@866752c) yasr: use patch file extension
* [`95ec8d2b`](NixOS/nixpkgs@95ec8d2) minikube: 1.12.1 -> 1.12.2
* [`1a83aa11`](NixOS/nixpkgs@1a83aa1) go_1_13: 1.13.14 -> 1.13.15
* [`22594a9d`](NixOS/nixpkgs@22594a9) ocamlformat: 0.14.2 -> 0.15.0
* [`07e74acd`](NixOS/nixpkgs@07e74ac) ocamlformat: add marsam to maintainers
* [`e4f471da`](NixOS/nixpkgs@e4f471d) packet-cli: 0.0.7 -> 0.0.8
* [`3a2d677b`](NixOS/nixpkgs@3a2d677) v4l-utils: fix by patchShebangs on cec-gen.pl
* [`dc5428e7`](NixOS/nixpkgs@dc5428e) packet-cli: alias packet-cli as packet
* [`20032b1e`](NixOS/nixpkgs@20032b1) python37Packages.cfgv: 3.1.0 -> 3.2.0
* [`bfac8637`](NixOS/nixpkgs@bfac863) python27Packages.cli-helpers: 2.0.1 -> 2.1.0
* [`4b5bae26`](NixOS/nixpkgs@4b5bae2) python3Packages.itemloaders: init at 1.0.1
* [`cf5bc04f`](NixOS/nixpkgs@cf5bc04) python3Packages.scrapy: 2.2.1 -> 2.3.0
* [`4d67cf18`](NixOS/nixpkgs@4d67cf1) python27Packages.azure-mgmt-monitor: 0.10.0 -> 0.11.0
* [`c542d216`](NixOS/nixpkgs@c542d21) mockgen: 1.4.3 -> 1.4.4
* [`c5564e17`](NixOS/nixpkgs@c5564e1) jetty: 9.4.29.v20200521 -> 9.4.31.v20200723
* [`002ecd07`](NixOS/nixpkgs@002ecd0) geekbench: 5.2.1 -> 5.2.3
* [`585e00a3`](NixOS/nixpkgs@585e00a) imgproxy: 2.14.0 -> 2.14.1
* [`0ca9e6b2`](NixOS/nixpkgs@0ca9e6b) ghq: 1.1.2 -> 1.1.5
* [`31e67d68`](NixOS/nixpkgs@31e67d6) giada: 0.16.3 -> 0.16.3.1
* [`6e276d36`](NixOS/nixpkgs@6e276d3) dbmate: 1.9.0 -> 1.9.1
* [`30469ea4`](NixOS/nixpkgs@30469ea) grml-zsh-config: 0.17.3 -> 0.17.4
* [`37e6ac04`](NixOS/nixpkgs@37e6ac0) flyctl: 0.0.135 -> 0.0.137
* [`9175f114`](NixOS/nixpkgs@9175f11) fwts: 20.06.01 -> 20.07.00
* [`c337ad41`](NixOS/nixpkgs@c337ad4) cockroachdb: 20.1.2 -> 20.1.3
* [`2cfff96e`](NixOS/nixpkgs@2cfff96) qtwebkit: 5.212-alpha-01-26-2018 -> 5.212.0-alpha4
* [`014d494e`](NixOS/nixpkgs@014d494) faudio: 20.07 -> 20.08
* [`3a49eaa7`](NixOS/nixpkgs@3a49eaa) mnemosyne: 2.7.1 -> 2.7.2
* [`6d85f8d5`](NixOS/nixpkgs@6d85f8d) python27Packages.braintree: 4.2.0 -> 4.3.0
* [`585aa266`](NixOS/nixpkgs@585aa26) gitlab-runner: 13.2.0 -> 13.2.2 (NixOS/nixpkgs#94818)
* [`febbcb62`](NixOS/nixpkgs@febbcb6) nim: 1.2.4 -> 1.2.6
* [`0ca30931`](NixOS/nixpkgs@0ca3093) snapper: 0.8.10 -> 0.8.12
* [`3012ed98`](NixOS/nixpkgs@3012ed9) waybar: 0.9.2 -> 0.9.3
* [`6c2f1e7f`](NixOS/nixpkgs@6c2f1e7) octopus: 9.2 -> 10.0
* [`91da8094`](NixOS/nixpkgs@91da809) thunderbird-bin: 78.1.0 -> 78.1.1
* [`821146db`](NixOS/nixpkgs@821146d) thunderbird: 78.1.0 -> 78.1.1
* [`1e99541b`](NixOS/nixpkgs@1e99541) thunderbird-bin: 68.10.0 -> 68.11.0
* [`997e6315`](NixOS/nixpkgs@997e631) thunderbird: 68.10.0 -> 68.11.0
* [`ba930d86`](NixOS/nixpkgs@ba930d8) nixos/modules: remove trailing whitespace
* [`49ef0fd5`](NixOS/nixpkgs@49ef0fd) rocclr: fix build (no OpenCL library is required)
* [`3f13e1af`](NixOS/nixpkgs@3f13e1a) openmpi: enable C++ bindings
* [`da88c6ee`](NixOS/nixpkgs@da88c6e) nixos/railcar: fix typo
* [`9bae9409`](NixOS/nixpkgs@9bae940) mame: 0.222 -> 0.223 (NixOS/nixpkgs#94853)
* [`2b09ecd1`](NixOS/nixpkgs@2b09ecd) pythonPackages.cot: init at 2.2.1
* [`8af72d55`](NixOS/nixpkgs@8af72d5) osu-lazer: osu-lazer: 2020.801.0 -> 2020.806.0
* [`4efcd73d`](NixOS/nixpkgs@4efcd73) azure-cli: pin cryptography
* [`ce10e04a`](NixOS/nixpkgs@ce10e04) cramfsprogs: init at 1.1
* [`07ea06b1`](NixOS/nixpkgs@07ea06b) cramfsswap: Make binary available
* [`35c702cc`](NixOS/nixpkgs@35c702c) pythonPackages.binwalk: add dependencies
* [`e165f419`](NixOS/nixpkgs@e165f41) LTS Haskell 16.8
* [`9613e64f`](NixOS/nixpkgs@9613e64) hackage2nix: update list of broken packages to fix evaluation errors
* [`7b3dbe3d`](NixOS/nixpkgs@7b3dbe3) ghc-{8.8.3, 8.8.4, 8.10.1}: fix typos
* [`81475fab`](NixOS/nixpkgs@81475fa) hackage-packages.nix: automatic Haskell package set update
* [`a08c537c`](NixOS/nixpkgs@a08c537) ghc-8.10.x: update override for dhall
* [`b38e6cf1`](NixOS/nixpkgs@b38e6cf) ghc-8.10.x: update override for optics-core
* [`f50a34bb`](NixOS/nixpkgs@f50a34b) haskell-lsp-test: update override to the latest version
* [`ed162342`](NixOS/nixpkgs@ed16234) ghcHEAD: 8.11.20200505 -> 8.11.20200731
* [`adcaeef3`](NixOS/nixpkgs@adcaeef) wob: 0.8 -> 0.9
* [`036d9248`](NixOS/nixpkgs@036d924) python3Packages.vega: fix build
* [`c9c957d4`](NixOS/nixpkgs@c9c957d) gopls: 0.4.3 -> 0.4.4 (NixOS/nixpkgs#94888)
* [`2204f74b`](NixOS/nixpkgs@2204f74) hdhomerun-config-gui: init at 20200521
* [`e768fce7`](NixOS/nixpkgs@e768fce) libhdhomerun: add comment about UDP firewall rule
* [`716cd39e`](NixOS/nixpkgs@716cd39) qt-video-wlr: init at 2020-08-03
* [`102864c2`](NixOS/nixpkgs@102864c) pythonPackages.jupyterhub: 1.0.0 -> 1.1.0
* [`b794182c`](NixOS/nixpkgs@b794182) pythonPackages.jupyter-telemetry: init at 0.1.0
* [`86fbad84`](NixOS/nixpkgs@86fbad8) ocamlPackages.lua-ml: 0.9 → 0.9.1
* [`b8dfca14`](NixOS/nixpkgs@b8dfca1) coq_8_12: 8.12+β1 → 8.12.0
* [`99f6fe15`](NixOS/nixpkgs@99f6fe1) pythonPackages.batchspawer: init at 1.0.0
* [`dcde3405`](NixOS/nixpkgs@dcde340) pythonPackages.dockerspawner: init at 0.11.1
* [`5d22e3ce`](NixOS/nixpkgs@5d22e3c) electrum: 3.3.8 -> 4.0.2
* [`18b5eb3f`](NixOS/nixpkgs@18b5eb3) kodi: 18.6 -> 18.8
* [`fa2b8b01`](NixOS/nixpkgs@fa2b8b0) maintainers.0x4A6F: update email
* [`cb8a5e5b`](NixOS/nixpkgs@cb8a5e5) spaceship-prompt: install prompt_spaceship_setup (NixOS/nixpkgs#94604)
* [`6ffc0fd6`](NixOS/nixpkgs@6ffc0fd) python3Packages.pytorch: fix Darwin build by disabling GCD
* [`bc7b404b`](NixOS/nixpkgs@bc7b404) python3Packages.pytorch: fix library names in lib output on Darwin
* [`ddd897c2`](NixOS/nixpkgs@ddd897c) prosody: update community modules to revision 2dcbc01c9931
github-actions bot added a commit to pbogdan/nvs that referenced this pull request Aug 9, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@8e2b14a...b50ef9af](NixOS/nixpkgs@8e2b14a...b50ef9a)

* [`2e3bc79c`](NixOS/nixpkgs@2e3bc79) linux: 4.14.191 -> 4.14.192
* [`af3de724`](NixOS/nixpkgs@af3de72) linux: 4.19.136 -> 4.19.137
* [`b2ef4872`](NixOS/nixpkgs@b2ef487) linux: 5.4.55 -> 5.4.56
* [`72c9b56c`](NixOS/nixpkgs@72c9b56) linux: 5.7.12 -> 5.7.13
* [`42de8384`](NixOS/nixpkgs@42de838) nodePackages.get-graphql-schema: init at 2.1.2
* [`5c62904a`](NixOS/nixpkgs@5c62904) python3Packages.trezor: 0.12.0 -> 0.12.1
* [`31dde677`](NixOS/nixpkgs@31dde67) gtg: refactor (description, platform, version, requirement, formatting)
* [`3d31c28c`](NixOS/nixpkgs@3d31c28) gnunet: 0.12.2 -> 0.13.1
* [`779e3587`](NixOS/nixpkgs@779e358) gnunet-gtk: 0.12.0 -> 0.13.1
* [`e5b91d92`](NixOS/nixpkgs@e5b91d9) valgrind: try fixing on darwin
* [`3d53c051`](NixOS/nixpkgs@3d53c05) element-web: 1.7.2 -> 1.7.3
* [`6e405a8e`](NixOS/nixpkgs@6e405a8) element-desktop: 1.7.2 -> 1.7.3
* [`5e6fe939`](NixOS/nixpkgs@5e6fe93) epkowa: update hashes (NixOS/nixpkgs#93846)
* [`1f01916d`](NixOS/nixpkgs@1f01916) kitty: remove myself from the maintainer list
* [`ff6c4637`](NixOS/nixpkgs@ff6c463) hiawatha: 10.9 -> 10.11
* [`72ff02c9`](NixOS/nixpkgs@72ff02c) kopia: init at 0.5.2
* [`f9f48250`](NixOS/nixpkgs@f9f4825) nixos/smartd: add option for notifiction email sender
* [`4f5fc729`](NixOS/nixpkgs@4f5fc72) nixos/postgresql: use a standard default value for dataDir
* [`e50e89e1`](NixOS/nixpkgs@e50e89e) nixos/postgresql: conditionally provision data directory with StateDirectory
* [`f42f8a6d`](NixOS/nixpkgs@f42f8a6) nixos/postgresql: replace deprecated usage of PermissionsStartOnly
* [`ab602aa6`](NixOS/nixpkgs@ab602aa) sacc: init at 1.01
* [`cc8d2ba2`](NixOS/nixpkgs@cc8d2ba) wire-desktop: linux 3.18.2925 -> 3.19.2928
* [`787a38bf`](NixOS/nixpkgs@787a38b) wire-desktop: mac 3.18.3728 -> 3.19.3799
* [`744d43f8`](NixOS/nixpkgs@744d43f) ledger: fix build on darwin
* [`8d57f75f`](NixOS/nixpkgs@8d57f75) nixos/smartd: fix description for docbook
* [`7503f280`](NixOS/nixpkgs@7503f28) nixos/systemd: fix TUN networking in LXC containers (NixOS/nixpkgs#81481)
* [`e74a6bcc`](NixOS/nixpkgs@e74a6bc) csxcad: init at unstable-2020-02-08
* [`0e0aba23`](NixOS/nixpkgs@0e0aba2) mailcore2: 0.6.3 -> 0.6.4
* [`98f9f814`](NixOS/nixpkgs@98f9f81) micronaut: 1.3.6 -> 1.3.7
* [`f0913d9a`](NixOS/nixpkgs@f0913d9) minder: 1.9.0 -> 1.9.1
* [`c6117648`](NixOS/nixpkgs@c611764) osu-lazer: 2020.725.0 -> 2020.801.0
* [`b41f79fe`](NixOS/nixpkgs@b41f79f) openxray: 558 -> 730
* [`29bdfffd`](NixOS/nixpkgs@29bdfff) adlplug, opnplug: 1.0.1 -> 1.0.2
* [`eaf6ef8f`](NixOS/nixpkgs@eaf6ef8) ArchiSteamFarm: 4.2.3.3 -> 4.2.3.6
* [`2774941c`](NixOS/nixpkgs@2774941) kmsxx: 2020-02-14 -> 2020-08-04
* [`de0caa8e`](NixOS/nixpkgs@de0caa8) openjk: 2019-11-29 -> 2020-07-03
* [`059675cd`](NixOS/nixpkgs@059675c) opl3bankeditor: 1.5 -> 1.5.1
* [`1ace8444`](NixOS/nixpkgs@1ace844) opn2bankeditor: 1.3-beta -> 1.3
* [`28300eb8`](NixOS/nixpkgs@28300eb) kustomize: 3.8.0 -> 3.8.1
* [`668e9f2c`](NixOS/nixpkgs@668e9f2) ldb: 2.1.4 -> 2.2.0
* [`461e2a61`](NixOS/nixpkgs@461e2a6) runc: 1.0.0-rc91 -> 1.0.0-rc92
* [`3f5258b6`](NixOS/nixpkgs@3f5258b) redshift,redshift-wlr: Fix a file path in postInstall
* [`79415b0b`](NixOS/nixpkgs@79415b0) gammastep: init at 2.0.1
* [`f4a0f554`](NixOS/nixpkgs@f4a0f55) cypress: 4.9.0 -> 4.12.1
* [`dfda85ce`](NixOS/nixpkgs@dfda85c) libmatroska: 1.6.0 -> 1.6.1
* [`3a64e5f7`](NixOS/nixpkgs@3a64e5f) arcanist: 20200127 -> 20200711 (NixOS/nixpkgs#93678)
* [`23511891`](NixOS/nixpkgs@2351189) .github/workflows/*: minor fixes
* [`3f1eb952`](NixOS/nixpkgs@3f1eb95) pahole: 1.16 -> 1.17
* [`deb12d39`](NixOS/nixpkgs@deb12d3) linux/hardened/patches/5.6: remove
* [`0834620b`](NixOS/nixpkgs@0834620) libmysofa: disable CODE_COVERAGE in build
* [`be42a66c`](NixOS/nixpkgs@be42a66) oh-my-zsh: 2020-07-30 -> 2020-08-06
* [`0afe6a28`](NixOS/nixpkgs@0afe6a2) openjdk8: 1.8.0_242 -> 1.8.0_265
* [`0c0cfa7b`](NixOS/nixpkgs@0c0cfa7) mcfly: 0.4.0 -> 0.4.1
* [`d3178c99`](NixOS/nixpkgs@d3178c9) monolith: 2.3.0 -> 2.3.1
* [`1e6f11a2`](NixOS/nixpkgs@1e6f11a) antimicro 2.3 -> antimicroX 3.0
* [`cecc4ce3`](NixOS/nixpkgs@cecc4ce) php.extensions.{mongodb,intl}: switch back to icu64
* [`43093651`](NixOS/nixpkgs@4309365) python3Packages.wxPython_4_0: remove unused dependencies
* [`8b76b920`](NixOS/nixpkgs@8b76b92) python3Packages.wxPython_4_0: enable format hardening
* [`7f15e316`](NixOS/nixpkgs@7f15e31) python3Packages.wxPython_4_0: remove manual wrapPythonPrograms invocation
* [`77c4dae8`](NixOS/nixpkgs@77c4dae) skaffold: 1.12.1 → 1.13.1
* [`4390d9b9`](NixOS/nixpkgs@4390d9b) hyp2mat: init at 0.0.17
* [`d4554905`](NixOS/nixpkgs@d455490) musikcube: 0.92.1 -> 0.93.1
* [`cee4e14b`](NixOS/nixpkgs@cee4e14) nixos/postgresql: fix setup script
* [`a4e77ce9`](NixOS/nixpkgs@a4e77ce) strace: 5.7 -> 5.8
* [`ded6c3db`](NixOS/nixpkgs@ded6c3d) discord: 0.0.10 -> 0.0.11
* [`deb0a6ce`](NixOS/nixpkgs@deb0a6c) gl2ps: make cmake a native build input
* [`5efc22d2`](NixOS/nixpkgs@5efc22d) sfrotz: init at 2.52
* [`76ee4f6d`](NixOS/nixpkgs@76ee4f6) discord-ptb: 0.0.20 -> 0.0.21
* [`9fbbe30a`](NixOS/nixpkgs@9fbbe30) discord-canary: 0.0.105 -> 0.0.106
* [`67712587`](NixOS/nixpkgs@6771258) frotz: 2.44 -> 2.52
* [`048e885b`](NixOS/nixpkgs@048e885) kdeApplications.okteta: 0.26.3 -> 0.26.4
* [`8fe906a8`](NixOS/nixpkgs@8fe906a) doona: init at unstable-2019-03-08
* [`bceadafb`](NixOS/nixpkgs@bceadaf) fritzing: use Qt's mkDerivation (NixOS/nixpkgs#89117)
* [`f3c31c1f`](NixOS/nixpkgs@f3c31c1) marble: switch from qtwebkit to qtwebengine
* [`d55276d7`](NixOS/nixpkgs@d55276d) beets: apply patch to fix incompatibilites with python 3.8
* [`5144ec19`](NixOS/nixpkgs@5144ec1) jetbrains.rider: fix dotnet location
* [`8bb50e72`](NixOS/nixpkgs@8bb50e7) Allow jdiskreport to build on Darwin
* [`7cd05de0`](NixOS/nixpkgs@7cd05de) multitail: add pkg-config dependency, needed for darwin builds
* [`ef3cb36b`](NixOS/nixpkgs@ef3cb36) torsocks: Fix the Darwin build
* [`6a359b23`](NixOS/nixpkgs@6a359b2) libxml2Python: Darwin builds require libintl (better fix)
* [`6dbeed2d`](NixOS/nixpkgs@6dbeed2) factorio: add .desktop file
* [`98e8c6be`](NixOS/nixpkgs@98e8c6b) pdns-recursor: 4.3.2 -> 4.3.3
* [`1365b9ac`](NixOS/nixpkgs@1365b9a) nixos/manual: Fix build
* [`846baaa1`](NixOS/nixpkgs@846baaa) postgresql11Packages.pgrouting: 3.0.1 -> 3.0.2
* [`2a49db6a`](NixOS/nixpkgs@2a49db6) transmission: apply RFC0042 and harden the service
* [`69eb22e4`](NixOS/nixpkgs@69eb22e) nixos/gitlab: fix module after NixOS/nixpkgs#94454
* [`d525a689`](NixOS/nixpkgs@d525a68) argo: 2.9.4 -> 2.9.5
* [`ca9c2e35`](NixOS/nixpkgs@ca9c2e3) petsc: 3.13.2 -> 3.13.3
* [`5ca7be38`](NixOS/nixpkgs@5ca7be3) .github/workflows/wait-ofborg.yml: 360 -> 540
* [`ed2e74d9`](NixOS/nixpkgs@ed2e74d) ocamlPackages.gmetadom: use patch file extension
* [`32e87e8b`](NixOS/nixpkgs@32e87e8) cproto: use patch file extension
* [`866752ce`](NixOS/nixpkgs@866752c) yasr: use patch file extension
* [`95ec8d2b`](NixOS/nixpkgs@95ec8d2) minikube: 1.12.1 -> 1.12.2
* [`1a83aa11`](NixOS/nixpkgs@1a83aa1) go_1_13: 1.13.14 -> 1.13.15
* [`22594a9d`](NixOS/nixpkgs@22594a9) ocamlformat: 0.14.2 -> 0.15.0
* [`07e74acd`](NixOS/nixpkgs@07e74ac) ocamlformat: add marsam to maintainers
* [`e4f471da`](NixOS/nixpkgs@e4f471d) packet-cli: 0.0.7 -> 0.0.8
* [`3a2d677b`](NixOS/nixpkgs@3a2d677) v4l-utils: fix by patchShebangs on cec-gen.pl
* [`dc5428e7`](NixOS/nixpkgs@dc5428e) packet-cli: alias packet-cli as packet
* [`20032b1e`](NixOS/nixpkgs@20032b1) python37Packages.cfgv: 3.1.0 -> 3.2.0
* [`bfac8637`](NixOS/nixpkgs@bfac863) python27Packages.cli-helpers: 2.0.1 -> 2.1.0
* [`4b5bae26`](NixOS/nixpkgs@4b5bae2) python3Packages.itemloaders: init at 1.0.1
* [`cf5bc04f`](NixOS/nixpkgs@cf5bc04) python3Packages.scrapy: 2.2.1 -> 2.3.0
* [`4d67cf18`](NixOS/nixpkgs@4d67cf1) python27Packages.azure-mgmt-monitor: 0.10.0 -> 0.11.0
* [`c542d216`](NixOS/nixpkgs@c542d21) mockgen: 1.4.3 -> 1.4.4
* [`c5564e17`](NixOS/nixpkgs@c5564e1) jetty: 9.4.29.v20200521 -> 9.4.31.v20200723
* [`002ecd07`](NixOS/nixpkgs@002ecd0) geekbench: 5.2.1 -> 5.2.3
* [`585e00a3`](NixOS/nixpkgs@585e00a) imgproxy: 2.14.0 -> 2.14.1
* [`0ca9e6b2`](NixOS/nixpkgs@0ca9e6b) ghq: 1.1.2 -> 1.1.5
* [`31e67d68`](NixOS/nixpkgs@31e67d6) giada: 0.16.3 -> 0.16.3.1
* [`6e276d36`](NixOS/nixpkgs@6e276d3) dbmate: 1.9.0 -> 1.9.1
* [`30469ea4`](NixOS/nixpkgs@30469ea) grml-zsh-config: 0.17.3 -> 0.17.4
* [`37e6ac04`](NixOS/nixpkgs@37e6ac0) flyctl: 0.0.135 -> 0.0.137
* [`9175f114`](NixOS/nixpkgs@9175f11) fwts: 20.06.01 -> 20.07.00
* [`c337ad41`](NixOS/nixpkgs@c337ad4) cockroachdb: 20.1.2 -> 20.1.3
* [`2cfff96e`](NixOS/nixpkgs@2cfff96) qtwebkit: 5.212-alpha-01-26-2018 -> 5.212.0-alpha4
* [`014d494e`](NixOS/nixpkgs@014d494) faudio: 20.07 -> 20.08
* [`3a49eaa7`](NixOS/nixpkgs@3a49eaa) mnemosyne: 2.7.1 -> 2.7.2
* [`6d85f8d5`](NixOS/nixpkgs@6d85f8d) python27Packages.braintree: 4.2.0 -> 4.3.0
* [`585aa266`](NixOS/nixpkgs@585aa26) gitlab-runner: 13.2.0 -> 13.2.2 (NixOS/nixpkgs#94818)
* [`febbcb62`](NixOS/nixpkgs@febbcb6) nim: 1.2.4 -> 1.2.6
* [`0ca30931`](NixOS/nixpkgs@0ca3093) snapper: 0.8.10 -> 0.8.12
* [`3012ed98`](NixOS/nixpkgs@3012ed9) waybar: 0.9.2 -> 0.9.3
* [`6c2f1e7f`](NixOS/nixpkgs@6c2f1e7) octopus: 9.2 -> 10.0
* [`91da8094`](NixOS/nixpkgs@91da809) thunderbird-bin: 78.1.0 -> 78.1.1
* [`821146db`](NixOS/nixpkgs@821146d) thunderbird: 78.1.0 -> 78.1.1
* [`1e99541b`](NixOS/nixpkgs@1e99541) thunderbird-bin: 68.10.0 -> 68.11.0
* [`997e6315`](NixOS/nixpkgs@997e631) thunderbird: 68.10.0 -> 68.11.0
* [`ba930d86`](NixOS/nixpkgs@ba930d8) nixos/modules: remove trailing whitespace
* [`49ef0fd5`](NixOS/nixpkgs@49ef0fd) rocclr: fix build (no OpenCL library is required)
* [`3f13e1af`](NixOS/nixpkgs@3f13e1a) openmpi: enable C++ bindings
* [`da88c6ee`](NixOS/nixpkgs@da88c6e) nixos/railcar: fix typo
* [`9bae9409`](NixOS/nixpkgs@9bae940) mame: 0.222 -> 0.223 (NixOS/nixpkgs#94853)
* [`2b09ecd1`](NixOS/nixpkgs@2b09ecd) pythonPackages.cot: init at 2.2.1
* [`8af72d55`](NixOS/nixpkgs@8af72d5) osu-lazer: osu-lazer: 2020.801.0 -> 2020.806.0
* [`4efcd73d`](NixOS/nixpkgs@4efcd73) azure-cli: pin cryptography
* [`ce10e04a`](NixOS/nixpkgs@ce10e04) cramfsprogs: init at 1.1
* [`07ea06b1`](NixOS/nixpkgs@07ea06b) cramfsswap: Make binary available
* [`35c702cc`](NixOS/nixpkgs@35c702c) pythonPackages.binwalk: add dependencies
* [`e165f419`](NixOS/nixpkgs@e165f41) LTS Haskell 16.8
* [`9613e64f`](NixOS/nixpkgs@9613e64) hackage2nix: update list of broken packages to fix evaluation errors
* [`7b3dbe3d`](NixOS/nixpkgs@7b3dbe3) ghc-{8.8.3, 8.8.4, 8.10.1}: fix typos
* [`81475fab`](NixOS/nixpkgs@81475fa) hackage-packages.nix: automatic Haskell package set update
* [`a08c537c`](NixOS/nixpkgs@a08c537) ghc-8.10.x: update override for dhall
* [`b38e6cf1`](NixOS/nixpkgs@b38e6cf) ghc-8.10.x: update override for optics-core
* [`f50a34bb`](NixOS/nixpkgs@f50a34b) haskell-lsp-test: update override to the latest version
* [`ed162342`](NixOS/nixpkgs@ed16234) ghcHEAD: 8.11.20200505 -> 8.11.20200731
* [`adcaeef3`](NixOS/nixpkgs@adcaeef) wob: 0.8 -> 0.9
* [`036d9248`](NixOS/nixpkgs@036d924) python3Packages.vega: fix build
* [`c9c957d4`](NixOS/nixpkgs@c9c957d) gopls: 0.4.3 -> 0.4.4 (NixOS/nixpkgs#94888)
* [`2204f74b`](NixOS/nixpkgs@2204f74) hdhomerun-config-gui: init at 20200521
* [`e768fce7`](NixOS/nixpkgs@e768fce) libhdhomerun: add comment about UDP firewall rule
* [`716cd39e`](NixOS/nixpkgs@716cd39) qt-video-wlr: init at 2020-08-03
* [`102864c2`](NixOS/nixpkgs@102864c) pythonPackages.jupyterhub: 1.0.0 -> 1.1.0
* [`b794182c`](NixOS/nixpkgs@b794182) pythonPackages.jupyter-telemetry: init at 0.1.0
* [`86fbad84`](NixOS/nixpkgs@86fbad8) ocamlPackages.lua-ml: 0.9 → 0.9.1
* [`b8dfca14`](NixOS/nixpkgs@b8dfca1) coq_8_12: 8.12+β1 → 8.12.0
* [`99f6fe15`](NixOS/nixpkgs@99f6fe1) pythonPackages.batchspawer: init at 1.0.0
* [`dcde3405`](NixOS/nixpkgs@dcde340) pythonPackages.dockerspawner: init at 0.11.1
* [`5d22e3ce`](NixOS/nixpkgs@5d22e3c) electrum: 3.3.8 -> 4.0.2
* [`18b5eb3f`](NixOS/nixpkgs@18b5eb3) kodi: 18.6 -> 18.8
* [`fa2b8b01`](NixOS/nixpkgs@fa2b8b0) maintainers.0x4A6F: update email
* [`cb8a5e5b`](NixOS/nixpkgs@cb8a5e5) spaceship-prompt: install prompt_spaceship_setup (NixOS/nixpkgs#94604)
* [`6ffc0fd6`](NixOS/nixpkgs@6ffc0fd) python3Packages.pytorch: fix Darwin build by disabling GCD
* [`bc7b404b`](NixOS/nixpkgs@bc7b404) python3Packages.pytorch: fix library names in lib output on Darwin
* [`ddd897c2`](NixOS/nixpkgs@ddd897c) prosody: update community modules to revision 2dcbc01c9931
github-actions bot added a commit to pbogdan/nix-nerd-fonts that referenced this pull request Aug 9, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@8e2b14a...b50ef9af](NixOS/nixpkgs@8e2b14a...b50ef9a)

* [`2e3bc79c`](NixOS/nixpkgs@2e3bc79) linux: 4.14.191 -> 4.14.192
* [`af3de724`](NixOS/nixpkgs@af3de72) linux: 4.19.136 -> 4.19.137
* [`b2ef4872`](NixOS/nixpkgs@b2ef487) linux: 5.4.55 -> 5.4.56
* [`72c9b56c`](NixOS/nixpkgs@72c9b56) linux: 5.7.12 -> 5.7.13
* [`42de8384`](NixOS/nixpkgs@42de838) nodePackages.get-graphql-schema: init at 2.1.2
* [`5c62904a`](NixOS/nixpkgs@5c62904) python3Packages.trezor: 0.12.0 -> 0.12.1
* [`31dde677`](NixOS/nixpkgs@31dde67) gtg: refactor (description, platform, version, requirement, formatting)
* [`3d31c28c`](NixOS/nixpkgs@3d31c28) gnunet: 0.12.2 -> 0.13.1
* [`779e3587`](NixOS/nixpkgs@779e358) gnunet-gtk: 0.12.0 -> 0.13.1
* [`e5b91d92`](NixOS/nixpkgs@e5b91d9) valgrind: try fixing on darwin
* [`3d53c051`](NixOS/nixpkgs@3d53c05) element-web: 1.7.2 -> 1.7.3
* [`6e405a8e`](NixOS/nixpkgs@6e405a8) element-desktop: 1.7.2 -> 1.7.3
* [`5e6fe939`](NixOS/nixpkgs@5e6fe93) epkowa: update hashes (NixOS/nixpkgs#93846)
* [`1f01916d`](NixOS/nixpkgs@1f01916) kitty: remove myself from the maintainer list
* [`ff6c4637`](NixOS/nixpkgs@ff6c463) hiawatha: 10.9 -> 10.11
* [`72ff02c9`](NixOS/nixpkgs@72ff02c) kopia: init at 0.5.2
* [`f9f48250`](NixOS/nixpkgs@f9f4825) nixos/smartd: add option for notifiction email sender
* [`4f5fc729`](NixOS/nixpkgs@4f5fc72) nixos/postgresql: use a standard default value for dataDir
* [`e50e89e1`](NixOS/nixpkgs@e50e89e) nixos/postgresql: conditionally provision data directory with StateDirectory
* [`f42f8a6d`](NixOS/nixpkgs@f42f8a6) nixos/postgresql: replace deprecated usage of PermissionsStartOnly
* [`ab602aa6`](NixOS/nixpkgs@ab602aa) sacc: init at 1.01
* [`cc8d2ba2`](NixOS/nixpkgs@cc8d2ba) wire-desktop: linux 3.18.2925 -> 3.19.2928
* [`787a38bf`](NixOS/nixpkgs@787a38b) wire-desktop: mac 3.18.3728 -> 3.19.3799
* [`744d43f8`](NixOS/nixpkgs@744d43f) ledger: fix build on darwin
* [`8d57f75f`](NixOS/nixpkgs@8d57f75) nixos/smartd: fix description for docbook
* [`7503f280`](NixOS/nixpkgs@7503f28) nixos/systemd: fix TUN networking in LXC containers (NixOS/nixpkgs#81481)
* [`e74a6bcc`](NixOS/nixpkgs@e74a6bc) csxcad: init at unstable-2020-02-08
* [`0e0aba23`](NixOS/nixpkgs@0e0aba2) mailcore2: 0.6.3 -> 0.6.4
* [`98f9f814`](NixOS/nixpkgs@98f9f81) micronaut: 1.3.6 -> 1.3.7
* [`f0913d9a`](NixOS/nixpkgs@f0913d9) minder: 1.9.0 -> 1.9.1
* [`c6117648`](NixOS/nixpkgs@c611764) osu-lazer: 2020.725.0 -> 2020.801.0
* [`b41f79fe`](NixOS/nixpkgs@b41f79f) openxray: 558 -> 730
* [`29bdfffd`](NixOS/nixpkgs@29bdfff) adlplug, opnplug: 1.0.1 -> 1.0.2
* [`eaf6ef8f`](NixOS/nixpkgs@eaf6ef8) ArchiSteamFarm: 4.2.3.3 -> 4.2.3.6
* [`2774941c`](NixOS/nixpkgs@2774941) kmsxx: 2020-02-14 -> 2020-08-04
* [`de0caa8e`](NixOS/nixpkgs@de0caa8) openjk: 2019-11-29 -> 2020-07-03
* [`059675cd`](NixOS/nixpkgs@059675c) opl3bankeditor: 1.5 -> 1.5.1
* [`1ace8444`](NixOS/nixpkgs@1ace844) opn2bankeditor: 1.3-beta -> 1.3
* [`28300eb8`](NixOS/nixpkgs@28300eb) kustomize: 3.8.0 -> 3.8.1
* [`668e9f2c`](NixOS/nixpkgs@668e9f2) ldb: 2.1.4 -> 2.2.0
* [`461e2a61`](NixOS/nixpkgs@461e2a6) runc: 1.0.0-rc91 -> 1.0.0-rc92
* [`3f5258b6`](NixOS/nixpkgs@3f5258b) redshift,redshift-wlr: Fix a file path in postInstall
* [`79415b0b`](NixOS/nixpkgs@79415b0) gammastep: init at 2.0.1
* [`f4a0f554`](NixOS/nixpkgs@f4a0f55) cypress: 4.9.0 -> 4.12.1
* [`dfda85ce`](NixOS/nixpkgs@dfda85c) libmatroska: 1.6.0 -> 1.6.1
* [`3a64e5f7`](NixOS/nixpkgs@3a64e5f) arcanist: 20200127 -> 20200711 (NixOS/nixpkgs#93678)
* [`23511891`](NixOS/nixpkgs@2351189) .github/workflows/*: minor fixes
* [`3f1eb952`](NixOS/nixpkgs@3f1eb95) pahole: 1.16 -> 1.17
* [`deb12d39`](NixOS/nixpkgs@deb12d3) linux/hardened/patches/5.6: remove
* [`0834620b`](NixOS/nixpkgs@0834620) libmysofa: disable CODE_COVERAGE in build
* [`be42a66c`](NixOS/nixpkgs@be42a66) oh-my-zsh: 2020-07-30 -> 2020-08-06
* [`0afe6a28`](NixOS/nixpkgs@0afe6a2) openjdk8: 1.8.0_242 -> 1.8.0_265
* [`0c0cfa7b`](NixOS/nixpkgs@0c0cfa7) mcfly: 0.4.0 -> 0.4.1
* [`d3178c99`](NixOS/nixpkgs@d3178c9) monolith: 2.3.0 -> 2.3.1
* [`1e6f11a2`](NixOS/nixpkgs@1e6f11a) antimicro 2.3 -> antimicroX 3.0
* [`cecc4ce3`](NixOS/nixpkgs@cecc4ce) php.extensions.{mongodb,intl}: switch back to icu64
* [`43093651`](NixOS/nixpkgs@4309365) python3Packages.wxPython_4_0: remove unused dependencies
* [`8b76b920`](NixOS/nixpkgs@8b76b92) python3Packages.wxPython_4_0: enable format hardening
* [`7f15e316`](NixOS/nixpkgs@7f15e31) python3Packages.wxPython_4_0: remove manual wrapPythonPrograms invocation
* [`77c4dae8`](NixOS/nixpkgs@77c4dae) skaffold: 1.12.1 → 1.13.1
* [`4390d9b9`](NixOS/nixpkgs@4390d9b) hyp2mat: init at 0.0.17
* [`d4554905`](NixOS/nixpkgs@d455490) musikcube: 0.92.1 -> 0.93.1
* [`cee4e14b`](NixOS/nixpkgs@cee4e14) nixos/postgresql: fix setup script
* [`a4e77ce9`](NixOS/nixpkgs@a4e77ce) strace: 5.7 -> 5.8
* [`ded6c3db`](NixOS/nixpkgs@ded6c3d) discord: 0.0.10 -> 0.0.11
* [`deb0a6ce`](NixOS/nixpkgs@deb0a6c) gl2ps: make cmake a native build input
* [`5efc22d2`](NixOS/nixpkgs@5efc22d) sfrotz: init at 2.52
* [`76ee4f6d`](NixOS/nixpkgs@76ee4f6) discord-ptb: 0.0.20 -> 0.0.21
* [`9fbbe30a`](NixOS/nixpkgs@9fbbe30) discord-canary: 0.0.105 -> 0.0.106
* [`67712587`](NixOS/nixpkgs@6771258) frotz: 2.44 -> 2.52
* [`048e885b`](NixOS/nixpkgs@048e885) kdeApplications.okteta: 0.26.3 -> 0.26.4
* [`8fe906a8`](NixOS/nixpkgs@8fe906a) doona: init at unstable-2019-03-08
* [`bceadafb`](NixOS/nixpkgs@bceadaf) fritzing: use Qt's mkDerivation (NixOS/nixpkgs#89117)
* [`f3c31c1f`](NixOS/nixpkgs@f3c31c1) marble: switch from qtwebkit to qtwebengine
* [`d55276d7`](NixOS/nixpkgs@d55276d) beets: apply patch to fix incompatibilites with python 3.8
* [`5144ec19`](NixOS/nixpkgs@5144ec1) jetbrains.rider: fix dotnet location
* [`8bb50e72`](NixOS/nixpkgs@8bb50e7) Allow jdiskreport to build on Darwin
* [`7cd05de0`](NixOS/nixpkgs@7cd05de) multitail: add pkg-config dependency, needed for darwin builds
* [`ef3cb36b`](NixOS/nixpkgs@ef3cb36) torsocks: Fix the Darwin build
* [`6a359b23`](NixOS/nixpkgs@6a359b2) libxml2Python: Darwin builds require libintl (better fix)
* [`6dbeed2d`](NixOS/nixpkgs@6dbeed2) factorio: add .desktop file
* [`98e8c6be`](NixOS/nixpkgs@98e8c6b) pdns-recursor: 4.3.2 -> 4.3.3
* [`1365b9ac`](NixOS/nixpkgs@1365b9a) nixos/manual: Fix build
* [`846baaa1`](NixOS/nixpkgs@846baaa) postgresql11Packages.pgrouting: 3.0.1 -> 3.0.2
* [`2a49db6a`](NixOS/nixpkgs@2a49db6) transmission: apply RFC0042 and harden the service
* [`69eb22e4`](NixOS/nixpkgs@69eb22e) nixos/gitlab: fix module after NixOS/nixpkgs#94454
* [`d525a689`](NixOS/nixpkgs@d525a68) argo: 2.9.4 -> 2.9.5
* [`ca9c2e35`](NixOS/nixpkgs@ca9c2e3) petsc: 3.13.2 -> 3.13.3
* [`5ca7be38`](NixOS/nixpkgs@5ca7be3) .github/workflows/wait-ofborg.yml: 360 -> 540
* [`ed2e74d9`](NixOS/nixpkgs@ed2e74d) ocamlPackages.gmetadom: use patch file extension
* [`32e87e8b`](NixOS/nixpkgs@32e87e8) cproto: use patch file extension
* [`866752ce`](NixOS/nixpkgs@866752c) yasr: use patch file extension
* [`95ec8d2b`](NixOS/nixpkgs@95ec8d2) minikube: 1.12.1 -> 1.12.2
* [`1a83aa11`](NixOS/nixpkgs@1a83aa1) go_1_13: 1.13.14 -> 1.13.15
* [`22594a9d`](NixOS/nixpkgs@22594a9) ocamlformat: 0.14.2 -> 0.15.0
* [`07e74acd`](NixOS/nixpkgs@07e74ac) ocamlformat: add marsam to maintainers
* [`e4f471da`](NixOS/nixpkgs@e4f471d) packet-cli: 0.0.7 -> 0.0.8
* [`3a2d677b`](NixOS/nixpkgs@3a2d677) v4l-utils: fix by patchShebangs on cec-gen.pl
* [`dc5428e7`](NixOS/nixpkgs@dc5428e) packet-cli: alias packet-cli as packet
* [`20032b1e`](NixOS/nixpkgs@20032b1) python37Packages.cfgv: 3.1.0 -> 3.2.0
* [`bfac8637`](NixOS/nixpkgs@bfac863) python27Packages.cli-helpers: 2.0.1 -> 2.1.0
* [`4b5bae26`](NixOS/nixpkgs@4b5bae2) python3Packages.itemloaders: init at 1.0.1
* [`cf5bc04f`](NixOS/nixpkgs@cf5bc04) python3Packages.scrapy: 2.2.1 -> 2.3.0
* [`4d67cf18`](NixOS/nixpkgs@4d67cf1) python27Packages.azure-mgmt-monitor: 0.10.0 -> 0.11.0
* [`c542d216`](NixOS/nixpkgs@c542d21) mockgen: 1.4.3 -> 1.4.4
* [`c5564e17`](NixOS/nixpkgs@c5564e1) jetty: 9.4.29.v20200521 -> 9.4.31.v20200723
* [`002ecd07`](NixOS/nixpkgs@002ecd0) geekbench: 5.2.1 -> 5.2.3
* [`585e00a3`](NixOS/nixpkgs@585e00a) imgproxy: 2.14.0 -> 2.14.1
* [`0ca9e6b2`](NixOS/nixpkgs@0ca9e6b) ghq: 1.1.2 -> 1.1.5
* [`31e67d68`](NixOS/nixpkgs@31e67d6) giada: 0.16.3 -> 0.16.3.1
* [`6e276d36`](NixOS/nixpkgs@6e276d3) dbmate: 1.9.0 -> 1.9.1
* [`30469ea4`](NixOS/nixpkgs@30469ea) grml-zsh-config: 0.17.3 -> 0.17.4
* [`37e6ac04`](NixOS/nixpkgs@37e6ac0) flyctl: 0.0.135 -> 0.0.137
* [`9175f114`](NixOS/nixpkgs@9175f11) fwts: 20.06.01 -> 20.07.00
* [`c337ad41`](NixOS/nixpkgs@c337ad4) cockroachdb: 20.1.2 -> 20.1.3
* [`2cfff96e`](NixOS/nixpkgs@2cfff96) qtwebkit: 5.212-alpha-01-26-2018 -> 5.212.0-alpha4
* [`014d494e`](NixOS/nixpkgs@014d494) faudio: 20.07 -> 20.08
* [`3a49eaa7`](NixOS/nixpkgs@3a49eaa) mnemosyne: 2.7.1 -> 2.7.2
* [`6d85f8d5`](NixOS/nixpkgs@6d85f8d) python27Packages.braintree: 4.2.0 -> 4.3.0
* [`585aa266`](NixOS/nixpkgs@585aa26) gitlab-runner: 13.2.0 -> 13.2.2 (NixOS/nixpkgs#94818)
* [`febbcb62`](NixOS/nixpkgs@febbcb6) nim: 1.2.4 -> 1.2.6
* [`0ca30931`](NixOS/nixpkgs@0ca3093) snapper: 0.8.10 -> 0.8.12
* [`3012ed98`](NixOS/nixpkgs@3012ed9) waybar: 0.9.2 -> 0.9.3
* [`6c2f1e7f`](NixOS/nixpkgs@6c2f1e7) octopus: 9.2 -> 10.0
* [`91da8094`](NixOS/nixpkgs@91da809) thunderbird-bin: 78.1.0 -> 78.1.1
* [`821146db`](NixOS/nixpkgs@821146d) thunderbird: 78.1.0 -> 78.1.1
* [`1e99541b`](NixOS/nixpkgs@1e99541) thunderbird-bin: 68.10.0 -> 68.11.0
* [`997e6315`](NixOS/nixpkgs@997e631) thunderbird: 68.10.0 -> 68.11.0
* [`ba930d86`](NixOS/nixpkgs@ba930d8) nixos/modules: remove trailing whitespace
* [`49ef0fd5`](NixOS/nixpkgs@49ef0fd) rocclr: fix build (no OpenCL library is required)
* [`3f13e1af`](NixOS/nixpkgs@3f13e1a) openmpi: enable C++ bindings
* [`da88c6ee`](NixOS/nixpkgs@da88c6e) nixos/railcar: fix typo
* [`9bae9409`](NixOS/nixpkgs@9bae940) mame: 0.222 -> 0.223 (NixOS/nixpkgs#94853)
* [`2b09ecd1`](NixOS/nixpkgs@2b09ecd) pythonPackages.cot: init at 2.2.1
* [`8af72d55`](NixOS/nixpkgs@8af72d5) osu-lazer: osu-lazer: 2020.801.0 -> 2020.806.0
* [`4efcd73d`](NixOS/nixpkgs@4efcd73) azure-cli: pin cryptography
* [`ce10e04a`](NixOS/nixpkgs@ce10e04) cramfsprogs: init at 1.1
* [`07ea06b1`](NixOS/nixpkgs@07ea06b) cramfsswap: Make binary available
* [`35c702cc`](NixOS/nixpkgs@35c702c) pythonPackages.binwalk: add dependencies
* [`e165f419`](NixOS/nixpkgs@e165f41) LTS Haskell 16.8
* [`9613e64f`](NixOS/nixpkgs@9613e64) hackage2nix: update list of broken packages to fix evaluation errors
* [`7b3dbe3d`](NixOS/nixpkgs@7b3dbe3) ghc-{8.8.3, 8.8.4, 8.10.1}: fix typos
* [`81475fab`](NixOS/nixpkgs@81475fa) hackage-packages.nix: automatic Haskell package set update
* [`a08c537c`](NixOS/nixpkgs@a08c537) ghc-8.10.x: update override for dhall
* [`b38e6cf1`](NixOS/nixpkgs@b38e6cf) ghc-8.10.x: update override for optics-core
* [`f50a34bb`](NixOS/nixpkgs@f50a34b) haskell-lsp-test: update override to the latest version
* [`ed162342`](NixOS/nixpkgs@ed16234) ghcHEAD: 8.11.20200505 -> 8.11.20200731
* [`adcaeef3`](NixOS/nixpkgs@adcaeef) wob: 0.8 -> 0.9
* [`036d9248`](NixOS/nixpkgs@036d924) python3Packages.vega: fix build
* [`c9c957d4`](NixOS/nixpkgs@c9c957d) gopls: 0.4.3 -> 0.4.4 (NixOS/nixpkgs#94888)
* [`2204f74b`](NixOS/nixpkgs@2204f74) hdhomerun-config-gui: init at 20200521
* [`e768fce7`](NixOS/nixpkgs@e768fce) libhdhomerun: add comment about UDP firewall rule
* [`716cd39e`](NixOS/nixpkgs@716cd39) qt-video-wlr: init at 2020-08-03
* [`102864c2`](NixOS/nixpkgs@102864c) pythonPackages.jupyterhub: 1.0.0 -> 1.1.0
* [`b794182c`](NixOS/nixpkgs@b794182) pythonPackages.jupyter-telemetry: init at 0.1.0
* [`86fbad84`](NixOS/nixpkgs@86fbad8) ocamlPackages.lua-ml: 0.9 → 0.9.1
* [`b8dfca14`](NixOS/nixpkgs@b8dfca1) coq_8_12: 8.12+β1 → 8.12.0
* [`99f6fe15`](NixOS/nixpkgs@99f6fe1) pythonPackages.batchspawer: init at 1.0.0
* [`dcde3405`](NixOS/nixpkgs@dcde340) pythonPackages.dockerspawner: init at 0.11.1
* [`5d22e3ce`](NixOS/nixpkgs@5d22e3c) electrum: 3.3.8 -> 4.0.2
* [`18b5eb3f`](NixOS/nixpkgs@18b5eb3) kodi: 18.6 -> 18.8
* [`fa2b8b01`](NixOS/nixpkgs@fa2b8b0) maintainers.0x4A6F: update email
* [`cb8a5e5b`](NixOS/nixpkgs@cb8a5e5) spaceship-prompt: install prompt_spaceship_setup (NixOS/nixpkgs#94604)
* [`6ffc0fd6`](NixOS/nixpkgs@6ffc0fd) python3Packages.pytorch: fix Darwin build by disabling GCD
* [`bc7b404b`](NixOS/nixpkgs@bc7b404) python3Packages.pytorch: fix library names in lib output on Darwin
* [`ddd897c2`](NixOS/nixpkgs@ddd897c) prosody: update community modules to revision 2dcbc01c9931
toraritte added a commit to toraritte/nixpkgs that referenced this pull request Aug 22, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

6 participants
You can’t perform that action at this time.