Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tlaplusToolbox: 1.6.0 -> 1.7.0 #92646

Merged
merged 1 commit into from Nov 29, 2020

Conversation

@r-ryantm
Copy link
Contributor

@r-ryantm r-ryantm commented Jul 7, 2020

Semi-automatic update generated by nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/tla-toolbox/versions.

meta.description for tlaplusToolbox is: "IDE for the TLA+ tools"

meta.homepage for tlaplusToolbox is: "http://research.microsoft.com/en-us/um/people/lamport/tla/toolbox.html"

meta.changelog for tlaplusToolbox is: ""

Updates performed
  • Version update
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
3 total rebuild path(s)

1 package rebuild(s)

1 x86_64-linux rebuild(s)
1 i686-linux rebuild(s)
0 x86_64-darwin rebuild(s)
1 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
tlaplusToolbox
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/11w1sv3gri6l6k84xn0csnimyssz724n-tla-toolbox-1.7.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A tlaplusToolbox https://github.com/r-ryantm/nixpkgs/archive/887f1978f62d2e12759e3dff2d5ede9d73b4dbc4.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/11w1sv3gri6l6k84xn0csnimyssz724n-tla-toolbox-1.7.0
ls -la /nix/store/11w1sv3gri6l6k84xn0csnimyssz724n-tla-toolbox-1.7.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

1 package built:
- tlaplusToolbox

Maintainer pings

cc @badi for testing.

@badmutex
Copy link
Contributor

@badmutex badmutex commented Jul 13, 2020

I'm getting an error when trying to build this. Seems like a GTK issue? (running in gnome3). I'll try to test another but here's what I'm seeing for now

$ git rev-parse HEAD
887f1978f62d2e12759e3dff2d5ede9d73b4dbc4

$ nix-build -A tlaplusToolbox
$ ./result/bin/tla-toolbox
...
An error has occurred. See the log file
/home/badi/.tla-toolbox/.metadata/.log.

That log file looks like

!SESSION 2020-07-12 19:23:35.448 -----------------------------------------------
eclipse.buildId=1.7.0
java.version=14.0.1
java.vendor=AdoptOpenJDK
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data /home/badi/.tla-toolbox

!ENTRY org.lamport.tla.toolbox.product.standalone 1 -1 2020-07-12 19:23:37.197
!MESSAGE TLA+ Toolbox started without arguments.

!ENTRY org.eclipse.osgi 4 0 2020-07-12 19:23:37.234
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: 'void org.eclipse.swt.internal.gtk.OS._cachejvmptr()'
        at org.eclipse.swt.internal.gtk.OS._cachejvmptr(Native Method)
        at org.eclipse.swt.internal.gtk.OS.cachejvmptr(OS.java:494)
        at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:93)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:209)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:155)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:161)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:735)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:162)
        at org.lamport.tla.toolbox.Application.start(Application.java:139)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1468)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1441)

!ENTRY org.eclipse.equinox.http.jetty 4 0 2020-07-12 19:23:37.369
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.equinox.http.jetty.internal.Activator.stop() of bundle org.eclipse.equinox.http.jetty.

<SNIP>

Root exception:
java.lang.InterruptedException

<SNIP>

@SuperSandro2000
Copy link
Member

@SuperSandro2000 SuperSandro2000 commented Nov 29, 2020

Result of nixpkgs-review pr 92646 run on x86_64-linux 1

1 package built:
  • tlaplusToolbox

@SuperSandro2000 SuperSandro2000 merged commit 4dc26ca into NixOS:master Nov 29, 2020
17 checks passed
@r-ryantm r-ryantm deleted the auto-update/tla-toolbox branch Nov 29, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants