Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Purity checking should accept $TMP and not just /tmp #93560

Merged
merged 1 commit into from Sep 4, 2020

Conversation

@twhitehead
Copy link
Contributor

@twhitehead twhitehead commented Jul 20, 2020

Motivation for this change

The badPath routine used by the various compiler paths to check purity is hard coded to accept /tmp. This can cause issues with nix-shell as it overrides /tmp by setting the various temporary variables (TMP,TEMP,TMPDIR, and TEMPDIR) to /run/user/$UID.

Normally this is masked by the fact NIX_BUILD_TOP is also set to /run/user/$UID so the usage of temporary storage by the tools gets covered under NIX_BUILD_TOP. In circumstances when the TMP and NIX_BUILD_TOP don't coincide though, things fall apart.

Here is a small example that demonstrates this

$ nix-shell -A hello
$ export NIX_ENFORCE_PURITY=1
$ echo $NIX_BUILD_TOP
/run/user/1000
$ echo $TMP
/run/user/1000
$ export NIX_BUILD_TOP=/tmp
$ cd $NIX_BUILD_TOP
$ eval "${unpackPhase:-unpackPhase}"
$ cd hello-2.10
$ eval "${patchPhase:-patchPhase}"
$ eval "${configurePhase:-configurePhase}"
...
configure: error: in `/tmp/hello-2.10':
configure: error: C compiler cannot create executables
See `config.log' for more details

Another example is issue #91431.

Things done

I have verified the above GNU helloworld (see above) compiles correctly in the above example once this change is made. This is actually quite extensive as change the badPath routine does result in a fairly significant rebuild of dependencies.

  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
@FRidh
Copy link
Member

@FRidh FRidh commented Aug 15, 2020

@Ericson2314 @matthewbauer could any of you review this?

@FRidh FRidh changed the base branch from master to staging Aug 15, 2020
@FRidh FRidh added this to the 20.09 milestone Aug 15, 2020
"${p:0:${#NIX_STORE}}" != "$NIX_STORE" -a \
"${p:0:4}" != "/tmp" -a \
"${p:0:${#NIX_BUILD_TOP}}" != "$NIX_BUILD_TOP"
"${p#${NIX_STORE}}" = "$p" -a \
"${p#${TMP:-/tmp}}" = "$p" -a \
"${p#${NIX_BUILD_TOP}}" = "$p"
Comment on lines -72 to +74

This comment has been minimized.

@jtojnar

jtojnar Aug 16, 2020
Contributor

This looks alright but feels harder to reason about. Compare:

  • beginning of p is not x
  • p with x removed from the start (if there) is still p

Also had to consult https://guide.bash.academy/expansions/?=Parameter_Expansion#h2.2.2 for the latter.

This comment has been minimized.

@twhitehead

twhitehead Aug 16, 2020
Author Contributor

I tried quite a few things and spent some time in the man page until I finally managed to come up with that. The really hard part was trying to come up with something that would let you default TMP to /tmp. 😁

Essentially we use the strip leading prefix of p expansion (${p#<prefix to try and strip>}} with each of our path prefixes we want the check

  • if it manages to strip a leading prefix (string is altered) then we had a leading prefix match and the path is okay
  • if it doesn't manage to strip a leading prefix (string isn't altered) then we didn't have a leading prefix match and the path is bad

This is quite flexible as the <prefix to try and strip> is itself expanded, so get to use all the power of expansion again when making our prefix to try and strip (in this case, the critical one being we can default TMP).

Staging automation moved this from Needs review to Ready Aug 17, 2020
@FRidh FRidh merged commit fb777be into NixOS:staging Sep 4, 2020
14 checks passed
14 checks passed
Evaluation Performance Report Evaluator Performance Report
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-darwin nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./pkgs/t
Details
grahamcofborg-eval-lib-tests nix-build --arg pkgs import ./. {} ./lib/tests/release.nix
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./nixos/
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./nixos/
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./nixos/
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="1465e2a"; rev="1465e2ac16809387fd4a4483dc99f0a717bed315"; } ./pkgs/t
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
Staging automation moved this from Ready to Done Sep 4, 2020
@pbogdan pbogdan mentioned this pull request Sep 6, 2020
0 of 10 tasks complete
FRidh added a commit to FRidh/nixpkgs that referenced this pull request Sep 6, 2020
Temporary fix. We definitely do not want to have two separate
implementations.
FRidh added a commit that referenced this pull request Sep 6, 2020
Temporary fix. We definitely do not want to have two separate
implementations.
FRidh added a commit that referenced this pull request Sep 6, 2020
Revert the hack and the original faulty commit.

This reverts commit 48264ee.

Revert "Purity checking should accept $TMP and not just /tmp"

This reverts commit fb777be.
@vcunat
Copy link
Member

@vcunat vcunat commented Sep 7, 2020

This has some unpleasant consequences (in addition to breaking Darwin stdenv). In usual sandboxed builds we have TMP=/build, i.e. this check started firing by this PR. Various configure-like scripts want to detect stuff by compiling temporary files and they started now getting errors like impure path '/build/foo' used in link. Previously we "only" had checks that /build is not referenced in the final output, which really fit the use cases much better.

So far I don't know how frequent the Linux regressions are; most of them should be among this list; I just worked around the libbpf regression and I glimpsed e.g. dmd. @worldofpeace: I'd probably prefer not to have this PR at all in 20.09 (which is about to start stabilization now), as it will be adding even more stuff to fix before the approaching release (and ATM I'm not yet really convinced that the PR is a good idea).

@pbogdan
Copy link
Member

@pbogdan pbogdan commented Sep 7, 2020

Just to add to what @vcunat said WRT. Darwin failure in case it helps (and before I forget). The failure was happening during cmake build, I added some simple debugging to the cc-wrapper which produced the following:

SKIPPING BAD PATH -I/tmp/nix-build-cmake-boot-3.18.2.drv-0/cmake-3.18.2/Utilities/cmzlib
NIX_BUILD_TOP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0
TMP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0
SKIPPING BAD PATH -I/tmp/nix-build-cmake-boot-3.18.2.drv-0/cmake-3.18.2/Utilities/cmzlib/..
NIX_BUILD_TOP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0                                                                                      
TMP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0                                                                                                
SKIPPING BAD PATH -I/tmp/nix-build-cmake-boot-3.18.2.drv-0/cmake-3.18.2/Source
NIX_BUILD_TOP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0
TMP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0
SKIPPING BAD PATH -I/tmp/nix-build-cmake-boot-3.18.2.drv-0/cmake-3.18.2/Source/kwsys
NIX_BUILD_TOP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0
TMP: /private/tmp/nix-build-cmake-boot-3.18.2.drv-0

As I understand it $TMP (and other temp-related variables) are set to /private/tmp whereas cmake somehow generates the -I flags pointing to /tmp. However on Darwin the latter is simply a symlink to /private/tmp so the string (prefix?) comparison rejects them even though technically they should be allowed, and cmake build can't find some of its headers.

(As a side note it would perhaps be nice if there was some sort of indication a path was filtered out in this way).

@worldofpeace
Copy link
Member

@worldofpeace worldofpeace commented Sep 7, 2020

This has some unpleasant consequences (in addition to breaking Darwin stdenv). In usual sandboxed builds we have TMP=/build, i.e. this check started firing by this PR. Various configure-like scripts want to detect stuff by compiling temporary files and they started now getting errors like impure path '/build/foo' used in link. Previously we "only" had checks that /build is not referenced in the final output, which really fit the use cases much better.

So far I don't know how frequent the Linux regressions are; most of them should be among this list; I just worked around the libbpf regression and I glimpsed e.g. dmd. @worldofpeace: I'd probably prefer not to have this PR at all in 20.09 (which is about to start stabilization now), as it will be adding even more stuff to fix before the approaching release (and ATM I'm not yet really convinced that the PR is a good idea).

Sounds correct to me. Has this been already reverted?

@twhitehead
Copy link
Contributor Author

@twhitehead twhitehead commented Sep 7, 2020

If I'm understanding correctly, the issue is that /tmp is still being used in many places despite $TMP being set to a non-/tmp path. As another example from the hydra list

https://hydra.nixos.org/build/126586507/nixlog/1

Compiling ncftpget:                                                   [ERROR]  
  gcc -D_REENTRANT -O2 -W -Wall -Wno-format-y2k -fstack-protector-all -D_FORTIF
  Y_SOURCE=2 -DLINUX=59116 -DLINUX_GLIBC=23100 -Dsh_util -DO_S="linux-x86_64-gl
  ibc2.31" -DSYSCONFDIR="/nix/store/aaakh5iza6n1b0p246gi6w5mkx6y561b-ncftp-3.2.
  6/etc" -DHAVE_CONFIG_H -DLINUX=59116 -DLINUX_GLIBC=23100 -I/build/ncftp-3.2.6
   -I../libncftp -I../Strn -I../sio -I/build/ncftp-3.2.6 -I/build/ncftp-3.2.6/l
  ibncftp -I/build/ncftp-3.2.6/sio -I/build/ncftp-3.2.6/Strn gpshare.o bookmark
  .o preffw.o spoolutil.o util.o gl_getline.o version.o ncftpget.c -o ../bin/nc
  ftpget -L../libncftp -L../Strn -L../sio -L/build/ncftp-3.2.6/libncftp -L/buil
  d/ncftp-3.2.6/sio -L/build/ncftp-3.2.6/Strn -lncftp -lStrn -lsio -lresolv
  impure path `/tmp/ccAJpfhO.o' used in link

Perhaps a better patch then would have not been to replace /tmp with $TMP, but rather to accept both both /tmp and $TMP (and presumable $TEMP and $TMPDIR too, just to cover them all)? This would be easy to do.

@vcunat
Copy link
Member

@vcunat vcunat commented Sep 7, 2020

No, in the Linux cases I saw, $TMP was used correctly and linking stuff inside $TMP/ got newly refused (in the "usual" case of TMP=/build).

@vcunat
Copy link
Member

@vcunat vcunat commented Sep 7, 2020

@worldofpeace: looking at the PR-pings above, on master it's "reverted for Darwin", as a quick-fix measure, and on staging the revert is finished (e560459). Touching the file causes rebuild of everything...

@FRidh
Copy link
Member

@FRidh FRidh commented Sep 7, 2020

and on staging the revert is finished (e560459)

as well as 5ceea57.

@twhitehead
Copy link
Contributor Author

@twhitehead twhitehead commented Sep 7, 2020

Hummm. That is very odd as the purpose of the patch was to honour $TMP and not to ignore it. If you look at the original code

    # Otherwise, the path should refer to the store or some temporary
    # directory (including the build directory).
    test \
        "$p" != "/dev/null" -a \
        "${p:0:${#NIX_STORE}}" != "$NIX_STORE" -a \
        "${p:0:4}" != "/tmp" -a \
        "${p:0:${#NIX_BUILD_TOP}}" != "$NIX_BUILD_TOP"

it clearly entirely ignores the setting of $TMP and just checks for /tmp. The only reason it wasn't blowing things up in most cases was that $NIX_BUILD_TOP happened to also be set the same as $TMP.

@vcunat do you have an example package where the problem was that the patch wasn't honouring $TMP that I can dig into and see if I can figure out what went wrong? Thanks!

github-actions bot added a commit to pbogdan/tag that referenced this pull request Sep 8, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@c59ea8b...a3173612](NixOS/nixpkgs@c59ea8b...a317361)

* [`9a21fc26`](NixOS/nixpkgs@9a21fc2) lightburn: 0.9.15 -> 0.9.16
* [`813be97d`](NixOS/nixpkgs@813be97) lyra: 1.4 -> 1.5.1
* [`f36c47f2`](NixOS/nixpkgs@f36c47f) miller: 5.9.0 -> 5.9.1
* [`4441733e`](NixOS/nixpkgs@4441733) minikube: 1.12.3 -> 1.13.0
* [`5664601f`](NixOS/nixpkgs@5664601) ocamlPackages.fdkaac: init at 0.3.2
* [`0a8c2f8c`](NixOS/nixpkgs@0a8c2f8) nushell: 0.18.1 -> 0.19.0
* [`5811b6c1`](NixOS/nixpkgs@5811b6c) chromiumDev: 86.0.4238.0 -> 86.0.4240.8
* [`bd9c787d`](NixOS/nixpkgs@bd9c787) openlibm: 0.7.0 -> 0.7.1
* [`de69b705`](NixOS/nixpkgs@de69b70) chromium: replace update.nix with Python impl
* [`5da66561`](NixOS/nixpkgs@5da6656) chromiumDev: 86.0.4240.8 -> 87.0.4252.0
* [`6c92847e`](NixOS/nixpkgs@6c92847) chromiumBeta: 85.0.4183.83 -> 86.0.4240.22
* [`611258f0`](NixOS/nixpkgs@611258f) document nix-env bug relating to multiple output installation
* [`e6f4f3a3`](NixOS/nixpkgs@e6f4f3a) maintainers: add j0hax
* [`452e5b93`](NixOS/nixpkgs@452e5b9) octoprint.python.pkgs.displaylayerprogress: init at 1.23.2
* [`4746456a`](NixOS/nixpkgs@4746456) octoprint.python.pkgs.octoprint-dashboard: init at 1.13.0
* [`c7a503bf`](NixOS/nixpkgs@c7a503b) Revert "chromiumDev: 86.0.4240.8 -> 87.0.4252.0"
* [`717d3779`](NixOS/nixpkgs@717d377) oppai-ng: 3.2.3 -> 3.3.0
* [`c763b498`](NixOS/nixpkgs@c763b49) mdcat: 0.20.0 -> 0.21.1
* [`0cf63fde`](NixOS/nixpkgs@0cf63fd) deno: 1.3.2 -> 1.3.3
* [`2e91a108`](NixOS/nixpkgs@2e91a10) osu-lazer: 2020.820.0 -> 2020.903.0
* [`1c368b0f`](NixOS/nixpkgs@1c368b0) picard-tools: 2.23.3 -> 2.23.4
* [`98d6b55f`](NixOS/nixpkgs@98d6b55) nixos/testing: remove remaining coverage-data logic
* [`86a1a0a6`](NixOS/nixpkgs@86a1a0a) mautrix-whatsapp: 0.1.3 -> 0.1.4
* [`2f4c7093`](NixOS/nixpkgs@2f4c709) gitea: 1.12.3 -> 1.12.4
* [`4e21edf9`](NixOS/nixpkgs@4e21edf) pspg: 3.1.2 -> 3.1.3
* [`33b860ec`](NixOS/nixpkgs@33b860e) tiledb: 1.7.7 -> 2.0.7
* [`f4753023`](NixOS/nixpkgs@f475302) rink: 0.5.0 -> 0.5.1
* [`bfa4aa15`](NixOS/nixpkgs@bfa4aa1) rssguard: 3.7.0 -> 3.7.2
* [`438d5b6b`](NixOS/nixpkgs@438d5b6) pythonPackages.tiledb: 0.5.6 -> 0.6.6
* [`6eea6447`](NixOS/nixpkgs@6eea644) nixos/tests/installer swraid: increase partition size
* [`1649ef9e`](NixOS/nixpkgs@1649ef9) sensu-go-backend: 5.21.1 -> 5.21.2
* [`e5b09183`](NixOS/nixpkgs@e5b0918) iso-flags: init at unstable-18012020
* [`430fe6c7`](NixOS/nixpkgs@430fe6c) cinnamon: add iso-flag* packages like in upstream
* [`ad59f20d`](NixOS/nixpkgs@ad59f20) cinnamon.cinnamon-screensaver: init at 4.4.0
* [`302c8a46`](NixOS/nixpkgs@302c8a4) cinnamon.cinnamon-common: init at 4.4.1
* [`ce2895da`](NixOS/nixpkgs@ce2895d) cinnamon.cinnamon-common.libcroco: init at 0.6.13
* [`0555dc1c`](NixOS/nixpkgs@0555dc1) shattered-pixel-dungeon: 0.8.2b -> 0.8.2d
* [`f7127a35`](NixOS/nixpkgs@f7127a3) sickgear: 0.21.36 -> 0.21.42
* [`1b197ce0`](NixOS/nixpkgs@1b197ce) wineUnstable: 5.14 -> 5.15
* [`e049f91e`](NixOS/nixpkgs@e049f91) wineUnstable: 5.15 -> 5.16
* [`bf9112cd`](NixOS/nixpkgs@bf9112c) skaffold: 1.13.2 -> 1.14.0
* [`cc797c4a`](NixOS/nixpkgs@cc797c4) star: 2.7.4a -> 2.7.5c
* [`f30e80ba`](NixOS/nixpkgs@f30e80b) hackage-packages.nix: fix eval pandoc_2_10_1 on hydra
* [`edeece0a`](NixOS/nixpkgs@edeece0) libpqxx: enable for darwin
* [`436b3a43`](NixOS/nixpkgs@436b3a4) terraform-ls: 0.6.1 -> 0.7.0
* [`a133475d`](NixOS/nixpkgs@a133475) linux_zen: 5.8.1 -> 5.8.7
* [`7a0eb473`](NixOS/nixpkgs@7a0eb47) gitkraken: 7.2.0 -> 7.3.0
* [`d977d765`](NixOS/nixpkgs@d977d76) postman: 7.30.1 -> 7.31.1
* [`854a229a`](NixOS/nixpkgs@854a229) nixos/terraria: allow dataDir to be configured (NixOS/nixpkgs#89033)
* [`6668937f`](NixOS/nixpkgs@6668937) nushell: enable for aarch64
* [`9323a3f3`](NixOS/nixpkgs@9323a3f) appimageTools: use buildFHSUserEnvBubblewrap
* [`328e30e1`](NixOS/nixpkgs@328e30e) zigbee2mqtt: 1.14.3 -> 1.14.4
* [`22a9d9aa`](NixOS/nixpkgs@22a9d9a) tiledb: enable for all unix, add tweaks for darwin & non-x86 systems
* [`ac05da41`](NixOS/nixpkgs@ac05da4) pantheon.elementary-dock: fix double includedir in .pc
* [`bc57f6d2`](NixOS/nixpkgs@bc57f6d) sndio: 1.6.0 -> 1.7.0
* [`96bd235e`](NixOS/nixpkgs@96bd235) sndio: fix up for Darwin
* [`fdefec4f`](NixOS/nixpkgs@fdefec4) vcsi: init at 7.0.12
* [`34b5c5c1`](NixOS/nixpkgs@34b5c5c) nixos/acme: More features and fixes
* [`f0cb5c6a`](NixOS/nixpkgs@f0cb5c6) Revert "nixos/fontconfig: fix 50-user.conf handling"
* [`92e990a8`](NixOS/nixpkgs@92e990a) vimPlugins: Inherit meta from node plugins
* [`de3a4a05`](NixOS/nixpkgs@de3a4a0) pdfcpu: 0.3.4 -> 0.3.5
* [`82eb3cd4`](NixOS/nixpkgs@82eb3cd) ocamlPackages.srt: init at 0.1.1
* [`e2d02e46`](NixOS/nixpkgs@e2d02e4) youtube-dl: 2020.07.28 -> 2020.09.06
* [`44f439fc`](NixOS/nixpkgs@44f439f) atlassian-jira: 8.10.0 -> 8.12.0
* [`abedb5c4`](NixOS/nixpkgs@abedb5c) Move KnightOS packages into folder
* [`b23940e5`](NixOS/nixpkgs@b23940e) texinfo: revert to version 6.5 on Darwin
* [`1488e7d1`](NixOS/nixpkgs@1488e7d) tbb: fix library install name on macOS
* [`5998a16b`](NixOS/nixpkgs@5998a16) epson-escpr2: 1.1.15 -> 1.1.17
* [`6a0149df`](NixOS/nixpkgs@6a0149d) vorta: 0.6.26 -> 0.7.0
* [`fd5f28af`](NixOS/nixpkgs@fd5f28a) vgrep: init at 2.4.0
* [`e60ff5a3`](NixOS/nixpkgs@e60ff5a) python3Packages.libarcus: 4.6.1 -> 4.7.1
* [`497ff43d`](NixOS/nixpkgs@497ff43) python3Packages.libsavitar: 4.6.1 -> 4.7.1
* [`daa77cc7`](NixOS/nixpkgs@daa77cc) python3Packages.uranium: 4.6.1 -> 4.7.1
* [`7a0ef553`](NixOS/nixpkgs@7a0ef55) curaengine: 4.6.1 -> 4.7.1
* [`6b4f9a16`](NixOS/nixpkgs@6b4f9a1) cura: 4.6.1 -> 4.7.1
* [`6841659b`](NixOS/nixpkgs@6841659) curaPlugins.octoprint: 3.5.12 -> 3.5.16
* [`dadab534`](NixOS/nixpkgs@dadab53) yafaray-core: 3.4.4 -> 3.5.0
* [`a3bcf4f7`](NixOS/nixpkgs@a3bcf4f) tippecanoe: 1.35.0 -> 1.36.0
* [`e523a709`](NixOS/nixpkgs@e523a70) yafaray-core: restrict to x86_64-linux
* [`2927a19b`](NixOS/nixpkgs@2927a19) chromium: Unblock nixos-unstable by using the correct argument to fetchurl
* [`9df09227`](NixOS/nixpkgs@9df0922) marwaita: 7.5.1 -> 7.6.1
* [`50285e24`](NixOS/nixpkgs@50285e2) fractal: add gtk support to gstreamer
* [`ebd2e632`](NixOS/nixpkgs@ebd2e63) gns3-{gui,server}: 2.2.12 -> 2.2.13
* [`08eb704b`](NixOS/nixpkgs@08eb704) utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels
* [`92cff610`](NixOS/nixpkgs@92cff61) pgformatter: 4.3 -> 4.4 (NixOS/nixpkgs#96920)
* [`1876163f`](NixOS/nixpkgs@1876163) bazel-kazel: 0.0.12 -> 0.1.0 (NixOS/nixpkgs#97074)
* [`f06b103e`](NixOS/nixpkgs@f06b103) eventstat: 0.04.09 -> 0.04.10
* [`2c58c24e`](NixOS/nixpkgs@2c58c24) wimlib: 1.13.1 -> 1.13.2
* [`6c2059b3`](NixOS/nixpkgs@6c2059b) qwt6_qt4: 6.1.4 -> 6.1.5
* [`f151fd87`](NixOS/nixpkgs@f151fd8) sysvinit: 2.96 -> 2.97
* [`1311343c`](NixOS/nixpkgs@1311343) fx_cast_bridge: 0.0.6 -> 0.0.7
* [`c39f775f`](NixOS/nixpkgs@c39f775) icingaweb2: 2.8.0 -> 2.8.1
* [`cd435ce7`](NixOS/nixpkgs@cd435ce) opencl-clhpp: 2.0.11 -> 2.0.12
* [`a5121f73`](NixOS/nixpkgs@a5121f7) catch2: 2.12.2 -> 2.12.3
* [`d4f6c94d`](NixOS/nixpkgs@d4f6c94) ocamlPackages.labltk: init at 8.06.9 for OCaml 4.11
* [`7dce8e21`](NixOS/nixpkgs@7dce8e2) python27Packages.pydub: 0.24.0 -> 0.24.1
* [`e6cbcc2a`](NixOS/nixpkgs@e6cbcc2) python3Packages.scapy: 2.4.3 -> 2.4.4 (NixOS/nixpkgs#97215)
* [`02590c96`](NixOS/nixpkgs@02590c9) nixos/qemu-vm: support nix run
* [`a8d6e4b7`](NixOS/nixpkgs@a8d6e4b) hping: 20051105 -> 2014-12-26 (NixOS/nixpkgs#94683)
* [`1835fc45`](NixOS/nixpkgs@1835fc4) services.openssh: add banner
* [`cac53395`](NixOS/nixpkgs@cac5339) nixos/doc/borgbackup: correct install instructions for `vorta`
* [`0f099965`](NixOS/nixpkgs@0f09996) keepalived: 2.0.20 -> 2.1.3
* [`e976a70f`](NixOS/nixpkgs@e976a70) awscli2: 2.0.36 -> 2.0.46 (NixOS/nixpkgs#97304)
* [`22e61f43`](NixOS/nixpkgs@22e61f4) buildah: 1.15.2 -> 1.16.0
* [`60f27064`](NixOS/nixpkgs@60f2706) gammastep: 2.0.1 -> 2.0.2 (NixOS/nixpkgs#97290)
* [`1fa610bd`](NixOS/nixpkgs@1fa610b) chromium: Prefix $PATH with xdg_utils (NixOS/nixpkgs#96922)
* [`1cd9dafc`](NixOS/nixpkgs@1cd9daf) ott: 0.30 -> 0.31
* [`0b64a703`](NixOS/nixpkgs@0b64a70) guile-sdl2: 0.4.0 -> 0.5.0
* [`dd272777`](NixOS/nixpkgs@dd27277) Revert "nixos/qemu-vm: support nix run"
* [`8d5d41e7`](NixOS/nixpkgs@8d5d41e) kubernetes-helm: 3.3.0 -> 3.3.1 (NixOS/nixpkgs#97147)
* [`6ed06dca`](NixOS/nixpkgs@6ed06dc) terragrunt: 0.23.33 -> 0.23.40
* [`2ff86abc`](NixOS/nixpkgs@2ff86ab) topgrade: 5.5.0 -> 5.7.0
* [`3690d1d7`](NixOS/nixpkgs@3690d1d) calibre: build with py3 by default
* [`4b25b12f`](NixOS/nixpkgs@4b25b12) calibre: 4.22.0 -> 4.23.0
* [`2497bf42`](NixOS/nixpkgs@2497bf4) calibre: remove self reference
* [`02e6ed4b`](NixOS/nixpkgs@02e6ed4) scc: 2.12.0 -> 2.13.0
* [`1936b11f`](NixOS/nixpkgs@1936b11) utils.bash: also "fix" cc-wrapper and pkg-config-wrapper
* [`6f712077`](NixOS/nixpkgs@6f71207) ugrep: 2.5.3 -> 2.5.5
* [`b6efe9d6`](NixOS/nixpkgs@b6efe9d) vale: 2.3.3 -> 2.3.4
* [`8532b0ae`](NixOS/nixpkgs@8532b0a) vultr-cli: 0.3.2 -> 0.4.0
* [`4dd118b4`](NixOS/nixpkgs@4dd118b) timescale-prometheus: 0.1.0-beta.2 -> 0.1.0-beta.4
* [`2a82f71b`](NixOS/nixpkgs@2a82f71) proverif: 2.01 → 2.02pl1
* [`5d510968`](NixOS/nixpkgs@5d51096) nixos/prometheus-exporters: fix default firewall filter
* [`7b537f99`](NixOS/nixpkgs@7b537f9) exa: remove maintainer
* [`3487a7b8`](NixOS/nixpkgs@3487a7b) exodus: 20.1.30 -> 20.8.28
* [`1d2c243d`](NixOS/nixpkgs@1d2c243) dune_2: fix hash
* [`d7fa5b6a`](NixOS/nixpkgs@d7fa5b6) liferea: 1.12.6 → 1.12.9
* [`3c0e3697`](NixOS/nixpkgs@3c0e369) liferea: remove myself from meta.maintainers
* [`bd954783`](NixOS/nixpkgs@bd95478) liquidsoap: 1.3.4 → 1.4.2
* [`85afe9cb`](NixOS/nixpkgs@85afe9c) nixos/tests/installer: increase RAM in the VM
* [`a3173612`](NixOS/nixpkgs@a317361) nixos/lorri: add package option
github-actions bot added a commit to pbogdan/nix-hie that referenced this pull request Sep 8, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@c59ea8b...a3173612](NixOS/nixpkgs@c59ea8b...a317361)

* [`9a21fc26`](NixOS/nixpkgs@9a21fc2) lightburn: 0.9.15 -> 0.9.16
* [`813be97d`](NixOS/nixpkgs@813be97) lyra: 1.4 -> 1.5.1
* [`f36c47f2`](NixOS/nixpkgs@f36c47f) miller: 5.9.0 -> 5.9.1
* [`4441733e`](NixOS/nixpkgs@4441733) minikube: 1.12.3 -> 1.13.0
* [`5664601f`](NixOS/nixpkgs@5664601) ocamlPackages.fdkaac: init at 0.3.2
* [`0a8c2f8c`](NixOS/nixpkgs@0a8c2f8) nushell: 0.18.1 -> 0.19.0
* [`5811b6c1`](NixOS/nixpkgs@5811b6c) chromiumDev: 86.0.4238.0 -> 86.0.4240.8
* [`bd9c787d`](NixOS/nixpkgs@bd9c787) openlibm: 0.7.0 -> 0.7.1
* [`de69b705`](NixOS/nixpkgs@de69b70) chromium: replace update.nix with Python impl
* [`5da66561`](NixOS/nixpkgs@5da6656) chromiumDev: 86.0.4240.8 -> 87.0.4252.0
* [`6c92847e`](NixOS/nixpkgs@6c92847) chromiumBeta: 85.0.4183.83 -> 86.0.4240.22
* [`611258f0`](NixOS/nixpkgs@611258f) document nix-env bug relating to multiple output installation
* [`e6f4f3a3`](NixOS/nixpkgs@e6f4f3a) maintainers: add j0hax
* [`452e5b93`](NixOS/nixpkgs@452e5b9) octoprint.python.pkgs.displaylayerprogress: init at 1.23.2
* [`4746456a`](NixOS/nixpkgs@4746456) octoprint.python.pkgs.octoprint-dashboard: init at 1.13.0
* [`c7a503bf`](NixOS/nixpkgs@c7a503b) Revert "chromiumDev: 86.0.4240.8 -> 87.0.4252.0"
* [`717d3779`](NixOS/nixpkgs@717d377) oppai-ng: 3.2.3 -> 3.3.0
* [`c763b498`](NixOS/nixpkgs@c763b49) mdcat: 0.20.0 -> 0.21.1
* [`0cf63fde`](NixOS/nixpkgs@0cf63fd) deno: 1.3.2 -> 1.3.3
* [`2e91a108`](NixOS/nixpkgs@2e91a10) osu-lazer: 2020.820.0 -> 2020.903.0
* [`1c368b0f`](NixOS/nixpkgs@1c368b0) picard-tools: 2.23.3 -> 2.23.4
* [`98d6b55f`](NixOS/nixpkgs@98d6b55) nixos/testing: remove remaining coverage-data logic
* [`86a1a0a6`](NixOS/nixpkgs@86a1a0a) mautrix-whatsapp: 0.1.3 -> 0.1.4
* [`2f4c7093`](NixOS/nixpkgs@2f4c709) gitea: 1.12.3 -> 1.12.4
* [`4e21edf9`](NixOS/nixpkgs@4e21edf) pspg: 3.1.2 -> 3.1.3
* [`33b860ec`](NixOS/nixpkgs@33b860e) tiledb: 1.7.7 -> 2.0.7
* [`f4753023`](NixOS/nixpkgs@f475302) rink: 0.5.0 -> 0.5.1
* [`bfa4aa15`](NixOS/nixpkgs@bfa4aa1) rssguard: 3.7.0 -> 3.7.2
* [`438d5b6b`](NixOS/nixpkgs@438d5b6) pythonPackages.tiledb: 0.5.6 -> 0.6.6
* [`6eea6447`](NixOS/nixpkgs@6eea644) nixos/tests/installer swraid: increase partition size
* [`1649ef9e`](NixOS/nixpkgs@1649ef9) sensu-go-backend: 5.21.1 -> 5.21.2
* [`e5b09183`](NixOS/nixpkgs@e5b0918) iso-flags: init at unstable-18012020
* [`430fe6c7`](NixOS/nixpkgs@430fe6c) cinnamon: add iso-flag* packages like in upstream
* [`ad59f20d`](NixOS/nixpkgs@ad59f20) cinnamon.cinnamon-screensaver: init at 4.4.0
* [`302c8a46`](NixOS/nixpkgs@302c8a4) cinnamon.cinnamon-common: init at 4.4.1
* [`ce2895da`](NixOS/nixpkgs@ce2895d) cinnamon.cinnamon-common.libcroco: init at 0.6.13
* [`0555dc1c`](NixOS/nixpkgs@0555dc1) shattered-pixel-dungeon: 0.8.2b -> 0.8.2d
* [`f7127a35`](NixOS/nixpkgs@f7127a3) sickgear: 0.21.36 -> 0.21.42
* [`1b197ce0`](NixOS/nixpkgs@1b197ce) wineUnstable: 5.14 -> 5.15
* [`e049f91e`](NixOS/nixpkgs@e049f91) wineUnstable: 5.15 -> 5.16
* [`bf9112cd`](NixOS/nixpkgs@bf9112c) skaffold: 1.13.2 -> 1.14.0
* [`cc797c4a`](NixOS/nixpkgs@cc797c4) star: 2.7.4a -> 2.7.5c
* [`f30e80ba`](NixOS/nixpkgs@f30e80b) hackage-packages.nix: fix eval pandoc_2_10_1 on hydra
* [`edeece0a`](NixOS/nixpkgs@edeece0) libpqxx: enable for darwin
* [`436b3a43`](NixOS/nixpkgs@436b3a4) terraform-ls: 0.6.1 -> 0.7.0
* [`a133475d`](NixOS/nixpkgs@a133475) linux_zen: 5.8.1 -> 5.8.7
* [`7a0eb473`](NixOS/nixpkgs@7a0eb47) gitkraken: 7.2.0 -> 7.3.0
* [`d977d765`](NixOS/nixpkgs@d977d76) postman: 7.30.1 -> 7.31.1
* [`854a229a`](NixOS/nixpkgs@854a229) nixos/terraria: allow dataDir to be configured (NixOS/nixpkgs#89033)
* [`6668937f`](NixOS/nixpkgs@6668937) nushell: enable for aarch64
* [`9323a3f3`](NixOS/nixpkgs@9323a3f) appimageTools: use buildFHSUserEnvBubblewrap
* [`328e30e1`](NixOS/nixpkgs@328e30e) zigbee2mqtt: 1.14.3 -> 1.14.4
* [`22a9d9aa`](NixOS/nixpkgs@22a9d9a) tiledb: enable for all unix, add tweaks for darwin & non-x86 systems
* [`ac05da41`](NixOS/nixpkgs@ac05da4) pantheon.elementary-dock: fix double includedir in .pc
* [`bc57f6d2`](NixOS/nixpkgs@bc57f6d) sndio: 1.6.0 -> 1.7.0
* [`96bd235e`](NixOS/nixpkgs@96bd235) sndio: fix up for Darwin
* [`fdefec4f`](NixOS/nixpkgs@fdefec4) vcsi: init at 7.0.12
* [`34b5c5c1`](NixOS/nixpkgs@34b5c5c) nixos/acme: More features and fixes
* [`f0cb5c6a`](NixOS/nixpkgs@f0cb5c6) Revert "nixos/fontconfig: fix 50-user.conf handling"
* [`92e990a8`](NixOS/nixpkgs@92e990a) vimPlugins: Inherit meta from node plugins
* [`de3a4a05`](NixOS/nixpkgs@de3a4a0) pdfcpu: 0.3.4 -> 0.3.5
* [`82eb3cd4`](NixOS/nixpkgs@82eb3cd) ocamlPackages.srt: init at 0.1.1
* [`e2d02e46`](NixOS/nixpkgs@e2d02e4) youtube-dl: 2020.07.28 -> 2020.09.06
* [`44f439fc`](NixOS/nixpkgs@44f439f) atlassian-jira: 8.10.0 -> 8.12.0
* [`abedb5c4`](NixOS/nixpkgs@abedb5c) Move KnightOS packages into folder
* [`b23940e5`](NixOS/nixpkgs@b23940e) texinfo: revert to version 6.5 on Darwin
* [`1488e7d1`](NixOS/nixpkgs@1488e7d) tbb: fix library install name on macOS
* [`5998a16b`](NixOS/nixpkgs@5998a16) epson-escpr2: 1.1.15 -> 1.1.17
* [`6a0149df`](NixOS/nixpkgs@6a0149d) vorta: 0.6.26 -> 0.7.0
* [`fd5f28af`](NixOS/nixpkgs@fd5f28a) vgrep: init at 2.4.0
* [`e60ff5a3`](NixOS/nixpkgs@e60ff5a) python3Packages.libarcus: 4.6.1 -> 4.7.1
* [`497ff43d`](NixOS/nixpkgs@497ff43) python3Packages.libsavitar: 4.6.1 -> 4.7.1
* [`daa77cc7`](NixOS/nixpkgs@daa77cc) python3Packages.uranium: 4.6.1 -> 4.7.1
* [`7a0ef553`](NixOS/nixpkgs@7a0ef55) curaengine: 4.6.1 -> 4.7.1
* [`6b4f9a16`](NixOS/nixpkgs@6b4f9a1) cura: 4.6.1 -> 4.7.1
* [`6841659b`](NixOS/nixpkgs@6841659) curaPlugins.octoprint: 3.5.12 -> 3.5.16
* [`dadab534`](NixOS/nixpkgs@dadab53) yafaray-core: 3.4.4 -> 3.5.0
* [`a3bcf4f7`](NixOS/nixpkgs@a3bcf4f) tippecanoe: 1.35.0 -> 1.36.0
* [`e523a709`](NixOS/nixpkgs@e523a70) yafaray-core: restrict to x86_64-linux
* [`2927a19b`](NixOS/nixpkgs@2927a19) chromium: Unblock nixos-unstable by using the correct argument to fetchurl
* [`9df09227`](NixOS/nixpkgs@9df0922) marwaita: 7.5.1 -> 7.6.1
* [`50285e24`](NixOS/nixpkgs@50285e2) fractal: add gtk support to gstreamer
* [`ebd2e632`](NixOS/nixpkgs@ebd2e63) gns3-{gui,server}: 2.2.12 -> 2.2.13
* [`08eb704b`](NixOS/nixpkgs@08eb704) utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels
* [`92cff610`](NixOS/nixpkgs@92cff61) pgformatter: 4.3 -> 4.4 (NixOS/nixpkgs#96920)
* [`1876163f`](NixOS/nixpkgs@1876163) bazel-kazel: 0.0.12 -> 0.1.0 (NixOS/nixpkgs#97074)
* [`f06b103e`](NixOS/nixpkgs@f06b103) eventstat: 0.04.09 -> 0.04.10
* [`2c58c24e`](NixOS/nixpkgs@2c58c24) wimlib: 1.13.1 -> 1.13.2
* [`6c2059b3`](NixOS/nixpkgs@6c2059b) qwt6_qt4: 6.1.4 -> 6.1.5
* [`f151fd87`](NixOS/nixpkgs@f151fd8) sysvinit: 2.96 -> 2.97
* [`1311343c`](NixOS/nixpkgs@1311343) fx_cast_bridge: 0.0.6 -> 0.0.7
* [`c39f775f`](NixOS/nixpkgs@c39f775) icingaweb2: 2.8.0 -> 2.8.1
* [`cd435ce7`](NixOS/nixpkgs@cd435ce) opencl-clhpp: 2.0.11 -> 2.0.12
* [`a5121f73`](NixOS/nixpkgs@a5121f7) catch2: 2.12.2 -> 2.12.3
* [`d4f6c94d`](NixOS/nixpkgs@d4f6c94) ocamlPackages.labltk: init at 8.06.9 for OCaml 4.11
* [`7dce8e21`](NixOS/nixpkgs@7dce8e2) python27Packages.pydub: 0.24.0 -> 0.24.1
* [`e6cbcc2a`](NixOS/nixpkgs@e6cbcc2) python3Packages.scapy: 2.4.3 -> 2.4.4 (NixOS/nixpkgs#97215)
* [`02590c96`](NixOS/nixpkgs@02590c9) nixos/qemu-vm: support nix run
* [`a8d6e4b7`](NixOS/nixpkgs@a8d6e4b) hping: 20051105 -> 2014-12-26 (NixOS/nixpkgs#94683)
* [`1835fc45`](NixOS/nixpkgs@1835fc4) services.openssh: add banner
* [`cac53395`](NixOS/nixpkgs@cac5339) nixos/doc/borgbackup: correct install instructions for `vorta`
* [`0f099965`](NixOS/nixpkgs@0f09996) keepalived: 2.0.20 -> 2.1.3
* [`e976a70f`](NixOS/nixpkgs@e976a70) awscli2: 2.0.36 -> 2.0.46 (NixOS/nixpkgs#97304)
* [`22e61f43`](NixOS/nixpkgs@22e61f4) buildah: 1.15.2 -> 1.16.0
* [`60f27064`](NixOS/nixpkgs@60f2706) gammastep: 2.0.1 -> 2.0.2 (NixOS/nixpkgs#97290)
* [`1fa610bd`](NixOS/nixpkgs@1fa610b) chromium: Prefix $PATH with xdg_utils (NixOS/nixpkgs#96922)
* [`1cd9dafc`](NixOS/nixpkgs@1cd9daf) ott: 0.30 -> 0.31
* [`0b64a703`](NixOS/nixpkgs@0b64a70) guile-sdl2: 0.4.0 -> 0.5.0
* [`dd272777`](NixOS/nixpkgs@dd27277) Revert "nixos/qemu-vm: support nix run"
* [`8d5d41e7`](NixOS/nixpkgs@8d5d41e) kubernetes-helm: 3.3.0 -> 3.3.1 (NixOS/nixpkgs#97147)
* [`6ed06dca`](NixOS/nixpkgs@6ed06dc) terragrunt: 0.23.33 -> 0.23.40
* [`2ff86abc`](NixOS/nixpkgs@2ff86ab) topgrade: 5.5.0 -> 5.7.0
* [`3690d1d7`](NixOS/nixpkgs@3690d1d) calibre: build with py3 by default
* [`4b25b12f`](NixOS/nixpkgs@4b25b12) calibre: 4.22.0 -> 4.23.0
* [`2497bf42`](NixOS/nixpkgs@2497bf4) calibre: remove self reference
* [`02e6ed4b`](NixOS/nixpkgs@02e6ed4) scc: 2.12.0 -> 2.13.0
* [`1936b11f`](NixOS/nixpkgs@1936b11) utils.bash: also "fix" cc-wrapper and pkg-config-wrapper
* [`6f712077`](NixOS/nixpkgs@6f71207) ugrep: 2.5.3 -> 2.5.5
* [`b6efe9d6`](NixOS/nixpkgs@b6efe9d) vale: 2.3.3 -> 2.3.4
* [`8532b0ae`](NixOS/nixpkgs@8532b0a) vultr-cli: 0.3.2 -> 0.4.0
* [`4dd118b4`](NixOS/nixpkgs@4dd118b) timescale-prometheus: 0.1.0-beta.2 -> 0.1.0-beta.4
* [`2a82f71b`](NixOS/nixpkgs@2a82f71) proverif: 2.01 → 2.02pl1
* [`5d510968`](NixOS/nixpkgs@5d51096) nixos/prometheus-exporters: fix default firewall filter
* [`7b537f99`](NixOS/nixpkgs@7b537f9) exa: remove maintainer
* [`3487a7b8`](NixOS/nixpkgs@3487a7b) exodus: 20.1.30 -> 20.8.28
* [`1d2c243d`](NixOS/nixpkgs@1d2c243) dune_2: fix hash
* [`d7fa5b6a`](NixOS/nixpkgs@d7fa5b6) liferea: 1.12.6 → 1.12.9
* [`3c0e3697`](NixOS/nixpkgs@3c0e369) liferea: remove myself from meta.maintainers
* [`bd954783`](NixOS/nixpkgs@bd95478) liquidsoap: 1.3.4 → 1.4.2
* [`85afe9cb`](NixOS/nixpkgs@85afe9c) nixos/tests/installer: increase RAM in the VM
* [`a3173612`](NixOS/nixpkgs@a317361) nixos/lorri: add package option
github-actions bot added a commit to pbogdan/nvs that referenced this pull request Sep 8, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@c59ea8b...a3173612](NixOS/nixpkgs@c59ea8b...a317361)

* [`9a21fc26`](NixOS/nixpkgs@9a21fc2) lightburn: 0.9.15 -> 0.9.16
* [`813be97d`](NixOS/nixpkgs@813be97) lyra: 1.4 -> 1.5.1
* [`f36c47f2`](NixOS/nixpkgs@f36c47f) miller: 5.9.0 -> 5.9.1
* [`4441733e`](NixOS/nixpkgs@4441733) minikube: 1.12.3 -> 1.13.0
* [`5664601f`](NixOS/nixpkgs@5664601) ocamlPackages.fdkaac: init at 0.3.2
* [`0a8c2f8c`](NixOS/nixpkgs@0a8c2f8) nushell: 0.18.1 -> 0.19.0
* [`5811b6c1`](NixOS/nixpkgs@5811b6c) chromiumDev: 86.0.4238.0 -> 86.0.4240.8
* [`bd9c787d`](NixOS/nixpkgs@bd9c787) openlibm: 0.7.0 -> 0.7.1
* [`de69b705`](NixOS/nixpkgs@de69b70) chromium: replace update.nix with Python impl
* [`5da66561`](NixOS/nixpkgs@5da6656) chromiumDev: 86.0.4240.8 -> 87.0.4252.0
* [`6c92847e`](NixOS/nixpkgs@6c92847) chromiumBeta: 85.0.4183.83 -> 86.0.4240.22
* [`611258f0`](NixOS/nixpkgs@611258f) document nix-env bug relating to multiple output installation
* [`e6f4f3a3`](NixOS/nixpkgs@e6f4f3a) maintainers: add j0hax
* [`452e5b93`](NixOS/nixpkgs@452e5b9) octoprint.python.pkgs.displaylayerprogress: init at 1.23.2
* [`4746456a`](NixOS/nixpkgs@4746456) octoprint.python.pkgs.octoprint-dashboard: init at 1.13.0
* [`c7a503bf`](NixOS/nixpkgs@c7a503b) Revert "chromiumDev: 86.0.4240.8 -> 87.0.4252.0"
* [`717d3779`](NixOS/nixpkgs@717d377) oppai-ng: 3.2.3 -> 3.3.0
* [`c763b498`](NixOS/nixpkgs@c763b49) mdcat: 0.20.0 -> 0.21.1
* [`0cf63fde`](NixOS/nixpkgs@0cf63fd) deno: 1.3.2 -> 1.3.3
* [`2e91a108`](NixOS/nixpkgs@2e91a10) osu-lazer: 2020.820.0 -> 2020.903.0
* [`1c368b0f`](NixOS/nixpkgs@1c368b0) picard-tools: 2.23.3 -> 2.23.4
* [`98d6b55f`](NixOS/nixpkgs@98d6b55) nixos/testing: remove remaining coverage-data logic
* [`86a1a0a6`](NixOS/nixpkgs@86a1a0a) mautrix-whatsapp: 0.1.3 -> 0.1.4
* [`2f4c7093`](NixOS/nixpkgs@2f4c709) gitea: 1.12.3 -> 1.12.4
* [`4e21edf9`](NixOS/nixpkgs@4e21edf) pspg: 3.1.2 -> 3.1.3
* [`33b860ec`](NixOS/nixpkgs@33b860e) tiledb: 1.7.7 -> 2.0.7
* [`f4753023`](NixOS/nixpkgs@f475302) rink: 0.5.0 -> 0.5.1
* [`bfa4aa15`](NixOS/nixpkgs@bfa4aa1) rssguard: 3.7.0 -> 3.7.2
* [`438d5b6b`](NixOS/nixpkgs@438d5b6) pythonPackages.tiledb: 0.5.6 -> 0.6.6
* [`6eea6447`](NixOS/nixpkgs@6eea644) nixos/tests/installer swraid: increase partition size
* [`1649ef9e`](NixOS/nixpkgs@1649ef9) sensu-go-backend: 5.21.1 -> 5.21.2
* [`e5b09183`](NixOS/nixpkgs@e5b0918) iso-flags: init at unstable-18012020
* [`430fe6c7`](NixOS/nixpkgs@430fe6c) cinnamon: add iso-flag* packages like in upstream
* [`ad59f20d`](NixOS/nixpkgs@ad59f20) cinnamon.cinnamon-screensaver: init at 4.4.0
* [`302c8a46`](NixOS/nixpkgs@302c8a4) cinnamon.cinnamon-common: init at 4.4.1
* [`ce2895da`](NixOS/nixpkgs@ce2895d) cinnamon.cinnamon-common.libcroco: init at 0.6.13
* [`0555dc1c`](NixOS/nixpkgs@0555dc1) shattered-pixel-dungeon: 0.8.2b -> 0.8.2d
* [`f7127a35`](NixOS/nixpkgs@f7127a3) sickgear: 0.21.36 -> 0.21.42
* [`1b197ce0`](NixOS/nixpkgs@1b197ce) wineUnstable: 5.14 -> 5.15
* [`e049f91e`](NixOS/nixpkgs@e049f91) wineUnstable: 5.15 -> 5.16
* [`bf9112cd`](NixOS/nixpkgs@bf9112c) skaffold: 1.13.2 -> 1.14.0
* [`cc797c4a`](NixOS/nixpkgs@cc797c4) star: 2.7.4a -> 2.7.5c
* [`f30e80ba`](NixOS/nixpkgs@f30e80b) hackage-packages.nix: fix eval pandoc_2_10_1 on hydra
* [`edeece0a`](NixOS/nixpkgs@edeece0) libpqxx: enable for darwin
* [`436b3a43`](NixOS/nixpkgs@436b3a4) terraform-ls: 0.6.1 -> 0.7.0
* [`a133475d`](NixOS/nixpkgs@a133475) linux_zen: 5.8.1 -> 5.8.7
* [`7a0eb473`](NixOS/nixpkgs@7a0eb47) gitkraken: 7.2.0 -> 7.3.0
* [`d977d765`](NixOS/nixpkgs@d977d76) postman: 7.30.1 -> 7.31.1
* [`854a229a`](NixOS/nixpkgs@854a229) nixos/terraria: allow dataDir to be configured (NixOS/nixpkgs#89033)
* [`6668937f`](NixOS/nixpkgs@6668937) nushell: enable for aarch64
* [`9323a3f3`](NixOS/nixpkgs@9323a3f) appimageTools: use buildFHSUserEnvBubblewrap
* [`328e30e1`](NixOS/nixpkgs@328e30e) zigbee2mqtt: 1.14.3 -> 1.14.4
* [`22a9d9aa`](NixOS/nixpkgs@22a9d9a) tiledb: enable for all unix, add tweaks for darwin & non-x86 systems
* [`ac05da41`](NixOS/nixpkgs@ac05da4) pantheon.elementary-dock: fix double includedir in .pc
* [`bc57f6d2`](NixOS/nixpkgs@bc57f6d) sndio: 1.6.0 -> 1.7.0
* [`96bd235e`](NixOS/nixpkgs@96bd235) sndio: fix up for Darwin
* [`fdefec4f`](NixOS/nixpkgs@fdefec4) vcsi: init at 7.0.12
* [`34b5c5c1`](NixOS/nixpkgs@34b5c5c) nixos/acme: More features and fixes
* [`f0cb5c6a`](NixOS/nixpkgs@f0cb5c6) Revert "nixos/fontconfig: fix 50-user.conf handling"
* [`92e990a8`](NixOS/nixpkgs@92e990a) vimPlugins: Inherit meta from node plugins
* [`de3a4a05`](NixOS/nixpkgs@de3a4a0) pdfcpu: 0.3.4 -> 0.3.5
* [`82eb3cd4`](NixOS/nixpkgs@82eb3cd) ocamlPackages.srt: init at 0.1.1
* [`e2d02e46`](NixOS/nixpkgs@e2d02e4) youtube-dl: 2020.07.28 -> 2020.09.06
* [`44f439fc`](NixOS/nixpkgs@44f439f) atlassian-jira: 8.10.0 -> 8.12.0
* [`abedb5c4`](NixOS/nixpkgs@abedb5c) Move KnightOS packages into folder
* [`b23940e5`](NixOS/nixpkgs@b23940e) texinfo: revert to version 6.5 on Darwin
* [`1488e7d1`](NixOS/nixpkgs@1488e7d) tbb: fix library install name on macOS
* [`5998a16b`](NixOS/nixpkgs@5998a16) epson-escpr2: 1.1.15 -> 1.1.17
* [`6a0149df`](NixOS/nixpkgs@6a0149d) vorta: 0.6.26 -> 0.7.0
* [`fd5f28af`](NixOS/nixpkgs@fd5f28a) vgrep: init at 2.4.0
* [`e60ff5a3`](NixOS/nixpkgs@e60ff5a) python3Packages.libarcus: 4.6.1 -> 4.7.1
* [`497ff43d`](NixOS/nixpkgs@497ff43) python3Packages.libsavitar: 4.6.1 -> 4.7.1
* [`daa77cc7`](NixOS/nixpkgs@daa77cc) python3Packages.uranium: 4.6.1 -> 4.7.1
* [`7a0ef553`](NixOS/nixpkgs@7a0ef55) curaengine: 4.6.1 -> 4.7.1
* [`6b4f9a16`](NixOS/nixpkgs@6b4f9a1) cura: 4.6.1 -> 4.7.1
* [`6841659b`](NixOS/nixpkgs@6841659) curaPlugins.octoprint: 3.5.12 -> 3.5.16
* [`dadab534`](NixOS/nixpkgs@dadab53) yafaray-core: 3.4.4 -> 3.5.0
* [`a3bcf4f7`](NixOS/nixpkgs@a3bcf4f) tippecanoe: 1.35.0 -> 1.36.0
* [`e523a709`](NixOS/nixpkgs@e523a70) yafaray-core: restrict to x86_64-linux
* [`2927a19b`](NixOS/nixpkgs@2927a19) chromium: Unblock nixos-unstable by using the correct argument to fetchurl
* [`9df09227`](NixOS/nixpkgs@9df0922) marwaita: 7.5.1 -> 7.6.1
* [`50285e24`](NixOS/nixpkgs@50285e2) fractal: add gtk support to gstreamer
* [`ebd2e632`](NixOS/nixpkgs@ebd2e63) gns3-{gui,server}: 2.2.12 -> 2.2.13
* [`08eb704b`](NixOS/nixpkgs@08eb704) utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels
* [`92cff610`](NixOS/nixpkgs@92cff61) pgformatter: 4.3 -> 4.4 (NixOS/nixpkgs#96920)
* [`1876163f`](NixOS/nixpkgs@1876163) bazel-kazel: 0.0.12 -> 0.1.0 (NixOS/nixpkgs#97074)
* [`f06b103e`](NixOS/nixpkgs@f06b103) eventstat: 0.04.09 -> 0.04.10
* [`2c58c24e`](NixOS/nixpkgs@2c58c24) wimlib: 1.13.1 -> 1.13.2
* [`6c2059b3`](NixOS/nixpkgs@6c2059b) qwt6_qt4: 6.1.4 -> 6.1.5
* [`f151fd87`](NixOS/nixpkgs@f151fd8) sysvinit: 2.96 -> 2.97
* [`1311343c`](NixOS/nixpkgs@1311343) fx_cast_bridge: 0.0.6 -> 0.0.7
* [`c39f775f`](NixOS/nixpkgs@c39f775) icingaweb2: 2.8.0 -> 2.8.1
* [`cd435ce7`](NixOS/nixpkgs@cd435ce) opencl-clhpp: 2.0.11 -> 2.0.12
* [`a5121f73`](NixOS/nixpkgs@a5121f7) catch2: 2.12.2 -> 2.12.3
* [`d4f6c94d`](NixOS/nixpkgs@d4f6c94) ocamlPackages.labltk: init at 8.06.9 for OCaml 4.11
* [`7dce8e21`](NixOS/nixpkgs@7dce8e2) python27Packages.pydub: 0.24.0 -> 0.24.1
* [`e6cbcc2a`](NixOS/nixpkgs@e6cbcc2) python3Packages.scapy: 2.4.3 -> 2.4.4 (NixOS/nixpkgs#97215)
* [`02590c96`](NixOS/nixpkgs@02590c9) nixos/qemu-vm: support nix run
* [`a8d6e4b7`](NixOS/nixpkgs@a8d6e4b) hping: 20051105 -> 2014-12-26 (NixOS/nixpkgs#94683)
* [`1835fc45`](NixOS/nixpkgs@1835fc4) services.openssh: add banner
* [`cac53395`](NixOS/nixpkgs@cac5339) nixos/doc/borgbackup: correct install instructions for `vorta`
* [`0f099965`](NixOS/nixpkgs@0f09996) keepalived: 2.0.20 -> 2.1.3
* [`e976a70f`](NixOS/nixpkgs@e976a70) awscli2: 2.0.36 -> 2.0.46 (NixOS/nixpkgs#97304)
* [`22e61f43`](NixOS/nixpkgs@22e61f4) buildah: 1.15.2 -> 1.16.0
* [`60f27064`](NixOS/nixpkgs@60f2706) gammastep: 2.0.1 -> 2.0.2 (NixOS/nixpkgs#97290)
* [`1fa610bd`](NixOS/nixpkgs@1fa610b) chromium: Prefix $PATH with xdg_utils (NixOS/nixpkgs#96922)
* [`1cd9dafc`](NixOS/nixpkgs@1cd9daf) ott: 0.30 -> 0.31
* [`0b64a703`](NixOS/nixpkgs@0b64a70) guile-sdl2: 0.4.0 -> 0.5.0
* [`dd272777`](NixOS/nixpkgs@dd27277) Revert "nixos/qemu-vm: support nix run"
* [`8d5d41e7`](NixOS/nixpkgs@8d5d41e) kubernetes-helm: 3.3.0 -> 3.3.1 (NixOS/nixpkgs#97147)
* [`6ed06dca`](NixOS/nixpkgs@6ed06dc) terragrunt: 0.23.33 -> 0.23.40
* [`2ff86abc`](NixOS/nixpkgs@2ff86ab) topgrade: 5.5.0 -> 5.7.0
* [`3690d1d7`](NixOS/nixpkgs@3690d1d) calibre: build with py3 by default
* [`4b25b12f`](NixOS/nixpkgs@4b25b12) calibre: 4.22.0 -> 4.23.0
* [`2497bf42`](NixOS/nixpkgs@2497bf4) calibre: remove self reference
* [`02e6ed4b`](NixOS/nixpkgs@02e6ed4) scc: 2.12.0 -> 2.13.0
* [`1936b11f`](NixOS/nixpkgs@1936b11) utils.bash: also "fix" cc-wrapper and pkg-config-wrapper
* [`6f712077`](NixOS/nixpkgs@6f71207) ugrep: 2.5.3 -> 2.5.5
* [`b6efe9d6`](NixOS/nixpkgs@b6efe9d) vale: 2.3.3 -> 2.3.4
* [`8532b0ae`](NixOS/nixpkgs@8532b0a) vultr-cli: 0.3.2 -> 0.4.0
* [`4dd118b4`](NixOS/nixpkgs@4dd118b) timescale-prometheus: 0.1.0-beta.2 -> 0.1.0-beta.4
* [`2a82f71b`](NixOS/nixpkgs@2a82f71) proverif: 2.01 → 2.02pl1
* [`5d510968`](NixOS/nixpkgs@5d51096) nixos/prometheus-exporters: fix default firewall filter
* [`7b537f99`](NixOS/nixpkgs@7b537f9) exa: remove maintainer
* [`3487a7b8`](NixOS/nixpkgs@3487a7b) exodus: 20.1.30 -> 20.8.28
* [`1d2c243d`](NixOS/nixpkgs@1d2c243) dune_2: fix hash
* [`d7fa5b6a`](NixOS/nixpkgs@d7fa5b6) liferea: 1.12.6 → 1.12.9
* [`3c0e3697`](NixOS/nixpkgs@3c0e369) liferea: remove myself from meta.maintainers
* [`bd954783`](NixOS/nixpkgs@bd95478) liquidsoap: 1.3.4 → 1.4.2
* [`85afe9cb`](NixOS/nixpkgs@85afe9c) nixos/tests/installer: increase RAM in the VM
* [`a3173612`](NixOS/nixpkgs@a317361) nixos/lorri: add package option
github-actions bot added a commit to pbogdan/nix-nerd-fonts that referenced this pull request Sep 8, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@c59ea8b...a3173612](NixOS/nixpkgs@c59ea8b...a317361)

* [`9a21fc26`](NixOS/nixpkgs@9a21fc2) lightburn: 0.9.15 -> 0.9.16
* [`813be97d`](NixOS/nixpkgs@813be97) lyra: 1.4 -> 1.5.1
* [`f36c47f2`](NixOS/nixpkgs@f36c47f) miller: 5.9.0 -> 5.9.1
* [`4441733e`](NixOS/nixpkgs@4441733) minikube: 1.12.3 -> 1.13.0
* [`5664601f`](NixOS/nixpkgs@5664601) ocamlPackages.fdkaac: init at 0.3.2
* [`0a8c2f8c`](NixOS/nixpkgs@0a8c2f8) nushell: 0.18.1 -> 0.19.0
* [`5811b6c1`](NixOS/nixpkgs@5811b6c) chromiumDev: 86.0.4238.0 -> 86.0.4240.8
* [`bd9c787d`](NixOS/nixpkgs@bd9c787) openlibm: 0.7.0 -> 0.7.1
* [`de69b705`](NixOS/nixpkgs@de69b70) chromium: replace update.nix with Python impl
* [`5da66561`](NixOS/nixpkgs@5da6656) chromiumDev: 86.0.4240.8 -> 87.0.4252.0
* [`6c92847e`](NixOS/nixpkgs@6c92847) chromiumBeta: 85.0.4183.83 -> 86.0.4240.22
* [`611258f0`](NixOS/nixpkgs@611258f) document nix-env bug relating to multiple output installation
* [`e6f4f3a3`](NixOS/nixpkgs@e6f4f3a) maintainers: add j0hax
* [`452e5b93`](NixOS/nixpkgs@452e5b9) octoprint.python.pkgs.displaylayerprogress: init at 1.23.2
* [`4746456a`](NixOS/nixpkgs@4746456) octoprint.python.pkgs.octoprint-dashboard: init at 1.13.0
* [`c7a503bf`](NixOS/nixpkgs@c7a503b) Revert "chromiumDev: 86.0.4240.8 -> 87.0.4252.0"
* [`717d3779`](NixOS/nixpkgs@717d377) oppai-ng: 3.2.3 -> 3.3.0
* [`c763b498`](NixOS/nixpkgs@c763b49) mdcat: 0.20.0 -> 0.21.1
* [`0cf63fde`](NixOS/nixpkgs@0cf63fd) deno: 1.3.2 -> 1.3.3
* [`2e91a108`](NixOS/nixpkgs@2e91a10) osu-lazer: 2020.820.0 -> 2020.903.0
* [`1c368b0f`](NixOS/nixpkgs@1c368b0) picard-tools: 2.23.3 -> 2.23.4
* [`98d6b55f`](NixOS/nixpkgs@98d6b55) nixos/testing: remove remaining coverage-data logic
* [`86a1a0a6`](NixOS/nixpkgs@86a1a0a) mautrix-whatsapp: 0.1.3 -> 0.1.4
* [`2f4c7093`](NixOS/nixpkgs@2f4c709) gitea: 1.12.3 -> 1.12.4
* [`4e21edf9`](NixOS/nixpkgs@4e21edf) pspg: 3.1.2 -> 3.1.3
* [`33b860ec`](NixOS/nixpkgs@33b860e) tiledb: 1.7.7 -> 2.0.7
* [`f4753023`](NixOS/nixpkgs@f475302) rink: 0.5.0 -> 0.5.1
* [`bfa4aa15`](NixOS/nixpkgs@bfa4aa1) rssguard: 3.7.0 -> 3.7.2
* [`438d5b6b`](NixOS/nixpkgs@438d5b6) pythonPackages.tiledb: 0.5.6 -> 0.6.6
* [`6eea6447`](NixOS/nixpkgs@6eea644) nixos/tests/installer swraid: increase partition size
* [`1649ef9e`](NixOS/nixpkgs@1649ef9) sensu-go-backend: 5.21.1 -> 5.21.2
* [`e5b09183`](NixOS/nixpkgs@e5b0918) iso-flags: init at unstable-18012020
* [`430fe6c7`](NixOS/nixpkgs@430fe6c) cinnamon: add iso-flag* packages like in upstream
* [`ad59f20d`](NixOS/nixpkgs@ad59f20) cinnamon.cinnamon-screensaver: init at 4.4.0
* [`302c8a46`](NixOS/nixpkgs@302c8a4) cinnamon.cinnamon-common: init at 4.4.1
* [`ce2895da`](NixOS/nixpkgs@ce2895d) cinnamon.cinnamon-common.libcroco: init at 0.6.13
* [`0555dc1c`](NixOS/nixpkgs@0555dc1) shattered-pixel-dungeon: 0.8.2b -> 0.8.2d
* [`f7127a35`](NixOS/nixpkgs@f7127a3) sickgear: 0.21.36 -> 0.21.42
* [`1b197ce0`](NixOS/nixpkgs@1b197ce) wineUnstable: 5.14 -> 5.15
* [`e049f91e`](NixOS/nixpkgs@e049f91) wineUnstable: 5.15 -> 5.16
* [`bf9112cd`](NixOS/nixpkgs@bf9112c) skaffold: 1.13.2 -> 1.14.0
* [`cc797c4a`](NixOS/nixpkgs@cc797c4) star: 2.7.4a -> 2.7.5c
* [`f30e80ba`](NixOS/nixpkgs@f30e80b) hackage-packages.nix: fix eval pandoc_2_10_1 on hydra
* [`edeece0a`](NixOS/nixpkgs@edeece0) libpqxx: enable for darwin
* [`436b3a43`](NixOS/nixpkgs@436b3a4) terraform-ls: 0.6.1 -> 0.7.0
* [`a133475d`](NixOS/nixpkgs@a133475) linux_zen: 5.8.1 -> 5.8.7
* [`7a0eb473`](NixOS/nixpkgs@7a0eb47) gitkraken: 7.2.0 -> 7.3.0
* [`d977d765`](NixOS/nixpkgs@d977d76) postman: 7.30.1 -> 7.31.1
* [`854a229a`](NixOS/nixpkgs@854a229) nixos/terraria: allow dataDir to be configured (NixOS/nixpkgs#89033)
* [`6668937f`](NixOS/nixpkgs@6668937) nushell: enable for aarch64
* [`9323a3f3`](NixOS/nixpkgs@9323a3f) appimageTools: use buildFHSUserEnvBubblewrap
* [`328e30e1`](NixOS/nixpkgs@328e30e) zigbee2mqtt: 1.14.3 -> 1.14.4
* [`22a9d9aa`](NixOS/nixpkgs@22a9d9a) tiledb: enable for all unix, add tweaks for darwin & non-x86 systems
* [`ac05da41`](NixOS/nixpkgs@ac05da4) pantheon.elementary-dock: fix double includedir in .pc
* [`bc57f6d2`](NixOS/nixpkgs@bc57f6d) sndio: 1.6.0 -> 1.7.0
* [`96bd235e`](NixOS/nixpkgs@96bd235) sndio: fix up for Darwin
* [`fdefec4f`](NixOS/nixpkgs@fdefec4) vcsi: init at 7.0.12
* [`34b5c5c1`](NixOS/nixpkgs@34b5c5c) nixos/acme: More features and fixes
* [`f0cb5c6a`](NixOS/nixpkgs@f0cb5c6) Revert "nixos/fontconfig: fix 50-user.conf handling"
* [`92e990a8`](NixOS/nixpkgs@92e990a) vimPlugins: Inherit meta from node plugins
* [`de3a4a05`](NixOS/nixpkgs@de3a4a0) pdfcpu: 0.3.4 -> 0.3.5
* [`82eb3cd4`](NixOS/nixpkgs@82eb3cd) ocamlPackages.srt: init at 0.1.1
* [`e2d02e46`](NixOS/nixpkgs@e2d02e4) youtube-dl: 2020.07.28 -> 2020.09.06
* [`44f439fc`](NixOS/nixpkgs@44f439f) atlassian-jira: 8.10.0 -> 8.12.0
* [`abedb5c4`](NixOS/nixpkgs@abedb5c) Move KnightOS packages into folder
* [`b23940e5`](NixOS/nixpkgs@b23940e) texinfo: revert to version 6.5 on Darwin
* [`1488e7d1`](NixOS/nixpkgs@1488e7d) tbb: fix library install name on macOS
* [`5998a16b`](NixOS/nixpkgs@5998a16) epson-escpr2: 1.1.15 -> 1.1.17
* [`6a0149df`](NixOS/nixpkgs@6a0149d) vorta: 0.6.26 -> 0.7.0
* [`fd5f28af`](NixOS/nixpkgs@fd5f28a) vgrep: init at 2.4.0
* [`e60ff5a3`](NixOS/nixpkgs@e60ff5a) python3Packages.libarcus: 4.6.1 -> 4.7.1
* [`497ff43d`](NixOS/nixpkgs@497ff43) python3Packages.libsavitar: 4.6.1 -> 4.7.1
* [`daa77cc7`](NixOS/nixpkgs@daa77cc) python3Packages.uranium: 4.6.1 -> 4.7.1
* [`7a0ef553`](NixOS/nixpkgs@7a0ef55) curaengine: 4.6.1 -> 4.7.1
* [`6b4f9a16`](NixOS/nixpkgs@6b4f9a1) cura: 4.6.1 -> 4.7.1
* [`6841659b`](NixOS/nixpkgs@6841659) curaPlugins.octoprint: 3.5.12 -> 3.5.16
* [`dadab534`](NixOS/nixpkgs@dadab53) yafaray-core: 3.4.4 -> 3.5.0
* [`a3bcf4f7`](NixOS/nixpkgs@a3bcf4f) tippecanoe: 1.35.0 -> 1.36.0
* [`e523a709`](NixOS/nixpkgs@e523a70) yafaray-core: restrict to x86_64-linux
* [`2927a19b`](NixOS/nixpkgs@2927a19) chromium: Unblock nixos-unstable by using the correct argument to fetchurl
* [`9df09227`](NixOS/nixpkgs@9df0922) marwaita: 7.5.1 -> 7.6.1
* [`50285e24`](NixOS/nixpkgs@50285e2) fractal: add gtk support to gstreamer
* [`ebd2e632`](NixOS/nixpkgs@ebd2e63) gns3-{gui,server}: 2.2.12 -> 2.2.13
* [`08eb704b`](NixOS/nixpkgs@08eb704) utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels
* [`92cff610`](NixOS/nixpkgs@92cff61) pgformatter: 4.3 -> 4.4 (NixOS/nixpkgs#96920)
* [`1876163f`](NixOS/nixpkgs@1876163) bazel-kazel: 0.0.12 -> 0.1.0 (NixOS/nixpkgs#97074)
* [`f06b103e`](NixOS/nixpkgs@f06b103) eventstat: 0.04.09 -> 0.04.10
* [`2c58c24e`](NixOS/nixpkgs@2c58c24) wimlib: 1.13.1 -> 1.13.2
* [`6c2059b3`](NixOS/nixpkgs@6c2059b) qwt6_qt4: 6.1.4 -> 6.1.5
* [`f151fd87`](NixOS/nixpkgs@f151fd8) sysvinit: 2.96 -> 2.97
* [`1311343c`](NixOS/nixpkgs@1311343) fx_cast_bridge: 0.0.6 -> 0.0.7
* [`c39f775f`](NixOS/nixpkgs@c39f775) icingaweb2: 2.8.0 -> 2.8.1
* [`cd435ce7`](NixOS/nixpkgs@cd435ce) opencl-clhpp: 2.0.11 -> 2.0.12
* [`a5121f73`](NixOS/nixpkgs@a5121f7) catch2: 2.12.2 -> 2.12.3
* [`d4f6c94d`](NixOS/nixpkgs@d4f6c94) ocamlPackages.labltk: init at 8.06.9 for OCaml 4.11
* [`7dce8e21`](NixOS/nixpkgs@7dce8e2) python27Packages.pydub: 0.24.0 -> 0.24.1
* [`e6cbcc2a`](NixOS/nixpkgs@e6cbcc2) python3Packages.scapy: 2.4.3 -> 2.4.4 (NixOS/nixpkgs#97215)
* [`02590c96`](NixOS/nixpkgs@02590c9) nixos/qemu-vm: support nix run
* [`a8d6e4b7`](NixOS/nixpkgs@a8d6e4b) hping: 20051105 -> 2014-12-26 (NixOS/nixpkgs#94683)
* [`1835fc45`](NixOS/nixpkgs@1835fc4) services.openssh: add banner
* [`cac53395`](NixOS/nixpkgs@cac5339) nixos/doc/borgbackup: correct install instructions for `vorta`
* [`0f099965`](NixOS/nixpkgs@0f09996) keepalived: 2.0.20 -> 2.1.3
* [`e976a70f`](NixOS/nixpkgs@e976a70) awscli2: 2.0.36 -> 2.0.46 (NixOS/nixpkgs#97304)
* [`22e61f43`](NixOS/nixpkgs@22e61f4) buildah: 1.15.2 -> 1.16.0
* [`60f27064`](NixOS/nixpkgs@60f2706) gammastep: 2.0.1 -> 2.0.2 (NixOS/nixpkgs#97290)
* [`1fa610bd`](NixOS/nixpkgs@1fa610b) chromium: Prefix $PATH with xdg_utils (NixOS/nixpkgs#96922)
* [`1cd9dafc`](NixOS/nixpkgs@1cd9daf) ott: 0.30 -> 0.31
* [`0b64a703`](NixOS/nixpkgs@0b64a70) guile-sdl2: 0.4.0 -> 0.5.0
* [`dd272777`](NixOS/nixpkgs@dd27277) Revert "nixos/qemu-vm: support nix run"
* [`8d5d41e7`](NixOS/nixpkgs@8d5d41e) kubernetes-helm: 3.3.0 -> 3.3.1 (NixOS/nixpkgs#97147)
* [`6ed06dca`](NixOS/nixpkgs@6ed06dc) terragrunt: 0.23.33 -> 0.23.40
* [`2ff86abc`](NixOS/nixpkgs@2ff86ab) topgrade: 5.5.0 -> 5.7.0
* [`3690d1d7`](NixOS/nixpkgs@3690d1d) calibre: build with py3 by default
* [`4b25b12f`](NixOS/nixpkgs@4b25b12) calibre: 4.22.0 -> 4.23.0
* [`2497bf42`](NixOS/nixpkgs@2497bf4) calibre: remove self reference
* [`02e6ed4b`](NixOS/nixpkgs@02e6ed4) scc: 2.12.0 -> 2.13.0
* [`1936b11f`](NixOS/nixpkgs@1936b11) utils.bash: also "fix" cc-wrapper and pkg-config-wrapper
* [`6f712077`](NixOS/nixpkgs@6f71207) ugrep: 2.5.3 -> 2.5.5
* [`b6efe9d6`](NixOS/nixpkgs@b6efe9d) vale: 2.3.3 -> 2.3.4
* [`8532b0ae`](NixOS/nixpkgs@8532b0a) vultr-cli: 0.3.2 -> 0.4.0
* [`4dd118b4`](NixOS/nixpkgs@4dd118b) timescale-prometheus: 0.1.0-beta.2 -> 0.1.0-beta.4
* [`2a82f71b`](NixOS/nixpkgs@2a82f71) proverif: 2.01 → 2.02pl1
* [`5d510968`](NixOS/nixpkgs@5d51096) nixos/prometheus-exporters: fix default firewall filter
* [`7b537f99`](NixOS/nixpkgs@7b537f9) exa: remove maintainer
* [`3487a7b8`](NixOS/nixpkgs@3487a7b) exodus: 20.1.30 -> 20.8.28
* [`1d2c243d`](NixOS/nixpkgs@1d2c243) dune_2: fix hash
* [`d7fa5b6a`](NixOS/nixpkgs@d7fa5b6) liferea: 1.12.6 → 1.12.9
* [`3c0e3697`](NixOS/nixpkgs@3c0e369) liferea: remove myself from meta.maintainers
* [`bd954783`](NixOS/nixpkgs@bd95478) liquidsoap: 1.3.4 → 1.4.2
* [`85afe9cb`](NixOS/nixpkgs@85afe9c) nixos/tests/installer: increase RAM in the VM
* [`a3173612`](NixOS/nixpkgs@a317361) nixos/lorri: add package option
FRidh added a commit to FRidh/nixpkgs that referenced this pull request Sep 9, 2020
Revert the hack and the original faulty commit.

This reverts commit 48264ee.

Revert "Purity checking should accept $TMP and not just /tmp"

This reverts commit fb777be.

(cherry picked from commit e560459)
FRidh added a commit that referenced this pull request Sep 12, 2020
Revert the hack and the original faulty commit.

This reverts commit 48264ee.

Revert "Purity checking should accept $TMP and not just /tmp"

This reverts commit fb777be.

(cherry picked from commit e560459)
aszlig added a commit that referenced this pull request Sep 18, 2020
Since commit fb777be, linking programs
in /tmp will no longer work, since with this commit (hardcoded) /tmp
will no longer be treated a valid temporary directory by the purity
checking logic.

Essentially what that logic does is checking whether the link target is
either relative, in some temporary directory or in the Nix store and if
that's not the case, an error is thrown like in this case:

  gcc -c /tmp/build.24.tmp.c -o /tmp/build.24.tmp.c.o
  gcc /tmp/build.24.tmp.c.o -o /tmp/build.24.tmp.out
  impure path `/tmp/build.24.tmp.out' used in link
  collect2: error: ld returned 1 exit status

Note here, that $TMP and $TMPDIR point to /build while the output here
still refers to /tmp. This is because the custom build system of uqm
simply hardcodes /tmp and doesn't honor any of these variables.

To fix this, all we need to do is the latter and we're now using $TMPDIR
instead of /tmp for these compile-tests during configure.

While the pull request[1] introducing said commit has a few comments
regarding other issues and it could still be either reverted or changed,
using $TMPDIR in the uqm build script is entirely backwards-compatible
and shouldn't hurt in any case.

[1]: #93560

Signed-off-by: aszlig <aszlig@nix.build>
github-actions bot added a commit to pbogdan/shell-cmd that referenced this pull request Sep 21, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@441a7da...2a35f664](NixOS/nixpkgs@441a7da...2a35f66)

* [`b5212f8b`](NixOS/nixpkgs@b5212f8) linux: remove dependency to utillinuxMinimal
* [`e560459c`](NixOS/nixpkgs@e560459) Revert "utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels"
* [`5ceea570`](NixOS/nixpkgs@5ceea57) Revert "utils.bash: also "fix" cc-wrapper and pkg-config-wrapper"
* [`31fed01d`](NixOS/nixpkgs@31fed01) vdr-epgsearch: 2.4.0 -> 20191202
* [`73653fe5`](NixOS/nixpkgs@73653fe) vdr-vaapidevice: 0.7.0 -> 20190526
* [`9db2ca30`](NixOS/nixpkgs@9db2ca3) gambatte: add alsa dependency, 2016-05-03 -> 2020-03-14
* [`bbd7ba6a`](NixOS/nixpkgs@bbd7ba6) linuxPackages.exfat-nofuse: 2019-09-06 -> 2020-04-15
* [`1966a0a4`](NixOS/nixpkgs@1966a0a) opencv: enable videoio on darwin
* [`90f01b1c`](NixOS/nixpkgs@90f01b1) bcachefs-tools: disable tests
* [`920441f9`](NixOS/nixpkgs@920441f) bcachefs-tools: 2020-04-04 -> 2020-08-25
* [`3cc3e864`](NixOS/nixpkgs@3cc3e86) linux_testing_bcachefs: 5.3 -> 5.8
* [`d284d320`](NixOS/nixpkgs@d284d32) nixos/dmidecode: added recommended patches
* [`c1e96ff7`](NixOS/nixpkgs@c1e96ff) release*: Support nixpkgsArgs for all release-*.nix files
* [`4ed3c35f`](NixOS/nixpkgs@4ed3c35) microserver: init at 0.1.8
* [`9092c614`](NixOS/nixpkgs@9092c61) nginxModules.naxsi: 2020.08.15 -> 2020.09.10
* [`6f32af17`](NixOS/nixpkgs@6f32af1) nginxModules.opentracing: v0.9.0 -> v0.10.0
* [`96311ca1`](NixOS/nixpkgs@96311ca) nginxModules.shibboleth: 2020.08.12 -> 2020.09.04
* [`79906c49`](NixOS/nixpkgs@79906c4) nginxModules.aws-auth: fix warning message
* [`2724f7be`](NixOS/nixpkgs@2724f7b) nbxplorer: init at 2.1.42
* [`2f55d6f6`](NixOS/nixpkgs@2f55d6f) btcpayserver: init at 1.0.5.4
* [`e2c8ae98`](NixOS/nixpkgs@e2c8ae9) softmaker-office: 1018 -> 1020
* [`9be28ee3`](NixOS/nixpkgs@9be28ee) libxsmm: 1.15 -> 1.16.1, improve derivation
* [`8cb1e75e`](NixOS/nixpkgs@8cb1e75) wordgrinder: fix build
* [`9f33ab62`](NixOS/nixpkgs@9f33ab6) nixos/testing: Add support for specialArgs
* [`aff7ee12`](NixOS/nixpkgs@aff7ee1) coursier: 2.0.0-RC6-25 -> 2.0.0-RC6-26
* [`c8ccaebf`](NixOS/nixpkgs@c8ccaeb) nodePackages.diagnostic-languageserver: init at 1.7.1
* [`19b5ef48`](NixOS/nixpkgs@19b5ef4) nixos/plasma5: Fix build with config.services.colord.enable = true
* [`6d0c57fb`](NixOS/nixpkgs@6d0c57f) gitAndTools.git-machete: 2.15.4 -> 2.15.5
* [`7a27aefc`](NixOS/nixpkgs@7a27aef) perlPackages.AstroFITSHeader: init at 3.07
* [`083041a6`](NixOS/nixpkgs@083041a) maintainers: add StephenWithPH
* [`fb779db8`](NixOS/nixpkgs@fb779db) go-swag: init at 1.6.7
* [`88363a87`](NixOS/nixpkgs@88363a8) matomo: 3.14.0 -> 3.14.1
* [`47ba35d6`](NixOS/nixpkgs@47ba35d) unnethack: 5.2.0 -> 5.3.2 (NixOS/nixpkgs#97595)
* [`9511b329`](NixOS/nixpkgs@9511b32) vscode-extensions.ms-python.python: 2020.7.96456 -> 2020.8.103604
* [`0617d9cf`](NixOS/nixpkgs@0617d9c) vimPlugins: update
* [`89c781cc`](NixOS/nixpkgs@89c781c) vimPlugins.vim-ocaml: init at 2020-08-20
* [`be33b546`](NixOS/nixpkgs@be33b54) maintainers/build: skip packages that don't evaluate
* [`c1d2464f`](NixOS/nixpkgs@c1d2464) shadowsocks-libev: 3.3.4 -> 3.3.5
* [`b0b730de`](NixOS/nixpkgs@b0b730d) sops: 3.6.0 -> 3.6.1
* [`ce065c62`](NixOS/nixpkgs@ce065c6) cli-visualizer: Fix build
* [`715790e2`](NixOS/nixpkgs@715790e) _1password-gui: 0.8.5-1 -> 0.8.6-2
* [`c15bcdd9`](NixOS/nixpkgs@c15bcdd) percona-server: 5.6.43-84.3 -> 5.6.49-89.0 (NixOS/nixpkgs#97923)
* [`02a7dde9`](NixOS/nixpkgs@02a7dde) mbtileserver: init at 0.6.1
* [`4a56effd`](NixOS/nixpkgs@4a56eff) redo-sh: 2.0.3 → 4.0.3
* [`c3be7658`](NixOS/nixpkgs@c3be765) nixos/xserver: clean up the useXFS option
* [`b632ca69`](NixOS/nixpkgs@b632ca6) citrix_workspace: add 20.09.0
* [`5b19fa94`](NixOS/nixpkgs@5b19fa9) jitsi-meet-electron: 2.2.0 -> 2.3.1
* [`fb1ff72f`](NixOS/nixpkgs@fb1ff72) perlPackages.PDL: init at 2.022
* [`5684d011`](NixOS/nixpkgs@5684d01) postman: 7.31.1 -> 7.32.0
* [`911c641a`](NixOS/nixpkgs@911c641) oh-my-zsh: 2020-09-12 -> 2020-09-14
* [`e469ddc9`](NixOS/nixpkgs@e469ddc) vcv-rack: fix broken pfft reference
* [`2b55bb43`](NixOS/nixpkgs@2b55bb4) python27.pkgs.joblib: Disable package
* [`43d588b0`](NixOS/nixpkgs@43d588b) python3Packages.ihatemoney: disable sandbox unfriendly tests, fix passthru
* [`20034954`](NixOS/nixpkgs@2003495) python3Packages.graphite_beacon: fix deps, add nixos test
* [`07660b28`](NixOS/nixpkgs@07660b2) streamlit: fix build
* [`dd9c0cf6`](NixOS/nixpkgs@dd9c0cf) maintainers: add mlvzk
* [`92ba6108`](NixOS/nixpkgs@92ba610) manix: init at 0.6.2
* [`0051c0a4`](NixOS/nixpkgs@0051c0a) pythonPackages.bcrypt: use 3.1.x for python older than 3.6
* [`5f4b880b`](NixOS/nixpkgs@5f4b880) python2Packages.trytond: disable for python2
* [`c35b6b3b`](NixOS/nixpkgs@c35b6b3) texstudio: 3.0.0 -> 3.0.1
* [`4d111fdf`](NixOS/nixpkgs@4d111fd) pythonPackages.sievelib: fix build by adding patch
* [`ca682af5`](NixOS/nixpkgs@ca682af) cod: init at unstable-2020-09-10
* [`ffc3f822`](NixOS/nixpkgs@ffc3f82) saga: use proj 6
* [`d92b2463`](NixOS/nixpkgs@d92b246) josm: 16812 -> 17013
* [`b4676300`](NixOS/nixpkgs@b467630) f2fs-tools: 1.13.0 -> 1.14.0
* [`c80258af`](NixOS/nixpkgs@c80258a) gist: 5.1.0 -> 6.0.0 (NixOS/nixpkgs#98053)
* [`afeed1fe`](NixOS/nixpkgs@afeed1f) nodejs-10_x: 10.22.0 -> 10.22.1
* [`095a3218`](NixOS/nixpkgs@095a321) nodejs-12_x: 12.18.3 -> 12.18.4
* [`deb412f5`](NixOS/nixpkgs@deb412f) maintainers: add dpercy
* [`16beff40`](NixOS/nixpkgs@16beff4) fac-build: init at 0.5.3
* [`8d27394e`](NixOS/nixpkgs@8d27394) ocamlPackages.qcheck-core: init at 0.15
* [`79a0130d`](NixOS/nixpkgs@79a0130) ocamlPackages.qcheck-ounit: init at 0.15
* [`491e8098`](NixOS/nixpkgs@491e809) ocamlPackages.qcheck-alcotest: init at 0.15
* [`10fef19f`](NixOS/nixpkgs@10fef19) ocamlPackages.qcheck: 0.7 → 0.15
* [`52c3214e`](NixOS/nixpkgs@52c3214) lxpanel: 0.9.3 -> 0.10.0
* [`db0e901b`](NixOS/nixpkgs@db0e901) lesspass-cli: 9.0.0 -> 9.1.9
* [`eabba0da`](NixOS/nixpkgs@eabba0d) python36Packages.ipython: 7.17 -> 7.16.1 (downgrade)
* [`389ab459`](NixOS/nixpkgs@389ab45) python3Packages.hickle: disable tests
* [`f1325cdf`](NixOS/nixpkgs@f1325cd) python2Packages.hickle: disable
* [`c6dd555b`](NixOS/nixpkgs@c6dd555) chromaprint: add darwin compatibility
* [`c12cfa42`](NixOS/nixpkgs@c12cfa4) chromaprint: fix derivation
* [`809ed032`](NixOS/nixpkgs@809ed03) scrot: 1.3 -> 1.4
* [`21779aec`](NixOS/nixpkgs@21779ae) matrix-synapse: 1.19.1 -> 1.19.2
* [`1c61a932`](NixOS/nixpkgs@1c61a93) linux/hardened/patches/5.4: 5.4.64.a -> 5.4.65.a
* [`b585d600`](NixOS/nixpkgs@b585d60) linux/hardened/patches/5.8: 5.8.8.a -> 5.8.9.a
* [`d39013b1`](NixOS/nixpkgs@d39013b) micro: 2.0.5 -> 2.0.7
* [`db645087`](NixOS/nixpkgs@db64508) ufraw: mark broken
* [`70399cc1`](NixOS/nixpkgs@70399cc) maintainers: add felschr
* [`b1423ee6`](NixOS/nixpkgs@b1423ee) filebot: init at 4.9.1
* [`60df61b6`](NixOS/nixpkgs@60df61b) mk-python-derivation: document pyproject format
* [`9839c0b2`](NixOS/nixpkgs@9839c0b) verilator: 4.040 -> 4.100
* [`b6b616bb`](NixOS/nixpkgs@b6b616b) androidStudioPackages.beta: 4.1.0.17 -> 4.1.0.18
* [`6a8415c9`](NixOS/nixpkgs@6a8415c) python3Packages.google_api_python_client: 1.11.0 -> 1.12.1
* [`99ae3e93`](NixOS/nixpkgs@99ae3e9) mkvtoolnix: 48.0.0 -> 50.0.0
* [`5e8db880`](NixOS/nixpkgs@5e8db88) transcribe: drop
* [`a4e50bb1`](NixOS/nixpkgs@a4e50bb) Revert "qutebrowser: use qt515 (NixOS/nixpkgs#97586)"
* [`c88f3adb`](NixOS/nixpkgs@c88f3ad) pythonPackages: set qt version by overriding pkgs
* [`2daf5702`](NixOS/nixpkgs@2daf570) qutebrowser: use qt 5.15
* [`00f16b7e`](NixOS/nixpkgs@00f16b7) pythonPackages.pyslurm: mark as broken
* [`bfa35d8d`](NixOS/nixpkgs@bfa35d8) qutebrowser: fixup
* [`d219ce3a`](NixOS/nixpkgs@d219ce3) sky: drop
* [`5a6ec92b`](NixOS/nixpkgs@5a6ec92) eksctl: 0.26.0 -> 0.27.0
* [`e77d4eca`](NixOS/nixpkgs@e77d4ec) react-native-debugger: fix build
* [`9dfcba81`](NixOS/nixpkgs@9dfcba8) jwt-cli: 3.1.0 -> 3.2.1
* [`c603f626`](NixOS/nixpkgs@c603f62) topydo: Don't fail build on tests
* [`0561fdef`](NixOS/nixpkgs@0561fde) xonsh: 0.9.21 -> 0.9.22
* [`35593698`](NixOS/nixpkgs@3559369) ntfy: Switch to python3. Also fixes test failure.
* [`a2f45098`](NixOS/nixpkgs@a2f4509) maintainers.midchildan: update info
* [`bc3d459c`](NixOS/nixpkgs@bc3d459) release-notes: mention cinnamon
* [`eaf667bb`](NixOS/nixpkgs@eaf667b) all-packages.nix: Remove trailing space for qutebrowser
* [`ce0a59cb`](NixOS/nixpkgs@ce0a59c) python3.pkgs.libiio: fix build
* [`ec63faba`](NixOS/nixpkgs@ec63fab) gitAndTools.gh: 0.12.0 -> 1.0.0
* [`1e832429`](NixOS/nixpkgs@1e83242) cri-o: 1.18.3 -> 1.19.0
* [`e363aef4`](NixOS/nixpkgs@e363aef) nixos/cri-o: remove deprecated manage_ns_lifecycle option
* [`eb6e2ac2`](NixOS/nixpkgs@eb6e2ac) terraform_0_13: 0.13.2 -> 0.13.3 (NixOS/nixpkgs#98137)
* [`3f1a356b`](NixOS/nixpkgs@3f1a356) gnomeExtensions.gsconnect: 39 -> 41
* [`af926111`](NixOS/nixpkgs@af92611) Revert "python: gsd: 1.7.0 -> 1.9.3"
* [`4560d7ed`](NixOS/nixpkgs@4560d7e) nixos/calibre-server: Allow multiple libraries
* [`114ad1a7`](NixOS/nixpkgs@114ad1a) react-native-debugger: 0.9.10 -> 0.11.4
* [`501eaab4`](NixOS/nixpkgs@501eaab) react-native-debugger: fix eval
* [`3df04bea`](NixOS/nixpkgs@3df04be) signal-desktop: ringrtc depends on libpulseaudio
* [`8263d6e6`](NixOS/nixpkgs@8263d6e) dnscontrol: 3.2.0 -> 3.3.0
* [`5cd3b2d6`](NixOS/nixpkgs@5cd3b2d) dnscontrol: replace stdenv.lib with lib
* [`139143ca`](NixOS/nixpkgs@139143c) dnscontrol: add SuperSandro2000 as maintainer
* [`cb4b908d`](NixOS/nixpkgs@cb4b908) linux: 4.19.145 -> 4.19.146
* [`e8121e56`](NixOS/nixpkgs@e8121e5) linux: 5.4.65 -> 5.4.66
* [`fa60ed8f`](NixOS/nixpkgs@fa60ed8) linux: 5.8.9 -> 5.8.10
* [`19f22514`](NixOS/nixpkgs@19f2251) pythonPackages.grpcio-tools: add setuptools dependency (NixOS/nixpkgs#98157)
* [`9c73e34d`](NixOS/nixpkgs@9c73e34) kicad: remove gettext from buildInputs, add to nativeBuildInputs
* [`35846440`](NixOS/nixpkgs@3584644) cloc: 1.86 -> 1.88
* [`d347b85c`](NixOS/nixpkgs@d347b85) linuxPackages.exfat-nofuse: lazier assertion (/cc NixOS/nixpkgs#97577)
* [`72b9660d`](NixOS/nixpkgs@72b9660) _3270font: 2.0.4 -> 2.1.0 (NixOS/nixpkgs#98156)
* [`5fa0612d`](NixOS/nixpkgs@5fa0612) cpuid: init at 20200427
* [`6dccacd3`](NixOS/nixpkgs@6dccacd) maintainers: Add NobbZ as a maintainer
* [`76e3103b`](NixOS/nixpkgs@76e3103) exercism: Add NobbZ as maintainer
* [`19f7f150`](NixOS/nixpkgs@19f7f15) solfege: fix build with texinfo 6.7
* [`948d8289`](NixOS/nixpkgs@948d828) uqm: Fix purity checking error during config phase
* [`d8511406`](NixOS/nixpkgs@d851140) trojita: disable withI18n by default
* [`deea9b8a`](NixOS/nixpkgs@deea9b8) linux/hardened/patches/5.8: 5.8.9.a -> 5.8.10.a
* [`c56e8e73`](NixOS/nixpkgs@c56e8e7) nodePackages.patch-package: init at 6.2.2
* [`524755d3`](NixOS/nixpkgs@524755d) embree: init at 3.11.0
* [`6b74f99a`](NixOS/nixpkgs@6b74f99) blender: 2.83.5 -> 2.90.0
* [`cfb9acad`](NixOS/nixpkgs@cfb9aca) gopls: 0.4.4 -> 0.5.0 (NixOS/nixpkgs#98182)
* [`e3c1b878`](NixOS/nixpkgs@e3c1b87) python3Packages.fluent-logger: relax version for msgpack
* [`20472523`](NixOS/nixpkgs@2047252) python3.pkgs.cartopy: 0.17 -> 0.18
* [`5f0f2b85`](NixOS/nixpkgs@5f0f2b8) python3Packages.requests-aws4auth: fix build
* [`6a4e7859`](NixOS/nixpkgs@6a4e785) python3Packages.word2vec: fix build and tests
* [`aa49a711`](NixOS/nixpkgs@aa49a71) vimPlugins: update
* [`93fd4b5c`](NixOS/nixpkgs@93fd4b5) vimPlugins.vim-nerdtree-syntax-highlight: init at 2020-07-19
* [`e2b99c07`](NixOS/nixpkgs@e2b99c0) LTS Haskell 16.15
* [`0be74333`](NixOS/nixpkgs@0be7433) hackage2nix: disable failing builds to fix evaluation on Hydra
* [`eb523e86`](NixOS/nixpkgs@eb523e8) hackage-packages.nix: automatic Haskell package set update
* [`f40afea4`](NixOS/nixpkgs@f40afea) haskellPackages.sbv: fix tests
* [`59617bc1`](NixOS/nixpkgs@59617bc) haskellPackages.ghcide: Fix build
* [`ae73fa0d`](NixOS/nixpkgs@ae73fa0) haskellPackages.ghc.withPackages: Remove obsolete ghcide wrapper
* [`2bf095d0`](NixOS/nixpkgs@2bf095d) haskellPackages.hnix: Fix build
* [`d0541e2e`](NixOS/nixpkgs@d0541e2) haskell-pandoc-plot: mark broken because of failing test suite
* [`7567bd6d`](NixOS/nixpkgs@7567bd6) python3Packages.irc: fix build
* [`a9162ffd`](NixOS/nixpkgs@a9162ff) python3Packages.runway-python: add missing deps
* [`2a35f664`](NixOS/nixpkgs@2a35f66) python3Packages.lightparam: fix source and deps
github-actions bot added a commit to pbogdan/nix-hie that referenced this pull request Sep 21, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@441a7da...2a35f664](NixOS/nixpkgs@441a7da...2a35f66)

* [`b5212f8b`](NixOS/nixpkgs@b5212f8) linux: remove dependency to utillinuxMinimal
* [`e560459c`](NixOS/nixpkgs@e560459) Revert "utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels"
* [`5ceea570`](NixOS/nixpkgs@5ceea57) Revert "utils.bash: also "fix" cc-wrapper and pkg-config-wrapper"
* [`31fed01d`](NixOS/nixpkgs@31fed01) vdr-epgsearch: 2.4.0 -> 20191202
* [`73653fe5`](NixOS/nixpkgs@73653fe) vdr-vaapidevice: 0.7.0 -> 20190526
* [`9db2ca30`](NixOS/nixpkgs@9db2ca3) gambatte: add alsa dependency, 2016-05-03 -> 2020-03-14
* [`bbd7ba6a`](NixOS/nixpkgs@bbd7ba6) linuxPackages.exfat-nofuse: 2019-09-06 -> 2020-04-15
* [`1966a0a4`](NixOS/nixpkgs@1966a0a) opencv: enable videoio on darwin
* [`90f01b1c`](NixOS/nixpkgs@90f01b1) bcachefs-tools: disable tests
* [`920441f9`](NixOS/nixpkgs@920441f) bcachefs-tools: 2020-04-04 -> 2020-08-25
* [`3cc3e864`](NixOS/nixpkgs@3cc3e86) linux_testing_bcachefs: 5.3 -> 5.8
* [`d284d320`](NixOS/nixpkgs@d284d32) nixos/dmidecode: added recommended patches
* [`c1e96ff7`](NixOS/nixpkgs@c1e96ff) release*: Support nixpkgsArgs for all release-*.nix files
* [`4ed3c35f`](NixOS/nixpkgs@4ed3c35) microserver: init at 0.1.8
* [`9092c614`](NixOS/nixpkgs@9092c61) nginxModules.naxsi: 2020.08.15 -> 2020.09.10
* [`6f32af17`](NixOS/nixpkgs@6f32af1) nginxModules.opentracing: v0.9.0 -> v0.10.0
* [`96311ca1`](NixOS/nixpkgs@96311ca) nginxModules.shibboleth: 2020.08.12 -> 2020.09.04
* [`79906c49`](NixOS/nixpkgs@79906c4) nginxModules.aws-auth: fix warning message
* [`2724f7be`](NixOS/nixpkgs@2724f7b) nbxplorer: init at 2.1.42
* [`2f55d6f6`](NixOS/nixpkgs@2f55d6f) btcpayserver: init at 1.0.5.4
* [`e2c8ae98`](NixOS/nixpkgs@e2c8ae9) softmaker-office: 1018 -> 1020
* [`9be28ee3`](NixOS/nixpkgs@9be28ee) libxsmm: 1.15 -> 1.16.1, improve derivation
* [`8cb1e75e`](NixOS/nixpkgs@8cb1e75) wordgrinder: fix build
* [`9f33ab62`](NixOS/nixpkgs@9f33ab6) nixos/testing: Add support for specialArgs
* [`aff7ee12`](NixOS/nixpkgs@aff7ee1) coursier: 2.0.0-RC6-25 -> 2.0.0-RC6-26
* [`c8ccaebf`](NixOS/nixpkgs@c8ccaeb) nodePackages.diagnostic-languageserver: init at 1.7.1
* [`19b5ef48`](NixOS/nixpkgs@19b5ef4) nixos/plasma5: Fix build with config.services.colord.enable = true
* [`6d0c57fb`](NixOS/nixpkgs@6d0c57f) gitAndTools.git-machete: 2.15.4 -> 2.15.5
* [`7a27aefc`](NixOS/nixpkgs@7a27aef) perlPackages.AstroFITSHeader: init at 3.07
* [`083041a6`](NixOS/nixpkgs@083041a) maintainers: add StephenWithPH
* [`fb779db8`](NixOS/nixpkgs@fb779db) go-swag: init at 1.6.7
* [`88363a87`](NixOS/nixpkgs@88363a8) matomo: 3.14.0 -> 3.14.1
* [`47ba35d6`](NixOS/nixpkgs@47ba35d) unnethack: 5.2.0 -> 5.3.2 (NixOS/nixpkgs#97595)
* [`9511b329`](NixOS/nixpkgs@9511b32) vscode-extensions.ms-python.python: 2020.7.96456 -> 2020.8.103604
* [`0617d9cf`](NixOS/nixpkgs@0617d9c) vimPlugins: update
* [`89c781cc`](NixOS/nixpkgs@89c781c) vimPlugins.vim-ocaml: init at 2020-08-20
* [`be33b546`](NixOS/nixpkgs@be33b54) maintainers/build: skip packages that don't evaluate
* [`c1d2464f`](NixOS/nixpkgs@c1d2464) shadowsocks-libev: 3.3.4 -> 3.3.5
* [`b0b730de`](NixOS/nixpkgs@b0b730d) sops: 3.6.0 -> 3.6.1
* [`ce065c62`](NixOS/nixpkgs@ce065c6) cli-visualizer: Fix build
* [`715790e2`](NixOS/nixpkgs@715790e) _1password-gui: 0.8.5-1 -> 0.8.6-2
* [`c15bcdd9`](NixOS/nixpkgs@c15bcdd) percona-server: 5.6.43-84.3 -> 5.6.49-89.0 (NixOS/nixpkgs#97923)
* [`02a7dde9`](NixOS/nixpkgs@02a7dde) mbtileserver: init at 0.6.1
* [`4a56effd`](NixOS/nixpkgs@4a56eff) redo-sh: 2.0.3 → 4.0.3
* [`c3be7658`](NixOS/nixpkgs@c3be765) nixos/xserver: clean up the useXFS option
* [`b632ca69`](NixOS/nixpkgs@b632ca6) citrix_workspace: add 20.09.0
* [`5b19fa94`](NixOS/nixpkgs@5b19fa9) jitsi-meet-electron: 2.2.0 -> 2.3.1
* [`fb1ff72f`](NixOS/nixpkgs@fb1ff72) perlPackages.PDL: init at 2.022
* [`5684d011`](NixOS/nixpkgs@5684d01) postman: 7.31.1 -> 7.32.0
* [`911c641a`](NixOS/nixpkgs@911c641) oh-my-zsh: 2020-09-12 -> 2020-09-14
* [`e469ddc9`](NixOS/nixpkgs@e469ddc) vcv-rack: fix broken pfft reference
* [`2b55bb43`](NixOS/nixpkgs@2b55bb4) python27.pkgs.joblib: Disable package
* [`43d588b0`](NixOS/nixpkgs@43d588b) python3Packages.ihatemoney: disable sandbox unfriendly tests, fix passthru
* [`20034954`](NixOS/nixpkgs@2003495) python3Packages.graphite_beacon: fix deps, add nixos test
* [`07660b28`](NixOS/nixpkgs@07660b2) streamlit: fix build
* [`dd9c0cf6`](NixOS/nixpkgs@dd9c0cf) maintainers: add mlvzk
* [`92ba6108`](NixOS/nixpkgs@92ba610) manix: init at 0.6.2
* [`0051c0a4`](NixOS/nixpkgs@0051c0a) pythonPackages.bcrypt: use 3.1.x for python older than 3.6
* [`5f4b880b`](NixOS/nixpkgs@5f4b880) python2Packages.trytond: disable for python2
* [`c35b6b3b`](NixOS/nixpkgs@c35b6b3) texstudio: 3.0.0 -> 3.0.1
* [`4d111fdf`](NixOS/nixpkgs@4d111fd) pythonPackages.sievelib: fix build by adding patch
* [`ca682af5`](NixOS/nixpkgs@ca682af) cod: init at unstable-2020-09-10
* [`ffc3f822`](NixOS/nixpkgs@ffc3f82) saga: use proj 6
* [`d92b2463`](NixOS/nixpkgs@d92b246) josm: 16812 -> 17013
* [`b4676300`](NixOS/nixpkgs@b467630) f2fs-tools: 1.13.0 -> 1.14.0
* [`c80258af`](NixOS/nixpkgs@c80258a) gist: 5.1.0 -> 6.0.0 (NixOS/nixpkgs#98053)
* [`afeed1fe`](NixOS/nixpkgs@afeed1f) nodejs-10_x: 10.22.0 -> 10.22.1
* [`095a3218`](NixOS/nixpkgs@095a321) nodejs-12_x: 12.18.3 -> 12.18.4
* [`deb412f5`](NixOS/nixpkgs@deb412f) maintainers: add dpercy
* [`16beff40`](NixOS/nixpkgs@16beff4) fac-build: init at 0.5.3
* [`8d27394e`](NixOS/nixpkgs@8d27394) ocamlPackages.qcheck-core: init at 0.15
* [`79a0130d`](NixOS/nixpkgs@79a0130) ocamlPackages.qcheck-ounit: init at 0.15
* [`491e8098`](NixOS/nixpkgs@491e809) ocamlPackages.qcheck-alcotest: init at 0.15
* [`10fef19f`](NixOS/nixpkgs@10fef19) ocamlPackages.qcheck: 0.7 → 0.15
* [`52c3214e`](NixOS/nixpkgs@52c3214) lxpanel: 0.9.3 -> 0.10.0
* [`db0e901b`](NixOS/nixpkgs@db0e901) lesspass-cli: 9.0.0 -> 9.1.9
* [`eabba0da`](NixOS/nixpkgs@eabba0d) python36Packages.ipython: 7.17 -> 7.16.1 (downgrade)
* [`389ab459`](NixOS/nixpkgs@389ab45) python3Packages.hickle: disable tests
* [`f1325cdf`](NixOS/nixpkgs@f1325cd) python2Packages.hickle: disable
* [`c6dd555b`](NixOS/nixpkgs@c6dd555) chromaprint: add darwin compatibility
* [`c12cfa42`](NixOS/nixpkgs@c12cfa4) chromaprint: fix derivation
* [`809ed032`](NixOS/nixpkgs@809ed03) scrot: 1.3 -> 1.4
* [`21779aec`](NixOS/nixpkgs@21779ae) matrix-synapse: 1.19.1 -> 1.19.2
* [`1c61a932`](NixOS/nixpkgs@1c61a93) linux/hardened/patches/5.4: 5.4.64.a -> 5.4.65.a
* [`b585d600`](NixOS/nixpkgs@b585d60) linux/hardened/patches/5.8: 5.8.8.a -> 5.8.9.a
* [`d39013b1`](NixOS/nixpkgs@d39013b) micro: 2.0.5 -> 2.0.7
* [`db645087`](NixOS/nixpkgs@db64508) ufraw: mark broken
* [`70399cc1`](NixOS/nixpkgs@70399cc) maintainers: add felschr
* [`b1423ee6`](NixOS/nixpkgs@b1423ee) filebot: init at 4.9.1
* [`60df61b6`](NixOS/nixpkgs@60df61b) mk-python-derivation: document pyproject format
* [`9839c0b2`](NixOS/nixpkgs@9839c0b) verilator: 4.040 -> 4.100
* [`b6b616bb`](NixOS/nixpkgs@b6b616b) androidStudioPackages.beta: 4.1.0.17 -> 4.1.0.18
* [`6a8415c9`](NixOS/nixpkgs@6a8415c) python3Packages.google_api_python_client: 1.11.0 -> 1.12.1
* [`99ae3e93`](NixOS/nixpkgs@99ae3e9) mkvtoolnix: 48.0.0 -> 50.0.0
* [`5e8db880`](NixOS/nixpkgs@5e8db88) transcribe: drop
* [`a4e50bb1`](NixOS/nixpkgs@a4e50bb) Revert "qutebrowser: use qt515 (NixOS/nixpkgs#97586)"
* [`c88f3adb`](NixOS/nixpkgs@c88f3ad) pythonPackages: set qt version by overriding pkgs
* [`2daf5702`](NixOS/nixpkgs@2daf570) qutebrowser: use qt 5.15
* [`00f16b7e`](NixOS/nixpkgs@00f16b7) pythonPackages.pyslurm: mark as broken
* [`bfa35d8d`](NixOS/nixpkgs@bfa35d8) qutebrowser: fixup
* [`d219ce3a`](NixOS/nixpkgs@d219ce3) sky: drop
* [`5a6ec92b`](NixOS/nixpkgs@5a6ec92) eksctl: 0.26.0 -> 0.27.0
* [`e77d4eca`](NixOS/nixpkgs@e77d4ec) react-native-debugger: fix build
* [`9dfcba81`](NixOS/nixpkgs@9dfcba8) jwt-cli: 3.1.0 -> 3.2.1
* [`c603f626`](NixOS/nixpkgs@c603f62) topydo: Don't fail build on tests
* [`0561fdef`](NixOS/nixpkgs@0561fde) xonsh: 0.9.21 -> 0.9.22
* [`35593698`](NixOS/nixpkgs@3559369) ntfy: Switch to python3. Also fixes test failure.
* [`a2f45098`](NixOS/nixpkgs@a2f4509) maintainers.midchildan: update info
* [`bc3d459c`](NixOS/nixpkgs@bc3d459) release-notes: mention cinnamon
* [`eaf667bb`](NixOS/nixpkgs@eaf667b) all-packages.nix: Remove trailing space for qutebrowser
* [`ce0a59cb`](NixOS/nixpkgs@ce0a59c) python3.pkgs.libiio: fix build
* [`ec63faba`](NixOS/nixpkgs@ec63fab) gitAndTools.gh: 0.12.0 -> 1.0.0
* [`1e832429`](NixOS/nixpkgs@1e83242) cri-o: 1.18.3 -> 1.19.0
* [`e363aef4`](NixOS/nixpkgs@e363aef) nixos/cri-o: remove deprecated manage_ns_lifecycle option
* [`eb6e2ac2`](NixOS/nixpkgs@eb6e2ac) terraform_0_13: 0.13.2 -> 0.13.3 (NixOS/nixpkgs#98137)
* [`3f1a356b`](NixOS/nixpkgs@3f1a356) gnomeExtensions.gsconnect: 39 -> 41
* [`af926111`](NixOS/nixpkgs@af92611) Revert "python: gsd: 1.7.0 -> 1.9.3"
* [`4560d7ed`](NixOS/nixpkgs@4560d7e) nixos/calibre-server: Allow multiple libraries
* [`114ad1a7`](NixOS/nixpkgs@114ad1a) react-native-debugger: 0.9.10 -> 0.11.4
* [`501eaab4`](NixOS/nixpkgs@501eaab) react-native-debugger: fix eval
* [`3df04bea`](NixOS/nixpkgs@3df04be) signal-desktop: ringrtc depends on libpulseaudio
* [`8263d6e6`](NixOS/nixpkgs@8263d6e) dnscontrol: 3.2.0 -> 3.3.0
* [`5cd3b2d6`](NixOS/nixpkgs@5cd3b2d) dnscontrol: replace stdenv.lib with lib
* [`139143ca`](NixOS/nixpkgs@139143c) dnscontrol: add SuperSandro2000 as maintainer
* [`cb4b908d`](NixOS/nixpkgs@cb4b908) linux: 4.19.145 -> 4.19.146
* [`e8121e56`](NixOS/nixpkgs@e8121e5) linux: 5.4.65 -> 5.4.66
* [`fa60ed8f`](NixOS/nixpkgs@fa60ed8) linux: 5.8.9 -> 5.8.10
* [`19f22514`](NixOS/nixpkgs@19f2251) pythonPackages.grpcio-tools: add setuptools dependency (NixOS/nixpkgs#98157)
* [`9c73e34d`](NixOS/nixpkgs@9c73e34) kicad: remove gettext from buildInputs, add to nativeBuildInputs
* [`35846440`](NixOS/nixpkgs@3584644) cloc: 1.86 -> 1.88
* [`d347b85c`](NixOS/nixpkgs@d347b85) linuxPackages.exfat-nofuse: lazier assertion (/cc NixOS/nixpkgs#97577)
* [`72b9660d`](NixOS/nixpkgs@72b9660) _3270font: 2.0.4 -> 2.1.0 (NixOS/nixpkgs#98156)
* [`5fa0612d`](NixOS/nixpkgs@5fa0612) cpuid: init at 20200427
* [`6dccacd3`](NixOS/nixpkgs@6dccacd) maintainers: Add NobbZ as a maintainer
* [`76e3103b`](NixOS/nixpkgs@76e3103) exercism: Add NobbZ as maintainer
* [`19f7f150`](NixOS/nixpkgs@19f7f15) solfege: fix build with texinfo 6.7
* [`948d8289`](NixOS/nixpkgs@948d828) uqm: Fix purity checking error during config phase
* [`d8511406`](NixOS/nixpkgs@d851140) trojita: disable withI18n by default
* [`deea9b8a`](NixOS/nixpkgs@deea9b8) linux/hardened/patches/5.8: 5.8.9.a -> 5.8.10.a
* [`c56e8e73`](NixOS/nixpkgs@c56e8e7) nodePackages.patch-package: init at 6.2.2
* [`524755d3`](NixOS/nixpkgs@524755d) embree: init at 3.11.0
* [`6b74f99a`](NixOS/nixpkgs@6b74f99) blender: 2.83.5 -> 2.90.0
* [`cfb9acad`](NixOS/nixpkgs@cfb9aca) gopls: 0.4.4 -> 0.5.0 (NixOS/nixpkgs#98182)
* [`e3c1b878`](NixOS/nixpkgs@e3c1b87) python3Packages.fluent-logger: relax version for msgpack
* [`20472523`](NixOS/nixpkgs@2047252) python3.pkgs.cartopy: 0.17 -> 0.18
* [`5f0f2b85`](NixOS/nixpkgs@5f0f2b8) python3Packages.requests-aws4auth: fix build
* [`6a4e7859`](NixOS/nixpkgs@6a4e785) python3Packages.word2vec: fix build and tests
* [`aa49a711`](NixOS/nixpkgs@aa49a71) vimPlugins: update
* [`93fd4b5c`](NixOS/nixpkgs@93fd4b5) vimPlugins.vim-nerdtree-syntax-highlight: init at 2020-07-19
* [`e2b99c07`](NixOS/nixpkgs@e2b99c0) LTS Haskell 16.15
* [`0be74333`](NixOS/nixpkgs@0be7433) hackage2nix: disable failing builds to fix evaluation on Hydra
* [`eb523e86`](NixOS/nixpkgs@eb523e8) hackage-packages.nix: automatic Haskell package set update
* [`f40afea4`](NixOS/nixpkgs@f40afea) haskellPackages.sbv: fix tests
* [`59617bc1`](NixOS/nixpkgs@59617bc) haskellPackages.ghcide: Fix build
* [`ae73fa0d`](NixOS/nixpkgs@ae73fa0) haskellPackages.ghc.withPackages: Remove obsolete ghcide wrapper
* [`2bf095d0`](NixOS/nixpkgs@2bf095d) haskellPackages.hnix: Fix build
* [`d0541e2e`](NixOS/nixpkgs@d0541e2) haskell-pandoc-plot: mark broken because of failing test suite
* [`7567bd6d`](NixOS/nixpkgs@7567bd6) python3Packages.irc: fix build
* [`a9162ffd`](NixOS/nixpkgs@a9162ff) python3Packages.runway-python: add missing deps
* [`2a35f664`](NixOS/nixpkgs@2a35f66) python3Packages.lightparam: fix source and deps
github-actions bot added a commit to pbogdan/tag that referenced this pull request Sep 21, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@441a7da...2a35f664](NixOS/nixpkgs@441a7da...2a35f66)

* [`b5212f8b`](NixOS/nixpkgs@b5212f8) linux: remove dependency to utillinuxMinimal
* [`e560459c`](NixOS/nixpkgs@e560459) Revert "utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels"
* [`5ceea570`](NixOS/nixpkgs@5ceea57) Revert "utils.bash: also "fix" cc-wrapper and pkg-config-wrapper"
* [`31fed01d`](NixOS/nixpkgs@31fed01) vdr-epgsearch: 2.4.0 -> 20191202
* [`73653fe5`](NixOS/nixpkgs@73653fe) vdr-vaapidevice: 0.7.0 -> 20190526
* [`9db2ca30`](NixOS/nixpkgs@9db2ca3) gambatte: add alsa dependency, 2016-05-03 -> 2020-03-14
* [`bbd7ba6a`](NixOS/nixpkgs@bbd7ba6) linuxPackages.exfat-nofuse: 2019-09-06 -> 2020-04-15
* [`1966a0a4`](NixOS/nixpkgs@1966a0a) opencv: enable videoio on darwin
* [`90f01b1c`](NixOS/nixpkgs@90f01b1) bcachefs-tools: disable tests
* [`920441f9`](NixOS/nixpkgs@920441f) bcachefs-tools: 2020-04-04 -> 2020-08-25
* [`3cc3e864`](NixOS/nixpkgs@3cc3e86) linux_testing_bcachefs: 5.3 -> 5.8
* [`d284d320`](NixOS/nixpkgs@d284d32) nixos/dmidecode: added recommended patches
* [`c1e96ff7`](NixOS/nixpkgs@c1e96ff) release*: Support nixpkgsArgs for all release-*.nix files
* [`4ed3c35f`](NixOS/nixpkgs@4ed3c35) microserver: init at 0.1.8
* [`9092c614`](NixOS/nixpkgs@9092c61) nginxModules.naxsi: 2020.08.15 -> 2020.09.10
* [`6f32af17`](NixOS/nixpkgs@6f32af1) nginxModules.opentracing: v0.9.0 -> v0.10.0
* [`96311ca1`](NixOS/nixpkgs@96311ca) nginxModules.shibboleth: 2020.08.12 -> 2020.09.04
* [`79906c49`](NixOS/nixpkgs@79906c4) nginxModules.aws-auth: fix warning message
* [`2724f7be`](NixOS/nixpkgs@2724f7b) nbxplorer: init at 2.1.42
* [`2f55d6f6`](NixOS/nixpkgs@2f55d6f) btcpayserver: init at 1.0.5.4
* [`e2c8ae98`](NixOS/nixpkgs@e2c8ae9) softmaker-office: 1018 -> 1020
* [`9be28ee3`](NixOS/nixpkgs@9be28ee) libxsmm: 1.15 -> 1.16.1, improve derivation
* [`8cb1e75e`](NixOS/nixpkgs@8cb1e75) wordgrinder: fix build
* [`9f33ab62`](NixOS/nixpkgs@9f33ab6) nixos/testing: Add support for specialArgs
* [`aff7ee12`](NixOS/nixpkgs@aff7ee1) coursier: 2.0.0-RC6-25 -> 2.0.0-RC6-26
* [`c8ccaebf`](NixOS/nixpkgs@c8ccaeb) nodePackages.diagnostic-languageserver: init at 1.7.1
* [`19b5ef48`](NixOS/nixpkgs@19b5ef4) nixos/plasma5: Fix build with config.services.colord.enable = true
* [`6d0c57fb`](NixOS/nixpkgs@6d0c57f) gitAndTools.git-machete: 2.15.4 -> 2.15.5
* [`7a27aefc`](NixOS/nixpkgs@7a27aef) perlPackages.AstroFITSHeader: init at 3.07
* [`083041a6`](NixOS/nixpkgs@083041a) maintainers: add StephenWithPH
* [`fb779db8`](NixOS/nixpkgs@fb779db) go-swag: init at 1.6.7
* [`88363a87`](NixOS/nixpkgs@88363a8) matomo: 3.14.0 -> 3.14.1
* [`47ba35d6`](NixOS/nixpkgs@47ba35d) unnethack: 5.2.0 -> 5.3.2 (NixOS/nixpkgs#97595)
* [`9511b329`](NixOS/nixpkgs@9511b32) vscode-extensions.ms-python.python: 2020.7.96456 -> 2020.8.103604
* [`0617d9cf`](NixOS/nixpkgs@0617d9c) vimPlugins: update
* [`89c781cc`](NixOS/nixpkgs@89c781c) vimPlugins.vim-ocaml: init at 2020-08-20
* [`be33b546`](NixOS/nixpkgs@be33b54) maintainers/build: skip packages that don't evaluate
* [`c1d2464f`](NixOS/nixpkgs@c1d2464) shadowsocks-libev: 3.3.4 -> 3.3.5
* [`b0b730de`](NixOS/nixpkgs@b0b730d) sops: 3.6.0 -> 3.6.1
* [`ce065c62`](NixOS/nixpkgs@ce065c6) cli-visualizer: Fix build
* [`715790e2`](NixOS/nixpkgs@715790e) _1password-gui: 0.8.5-1 -> 0.8.6-2
* [`c15bcdd9`](NixOS/nixpkgs@c15bcdd) percona-server: 5.6.43-84.3 -> 5.6.49-89.0 (NixOS/nixpkgs#97923)
* [`02a7dde9`](NixOS/nixpkgs@02a7dde) mbtileserver: init at 0.6.1
* [`4a56effd`](NixOS/nixpkgs@4a56eff) redo-sh: 2.0.3 → 4.0.3
* [`c3be7658`](NixOS/nixpkgs@c3be765) nixos/xserver: clean up the useXFS option
* [`b632ca69`](NixOS/nixpkgs@b632ca6) citrix_workspace: add 20.09.0
* [`5b19fa94`](NixOS/nixpkgs@5b19fa9) jitsi-meet-electron: 2.2.0 -> 2.3.1
* [`fb1ff72f`](NixOS/nixpkgs@fb1ff72) perlPackages.PDL: init at 2.022
* [`5684d011`](NixOS/nixpkgs@5684d01) postman: 7.31.1 -> 7.32.0
* [`911c641a`](NixOS/nixpkgs@911c641) oh-my-zsh: 2020-09-12 -> 2020-09-14
* [`e469ddc9`](NixOS/nixpkgs@e469ddc) vcv-rack: fix broken pfft reference
* [`2b55bb43`](NixOS/nixpkgs@2b55bb4) python27.pkgs.joblib: Disable package
* [`43d588b0`](NixOS/nixpkgs@43d588b) python3Packages.ihatemoney: disable sandbox unfriendly tests, fix passthru
* [`20034954`](NixOS/nixpkgs@2003495) python3Packages.graphite_beacon: fix deps, add nixos test
* [`07660b28`](NixOS/nixpkgs@07660b2) streamlit: fix build
* [`dd9c0cf6`](NixOS/nixpkgs@dd9c0cf) maintainers: add mlvzk
* [`92ba6108`](NixOS/nixpkgs@92ba610) manix: init at 0.6.2
* [`0051c0a4`](NixOS/nixpkgs@0051c0a) pythonPackages.bcrypt: use 3.1.x for python older than 3.6
* [`5f4b880b`](NixOS/nixpkgs@5f4b880) python2Packages.trytond: disable for python2
* [`c35b6b3b`](NixOS/nixpkgs@c35b6b3) texstudio: 3.0.0 -> 3.0.1
* [`4d111fdf`](NixOS/nixpkgs@4d111fd) pythonPackages.sievelib: fix build by adding patch
* [`ca682af5`](NixOS/nixpkgs@ca682af) cod: init at unstable-2020-09-10
* [`ffc3f822`](NixOS/nixpkgs@ffc3f82) saga: use proj 6
* [`d92b2463`](NixOS/nixpkgs@d92b246) josm: 16812 -> 17013
* [`b4676300`](NixOS/nixpkgs@b467630) f2fs-tools: 1.13.0 -> 1.14.0
* [`c80258af`](NixOS/nixpkgs@c80258a) gist: 5.1.0 -> 6.0.0 (NixOS/nixpkgs#98053)
* [`afeed1fe`](NixOS/nixpkgs@afeed1f) nodejs-10_x: 10.22.0 -> 10.22.1
* [`095a3218`](NixOS/nixpkgs@095a321) nodejs-12_x: 12.18.3 -> 12.18.4
* [`deb412f5`](NixOS/nixpkgs@deb412f) maintainers: add dpercy
* [`16beff40`](NixOS/nixpkgs@16beff4) fac-build: init at 0.5.3
* [`8d27394e`](NixOS/nixpkgs@8d27394) ocamlPackages.qcheck-core: init at 0.15
* [`79a0130d`](NixOS/nixpkgs@79a0130) ocamlPackages.qcheck-ounit: init at 0.15
* [`491e8098`](NixOS/nixpkgs@491e809) ocamlPackages.qcheck-alcotest: init at 0.15
* [`10fef19f`](NixOS/nixpkgs@10fef19) ocamlPackages.qcheck: 0.7 → 0.15
* [`52c3214e`](NixOS/nixpkgs@52c3214) lxpanel: 0.9.3 -> 0.10.0
* [`db0e901b`](NixOS/nixpkgs@db0e901) lesspass-cli: 9.0.0 -> 9.1.9
* [`eabba0da`](NixOS/nixpkgs@eabba0d) python36Packages.ipython: 7.17 -> 7.16.1 (downgrade)
* [`389ab459`](NixOS/nixpkgs@389ab45) python3Packages.hickle: disable tests
* [`f1325cdf`](NixOS/nixpkgs@f1325cd) python2Packages.hickle: disable
* [`c6dd555b`](NixOS/nixpkgs@c6dd555) chromaprint: add darwin compatibility
* [`c12cfa42`](NixOS/nixpkgs@c12cfa4) chromaprint: fix derivation
* [`809ed032`](NixOS/nixpkgs@809ed03) scrot: 1.3 -> 1.4
* [`21779aec`](NixOS/nixpkgs@21779ae) matrix-synapse: 1.19.1 -> 1.19.2
* [`1c61a932`](NixOS/nixpkgs@1c61a93) linux/hardened/patches/5.4: 5.4.64.a -> 5.4.65.a
* [`b585d600`](NixOS/nixpkgs@b585d60) linux/hardened/patches/5.8: 5.8.8.a -> 5.8.9.a
* [`d39013b1`](NixOS/nixpkgs@d39013b) micro: 2.0.5 -> 2.0.7
* [`db645087`](NixOS/nixpkgs@db64508) ufraw: mark broken
* [`70399cc1`](NixOS/nixpkgs@70399cc) maintainers: add felschr
* [`b1423ee6`](NixOS/nixpkgs@b1423ee) filebot: init at 4.9.1
* [`60df61b6`](NixOS/nixpkgs@60df61b) mk-python-derivation: document pyproject format
* [`9839c0b2`](NixOS/nixpkgs@9839c0b) verilator: 4.040 -> 4.100
* [`b6b616bb`](NixOS/nixpkgs@b6b616b) androidStudioPackages.beta: 4.1.0.17 -> 4.1.0.18
* [`6a8415c9`](NixOS/nixpkgs@6a8415c) python3Packages.google_api_python_client: 1.11.0 -> 1.12.1
* [`99ae3e93`](NixOS/nixpkgs@99ae3e9) mkvtoolnix: 48.0.0 -> 50.0.0
* [`5e8db880`](NixOS/nixpkgs@5e8db88) transcribe: drop
* [`a4e50bb1`](NixOS/nixpkgs@a4e50bb) Revert "qutebrowser: use qt515 (NixOS/nixpkgs#97586)"
* [`c88f3adb`](NixOS/nixpkgs@c88f3ad) pythonPackages: set qt version by overriding pkgs
* [`2daf5702`](NixOS/nixpkgs@2daf570) qutebrowser: use qt 5.15
* [`00f16b7e`](NixOS/nixpkgs@00f16b7) pythonPackages.pyslurm: mark as broken
* [`bfa35d8d`](NixOS/nixpkgs@bfa35d8) qutebrowser: fixup
* [`d219ce3a`](NixOS/nixpkgs@d219ce3) sky: drop
* [`5a6ec92b`](NixOS/nixpkgs@5a6ec92) eksctl: 0.26.0 -> 0.27.0
* [`e77d4eca`](NixOS/nixpkgs@e77d4ec) react-native-debugger: fix build
* [`9dfcba81`](NixOS/nixpkgs@9dfcba8) jwt-cli: 3.1.0 -> 3.2.1
* [`c603f626`](NixOS/nixpkgs@c603f62) topydo: Don't fail build on tests
* [`0561fdef`](NixOS/nixpkgs@0561fde) xonsh: 0.9.21 -> 0.9.22
* [`35593698`](NixOS/nixpkgs@3559369) ntfy: Switch to python3. Also fixes test failure.
* [`a2f45098`](NixOS/nixpkgs@a2f4509) maintainers.midchildan: update info
* [`bc3d459c`](NixOS/nixpkgs@bc3d459) release-notes: mention cinnamon
* [`eaf667bb`](NixOS/nixpkgs@eaf667b) all-packages.nix: Remove trailing space for qutebrowser
* [`ce0a59cb`](NixOS/nixpkgs@ce0a59c) python3.pkgs.libiio: fix build
* [`ec63faba`](NixOS/nixpkgs@ec63fab) gitAndTools.gh: 0.12.0 -> 1.0.0
* [`1e832429`](NixOS/nixpkgs@1e83242) cri-o: 1.18.3 -> 1.19.0
* [`e363aef4`](NixOS/nixpkgs@e363aef) nixos/cri-o: remove deprecated manage_ns_lifecycle option
* [`eb6e2ac2`](NixOS/nixpkgs@eb6e2ac) terraform_0_13: 0.13.2 -> 0.13.3 (NixOS/nixpkgs#98137)
* [`3f1a356b`](NixOS/nixpkgs@3f1a356) gnomeExtensions.gsconnect: 39 -> 41
* [`af926111`](NixOS/nixpkgs@af92611) Revert "python: gsd: 1.7.0 -> 1.9.3"
* [`4560d7ed`](NixOS/nixpkgs@4560d7e) nixos/calibre-server: Allow multiple libraries
* [`114ad1a7`](NixOS/nixpkgs@114ad1a) react-native-debugger: 0.9.10 -> 0.11.4
* [`501eaab4`](NixOS/nixpkgs@501eaab) react-native-debugger: fix eval
* [`3df04bea`](NixOS/nixpkgs@3df04be) signal-desktop: ringrtc depends on libpulseaudio
* [`8263d6e6`](NixOS/nixpkgs@8263d6e) dnscontrol: 3.2.0 -> 3.3.0
* [`5cd3b2d6`](NixOS/nixpkgs@5cd3b2d) dnscontrol: replace stdenv.lib with lib
* [`139143ca`](NixOS/nixpkgs@139143c) dnscontrol: add SuperSandro2000 as maintainer
* [`cb4b908d`](NixOS/nixpkgs@cb4b908) linux: 4.19.145 -> 4.19.146
* [`e8121e56`](NixOS/nixpkgs@e8121e5) linux: 5.4.65 -> 5.4.66
* [`fa60ed8f`](NixOS/nixpkgs@fa60ed8) linux: 5.8.9 -> 5.8.10
* [`19f22514`](NixOS/nixpkgs@19f2251) pythonPackages.grpcio-tools: add setuptools dependency (NixOS/nixpkgs#98157)
* [`9c73e34d`](NixOS/nixpkgs@9c73e34) kicad: remove gettext from buildInputs, add to nativeBuildInputs
* [`35846440`](NixOS/nixpkgs@3584644) cloc: 1.86 -> 1.88
* [`d347b85c`](NixOS/nixpkgs@d347b85) linuxPackages.exfat-nofuse: lazier assertion (/cc NixOS/nixpkgs#97577)
* [`72b9660d`](NixOS/nixpkgs@72b9660) _3270font: 2.0.4 -> 2.1.0 (NixOS/nixpkgs#98156)
* [`5fa0612d`](NixOS/nixpkgs@5fa0612) cpuid: init at 20200427
* [`6dccacd3`](NixOS/nixpkgs@6dccacd) maintainers: Add NobbZ as a maintainer
* [`76e3103b`](NixOS/nixpkgs@76e3103) exercism: Add NobbZ as maintainer
* [`19f7f150`](NixOS/nixpkgs@19f7f15) solfege: fix build with texinfo 6.7
* [`948d8289`](NixOS/nixpkgs@948d828) uqm: Fix purity checking error during config phase
* [`d8511406`](NixOS/nixpkgs@d851140) trojita: disable withI18n by default
* [`deea9b8a`](NixOS/nixpkgs@deea9b8) linux/hardened/patches/5.8: 5.8.9.a -> 5.8.10.a
* [`c56e8e73`](NixOS/nixpkgs@c56e8e7) nodePackages.patch-package: init at 6.2.2
* [`524755d3`](NixOS/nixpkgs@524755d) embree: init at 3.11.0
* [`6b74f99a`](NixOS/nixpkgs@6b74f99) blender: 2.83.5 -> 2.90.0
* [`cfb9acad`](NixOS/nixpkgs@cfb9aca) gopls: 0.4.4 -> 0.5.0 (NixOS/nixpkgs#98182)
* [`e3c1b878`](NixOS/nixpkgs@e3c1b87) python3Packages.fluent-logger: relax version for msgpack
* [`20472523`](NixOS/nixpkgs@2047252) python3.pkgs.cartopy: 0.17 -> 0.18
* [`5f0f2b85`](NixOS/nixpkgs@5f0f2b8) python3Packages.requests-aws4auth: fix build
* [`6a4e7859`](NixOS/nixpkgs@6a4e785) python3Packages.word2vec: fix build and tests
* [`aa49a711`](NixOS/nixpkgs@aa49a71) vimPlugins: update
* [`93fd4b5c`](NixOS/nixpkgs@93fd4b5) vimPlugins.vim-nerdtree-syntax-highlight: init at 2020-07-19
* [`e2b99c07`](NixOS/nixpkgs@e2b99c0) LTS Haskell 16.15
* [`0be74333`](NixOS/nixpkgs@0be7433) hackage2nix: disable failing builds to fix evaluation on Hydra
* [`eb523e86`](NixOS/nixpkgs@eb523e8) hackage-packages.nix: automatic Haskell package set update
* [`f40afea4`](NixOS/nixpkgs@f40afea) haskellPackages.sbv: fix tests
* [`59617bc1`](NixOS/nixpkgs@59617bc) haskellPackages.ghcide: Fix build
* [`ae73fa0d`](NixOS/nixpkgs@ae73fa0) haskellPackages.ghc.withPackages: Remove obsolete ghcide wrapper
* [`2bf095d0`](NixOS/nixpkgs@2bf095d) haskellPackages.hnix: Fix build
* [`d0541e2e`](NixOS/nixpkgs@d0541e2) haskell-pandoc-plot: mark broken because of failing test suite
* [`7567bd6d`](NixOS/nixpkgs@7567bd6) python3Packages.irc: fix build
* [`a9162ffd`](NixOS/nixpkgs@a9162ff) python3Packages.runway-python: add missing deps
* [`2a35f664`](NixOS/nixpkgs@2a35f66) python3Packages.lightparam: fix source and deps
github-actions bot added a commit to pbogdan/nvs that referenced this pull request Sep 21, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@441a7da...2a35f664](NixOS/nixpkgs@441a7da...2a35f66)

* [`b5212f8b`](NixOS/nixpkgs@b5212f8) linux: remove dependency to utillinuxMinimal
* [`e560459c`](NixOS/nixpkgs@e560459) Revert "utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels"
* [`5ceea570`](NixOS/nixpkgs@5ceea57) Revert "utils.bash: also "fix" cc-wrapper and pkg-config-wrapper"
* [`31fed01d`](NixOS/nixpkgs@31fed01) vdr-epgsearch: 2.4.0 -> 20191202
* [`73653fe5`](NixOS/nixpkgs@73653fe) vdr-vaapidevice: 0.7.0 -> 20190526
* [`9db2ca30`](NixOS/nixpkgs@9db2ca3) gambatte: add alsa dependency, 2016-05-03 -> 2020-03-14
* [`bbd7ba6a`](NixOS/nixpkgs@bbd7ba6) linuxPackages.exfat-nofuse: 2019-09-06 -> 2020-04-15
* [`1966a0a4`](NixOS/nixpkgs@1966a0a) opencv: enable videoio on darwin
* [`90f01b1c`](NixOS/nixpkgs@90f01b1) bcachefs-tools: disable tests
* [`920441f9`](NixOS/nixpkgs@920441f) bcachefs-tools: 2020-04-04 -> 2020-08-25
* [`3cc3e864`](NixOS/nixpkgs@3cc3e86) linux_testing_bcachefs: 5.3 -> 5.8
* [`d284d320`](NixOS/nixpkgs@d284d32) nixos/dmidecode: added recommended patches
* [`c1e96ff7`](NixOS/nixpkgs@c1e96ff) release*: Support nixpkgsArgs for all release-*.nix files
* [`4ed3c35f`](NixOS/nixpkgs@4ed3c35) microserver: init at 0.1.8
* [`9092c614`](NixOS/nixpkgs@9092c61) nginxModules.naxsi: 2020.08.15 -> 2020.09.10
* [`6f32af17`](NixOS/nixpkgs@6f32af1) nginxModules.opentracing: v0.9.0 -> v0.10.0
* [`96311ca1`](NixOS/nixpkgs@96311ca) nginxModules.shibboleth: 2020.08.12 -> 2020.09.04
* [`79906c49`](NixOS/nixpkgs@79906c4) nginxModules.aws-auth: fix warning message
* [`2724f7be`](NixOS/nixpkgs@2724f7b) nbxplorer: init at 2.1.42
* [`2f55d6f6`](NixOS/nixpkgs@2f55d6f) btcpayserver: init at 1.0.5.4
* [`e2c8ae98`](NixOS/nixpkgs@e2c8ae9) softmaker-office: 1018 -> 1020
* [`9be28ee3`](NixOS/nixpkgs@9be28ee) libxsmm: 1.15 -> 1.16.1, improve derivation
* [`8cb1e75e`](NixOS/nixpkgs@8cb1e75) wordgrinder: fix build
* [`9f33ab62`](NixOS/nixpkgs@9f33ab6) nixos/testing: Add support for specialArgs
* [`aff7ee12`](NixOS/nixpkgs@aff7ee1) coursier: 2.0.0-RC6-25 -> 2.0.0-RC6-26
* [`c8ccaebf`](NixOS/nixpkgs@c8ccaeb) nodePackages.diagnostic-languageserver: init at 1.7.1
* [`19b5ef48`](NixOS/nixpkgs@19b5ef4) nixos/plasma5: Fix build with config.services.colord.enable = true
* [`6d0c57fb`](NixOS/nixpkgs@6d0c57f) gitAndTools.git-machete: 2.15.4 -> 2.15.5
* [`7a27aefc`](NixOS/nixpkgs@7a27aef) perlPackages.AstroFITSHeader: init at 3.07
* [`083041a6`](NixOS/nixpkgs@083041a) maintainers: add StephenWithPH
* [`fb779db8`](NixOS/nixpkgs@fb779db) go-swag: init at 1.6.7
* [`88363a87`](NixOS/nixpkgs@88363a8) matomo: 3.14.0 -> 3.14.1
* [`47ba35d6`](NixOS/nixpkgs@47ba35d) unnethack: 5.2.0 -> 5.3.2 (NixOS/nixpkgs#97595)
* [`9511b329`](NixOS/nixpkgs@9511b32) vscode-extensions.ms-python.python: 2020.7.96456 -> 2020.8.103604
* [`0617d9cf`](NixOS/nixpkgs@0617d9c) vimPlugins: update
* [`89c781cc`](NixOS/nixpkgs@89c781c) vimPlugins.vim-ocaml: init at 2020-08-20
* [`be33b546`](NixOS/nixpkgs@be33b54) maintainers/build: skip packages that don't evaluate
* [`c1d2464f`](NixOS/nixpkgs@c1d2464) shadowsocks-libev: 3.3.4 -> 3.3.5
* [`b0b730de`](NixOS/nixpkgs@b0b730d) sops: 3.6.0 -> 3.6.1
* [`ce065c62`](NixOS/nixpkgs@ce065c6) cli-visualizer: Fix build
* [`715790e2`](NixOS/nixpkgs@715790e) _1password-gui: 0.8.5-1 -> 0.8.6-2
* [`c15bcdd9`](NixOS/nixpkgs@c15bcdd) percona-server: 5.6.43-84.3 -> 5.6.49-89.0 (NixOS/nixpkgs#97923)
* [`02a7dde9`](NixOS/nixpkgs@02a7dde) mbtileserver: init at 0.6.1
* [`4a56effd`](NixOS/nixpkgs@4a56eff) redo-sh: 2.0.3 → 4.0.3
* [`c3be7658`](NixOS/nixpkgs@c3be765) nixos/xserver: clean up the useXFS option
* [`b632ca69`](NixOS/nixpkgs@b632ca6) citrix_workspace: add 20.09.0
* [`5b19fa94`](NixOS/nixpkgs@5b19fa9) jitsi-meet-electron: 2.2.0 -> 2.3.1
* [`fb1ff72f`](NixOS/nixpkgs@fb1ff72) perlPackages.PDL: init at 2.022
* [`5684d011`](NixOS/nixpkgs@5684d01) postman: 7.31.1 -> 7.32.0
* [`911c641a`](NixOS/nixpkgs@911c641) oh-my-zsh: 2020-09-12 -> 2020-09-14
* [`e469ddc9`](NixOS/nixpkgs@e469ddc) vcv-rack: fix broken pfft reference
* [`2b55bb43`](NixOS/nixpkgs@2b55bb4) python27.pkgs.joblib: Disable package
* [`43d588b0`](NixOS/nixpkgs@43d588b) python3Packages.ihatemoney: disable sandbox unfriendly tests, fix passthru
* [`20034954`](NixOS/nixpkgs@2003495) python3Packages.graphite_beacon: fix deps, add nixos test
* [`07660b28`](NixOS/nixpkgs@07660b2) streamlit: fix build
* [`dd9c0cf6`](NixOS/nixpkgs@dd9c0cf) maintainers: add mlvzk
* [`92ba6108`](NixOS/nixpkgs@92ba610) manix: init at 0.6.2
* [`0051c0a4`](NixOS/nixpkgs@0051c0a) pythonPackages.bcrypt: use 3.1.x for python older than 3.6
* [`5f4b880b`](NixOS/nixpkgs@5f4b880) python2Packages.trytond: disable for python2
* [`c35b6b3b`](NixOS/nixpkgs@c35b6b3) texstudio: 3.0.0 -> 3.0.1
* [`4d111fdf`](NixOS/nixpkgs@4d111fd) pythonPackages.sievelib: fix build by adding patch
* [`ca682af5`](NixOS/nixpkgs@ca682af) cod: init at unstable-2020-09-10
* [`ffc3f822`](NixOS/nixpkgs@ffc3f82) saga: use proj 6
* [`d92b2463`](NixOS/nixpkgs@d92b246) josm: 16812 -> 17013
* [`b4676300`](NixOS/nixpkgs@b467630) f2fs-tools: 1.13.0 -> 1.14.0
* [`c80258af`](NixOS/nixpkgs@c80258a) gist: 5.1.0 -> 6.0.0 (NixOS/nixpkgs#98053)
* [`afeed1fe`](NixOS/nixpkgs@afeed1f) nodejs-10_x: 10.22.0 -> 10.22.1
* [`095a3218`](NixOS/nixpkgs@095a321) nodejs-12_x: 12.18.3 -> 12.18.4
* [`deb412f5`](NixOS/nixpkgs@deb412f) maintainers: add dpercy
* [`16beff40`](NixOS/nixpkgs@16beff4) fac-build: init at 0.5.3
* [`8d27394e`](NixOS/nixpkgs@8d27394) ocamlPackages.qcheck-core: init at 0.15
* [`79a0130d`](NixOS/nixpkgs@79a0130) ocamlPackages.qcheck-ounit: init at 0.15
* [`491e8098`](NixOS/nixpkgs@491e809) ocamlPackages.qcheck-alcotest: init at 0.15
* [`10fef19f`](NixOS/nixpkgs@10fef19) ocamlPackages.qcheck: 0.7 → 0.15
* [`52c3214e`](NixOS/nixpkgs@52c3214) lxpanel: 0.9.3 -> 0.10.0
* [`db0e901b`](NixOS/nixpkgs@db0e901) lesspass-cli: 9.0.0 -> 9.1.9
* [`eabba0da`](NixOS/nixpkgs@eabba0d) python36Packages.ipython: 7.17 -> 7.16.1 (downgrade)
* [`389ab459`](NixOS/nixpkgs@389ab45) python3Packages.hickle: disable tests
* [`f1325cdf`](NixOS/nixpkgs@f1325cd) python2Packages.hickle: disable
* [`c6dd555b`](NixOS/nixpkgs@c6dd555) chromaprint: add darwin compatibility
* [`c12cfa42`](NixOS/nixpkgs@c12cfa4) chromaprint: fix derivation
* [`809ed032`](NixOS/nixpkgs@809ed03) scrot: 1.3 -> 1.4
* [`21779aec`](NixOS/nixpkgs@21779ae) matrix-synapse: 1.19.1 -> 1.19.2
* [`1c61a932`](NixOS/nixpkgs@1c61a93) linux/hardened/patches/5.4: 5.4.64.a -> 5.4.65.a
* [`b585d600`](NixOS/nixpkgs@b585d60) linux/hardened/patches/5.8: 5.8.8.a -> 5.8.9.a
* [`d39013b1`](NixOS/nixpkgs@d39013b) micro: 2.0.5 -> 2.0.7
* [`db645087`](NixOS/nixpkgs@db64508) ufraw: mark broken
* [`70399cc1`](NixOS/nixpkgs@70399cc) maintainers: add felschr
* [`b1423ee6`](NixOS/nixpkgs@b1423ee) filebot: init at 4.9.1
* [`60df61b6`](NixOS/nixpkgs@60df61b) mk-python-derivation: document pyproject format
* [`9839c0b2`](NixOS/nixpkgs@9839c0b) verilator: 4.040 -> 4.100
* [`b6b616bb`](NixOS/nixpkgs@b6b616b) androidStudioPackages.beta: 4.1.0.17 -> 4.1.0.18
* [`6a8415c9`](NixOS/nixpkgs@6a8415c) python3Packages.google_api_python_client: 1.11.0 -> 1.12.1
* [`99ae3e93`](NixOS/nixpkgs@99ae3e9) mkvtoolnix: 48.0.0 -> 50.0.0
* [`5e8db880`](NixOS/nixpkgs@5e8db88) transcribe: drop
* [`a4e50bb1`](NixOS/nixpkgs@a4e50bb) Revert "qutebrowser: use qt515 (NixOS/nixpkgs#97586)"
* [`c88f3adb`](NixOS/nixpkgs@c88f3ad) pythonPackages: set qt version by overriding pkgs
* [`2daf5702`](NixOS/nixpkgs@2daf570) qutebrowser: use qt 5.15
* [`00f16b7e`](NixOS/nixpkgs@00f16b7) pythonPackages.pyslurm: mark as broken
* [`bfa35d8d`](NixOS/nixpkgs@bfa35d8) qutebrowser: fixup
* [`d219ce3a`](NixOS/nixpkgs@d219ce3) sky: drop
* [`5a6ec92b`](NixOS/nixpkgs@5a6ec92) eksctl: 0.26.0 -> 0.27.0
* [`e77d4eca`](NixOS/nixpkgs@e77d4ec) react-native-debugger: fix build
* [`9dfcba81`](NixOS/nixpkgs@9dfcba8) jwt-cli: 3.1.0 -> 3.2.1
* [`c603f626`](NixOS/nixpkgs@c603f62) topydo: Don't fail build on tests
* [`0561fdef`](NixOS/nixpkgs@0561fde) xonsh: 0.9.21 -> 0.9.22
* [`35593698`](NixOS/nixpkgs@3559369) ntfy: Switch to python3. Also fixes test failure.
* [`a2f45098`](NixOS/nixpkgs@a2f4509) maintainers.midchildan: update info
* [`bc3d459c`](NixOS/nixpkgs@bc3d459) release-notes: mention cinnamon
* [`eaf667bb`](NixOS/nixpkgs@eaf667b) all-packages.nix: Remove trailing space for qutebrowser
* [`ce0a59cb`](NixOS/nixpkgs@ce0a59c) python3.pkgs.libiio: fix build
* [`ec63faba`](NixOS/nixpkgs@ec63fab) gitAndTools.gh: 0.12.0 -> 1.0.0
* [`1e832429`](NixOS/nixpkgs@1e83242) cri-o: 1.18.3 -> 1.19.0
* [`e363aef4`](NixOS/nixpkgs@e363aef) nixos/cri-o: remove deprecated manage_ns_lifecycle option
* [`eb6e2ac2`](NixOS/nixpkgs@eb6e2ac) terraform_0_13: 0.13.2 -> 0.13.3 (NixOS/nixpkgs#98137)
* [`3f1a356b`](NixOS/nixpkgs@3f1a356) gnomeExtensions.gsconnect: 39 -> 41
* [`af926111`](NixOS/nixpkgs@af92611) Revert "python: gsd: 1.7.0 -> 1.9.3"
* [`4560d7ed`](NixOS/nixpkgs@4560d7e) nixos/calibre-server: Allow multiple libraries
* [`114ad1a7`](NixOS/nixpkgs@114ad1a) react-native-debugger: 0.9.10 -> 0.11.4
* [`501eaab4`](NixOS/nixpkgs@501eaab) react-native-debugger: fix eval
* [`3df04bea`](NixOS/nixpkgs@3df04be) signal-desktop: ringrtc depends on libpulseaudio
* [`8263d6e6`](NixOS/nixpkgs@8263d6e) dnscontrol: 3.2.0 -> 3.3.0
* [`5cd3b2d6`](NixOS/nixpkgs@5cd3b2d) dnscontrol: replace stdenv.lib with lib
* [`139143ca`](NixOS/nixpkgs@139143c) dnscontrol: add SuperSandro2000 as maintainer
* [`cb4b908d`](NixOS/nixpkgs@cb4b908) linux: 4.19.145 -> 4.19.146
* [`e8121e56`](NixOS/nixpkgs@e8121e5) linux: 5.4.65 -> 5.4.66
* [`fa60ed8f`](NixOS/nixpkgs@fa60ed8) linux: 5.8.9 -> 5.8.10
* [`19f22514`](NixOS/nixpkgs@19f2251) pythonPackages.grpcio-tools: add setuptools dependency (NixOS/nixpkgs#98157)
* [`9c73e34d`](NixOS/nixpkgs@9c73e34) kicad: remove gettext from buildInputs, add to nativeBuildInputs
* [`35846440`](NixOS/nixpkgs@3584644) cloc: 1.86 -> 1.88
* [`d347b85c`](NixOS/nixpkgs@d347b85) linuxPackages.exfat-nofuse: lazier assertion (/cc NixOS/nixpkgs#97577)
* [`72b9660d`](NixOS/nixpkgs@72b9660) _3270font: 2.0.4 -> 2.1.0 (NixOS/nixpkgs#98156)
* [`5fa0612d`](NixOS/nixpkgs@5fa0612) cpuid: init at 20200427
* [`6dccacd3`](NixOS/nixpkgs@6dccacd) maintainers: Add NobbZ as a maintainer
* [`76e3103b`](NixOS/nixpkgs@76e3103) exercism: Add NobbZ as maintainer
* [`19f7f150`](NixOS/nixpkgs@19f7f15) solfege: fix build with texinfo 6.7
* [`948d8289`](NixOS/nixpkgs@948d828) uqm: Fix purity checking error during config phase
* [`d8511406`](NixOS/nixpkgs@d851140) trojita: disable withI18n by default
* [`deea9b8a`](NixOS/nixpkgs@deea9b8) linux/hardened/patches/5.8: 5.8.9.a -> 5.8.10.a
* [`c56e8e73`](NixOS/nixpkgs@c56e8e7) nodePackages.patch-package: init at 6.2.2
* [`524755d3`](NixOS/nixpkgs@524755d) embree: init at 3.11.0
* [`6b74f99a`](NixOS/nixpkgs@6b74f99) blender: 2.83.5 -> 2.90.0
* [`cfb9acad`](NixOS/nixpkgs@cfb9aca) gopls: 0.4.4 -> 0.5.0 (NixOS/nixpkgs#98182)
* [`e3c1b878`](NixOS/nixpkgs@e3c1b87) python3Packages.fluent-logger: relax version for msgpack
* [`20472523`](NixOS/nixpkgs@2047252) python3.pkgs.cartopy: 0.17 -> 0.18
* [`5f0f2b85`](NixOS/nixpkgs@5f0f2b8) python3Packages.requests-aws4auth: fix build
* [`6a4e7859`](NixOS/nixpkgs@6a4e785) python3Packages.word2vec: fix build and tests
* [`aa49a711`](NixOS/nixpkgs@aa49a71) vimPlugins: update
* [`93fd4b5c`](NixOS/nixpkgs@93fd4b5) vimPlugins.vim-nerdtree-syntax-highlight: init at 2020-07-19
* [`e2b99c07`](NixOS/nixpkgs@e2b99c0) LTS Haskell 16.15
* [`0be74333`](NixOS/nixpkgs@0be7433) hackage2nix: disable failing builds to fix evaluation on Hydra
* [`eb523e86`](NixOS/nixpkgs@eb523e8) hackage-packages.nix: automatic Haskell package set update
* [`f40afea4`](NixOS/nixpkgs@f40afea) haskellPackages.sbv: fix tests
* [`59617bc1`](NixOS/nixpkgs@59617bc) haskellPackages.ghcide: Fix build
* [`ae73fa0d`](NixOS/nixpkgs@ae73fa0) haskellPackages.ghc.withPackages: Remove obsolete ghcide wrapper
* [`2bf095d0`](NixOS/nixpkgs@2bf095d) haskellPackages.hnix: Fix build
* [`d0541e2e`](NixOS/nixpkgs@d0541e2) haskell-pandoc-plot: mark broken because of failing test suite
* [`7567bd6d`](NixOS/nixpkgs@7567bd6) python3Packages.irc: fix build
* [`a9162ffd`](NixOS/nixpkgs@a9162ff) python3Packages.runway-python: add missing deps
* [`2a35f664`](NixOS/nixpkgs@2a35f66) python3Packages.lightparam: fix source and deps
github-actions bot added a commit to pbogdan/nix-nerd-fonts that referenced this pull request Sep 21, 2020
## Motivation

Dependencies should be up to date.

## Changelog for unstable:
Commits: [NixOS/nixpkgs@441a7da...2a35f664](NixOS/nixpkgs@441a7da...2a35f66)

* [`b5212f8b`](NixOS/nixpkgs@b5212f8) linux: remove dependency to utillinuxMinimal
* [`e560459c`](NixOS/nixpkgs@e560459) Revert "utils.bash: revert NixOS/nixpkgs#93560 for darwin, unblocks channels"
* [`5ceea570`](NixOS/nixpkgs@5ceea57) Revert "utils.bash: also "fix" cc-wrapper and pkg-config-wrapper"
* [`31fed01d`](NixOS/nixpkgs@31fed01) vdr-epgsearch: 2.4.0 -> 20191202
* [`73653fe5`](NixOS/nixpkgs@73653fe) vdr-vaapidevice: 0.7.0 -> 20190526
* [`9db2ca30`](NixOS/nixpkgs@9db2ca3) gambatte: add alsa dependency, 2016-05-03 -> 2020-03-14
* [`bbd7ba6a`](NixOS/nixpkgs@bbd7ba6) linuxPackages.exfat-nofuse: 2019-09-06 -> 2020-04-15
* [`1966a0a4`](NixOS/nixpkgs@1966a0a) opencv: enable videoio on darwin
* [`90f01b1c`](NixOS/nixpkgs@90f01b1) bcachefs-tools: disable tests
* [`920441f9`](NixOS/nixpkgs@920441f) bcachefs-tools: 2020-04-04 -> 2020-08-25
* [`3cc3e864`](NixOS/nixpkgs@3cc3e86) linux_testing_bcachefs: 5.3 -> 5.8
* [`d284d320`](NixOS/nixpkgs@d284d32) nixos/dmidecode: added recommended patches
* [`c1e96ff7`](NixOS/nixpkgs@c1e96ff) release*: Support nixpkgsArgs for all release-*.nix files
* [`4ed3c35f`](NixOS/nixpkgs@4ed3c35) microserver: init at 0.1.8
* [`9092c614`](NixOS/nixpkgs@9092c61) nginxModules.naxsi: 2020.08.15 -> 2020.09.10
* [`6f32af17`](NixOS/nixpkgs@6f32af1) nginxModules.opentracing: v0.9.0 -> v0.10.0
* [`96311ca1`](NixOS/nixpkgs@96311ca) nginxModules.shibboleth: 2020.08.12 -> 2020.09.04
* [`79906c49`](NixOS/nixpkgs@79906c4) nginxModules.aws-auth: fix warning message
* [`2724f7be`](NixOS/nixpkgs@2724f7b) nbxplorer: init at 2.1.42
* [`2f55d6f6`](NixOS/nixpkgs@2f55d6f) btcpayserver: init at 1.0.5.4
* [`e2c8ae98`](NixOS/nixpkgs@e2c8ae9) softmaker-office: 1018 -> 1020
* [`9be28ee3`](NixOS/nixpkgs@9be28ee) libxsmm: 1.15 -> 1.16.1, improve derivation
* [`8cb1e75e`](NixOS/nixpkgs@8cb1e75) wordgrinder: fix build
* [`9f33ab62`](NixOS/nixpkgs@9f33ab6) nixos/testing: Add support for specialArgs
* [`aff7ee12`](NixOS/nixpkgs@aff7ee1) coursier: 2.0.0-RC6-25 -> 2.0.0-RC6-26
* [`c8ccaebf`](NixOS/nixpkgs@c8ccaeb) nodePackages.diagnostic-languageserver: init at 1.7.1
* [`19b5ef48`](NixOS/nixpkgs@19b5ef4) nixos/plasma5: Fix build with config.services.colord.enable = true
* [`6d0c57fb`](NixOS/nixpkgs@6d0c57f) gitAndTools.git-machete: 2.15.4 -> 2.15.5
* [`7a27aefc`](NixOS/nixpkgs@7a27aef) perlPackages.AstroFITSHeader: init at 3.07
* [`083041a6`](NixOS/nixpkgs@083041a) maintainers: add StephenWithPH
* [`fb779db8`](NixOS/nixpkgs@fb779db) go-swag: init at 1.6.7
* [`88363a87`](NixOS/nixpkgs@88363a8) matomo: 3.14.0 -> 3.14.1
* [`47ba35d6`](NixOS/nixpkgs@47ba35d) unnethack: 5.2.0 -> 5.3.2 (NixOS/nixpkgs#97595)
* [`9511b329`](NixOS/nixpkgs@9511b32) vscode-extensions.ms-python.python: 2020.7.96456 -> 2020.8.103604
* [`0617d9cf`](NixOS/nixpkgs@0617d9c) vimPlugins: update
* [`89c781cc`](NixOS/nixpkgs@89c781c) vimPlugins.vim-ocaml: init at 2020-08-20
* [`be33b546`](NixOS/nixpkgs@be33b54) maintainers/build: skip packages that don't evaluate
* [`c1d2464f`](NixOS/nixpkgs@c1d2464) shadowsocks-libev: 3.3.4 -> 3.3.5
* [`b0b730de`](NixOS/nixpkgs@b0b730d) sops: 3.6.0 -> 3.6.1
* [`ce065c62`](NixOS/nixpkgs@ce065c6) cli-visualizer: Fix build
* [`715790e2`](NixOS/nixpkgs@715790e) _1password-gui: 0.8.5-1 -> 0.8.6-2
* [`c15bcdd9`](NixOS/nixpkgs@c15bcdd) percona-server: 5.6.43-84.3 -> 5.6.49-89.0 (NixOS/nixpkgs#97923)
* [`02a7dde9`](NixOS/nixpkgs@02a7dde) mbtileserver: init at 0.6.1
* [`4a56effd`](NixOS/nixpkgs@4a56eff) redo-sh: 2.0.3 → 4.0.3
* [`c3be7658`](NixOS/nixpkgs@c3be765) nixos/xserver: clean up the useXFS option
* [`b632ca69`](NixOS/nixpkgs@b632ca6) citrix_workspace: add 20.09.0
* [`5b19fa94`](NixOS/nixpkgs@5b19fa9) jitsi-meet-electron: 2.2.0 -> 2.3.1
* [`fb1ff72f`](NixOS/nixpkgs@fb1ff72) perlPackages.PDL: init at 2.022
* [`5684d011`](NixOS/nixpkgs@5684d01) postman: 7.31.1 -> 7.32.0
* [`911c641a`](NixOS/nixpkgs@911c641) oh-my-zsh: 2020-09-12 -> 2020-09-14
* [`e469ddc9`](NixOS/nixpkgs@e469ddc) vcv-rack: fix broken pfft reference
* [`2b55bb43`](NixOS/nixpkgs@2b55bb4) python27.pkgs.joblib: Disable package
* [`43d588b0`](NixOS/nixpkgs@43d588b) python3Packages.ihatemoney: disable sandbox unfriendly tests, fix passthru
* [`20034954`](NixOS/nixpkgs@2003495) python3Packages.graphite_beacon: fix deps, add nixos test
* [`07660b28`](NixOS/nixpkgs@07660b2) streamlit: fix build
* [`dd9c0cf6`](NixOS/nixpkgs@dd9c0cf) maintainers: add mlvzk
* [`92ba6108`](NixOS/nixpkgs@92ba610) manix: init at 0.6.2
* [`0051c0a4`](NixOS/nixpkgs@0051c0a) pythonPackages.bcrypt: use 3.1.x for python older than 3.6
* [`5f4b880b`](NixOS/nixpkgs@5f4b880) python2Packages.trytond: disable for python2
* [`c35b6b3b`](NixOS/nixpkgs@c35b6b3) texstudio: 3.0.0 -> 3.0.1
* [`4d111fdf`](NixOS/nixpkgs@4d111fd) pythonPackages.sievelib: fix build by adding patch
* [`ca682af5`](NixOS/nixpkgs@ca682af) cod: init at unstable-2020-09-10
* [`ffc3f822`](NixOS/nixpkgs@ffc3f82) saga: use proj 6
* [`d92b2463`](NixOS/nixpkgs@d92b246) josm: 16812 -> 17013
* [`b4676300`](NixOS/nixpkgs@b467630) f2fs-tools: 1.13.0 -> 1.14.0
* [`c80258af`](NixOS/nixpkgs@c80258a) gist: 5.1.0 -> 6.0.0 (NixOS/nixpkgs#98053)
* [`afeed1fe`](NixOS/nixpkgs@afeed1f) nodejs-10_x: 10.22.0 -> 10.22.1
* [`095a3218`](NixOS/nixpkgs@095a321) nodejs-12_x: 12.18.3 -> 12.18.4
* [`deb412f5`](NixOS/nixpkgs@deb412f) maintainers: add dpercy
* [`16beff40`](NixOS/nixpkgs@16beff4) fac-build: init at 0.5.3
* [`8d27394e`](NixOS/nixpkgs@8d27394) ocamlPackages.qcheck-core: init at 0.15
* [`79a0130d`](NixOS/nixpkgs@79a0130) ocamlPackages.qcheck-ounit: init at 0.15
* [`491e8098`](NixOS/nixpkgs@491e809) ocamlPackages.qcheck-alcotest: init at 0.15
* [`10fef19f`](NixOS/nixpkgs@10fef19) ocamlPackages.qcheck: 0.7 → 0.15
* [`52c3214e`](NixOS/nixpkgs@52c3214) lxpanel: 0.9.3 -> 0.10.0
* [`db0e901b`](NixOS/nixpkgs@db0e901) lesspass-cli: 9.0.0 -> 9.1.9
* [`eabba0da`](NixOS/nixpkgs@eabba0d) python36Packages.ipython: 7.17 -> 7.16.1 (downgrade)
* [`389ab459`](NixOS/nixpkgs@389ab45) python3Packages.hickle: disable tests
* [`f1325cdf`](NixOS/nixpkgs@f1325cd) python2Packages.hickle: disable
* [`c6dd555b`](NixOS/nixpkgs@c6dd555) chromaprint: add darwin compatibility
* [`c12cfa42`](NixOS/nixpkgs@c12cfa4) chromaprint: fix derivation
* [`809ed032`](NixOS/nixpkgs@809ed03) scrot: 1.3 -> 1.4
* [`21779aec`](NixOS/nixpkgs@21779ae) matrix-synapse: 1.19.1 -> 1.19.2
* [`1c61a932`](NixOS/nixpkgs@1c61a93) linux/hardened/patches/5.4: 5.4.64.a -> 5.4.65.a
* [`b585d600`](NixOS/nixpkgs@b585d60) linux/hardened/patches/5.8: 5.8.8.a -> 5.8.9.a
* [`d39013b1`](NixOS/nixpkgs@d39013b) micro: 2.0.5 -> 2.0.7
* [`db645087`](NixOS/nixpkgs@db64508) ufraw: mark broken
* [`70399cc1`](NixOS/nixpkgs@70399cc) maintainers: add felschr
* [`b1423ee6`](NixOS/nixpkgs@b1423ee) filebot: init at 4.9.1
* [`60df61b6`](NixOS/nixpkgs@60df61b) mk-python-derivation: document pyproject format
* [`9839c0b2`](NixOS/nixpkgs@9839c0b) verilator: 4.040 -> 4.100
* [`b6b616bb`](NixOS/nixpkgs@b6b616b) androidStudioPackages.beta: 4.1.0.17 -> 4.1.0.18
* [`6a8415c9`](NixOS/nixpkgs@6a8415c) python3Packages.google_api_python_client: 1.11.0 -> 1.12.1
* [`99ae3e93`](NixOS/nixpkgs@99ae3e9) mkvtoolnix: 48.0.0 -> 50.0.0
* [`5e8db880`](NixOS/nixpkgs@5e8db88) transcribe: drop
* [`a4e50bb1`](NixOS/nixpkgs@a4e50bb) Revert "qutebrowser: use qt515 (NixOS/nixpkgs#97586)"
* [`c88f3adb`](NixOS/nixpkgs@c88f3ad) pythonPackages: set qt version by overriding pkgs
* [`2daf5702`](NixOS/nixpkgs@2daf570) qutebrowser: use qt 5.15
* [`00f16b7e`](NixOS/nixpkgs@00f16b7) pythonPackages.pyslurm: mark as broken
* [`bfa35d8d`](NixOS/nixpkgs@bfa35d8) qutebrowser: fixup
* [`d219ce3a`](NixOS/nixpkgs@d219ce3) sky: drop
* [`5a6ec92b`](NixOS/nixpkgs@5a6ec92) eksctl: 0.26.0 -> 0.27.0
* [`e77d4eca`](NixOS/nixpkgs@e77d4ec) react-native-debugger: fix build
* [`9dfcba81`](NixOS/nixpkgs@9dfcba8) jwt-cli: 3.1.0 -> 3.2.1
* [`c603f626`](NixOS/nixpkgs@c603f62) topydo: Don't fail build on tests
* [`0561fdef`](NixOS/nixpkgs@0561fde) xonsh: 0.9.21 -> 0.9.22
* [`35593698`](NixOS/nixpkgs@3559369) ntfy: Switch to python3. Also fixes test failure.
* [`a2f45098`](NixOS/nixpkgs@a2f4509) maintainers.midchildan: update info
* [`bc3d459c`](NixOS/nixpkgs@bc3d459) release-notes: mention cinnamon
* [`eaf667bb`](NixOS/nixpkgs@eaf667b) all-packages.nix: Remove trailing space for qutebrowser
* [`ce0a59cb`](NixOS/nixpkgs@ce0a59c) python3.pkgs.libiio: fix build
* [`ec63faba`](NixOS/nixpkgs@ec63fab) gitAndTools.gh: 0.12.0 -> 1.0.0
* [`1e832429`](NixOS/nixpkgs@1e83242) cri-o: 1.18.3 -> 1.19.0
* [`e363aef4`](NixOS/nixpkgs@e363aef) nixos/cri-o: remove deprecated manage_ns_lifecycle option
* [`eb6e2ac2`](NixOS/nixpkgs@eb6e2ac) terraform_0_13: 0.13.2 -> 0.13.3 (NixOS/nixpkgs#98137)
* [`3f1a356b`](NixOS/nixpkgs@3f1a356) gnomeExtensions.gsconnect: 39 -> 41
* [`af926111`](NixOS/nixpkgs@af92611) Revert "python: gsd: 1.7.0 -> 1.9.3"
* [`4560d7ed`](NixOS/nixpkgs@4560d7e) nixos/calibre-server: Allow multiple libraries
* [`114ad1a7`](NixOS/nixpkgs@114ad1a) react-native-debugger: 0.9.10 -> 0.11.4
* [`501eaab4`](NixOS/nixpkgs@501eaab) react-native-debugger: fix eval
* [`3df04bea`](NixOS/nixpkgs@3df04be) signal-desktop: ringrtc depends on libpulseaudio
* [`8263d6e6`](NixOS/nixpkgs@8263d6e) dnscontrol: 3.2.0 -> 3.3.0
* [`5cd3b2d6`](NixOS/nixpkgs@5cd3b2d) dnscontrol: replace stdenv.lib with lib
* [`139143ca`](NixOS/nixpkgs@139143c) dnscontrol: add SuperSandro2000 as maintainer
* [`cb4b908d`](NixOS/nixpkgs@cb4b908) linux: 4.19.145 -> 4.19.146
* [`e8121e56`](NixOS/nixpkgs@e8121e5) linux: 5.4.65 -> 5.4.66
* [`fa60ed8f`](NixOS/nixpkgs@fa60ed8) linux: 5.8.9 -> 5.8.10
* [`19f22514`](NixOS/nixpkgs@19f2251) pythonPackages.grpcio-tools: add setuptools dependency (NixOS/nixpkgs#98157)
* [`9c73e34d`](NixOS/nixpkgs@9c73e34) kicad: remove gettext from buildInputs, add to nativeBuildInputs
* [`35846440`](NixOS/nixpkgs@3584644) cloc: 1.86 -> 1.88
* [`d347b85c`](NixOS/nixpkgs@d347b85) linuxPackages.exfat-nofuse: lazier assertion (/cc NixOS/nixpkgs#97577)
* [`72b9660d`](NixOS/nixpkgs@72b9660) _3270font: 2.0.4 -> 2.1.0 (NixOS/nixpkgs#98156)
* [`5fa0612d`](NixOS/nixpkgs@5fa0612) cpuid: init at 20200427
* [`6dccacd3`](NixOS/nixpkgs@6dccacd) maintainers: Add NobbZ as a maintainer
* [`76e3103b`](NixOS/nixpkgs@76e3103) exercism: Add NobbZ as maintainer
* [`19f7f150`](NixOS/nixpkgs@19f7f15) solfege: fix build with texinfo 6.7
* [`948d8289`](NixOS/nixpkgs@948d828) uqm: Fix purity checking error during config phase
* [`d8511406`](NixOS/nixpkgs@d851140) trojita: disable withI18n by default
* [`deea9b8a`](NixOS/nixpkgs@deea9b8) linux/hardened/patches/5.8: 5.8.9.a -> 5.8.10.a
* [`c56e8e73`](NixOS/nixpkgs@c56e8e7) nodePackages.patch-package: init at 6.2.2
* [`524755d3`](NixOS/nixpkgs@524755d) embree: init at 3.11.0
* [`6b74f99a`](NixOS/nixpkgs@6b74f99) blender: 2.83.5 -> 2.90.0
* [`cfb9acad`](NixOS/nixpkgs@cfb9aca) gopls: 0.4.4 -> 0.5.0 (NixOS/nixpkgs#98182)
* [`e3c1b878`](NixOS/nixpkgs@e3c1b87) python3Packages.fluent-logger: relax version for msgpack
* [`20472523`](NixOS/nixpkgs@2047252) python3.pkgs.cartopy: 0.17 -> 0.18
* [`5f0f2b85`](NixOS/nixpkgs@5f0f2b8) python3Packages.requests-aws4auth: fix build
* [`6a4e7859`](NixOS/nixpkgs@6a4e785) python3Packages.word2vec: fix build and tests
* [`aa49a711`](NixOS/nixpkgs@aa49a71) vimPlugins: update
* [`93fd4b5c`](NixOS/nixpkgs@93fd4b5) vimPlugins.vim-nerdtree-syntax-highlight: init at 2020-07-19
* [`e2b99c07`](NixOS/nixpkgs@e2b99c0) LTS Haskell 16.15
* [`0be74333`](NixOS/nixpkgs@0be7433) hackage2nix: disable failing builds to fix evaluation on Hydra
* [`eb523e86`](NixOS/nixpkgs@eb523e8) hackage-packages.nix: automatic Haskell package set update
* [`f40afea4`](NixOS/nixpkgs@f40afea) haskellPackages.sbv: fix tests
* [`59617bc1`](NixOS/nixpkgs@59617bc) haskellPackages.ghcide: Fix build
* [`ae73fa0d`](NixOS/nixpkgs@ae73fa0) haskellPackages.ghc.withPackages: Remove obsolete ghcide wrapper
* [`2bf095d0`](NixOS/nixpkgs@2bf095d) haskellPackages.hnix: Fix build
* [`d0541e2e`](NixOS/nixpkgs@d0541e2) haskell-pandoc-plot: mark broken because of failing test suite
* [`7567bd6d`](NixOS/nixpkgs@7567bd6) python3Packages.irc: fix build
* [`a9162ffd`](NixOS/nixpkgs@a9162ff) python3Packages.runway-python: add missing deps
* [`2a35f664`](NixOS/nixpkgs@2a35f66) python3Packages.lightparam: fix source and deps
risicle added a commit to risicle/nixpkgs that referenced this pull request Oct 18, 2020
(modified cherry pick of commit 4a9dba6)

some tricks are required to make this work because NixOS#93560 and NixOS#97597
didn't make it into this branch, but this example shows what is required
to import theano from within a nix build environment on this branch.
risicle added a commit to risicle/nixpkgs that referenced this pull request Oct 18, 2020
(modified cherry pick of commit 4a9dba6)

some tricks are required to make this work because NixOS#93560 and NixOS#97597
didn't make it into this branch, but this example shows what is required
to import theano from within a nix build environment on this branch.
jonringer added a commit that referenced this pull request Oct 19, 2020
(modified cherry pick of commit 4a9dba6)

some tricks are required to make this work because #93560 and #97597
didn't make it into this branch, but this example shows what is required
to import theano from within a nix build environment on this branch.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Staging
  
Done
Linked issues

Successfully merging this pull request may close these issues.

None yet

7 participants
You can’t perform that action at this time.