Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

libcerf: 1.13 -> 2.0 #94768

Open
wants to merge 1 commit into
base: master
from
Open

libcerf: 1.13 -> 2.0 #94768

wants to merge 1 commit into from

Conversation

@r-ryantm
Copy link
Contributor

r-ryantm commented Aug 6, 2020

Automatic update generated by nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/libcerf/versions.

meta.description for libcerf is: "Complex error (erf), Dawson, Faddeeva, and Voigt function library"

meta.homepage for libcerf is: "https://jugit.fz-juelich.de/mlz/libcerf"

meta.changelog for libcerf is: ""

Updates performed
  • Version update
To inspect upstream changes
Impact
Checks done (click to expand)

Rebuild report (if merged into master) (click to expand)
221 total rebuild path(s)

70 package rebuild(s)

70 x86_64-linux rebuild(s)
65 i686-linux rebuild(s)
22 x86_64-darwin rebuild(s)
64 aarch64-linux rebuild(s)


First fifty rebuilds by attrpath
bpm-tools
cubicsdr
eplot
feedgnuplot
fityk
fmbt
gama
gitstats
gnuplot
gnuplot_aquaterm
gnuplot_qt
gnuradio-with-packages
gqrx
gr-ais
gr-gsm
gr-limesdr
gr-osmosdr
image-analyzer
iozone
kde-cli-tools
kdeplasma-addons
kdev-php
kdev-python
kdevelop
kdevelop-unwrapped
kmenuedit
krohnkite
kwin-tiling
libcerf
libqalculate
libsForQt5.khotkeys
libsForQt512.khotkeys
limesuite
maxima
maxima-ecl
minc_widgets
nasc
octave
octave-jit
octaveFull
plasma-desktop
plasma-workspace
plasma5.kde-cli-tools
plasma5.kdeplasma-addons
plasma5.khotkeys
plasma5.kmenuedit
plasma5.plasma-desktop
plasma5.plasma-workspace
plasma5.powerdevil
plasma5.systemsettings
Instructions to test this update (click to expand)

Either download from Cachix:

nix-store -r /nix/store/c1858v3pz4qr264c263fnhvg8v3rnjxn-libcerf-2.0 \
  --option binary-caches 'https://cache.nixos.org/ https://r-ryantm.cachix.org/' \
  --option trusted-public-keys '
  r-ryantm.cachix.org-1:gkUbLkouDAyvBdpBX0JOdIiD2/DP1ldF3Z3Y6Gqcc4c=
  cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=
  '

(r-ryantm's Cachix cache is only trusted for this store-path realization.)
For the Cachix download to work, your user must be in the trusted-users list or you can use sudo since root is effectively trusted.

Or, build yourself:

nix-build -A libcerf https://github.com/r-ryantm/nixpkgs/archive/0a6b979105c3e68144f2afe254c980aaa758359d.tar.gz

After you've downloaded or built it, look at the files and if there are any, run the binaries:

ls -la /nix/store/c1858v3pz4qr264c263fnhvg8v3rnjxn-libcerf-2.0
ls -la /nix/store/c1858v3pz4qr264c263fnhvg8v3rnjxn-libcerf-2.0/bin


Pre-merge build results

We have automatically built all packages that will get rebuilt due to
this change.

This gives evidence on whether the upgrade will break dependent packages.
Note sometimes packages show up as failed to build independent of the
change, simply because they are already broken on the target branch.

Result of nixpkgs-review 1

4 packages failed to build:
  • octave-jit
  • purePackages.gplot
  • sage (sagemath)
  • sageWithDoc
67 packages built:
  • bpm-tools
  • cubicsdr
  • eplot
  • feedgnuplot
  • fityk
  • fmbt
  • gama
  • gitstats
  • gnuplot
  • gnuplot_aquaterm
  • gnuplot_qt
  • gr-ais (gnuradio-ais)
  • gr-gsm (gnuradio-gsm)
  • gr-limesdr (gnuradio-limesdr)
  • gr-osmosdr (gnuradio-osmosdr)
  • gnuradio-with-packages
  • gqrx
  • image-analyzer
  • iozone
  • kde-cli-tools
  • kdeplasma-addons
  • kdev-php
  • kdev-python
  • kdevelop
  • kdevelop-unwrapped
  • kmenuedit
  • krohnkite
  • kwin-tiling
  • libcerf
  • libqalculate
  • plasma5.khotkeys (libsForQt5.khotkeys)
  • limesuite
  • maxima
  • maxima-ecl
  • minc_widgets
  • nasc
  • ocamlPackages.gnuplot
  • ocamlPackages.irmin-fs
  • ocamlPackages.irmin-git
  • ocamlPackages.irmin-http
  • ocamlPackages.irmin-mem
  • ocamlPackages.irmin-pack
  • ocamlPackages.irmin-test
  • ocamlPackages.irmin-unix
  • ocamlPackages.metrics-unix
  • ocamlPackages.phylogenetics
  • octave
  • octaveFull
  • plasma-desktop
  • plasma-workspace
  • plasma5.powerdevil
  • plasma5.systemsettings
  • python27Packages.soapysdr-with-plugins
  • python37Packages.soapysdr-with-plugins
  • python38Packages.soapysdr-with-plugins
  • qalculate-gtk
  • qradiolink
  • qtikz
  • rofi-calc
  • rtl_433
  • sdrangel
  • soapysdr-with-plugins
  • tsung
  • urh
  • wacomtablet
  • welle-io
  • wxmaxima

Maintainer pings

cc @orivej for testing.

@risicle
Copy link
Contributor

risicle commented Sep 3, 2020

Tested macos 10.14, only rebuild failures are pre-existing (octave, gama).

@tomberek
Copy link
Contributor

tomberek commented Sep 6, 2020

Result of nixpkgs-review pr 94768 1

5 packages failed to build:
- libsForQt512.khotkeys
- octave-jit
- purePackages.gplot
- sage
- sageWithDoc
57 packages built:
- bpm-tools
- cubicsdr
- eplot
- feedgnuplot
- fityk
- fmbt
- gama
- gitstats
- gnuplot
- gnuplot_aquaterm
- gnuplot_qt
- gnuradio-with-packages
- gqrx
- gr-ais
- gr-gsm
- gr-limesdr
- gr-osmosdr
- image-analyzer
- iozone
- kde-cli-tools (plasma5.kde-cli-tools)
- kdeplasma-addons (plasma5.kdeplasma-addons)
- kdev-php
- kdev-python
- kdevelop
- kdevelop-unwrapped
- kmenuedit (plasma5.kmenuedit)
- krohnkite
- kwin-tiling
- libcerf
- libqalculate
- plasma5.khotkeys (libsForQt5.khotkeys)
- limesuite
- maxima
- maxima-ecl
- minc_widgets
- nasc
- octave
- octaveFull
- plasma-desktop (plasma5.plasma-desktop)
- plasma-workspace (plasma5.plasma-workspace)
- powerdevil (plasma5.powerdevil)
- systemsettings (plasma5.systemsettings)
- python27Packages.soapysdr-with-plugins
- python37Packages.soapysdr-with-plugins
- python38Packages.soapysdr-with-plugins
- qalculate-gtk
- qradiolink
- qtikz
- rofi-calc
- rtl_433
- sdrangel
- soapysdr-with-plugins
- tsung
- urh
- wacomtablet
- welle-io
- wxmaxima
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.