Skip to content
This repository
Browse code

Merge pull request #330 from ramkidarla/oauth2-update

Update the oauth2 gem
  • Loading branch information...
commit 912b7567d2c7b441c1d3be785c172b76acfd14fe 2 parents c6aeaab + 64a7a78
Noam Ben Ari authored August 23, 2012
2  Gemfile
@@ -3,7 +3,7 @@ source :rubygems
3 3
 # Example:
4 4
 #   gem "activesupport", ">= 2.3.5"
5 5
 gem 'oauth', "~> 0.4.4"
6  
-gem 'oauth2', "~> 0.6.0"
  6
+gem 'oauth2', "~> 0.7.1"
7 7
 gem 'bcrypt-ruby', "~> 3.0.0"
8 8
 
9 9
 # Add dependencies to develop your gem here.
11  Gemfile.lock
@@ -46,7 +46,7 @@ GEM
46 46
     columnize (0.3.6)
47 47
     diff-lcs (1.1.3)
48 48
     erubis (2.7.0)
49  
-    faraday (0.8.1)
  49
+    faraday (0.8.4)
50 50
       multipart-post (~> 1.1)
51 51
     ffi (1.0.11)
52 52
     git (1.2.5)
@@ -81,10 +81,11 @@ GEM
81 81
     multipart-post (1.1.5)
82 82
     nokogiri (1.5.2)
83 83
     oauth (0.4.5)
84  
-    oauth2 (0.6.1)
85  
-      faraday (~> 0.7)
  84
+    oauth2 (0.7.1)
  85
+      faraday (~> 0.8)
86 86
       httpauth (~> 0.1)
87  
-      multi_json (~> 1.3)
  87
+      multi_json (~> 1.0)
  88
+      rack (~> 1.4)
88 89
     plucky (0.4.4)
89 90
       mongo (~> 1.5)
90 91
     polyglot (0.3.3)
@@ -177,7 +178,7 @@ DEPENDENCIES
177 178
   mongo_mapper
178 179
   mongoid (~> 2.4.4)
179 180
   oauth (~> 0.4.4)
180  
-  oauth2 (~> 0.6.0)
  181
+  oauth2 (~> 0.7.1)
181 182
   rails (>= 3.0.0)
182 183
   rspec (~> 2.5.0)
183 184
   rspec-rails (~> 2.5.0)
6  sorcery.gemspec
@@ -310,7 +310,7 @@ Gem::Specification.new do |s|
310 310
 
311 311
     if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
312 312
       s.add_runtime_dependency(%q<oauth>, ["~> 0.4.4"])
313  
-      s.add_runtime_dependency(%q<oauth2>, ["~> 0.6.0"])
  313
+      s.add_runtime_dependency(%q<oauth2>, ["~> 0.7.1"])
314 314
       s.add_runtime_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
315 315
       s.add_development_dependency(%q<abstract>, [">= 1.0.0"])
316 316
       s.add_development_dependency(%q<rails>, [">= 3.0.0"])
@@ -329,7 +329,7 @@ Gem::Specification.new do |s|
329 329
       s.add_development_dependency(%q<mongoid>, ["~> 2.4.4"])
330 330
     else
331 331
       s.add_dependency(%q<oauth>, ["~> 0.4.4"])
332  
-      s.add_dependency(%q<oauth2>, ["~> 0.6.0"])
  332
+      s.add_dependency(%q<oauth2>, ["~> 0.7.1"])
333 333
       s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
334 334
       s.add_dependency(%q<abstract>, [">= 1.0.0"])
335 335
       s.add_dependency(%q<rails>, [">= 3.0.0"])
@@ -349,7 +349,7 @@ Gem::Specification.new do |s|
349 349
     end
350 350
   else
351 351
     s.add_dependency(%q<oauth>, ["~> 0.4.4"])
352  
-    s.add_dependency(%q<oauth2>, ["~> 0.6.0"])
  352
+    s.add_dependency(%q<oauth2>, ["~> 0.7.1"])
353 353
     s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
354 354
     s.add_dependency(%q<abstract>, [">= 1.0.0"])
355 355
     s.add_dependency(%q<rails>, [">= 3.0.0"])

0 notes on commit 912b756

Please sign in to comment.
Something went wrong with that request. Please try again.