Permalink
Browse files

fixing horrible gemspec mess

  • Loading branch information...
1 parent 79a7d05 commit 95330ded52212752fe0cef9a3d614f719632f16a @NoamB committed Apr 18, 2012
Showing with 56 additions and 52 deletions.
  1. +23 −1 Gemfile
  2. +4 −13 Gemfile.lock
  3. +0 −4 Rakefile
  4. +21 −30 sorcery.gemspec
  5. +2 −1 spec/Gemfile.lock
  6. +2 −1 spec/rails3/Gemfile.lock
  7. +2 −1 spec/rails3_mongo_mapper/Gemfile.lock
  8. +2 −1 spec/rails3_mongoid/Gemfile.lock
View
@@ -1,3 +1,25 @@
source :rubygems
+# Add dependencies required to use your gem here.
+# Example:
+# gem "activesupport", ">= 2.3.5"
+gem 'oauth', "~> 0.4.4"
+gem 'oauth2', "~> 0.5.1"
-gemspec
+# Add dependencies to develop your gem here.
+# Include everything needed to run rake, tests, features, etc.
+group :development do
+ gem "rails", ">= 3.0.0"
+ gem 'json', ">= 1.5.1"
+ gem "rspec", "~> 2.5.0"
+ gem 'rspec-rails', "~> 2.5.0"
+ gem 'ruby-debug19'
+ gem 'sqlite3-ruby', :require => 'sqlite3'
+ gem "yard", "~> 0.6.0"
+ gem "bundler", ">= 1.1.0"
+ gem "jeweler", "~> 1.8.3"
+ gem 'simplecov', '>= 0.3.8', :require => false # Will install simplecov-html as a dependency
+ gem 'timecop'
+ gem 'capybara'
+ gem 'bcrypt-ruby', "~> 3.0.0"
+ gem 'mongoid', "~> 2.4.4"
+end
View
@@ -1,13 +1,3 @@
-PATH
- remote: .
- specs:
- sorcery (0.7.8)
- bcrypt-ruby (~> 3.0.0)
- bundler (>= 1.1.0)
- oauth (~> 0.4.4)
- oauth2 (~> 0.5.1)
- sorcery
-
GEM
remote: http://rubygems.org/
specs:
@@ -84,7 +74,7 @@ GEM
activemodel (~> 3.1)
mongo (~> 1.3)
tzinfo (~> 0.3.22)
- multi_json (1.2.0)
+ multi_json (1.3.2)
multipart-post (1.1.5)
nokogiri (1.5.2)
oauth (0.4.5)
@@ -174,16 +164,17 @@ PLATFORMS
DEPENDENCIES
bcrypt-ruby (~> 3.0.0)
bundler (>= 1.1.0)
- capybara (>= 1.1.2)
+ capybara
jeweler (~> 1.8.3)
json (>= 1.5.1)
mongoid (~> 2.4.4)
+ oauth (~> 0.4.4)
+ oauth2 (~> 0.5.1)
rails (>= 3.0.0)
rspec (~> 2.5.0)
rspec-rails (~> 2.5.0)
ruby-debug19
simplecov (>= 0.3.8)
- sorcery!
sqlite3-ruby
timecop
yard (~> 0.6.0)
View
@@ -25,10 +25,6 @@ Jeweler::Tasks.new do |gem|
# and development dependencies are only needed for development (ie running rake tasks, tests, etc)
# gem.add_runtime_dependency 'jabber4r', '> 0.1'
# gem.add_development_dependency 'rspec', '> 1.2.3'
- gem.add_runtime_dependency 'bundler', '1.1.0'
- gem.add_runtime_dependency 'bcrypt-ruby', '~> 3.0.0'
- gem.add_runtime_dependency 'oauth', '~> 0.4.4'
- gem.add_runtime_dependency 'oauth2', '~> 0.5.1'
end
Jeweler::RubygemsDotOrgTasks.new
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Noam Ben Ari"]
- s.date = "2012-04-17"
+ s.date = "2012-04-18"
s.description = "Provides common authentication needs such as signing in/out, activating by email and resetting password."
s.email = "nbenari@gmail.com"
s.extra_rdoc_files = [
@@ -302,73 +302,64 @@ Gem::Specification.new do |s|
s.homepage = "http://github.com/NoamB/sorcery"
s.licenses = ["MIT"]
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.10"
+ s.rubygems_version = "1.8.21"
s.summary = "Magical authentication for Rails 3 applications"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<sorcery>, [">= 0"])
- s.add_development_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
+ s.add_runtime_dependency(%q<oauth>, ["~> 0.4.4"])
+ s.add_runtime_dependency(%q<oauth2>, ["~> 0.5.1"])
s.add_development_dependency(%q<rails>, [">= 3.0.0"])
s.add_development_dependency(%q<json>, [">= 1.5.1"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<rspec-rails>, ["~> 2.5.0"])
s.add_development_dependency(%q<ruby-debug19>, [">= 0"])
s.add_development_dependency(%q<sqlite3-ruby>, [">= 0"])
s.add_development_dependency(%q<yard>, ["~> 0.6.0"])
- s.add_development_dependency(%q<bundler>, [">= 1.1.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.8.3"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_development_dependency(%q<simplecov>, [">= 0.3.8"])
- s.add_development_dependency(%q<capybara>, [">= 1.1.2"])
- s.add_development_dependency(%q<mongoid>, ["~> 2.4.4"])
s.add_development_dependency(%q<timecop>, [">= 0"])
- s.add_runtime_dependency(%q<bundler>, ["= 1.1.0"])
- s.add_runtime_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
- s.add_runtime_dependency(%q<oauth>, ["~> 0.4.4"])
- s.add_runtime_dependency(%q<oauth2>, ["~> 0.5.1"])
+ s.add_development_dependency(%q<capybara>, [">= 0"])
+ s.add_development_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
+ s.add_development_dependency(%q<mongoid>, ["~> 2.4.4"])
else
- s.add_dependency(%q<sorcery>, [">= 0"])
- s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
+ s.add_dependency(%q<oauth>, ["~> 0.4.4"])
+ s.add_dependency(%q<oauth2>, ["~> 0.5.1"])
s.add_dependency(%q<rails>, [">= 3.0.0"])
s.add_dependency(%q<json>, [">= 1.5.1"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<rspec-rails>, ["~> 2.5.0"])
s.add_dependency(%q<ruby-debug19>, [">= 0"])
s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
s.add_dependency(%q<yard>, ["~> 0.6.0"])
- s.add_dependency(%q<bundler>, [">= 1.1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
+ s.add_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<simplecov>, [">= 0.3.8"])
- s.add_dependency(%q<capybara>, [">= 1.1.2"])
- s.add_dependency(%q<mongoid>, ["~> 2.4.4"])
s.add_dependency(%q<timecop>, [">= 0"])
- s.add_dependency(%q<bundler>, ["= 1.1.0"])
+ s.add_dependency(%q<capybara>, [">= 0"])
s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
- s.add_dependency(%q<oauth>, ["~> 0.4.4"])
- s.add_dependency(%q<oauth2>, ["~> 0.5.1"])
+ s.add_dependency(%q<mongoid>, ["~> 2.4.4"])
end
else
- s.add_dependency(%q<sorcery>, [">= 0"])
- s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
+ s.add_dependency(%q<oauth>, ["~> 0.4.4"])
+ s.add_dependency(%q<oauth2>, ["~> 0.5.1"])
s.add_dependency(%q<rails>, [">= 3.0.0"])
s.add_dependency(%q<json>, [">= 1.5.1"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<rspec-rails>, ["~> 2.5.0"])
s.add_dependency(%q<ruby-debug19>, [">= 0"])
s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
s.add_dependency(%q<yard>, ["~> 0.6.0"])
- s.add_dependency(%q<bundler>, [">= 1.1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
+ s.add_dependency(%q<bundler>, ["~> 1.0.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<simplecov>, [">= 0.3.8"])
- s.add_dependency(%q<capybara>, [">= 1.1.2"])
- s.add_dependency(%q<mongoid>, ["~> 2.4.4"])
s.add_dependency(%q<timecop>, [">= 0"])
- s.add_dependency(%q<bundler>, ["= 1.1.0"])
+ s.add_dependency(%q<capybara>, [">= 0"])
s.add_dependency(%q<bcrypt-ruby>, ["~> 3.0.0"])
- s.add_dependency(%q<oauth>, ["~> 0.4.4"])
- s.add_dependency(%q<oauth2>, ["~> 0.5.1"])
+ s.add_dependency(%q<mongoid>, ["~> 2.4.4"])
end
end
View
@@ -1,11 +1,12 @@
PATH
remote: ../
specs:
- sorcery (0.7.8)
+ sorcery (0.7.10)
bcrypt-ruby (~> 3.0.0)
bundler (>= 1.1.0)
oauth (~> 0.4.4)
oauth2 (~> 0.5.1)
+ sorcery
GEM
remote: http://rubygems.org/
@@ -1,11 +1,12 @@
PATH
remote: ../../
specs:
- sorcery (0.7.8)
+ sorcery (0.7.10)
bcrypt-ruby (~> 3.0.0)
bundler (>= 1.1.0)
oauth (~> 0.4.4)
oauth2 (~> 0.5.1)
+ sorcery
GEM
remote: http://rubygems.org/
@@ -1,11 +1,12 @@
PATH
remote: ../../
specs:
- sorcery (0.7.8)
+ sorcery (0.7.10)
bcrypt-ruby (~> 3.0.0)
bundler (>= 1.1.0)
oauth (~> 0.4.4)
oauth2 (~> 0.5.1)
+ sorcery
GEM
remote: http://rubygems.org/
@@ -1,11 +1,12 @@
PATH
remote: ../../
specs:
- sorcery (0.7.8)
+ sorcery (0.7.10)
bcrypt-ruby (~> 3.0.0)
bundler (>= 1.1.0)
oauth (~> 0.4.4)
oauth2 (~> 0.5.1)
+ sorcery
GEM
remote: http://rubygems.org/

0 comments on commit 95330de

Please sign in to comment.