push command doesnt work with NuGet.exe 3.2.0 #1237

Closed
bhuvak opened this Issue Aug 22, 2015 · 2 comments

Projects

None yet

5 participants

@bhuvak
bhuvak commented Aug 22, 2015

Basic push command returns 404 with nuget.exe 3.2.0 ( against V2 source).
It happens both with -source command and when the source is specified in the config.

nuget.exe push does not work when the input is https://www.nuget.org/api/v2/Package

@yishaigalatzer yishaigalatzer added this to the 3.2 milestone Aug 25, 2015
@yishaigalatzer

@deepakaravindr this sounds like something that should just work. Can you verify and fix if necessary?

@deepakaravindr
Member

Verified that nuget.exe push does not work when the input is https://www.nuget.org/api/v2/Package

PushCommandResource ends up doing a GET request because it treats the input as a package source. However, https://www.nuget.org/api/v2/Package is not a package source and only accepts PUT requests. This is the bug

@deepakaravindr deepakaravindr added a commit to NuGetArchive/NuGet3 that referenced this issue Aug 26, 2015
@deepakaravindr deepakaravindr Fixes NuGet/Home#1237
SourceRepository need not be a package source for PushCommand.
So, simply return the SourceRepository.PackageSource.Source
4a1429b
@deepakaravindr deepakaravindr added a commit to NuGetArchive/NuGet3 that closed this issue Aug 26, 2015
@deepakaravindr deepakaravindr Fixes NuGet/Home#1237
SourceRepository need not be a package source for PushCommand.
So, simply return the SourceRepository.PackageSource.Source
f952337
@RanjiniM RanjiniM added the 2 - Working label Sep 1, 2015
@emgarten emgarten added 3 - Done and removed 2 - Working labels Sep 2, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment