New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When installed VS 2015 update 3 on a VS that uses NuGet version 3.5.0 error occurs #3053

Closed
skofman1 opened this Issue Jun 27, 2016 · 4 comments

Comments

Projects
None yet
3 participants
@skofman1

skofman1 commented Jun 27, 2016

Repro:

  1. On VS 2015 update 2, installe NuGet vsix version 3.5.0
  2. Update to VS 2015 upgrade 3
  3. Open VS

The error:

CreateInstance failed for package [NuGetPackage]Source: 'mscorlib' Description: Could not load file or assembly 'NuGet.Tools, Version=3.5.0.1284, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly 'NuGet.Tools, Version=3.5.0.1284, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. File name: 'NuGet.Tools, Version=3.5.0.1284, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Activator.CreateInstance(String assemblyString, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark) at System.Activator.CreateInstance(String assemblyName, String typeName) at System.AppDomain.CreateInstance(String assemblyName, String typeName) WRN: Assembly binding logging is turned OFF. To enable assembly bind failure logging, set the registry value HKLM\Software\Microsoft\Fusion!EnableLog to 1. Note: There is some performance penalty associated with assembly bind failure logging. To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

@rrelyea rrelyea added this to the 3.5 RTM milestone Jun 27, 2016

@rrelyea rrelyea added the Type:Bug label Jun 28, 2016

@drewgillies drewgillies self-assigned this Jun 29, 2016

@drewgillies

This comment has been minimized.

Show comment
Hide comment
@drewgillies

drewgillies Jun 30, 2016

Contributor

Not seeing the repro. Suggest closing and re-open if it turns up again.

Contributor

drewgillies commented Jun 30, 2016

Not seeing the repro. Suggest closing and re-open if it turns up again.

@rrelyea

This comment has been minimized.

Show comment
Hide comment
@rrelyea

rrelyea Jun 30, 2016

Contributor

Have you asked @skofman1 ? She and @emgarten were able to hit this, I believe.

Contributor

rrelyea commented Jun 30, 2016

Have you asked @skofman1 ? She and @emgarten were able to hit this, I believe.

@drewgillies

This comment has been minimized.

Show comment
Hide comment
@drewgillies

drewgillies Jun 30, 2016

Contributor

Yes, but nothing has yielded a repro yet. I'll re-open and bang on it some more.

Contributor

drewgillies commented Jun 30, 2016

Yes, but nothing has yielded a repro yet. I'll re-open and bang on it some more.

@drewgillies drewgillies reopened this Jun 30, 2016

@drewgillies

This comment has been minimized.

Show comment
Hide comment
@drewgillies

drewgillies Jul 1, 2016

Contributor

I'm closing this again. I've re-run the steps above using 3.5.0-beta2 as the NuGet install, and still no failure. I've created a UWP app, modified packages in the VS UI, built, no problems. Tagging @skofman1 and @emgarten --if you're able to find any extra steps which will yield this repro, please add them and re-open.

Contributor

drewgillies commented Jul 1, 2016

I'm closing this again. I've re-run the steps above using 3.5.0-beta2 as the NuGet install, and still no failure. I've created a UWP app, modified packages in the VS UI, built, no problems. Tagging @skofman1 and @emgarten --if you're able to find any extra steps which will yield this repro, please add them and re-open.

@drewgillies drewgillies closed this Jul 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment