New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error when "Install-Package jquery.validation" on dev15 #3061

Closed
v-sojian opened this Issue Jun 29, 2016 · 2 comments

Comments

Projects
None yet
3 participants
@v-sojian

v-sojian commented Jun 29, 2016

Nuget: 3.5.0.1544 on dev15
Repro Steps:

  1. Click File -> Visual C# ->Office/SharePoint ->SharePoint Add-in ->click ok
  2. Enter the SharePoint site and select Provider and click next. Then select SharePoint Online click finish.
  3. Start Package Manager Console and type " install-package jquery.validation" then meet the error, as the picture shows.
    3
  4. Then delete the "Packages" folder from the solution and build the solution, meet the error as the picture shows.
    4

Expected:
No errors.

@rrelyea rrelyea added this to the 3.5 RTM milestone Jun 29, 2016

@rrelyea rrelyea changed the title from Type "Install-Package <package name>" and press enter in PMC, meet error to Error when "Install-Package jquery.validation" on dev15 Jun 29, 2016

@joelverhagen joelverhagen self-assigned this Jul 5, 2016

@joelverhagen

This comment has been minimized.

Show comment
Hide comment
@joelverhagen

joelverhagen Jul 5, 2016

Member

This seems to be due to the fact that this template depends on the 3.1.5 version of AppForSharePointWebToolkit, which is not available on NuGet.org or in the C:\Program Files (x86)\Microsoft SDKs\NuGetPackages installer source.

This is the latest version on NuGet.org:
https://www.nuget.org/packages/AppForSharePointWebToolkit/3.1.4

I am following up with the owner of this package to determine why the 3.1.5 version is not available.

Member

joelverhagen commented Jul 5, 2016

This seems to be due to the fact that this template depends on the 3.1.5 version of AppForSharePointWebToolkit, which is not available on NuGet.org or in the C:\Program Files (x86)\Microsoft SDKs\NuGetPackages installer source.

This is the latest version on NuGet.org:
https://www.nuget.org/packages/AppForSharePointWebToolkit/3.1.4

I am following up with the owner of this package to determine why the 3.1.5 version is not available.

@joelverhagen

This comment has been minimized.

Show comment
Hide comment
@joelverhagen

joelverhagen Jul 5, 2016

Member

This problem only existing in Visual Studio '15 (dev15) Preview 3, which is not publicly released yet. I confirmed with the package owners that the package will be published prior to Preview 3 release.

Member

joelverhagen commented Jul 5, 2016

This problem only existing in Visual Studio '15 (dev15) Preview 3, which is not publicly released yet. I confirmed with the package owners that the package will be published prior to Preview 3 release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment