New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

nuget pack forcefully adds .tt files to content folder no matter what #3203

Closed
Ackara opened this Issue Jul 24, 2016 · 5 comments

Comments

Projects
None yet
4 participants
@Ackara

Ackara commented Jul 24, 2016

If my project contains a .tt (T4 Template) file, and run the nuget pack command. All of the .tt files will be added to the package's content folder, regardless if you try to exclude the .tt files in the .nuspec.

Right now all of my .tt files are being forcefully packaged and breaking some of my builds please fix this.

I have attached a sample project so that you guys can see for yourself. Run the build.ps1.

The nuget version is 3.4.4 (The latest as of today)

NugetIssue.zip

@rrelyea

This comment has been minimized.

Show comment
Hide comment
@rrelyea

rrelyea Jul 25, 2016

Contributor

Can you please try this out with 3.5.0-beta2 or 3.5.0-rc (daily build) from http://nuget.org/downloads.
Still an issue?

Contributor

rrelyea commented Jul 25, 2016

Can you please try this out with 3.5.0-beta2 or 3.5.0-rc (daily build) from http://nuget.org/downloads.
Still an issue?

@Ackara

This comment has been minimized.

Show comment
Hide comment
@Ackara

Ackara Jul 25, 2016

Yes, the same issue occur when using v 3.5.0. However it works as expected with version v 3.4.3.

Ackara commented Jul 25, 2016

Yes, the same issue occur when using v 3.5.0. However it works as expected with version v 3.4.3.

@rrelyea

This comment has been minimized.

Show comment
Hide comment
@rrelyea

rrelyea Jul 25, 2016

Contributor

Duplicate of #3149

Contributor

rrelyea commented Jul 25, 2016

Duplicate of #3149

@rrelyea rrelyea added this to the 3.5 RTM milestone Jul 25, 2016

@rrelyea rrelyea closed this Jul 25, 2016

@fruby

This comment has been minimized.

Show comment
Hide comment
@fruby

fruby Oct 11, 2017

This reproes when I try to use the nuget pack task in vsts continuous integration. The version I use is 2.*

fruby commented Oct 11, 2017

This reproes when I try to use the nuget pack task in vsts continuous integration. The version I use is 2.*

@mdchafin

This comment has been minimized.

Show comment
Hide comment
@mdchafin

mdchafin Sep 26, 2018

I'm having the same issue today.

mdchafin commented Sep 26, 2018

I'm having the same issue today.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment