Default Copy of ContentFiles are incorrect for MsBuild /t:pack #3894

Closed
harikmenon opened this Issue Nov 8, 2016 · 3 comments

Comments

Projects
None yet
4 participants
@harikmenon

Details about Problem

NuGet Pack Task

NuGet version (x.x.x.xxx): 4.0

VS version (if appropriate): VS 15

Detailed repro steps so we can see the same problem

  1. Create a .Net Core class library

  2. Add a text file

  3. Pack the project

Expected
ContentFile is packed to contentFiles/any/netstandard1.4

Actual
Copied to ContentFiles root

@rrelyea

This comment has been minimized.

Show comment
Hide comment
@rrelyea

rrelyea Dec 8, 2016

Contributor

@emgarten - thoughts on Hari's feedback here? is that what you'd expect?

Contributor

rrelyea commented Dec 8, 2016

@emgarten - thoughts on Hari's feedback here? is that what you'd expect?

@rrelyea rrelyea added this to the 4.0 RC3 milestone Dec 8, 2016

@emgarten

This comment has been minimized.

Show comment
Hide comment
@emgarten

emgarten Dec 9, 2016

Contributor

yes, contentFiles/any/{projectTFM} is probably the best default

Contributor

emgarten commented Dec 9, 2016

yes, contentFiles/any/{projectTFM} is probably the best default

@rohit21agrawal

This comment has been minimized.

Show comment
Hide comment
@rohit21agrawal

rohit21agrawal Dec 12, 2016

Contributor

@emgarten so for a project with multiple TFM all files would go to each of those TFMs ?

Contributor

rohit21agrawal commented Dec 12, 2016

@emgarten so for a project with multiple TFM all files would go to each of those TFMs ?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment