Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dotNet Core SDK 3.1.100 failing to restore because of bad versions #9051

Open
wli3 opened this issue Jan 11, 2020 · 0 comments
Open

dotNet Core SDK 3.1.100 failing to restore because of bad versions #9051

wli3 opened this issue Jan 11, 2020 · 0 comments

Comments

@wli3
Copy link

@wli3 wli3 commented Jan 11, 2020

From @predatorian3 on Saturday, January 11, 2020 1:53:54 AM

Issue Description

On a brand new install of dotNet Core SDK 3.1.100 for Windows 10 x64, It seems to be missing dependencies with the install. Should I need to include other feeds to get the dotnet restore to work after doing a dotnet new xunit? I was following this document: Organizing and testing projects with the .NET Core command line. Some of the references are a little old so maybe something changed?

Steps performed

dotnet new xunit
dotnet restore

System Information

C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests>systeminfo

Host Name:                 FENIX
OS Name:                   Microsoft Windows 10 Pro
OS Version:                10.0.18362 N/A Build 18362
OS Manufacturer:           Microsoft Corporation

dotnet Errors

C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests>dotnet restore 
Restore completed in 25.54 ms for C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\src\NewTypes\NewTypes.csproj.
C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests\NewTypesTests.csproj : error NU1100: Unable to resolve 'Microsoft.NET.Test.Sdk (>= 16.2.0)' for '.NETCoreApp,Version=v3.1'.
C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests\NewTypesTests.csproj : error NU1100: Unable to resolve 'xunit (>= 2.4.0)' for '.NETCoreApp,Version=v3.1'.
C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests\NewTypesTests.csproj : error NU1100: Unable to resolve 'xunit.runner.visualstudio (>= 2.4.0)' for '.NETCoreApp,Version=v3.1'.
C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests\NewTypesTests.csproj : error NU1100: Unable to resolve 'coverlet.collector (>= 1.0.1)' for '.NETCoreApp,Version=v3.1'.
  Restore failed in 150.83 ms for C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests\NewTypesTests.csproj.

dotnet information

C:\Users\Phillip\Desktop\dotNetCore\01_NewTypes\test\NewTypesTests>dotnet --info
.NET Core SDK (reflecting any global.json):
 Version:   3.1.100
 Commit:    cd82f021f4

Runtime Environment:
 OS Name:     Windows
 OS Version:  10.0.18362
 OS Platform: Windows
 RID:         win10-x64
 Base Path:   C:\Program Files\dotnet\sdk\3.1.100\

Host (useful for support):
  Version: 3.1.0
  Commit:  65f04fb6db

.NET Core SDKs installed:
  3.1.100 [C:\Program Files\dotnet\sdk]

.NET Core runtimes installed:
  Microsoft.AspNetCore.App 3.1.0 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 3.1.0 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
  Microsoft.WindowsDesktop.App 3.1.0 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]

To install additional .NET Core runtimes or SDKs:
  https://aka.ms/dotnet-download

Copied from original issue: dotnet/sdk#4156

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.