Skip to content
Browse files

OpamClient.SafeAPI can now be used in a toplevel.

Fix #544
  • Loading branch information...
1 parent 5dee36b commit 6fcd3db674a82e1c70df00eb5cfb977d3b4c4d76 @samoht samoht committed Mar 19, 2013
Showing with 5 additions and 5 deletions.
  1. +2 −2 META.in
  2. +3 −3 Makefile
View
4 META.in
@@ -1,6 +1,6 @@
version = "@VERSION@"
description = "OCaml Package Manager base API"
-requires = "dose, cudf, ocamlgraph, unix, re"
+requires = "dose, cudf, ocamlgraph, unix, re, re.glob"
archive(byte) = "opam-core.cma"
archive(native) = "opam-core.cmxa"
@@ -19,5 +19,5 @@ package "solver" (
package "client" (
archive(byte) = "opam-client.cma"
archive(native) = "opam-client.cmxa"
- requires = "opam, opam.solver, opam.repositories"
+ requires = "opam, opam.solver, opam.repositories, cmdliner"
)
View
6 Makefile
@@ -27,12 +27,12 @@ OCAMLBUILD_FLAGS=\
with-ocamlbuild: autogen
@for i in core repositories solver client; do\
echo Compiling opam-$$i;\
- find src/$$i -type f -name \*.ml -or -name \*.mll -or -name \*.mly\
+ find src/$$i -type f \( -not -name opamMain.ml \) \
+ \( -name \*.ml -or -name \*.mly -or -name \*.mll \)\
| xargs -n 1 basename\
| awk -F. "{ print (toupper(substr(\$$1,0,1)) substr(\$$1,2)) }"\
> src/$$i/opam-$$i.mllib &&\
- ocamlbuild $(OCAMLBUILD_FLAGS) opam-$$i.cma opam-$$i.cmxa &&\
- rm -f src/$$i/opam-$$i.mllib;\
+ ocamlbuild $(OCAMLBUILD_FLAGS) opam-$$i.cma opam-$$i.cmxa;\
done;\
ocamlbuild $(OCAMLBUILD_FLAGS) opamMain.native opam_mk_repo.native opam_repo_check.native &&\
ln -sf _build/src/client/opamMain.native opam &&\

0 comments on commit 6fcd3db

Please sign in to comment.
Something went wrong with that request. Please try again.