Skip to content
This repository

Build fails on OS X Lion 10.7.3 #54

Open
dogfishbar opened this Issue · 8 comments

3 participants

dogfishbar Thomas Gazagnaire Fabrice Le Fessant
dogfishbar

Searched the archives, didn't find anything. Maybe this is question is too newbie-ish but I am getting a linker (loader) error when attempting to make the runtime system. In particular, the loader doesn't seem to be able to track down the library crt1.10.6.o.

I am running ocamlc version 3.12. Any hints appreciated.
Thanks,
Bob Muller

air:~/Desktop/typerex-1.0.1> make
mkdir -p ./obuild
ocamlc -o ./_obuild/unixrun -make-runtime unix.cma
ld: library not found for -lcrt1.10.6.o
collect2: ld returned 1 exit status
File "_none
", line 1, characters 0-1:
Error: Error while building custom runtime system
make: *** [_obuild/unixrun] Error 2

Thomas Gazagnaire
samoht commented

Have you installed ocaml from the .dmg available on INRIA website ? If yes, I would advise to reinstall it from the sources ...

dogfishbar
dogfishbar
dogfishbar
Thomas Gazagnaire

Hi Bob,
unfortunately typerex is not working with 4.00.0. We are starting designing typerex v2 (which will not contain the exact same features as typerex v1) but unfortunately we don't have enough ressources to maintain typerex v1 for new releases of OCaml.

dogfishbar
Fabrice Le Fessant
Owner

Hi Bob,

Just one question about your use of TypeRex: for which features did you decide to use it ? Since we are designing currently what should be TypeRex 2, we would be particularly interested in the features for which developers want to use it, compared to other emacs modes like Tuareg or Caml-mode.

Best regards,
--Fabrice

dogfishbar
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.