Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

What's the deal with NetCDF 1.4 #482

Closed
fmaussion opened this Issue Jun 21, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@fmaussion
Copy link
Member

fmaussion commented Jun 21, 2018

Just because I've seen this in #481

What is the issue with NetCDF 1.4? Did we find out where the problem lies?

@fmaussion

This comment has been minimized.

Copy link
Member Author

fmaussion commented Jun 21, 2018

At least we should put a big warning in the installation docs warning about it.

@TimoRoth

This comment has been minimized.

Copy link
Contributor

TimoRoth commented Jun 21, 2018

I have no idea what the issue is. In general, everything still works fine, but it takes insanely long.
Running the tests with netCDF 1.4 compared to <1.4 increases the time from 5-10 minutes to over 2 hours for me.

Also, if the asv PR is merged, installing oggm will ensure that it's <1.4 due to the setup.py changes.

@fmaussion

This comment has been minimized.

Copy link
Member Author

fmaussion commented Jun 22, 2018

@fmaussion fmaussion referenced this issue Jun 29, 2018

Merged

Set netCDF4's auto_mask to False #492

3 of 3 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.