Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spreadsheet hidden numbers #467

Closed
mariuspana opened this issue Jan 5, 2019 · 6 comments

Comments

Projects
None yet
3 participants
@mariuspana
Copy link

commented Jan 5, 2019

Do you want to request a feature or report a bug?
Bug

What is the current behavior?
Some numbers within the Spreadsheet editor do not show up correctly. FOr example, using the format "general", the number 128 shows as 1. Adding decimal places makes it 1.00. Changing the format to "number" does not change this. Changing the format to currency works but these are not currencies.

If the current behavior is a bug, please provide the steps to reproduce and if possible a minimal demo of the problem.
ezgif-4-5f972936d1aa

What is the expected behavior?
Numbers should show up as inserted in the cell.

Did this work in previous versions of DocumentServer?
Have not tested.

DocumentServer version:
5.1.5-59

Operating System:
Ubuntu 16.04.5 LTS

Browser version:
Safari Version 12.0.2 (14606.3.4)

@Rita-Bubnova

This comment has been minimized.

Copy link

commented Jan 9, 2019

Hello, @mariuspana.
Please try to reproduce a problem in another browser (for example, Chrome). Is it still occurs?

@mariuspana

This comment has been minimized.

Copy link
Author

commented Jan 10, 2019

Hello @Rita-Bubnova, thank you for the hint. I have just tested in Chrome and Firefox and
this issue does not exist. Im not sure how many users are using Safari but if there is anything I can help with to get this resolved it would be great.

Thanks!

@Rita-Bubnova

This comment has been minimized.

Copy link

commented Jan 11, 2019

It is known bug 39878 in our internal issue tracker.
Thanks for the feedback.

@ShockwaveNN ShockwaveNN added the bug label Jan 11, 2019

@mariuspana

This comment has been minimized.

Copy link
Author

commented Jan 11, 2019

Is it possible for us/me to follow this issue somewhere to be notified when it gets resolved? Or does that happen here with this issue? Thanks

@Rita-Bubnova

This comment has been minimized.

Copy link

commented Jan 11, 2019

We'll close this issue as soon as we release version with fix of your bug.

konovalovsergey added a commit to ONLYOFFICE/sdkjs that referenced this issue Jan 21, 2019

[se] Fix bug 39878 , ONLYOFFICE/DocumentServer#477 , ONLYOFFICE/Docum…
…entServer#467

Closure Compiler produced that "0 == d". It incorrectly works on Safari(12.0.2) in some cases.

@ShockwaveNN ShockwaveNN added fixed and removed bug labels Feb 1, 2019

@ShockwaveNN

This comment has been minimized.

Copy link
Member

commented Feb 6, 2019

Problem fixed and released in DocumentServer 5.2.8

@ShockwaveNN ShockwaveNN closed this Feb 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.