Skip to content
Permalink
Branch: master
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
30 lines (19 sloc) 663 Bytes
mod_nis php extension
작성: 김정균 <http://oops.org>
$Id$
* 경고
1.0.x 부터는 PHP 7 이상만을 지원한다. PHP 7 미만에서는 0.x 버전을 사용
해야 한다. (기능적 차이는 없다.)
This extension can't thread safe!
* 개요
mod_nis php 확장은 nis entry 를 이용하여 인증을 하기 위한 모듈이다.
shadow system 에서는 mod_pam 의 경우, root 권한이 있어야 정상 작동을
하기 때문에, root 권한이 없는 apache module 로서의 사용시에 NIS 인증을
할 수 있도록 하기 위한 모듈이다.
단 단점으로는, NIS entry 에 존재하는 리스트만 인증이 가능하다. PAM 처럼
local account 까지 처리를 해 주지는 못한다.
* 설치
phpize
./configure
make
cp -af modules/nis.so $PHP_SHARED_EXTENSION_DIR/nis.so
You can’t perform that action at this time.