Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto sign in triggers aren't being handled correctly #5018

Closed
slewis74 opened this issue Oct 23, 2018 · 2 comments

Comments

@slewis74
Copy link

commented Oct 23, 2018

The recent changes to allow the external authentication servers to trigger a login contained a logic issue that prevents auto login triggering for the AD provider.

The issue only manifests because the AD provider falls into an edge case gap between the providers that have forms auth and those that don't (it can be either depending on whether you've allowed forms auth specifically for AD).

While investigating I also found an issue where if the AD provider and a single other OIDC provider where enabled, along with Auto Login then the UI would trigger auto login on the AD provider.

Links

https://secure.helpscout.net/conversation/690832669

@octoreleasebot

This comment has been minimized.

Copy link

commented Oct 23, 2018

Release Note: Fixed a bug with auto login when only the Active Directory provider was enabled

@MJRichardson MJRichardson modified the milestones: 2018.8.13, 2018.9.0 Oct 23, 2018
@lock

This comment has been minimized.

Copy link

commented Jan 21, 2019

This thread has been automatically locked since there has not been any recent activity after it was closed. If you think you've found a related issue, please contact our support team so we can triage your issue, and make sure it's handled appropriately.

@lock lock bot locked as resolved and limited conversation to collaborators Jan 21, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
3 participants
You can’t perform that action at this time.